source: projects/specs/trunk/e/expat1/expat1-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define sourcename expat
3%define version 1.95.8
4%define release 1%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{sourcename}1
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{sourcename}-%{version}.tar.gz
15Patch0:         expat-1.95.8-mandir.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildPreReq:    libtool
19
20%description
21
22%package -n lib%{name}
23Summary:        Runtime library of expat
24Summary(ja):    Expat のための実行ライブラリ
25Group:          System Environment/Libraries
26Obsoletes:      libexpat < 2.0.0
27
28%description -n lib%{name}
29This package contains the runtime, shared library of expat, the C
30library for parsing XML.
31
32%description -n lib%{name} -l ja
33Expat を動作させるために必用となるライブラリです.
34
35## to build compat32 for x86_64 architecture support
36%package -n compat32-lib%{name}
37Summary:        Runtime library of expat
38Group:          System Environment/Libraries
39%description -n compat32-lib%{name}
40This package contains the runtime, shared library of expat, the C
41library for parsing XML.
42
43%prep
44%setup -q -n %{sourcename}-%{version}
45%patch0 -p1 -b .mandir
46
47%build
48export CFLAGS="$RPM_OPT_FLAGS -fPIC"
49%if %{build_compat32}
50## to build compat32 for x86_64 architecture support
51%configure CC='gcc -m32' --enable-shared
52%else
53%configure --enable-shared
54%endif
55
56# Dadou - 1.1-2mdk - Don't try to use optimizations. It breaks build
57make
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%makeinstall
62rm -rf $RPM_BUILD_ROOT%{_bindir}
63rm -rf $RPM_BUILD_ROOT%{_includedir}
64rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.so
66rm -rf $RPM_BUILD_ROOT%{_datadir}
67
68%clean
69rm -rf %buildroot
70
71%post -n lib%{name} -p /sbin/ldconfig
72
73%postun -n lib%{name} -p /sbin/ldconfig
74
75%if %{build_compat32}
76%post -n compat32-lib%{name} -p /sbin/ldconfig
77%postun -n compat32-lib%{name} -p /sbin/ldconfig
78%endif
79
80%if !%{build_compat32}
81%files -n lib%{name}
82%defattr(-,root,root)
83%doc COPYING Changes README
84%{_libdir}/libexpat.so.*
85%endif
86
87## to build compat32 for x86_64 architecture support
88%if %{build_compat32}
89%files -n compat32-lib%{name}
90%defattr(-,root,root)
91%{_libdir}/libexpat.so.*
92%endif
93
94%changelog
95* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 1.95.8-1vl5
96- applied new versioning policy, spec in utf-8
97
98* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.95.8-0vl7
99- rename to expat1
100- add -fPIC
101- distribute libexpat1 only
102- add Obsoletes: libexpat < 2.0.0
103
104* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
105- rebuilt
106
107* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
108- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
109
110* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
111- added compat32* packages for x86_64 architecture support
112
113* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
114- add missing header file (expat_external.h) to %%files.
115
116* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
117- updated/revised Patch1 (%%install will fail without this patch)
118
119* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
120- new upstream release
121        -- dropped patch1
122
123* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
124- updated to 1.95.7
125- changed URL and Group
126- fixed License to MIT/X (based on rpm package at sourceforge)
127
128* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
129- version up to 1.95.6
130- drop expat-xmlwf-dynamiclink.patch (Patch0)
131- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
132- add manpage (xmlwf.1)
133
134* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
135- fixed license ( s/MPL or GPL/distributable/ )
136- use License tag
137
138* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
139- new sub-package libexpat.
140- added BuildPreReq: libtool
141
142* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
143- updated to 1.95.2 release
144
145* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
146- 1.95.1-3vl1
147- based on 1.95.1-3mdk from Mandrake 8.0
148- added Japanese summary and description
149- modified spec macros for Vine
150
151* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
152- real version is 1.95.1
153- reenable optimisations
154
155* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
156- release .
157
158* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
159- Don't try to use optimizations
160- Bzip2 sources
161
162* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
163- first version
Note: See TracBrowser for help on using the repository browser.