source: projects/specs/trunk/e/expat/expat-vl.spec @ 3706

Revision 3706, 7.2 KB checked in by iwaim, 13 years ago (diff)

expat-2.0.1-8

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.0.1
4%define release 8%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
15Patch100:       expat-2.0.1-CVE-2009-3560-revised.patch
16Patch110:       expat-2.0.1_CVE-2009-3720.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19Requires:       lib%{name} = %{version}-%{release}
20BuildRequires:  libtool
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26This is Expat, a C library for parsing XML, written by James Clark.
27Expat is a stream-oriented XML parser.  This means that you register
28handlers with the parser before starting the parse.  These handlers
29are called when the parser discovers the associated structures in the
30document being parsed.  A start tag is an example of the kind of
31structures for which you may register handlers.
32
33%package -n lib%{name}
34Summary:        Runtime library of expat
35Summary(ja):    Expat のための実行ライブラリ
36Group:          System Environment/Libraries
37
38
39%description -n lib%{name}
40This package contains the runtime, shared library of expat, the C
41library for parsing XML.
42
43%description -n lib%{name} -l ja
44Expat を動作させるために必用となるライブラリです.
45
46%package devel
47Summary:        Development environment for the expat XML parser
48Summary(ja):    expat XML パーサ用開発環境
49Group:          Development/Libraries
50Requires:       lib%{name} = %{version}-%{release}
51
52%description devel
53Development environment for the expat XML parser
54
55%description devel -l ja
56expat XML パーサ用開発環境です.
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-lib%{name}
60Summary:        Runtime library of expat
61Summary(ja):    Expat のための実行ライブラリ
62Group:          System Environment/Libraries
63Requires:       lib%{name} = %{version}-%{release}
64
65%description -n compat32-lib%{name}
66This package contains the runtime, shared library of expat, the C
67library for parsing XML.
68
69%description -n compat32-lib%{name} -l ja
70Expat を動作させるために必用となるライブラリです.
71
72%package -n compat32-%{name}-devel
73Summary:        Development environment for the expat XML parser
74Summary(ja):    expat XML パーサ用開発環境
75Group:          Development/Libraries
76Requires:       %{name}-devel = %{version}-%{release}
77Requires:       compat32-lib%{name} = %{version}-%{release}
78
79%description -n compat32-%{name}-devel
80Development environment for the expat XML parser
81
82%description -n compat32-%{name}-devel -l ja
83expat XML パーサ用開発環境です.
84
85%prep
86%setup -q
87%patch100 -p1 -b .CVE-2009-3560
88%patch110 -p1 -b .CVE-2009-3720
89
90%build
91export CFLAGS="$RPM_OPT_FLAGS -fPIC"
92%configure --enable-shared
93make %{?_smp_mflags}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98rm -f examples/*.dsp
99chmod 644 README COPYING Changes doc/* examples/*
100
101make DESTDIR=$RPM_BUILD_ROOT install
102rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -n lib%{name} -p /sbin/ldconfig
108
109%postun -n lib%{name} -p /sbin/ldconfig
110
111%post -n compat32-lib%{name} -p /sbin/ldconfig
112
113%postun -n compat32-lib%{name} -p /sbin/ldconfig
114
115%files
116%defattr(-,root,root)
117%doc COPYING Changes README
118%{_bindir}/xmlwf
119%{_mandir}/man1/xmlwf.1*
120
121%files -n lib%{name}
122%defattr(-,root,root)
123%doc COPYING Changes README
124%{_libdir}/libexpat.so.*
125
126%files devel
127%defattr(-,root,root)
128%doc COPYING Changes README doc/* examples
129%{_includedir}/*
130%{_libdir}/libexpat.a
131%{_libdir}/libexpat.so
132
133## to build compat32 for x86_64 architecture support
134%if %{build_compat32}
135%files -n compat32-lib%{name}
136%defattr(-,root,root)
137%{_libdir}/libexpat.so.*
138
139%files -n compat32-%{name}-devel
140%defattr(-,root,root)
141%{_libdir}/libexpat.a
142%{_libdir}/libexpat.so
143%endif
144
145%changelog
146* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
147- update patch100 to regrassion fix (same as debian bug #561658)
148- add Vendor and Distribution tags
149
150* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
151- rebuilt with rpm-4.8.1-3
152
153* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
154- rebuilt with gcc-4.4.3-3 on ppc
155
156* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
157- rebuilt with new toolchains (for VineSeed)
158
159* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
160- add patch110 for fix CVE-2009-3720 (xml parser)
161
162* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
163- add Patch100 for fix CVE-2009-3560 (xml parser)
164
165* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
166- added Requires: tag to compat32-* sub-packages.
167- removed unnecessary %%configure CC='gcc -m32' option
168
169* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
170- applied new versioning policy and spec in utf-8
171
172* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
173- removed %%if !%%{build_compat32} case condition
174
175* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
176- new upstream release
177- drop Patch0
178- drop .la
179- chmod 644 the documentation
180- strip DSP files from examples
181- update description and drop description-ja
182- add -fPIC
183
184* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
185- rebuilt
186
187* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
188- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
189
190* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
191- added compat32* packages for x86_64 architecture support
192
193* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
194- add missing header file (expat_external.h) to %%files.
195
196* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
197- updated/revised Patch1 (%%install will fail without this patch)
198
199* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
200- new upstream release
201        -- dropped patch1
202
203* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
204- updated to 1.95.7
205- changed URL and Group
206- fixed License to MIT/X (based on rpm package at sourceforge)
207
208* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
209- version up to 1.95.6
210- drop expat-xmlwf-dynamiclink.patch (Patch0)
211- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
212- add manpage (xmlwf.1)
213
214* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
215- fixed license ( s/MPL or GPL/distributable/ )
216- use License tag
217
218* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
219- new sub-package libexpat.
220- added BuildPreReq: libtool
221
222* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
223- updated to 1.95.2 release
224
225* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
226- 1.95.1-3vl1
227- based on 1.95.1-3mdk from Mandrake 8.0
228- added Japanese summary and description
229- modified spec macros for Vine
230
231* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
232- real version is 1.95.1
233- reenable optimisations
234
235* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
236- release .
237
238* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
239- Don't try to use optimizations
240- Bzip2 sources
241
242* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
243- first version
Note: See TracBrowser for help on using the repository browser.