source: projects/specs/trunk/e/expat/expat-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.0.1
4%define release 6%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
15Patch100:       expat-2.0.1_CVE-2009-3560.patch
16Patch110:       expat-2.0.1_CVE-2009-3720.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19Requires:       lib%{name} = %{version}-%{release}
20BuildRequires:  libtool
21
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          System Environment/Libraries
35
36
37%description -n lib%{name}
38This package contains the runtime, shared library of expat, the C
39library for parsing XML.
40
41%description -n lib%{name} -l ja
42Expat を動作させるために必用となるライブラリです.
43
44%package devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          Development/Libraries
48Requires:       lib%{name} = %{version}-%{release}
49
50%description devel
51Development environment for the expat XML parser
52
53%description devel -l ja
54expat XML パーサ用開発環境です.
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-lib%{name}
58Summary:        Runtime library of expat
59Summary(ja):    Expat のための実行ライブラリ
60Group:          System Environment/Libraries
61Requires:       lib%{name} = %{version}-%{release}
62
63%description -n compat32-lib%{name}
64This package contains the runtime, shared library of expat, the C
65library for parsing XML.
66
67%description -n compat32-lib%{name} -l ja
68Expat を動作させるために必用となるライブラリです.
69
70%package -n compat32-%{name}-devel
71Summary:        Development environment for the expat XML parser
72Summary(ja):    expat XML パーサ用開発環境
73Group:          Development/Libraries
74Requires:       %{name}-devel = %{version}-%{release}
75Requires:       compat32-lib%{name} = %{version}-%{release}
76
77%description -n compat32-%{name}-devel
78Development environment for the expat XML parser
79
80%description -n compat32-%{name}-devel -l ja
81expat XML パーサ用開発環境です.
82
83%prep
84%setup -q
85%patch100 -p1 -b .CVE-2009-3560
86%patch110 -p1 -b .CVE-2009-3720
87
88%build
89export CFLAGS="$RPM_OPT_FLAGS -fPIC"
90%configure --enable-shared
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96rm -f examples/*.dsp
97chmod 644 README COPYING Changes doc/* examples/*
98
99make DESTDIR=$RPM_BUILD_ROOT install
100rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -n lib%{name} -p /sbin/ldconfig
106
107%postun -n lib%{name} -p /sbin/ldconfig
108
109%post -n compat32-lib%{name} -p /sbin/ldconfig
110
111%postun -n compat32-lib%{name} -p /sbin/ldconfig
112
113%files
114%defattr(-,root,root)
115%doc COPYING Changes README
116%{_bindir}/xmlwf
117%{_mandir}/man1/xmlwf.1*
118
119%files -n lib%{name}
120%defattr(-,root,root)
121%doc COPYING Changes README
122%{_libdir}/libexpat.so.*
123
124%files devel
125%defattr(-,root,root)
126%doc COPYING Changes README doc/* examples
127%{_includedir}/*
128%{_libdir}/libexpat.a
129%{_libdir}/libexpat.so
130
131## to build compat32 for x86_64 architecture support
132%if %{build_compat32}
133%files -n compat32-lib%{name}
134%defattr(-,root,root)
135%{_libdir}/libexpat.so.*
136
137%files -n compat32-%{name}-devel
138%defattr(-,root,root)
139%{_libdir}/libexpat.a
140%{_libdir}/libexpat.so
141%endif
142
143%changelog
144* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
145- rebuilt with gcc-4.4.3-3 on ppc
146
147* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
148- rebuilt with new toolchains (for VineSeed)
149
150* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
151- add patch110 for fix CVE-2009-3720 (xml parser)
152
153* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
154- add Patch100 for fix CVE-2009-3560 (xml parser)
155
156* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
157- added Requires: tag to compat32-* sub-packages.
158- removed unnecessary %%configure CC='gcc -m32' option
159
160* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
161- applied new versioning policy and spec in utf-8
162
163* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
164- removed %%if !%%{build_compat32} case condition
165
166* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
167- new upstream release
168- drop Patch0
169- drop .la
170- chmod 644 the documentation
171- strip DSP files from examples
172- update description and drop description-ja
173- add -fPIC
174
175* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
176- rebuilt
177
178* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
179- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
180
181* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
182- added compat32* packages for x86_64 architecture support
183
184* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
185- add missing header file (expat_external.h) to %%files.
186
187* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
188- updated/revised Patch1 (%%install will fail without this patch)
189
190* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
191- new upstream release
192        -- dropped patch1
193
194* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
195- updated to 1.95.7
196- changed URL and Group
197- fixed License to MIT/X (based on rpm package at sourceforge)
198
199* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
200- version up to 1.95.6
201- drop expat-xmlwf-dynamiclink.patch (Patch0)
202- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
203- add manpage (xmlwf.1)
204
205* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
206- fixed license ( s/MPL or GPL/distributable/ )
207- use License tag
208
209* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
210- new sub-package libexpat.
211- added BuildPreReq: libtool
212
213* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
214- updated to 1.95.2 release
215
216* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
217- 1.95.1-3vl1
218- based on 1.95.1-3mdk from Mandrake 8.0
219- added Japanese summary and description
220- modified spec macros for Vine
221
222* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
223- real version is 1.95.1
224- reenable optimisations
225
226* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
227- release .
228
229* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
230- Don't try to use optimizations
231- Bzip2 sources
232
233* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
234- first version
Note: See TracBrowser for help on using the repository browser.