source: projects/specs/trunk/e/expat/expat-vl.spec @ 12277

Revision 12277, 7.9 KB checked in by tomop, 5 years ago (diff)

updated 22 packages

Cython-0.29.13-1

alsa-lib-1.1.9-1

alsa-plugins-1.1.9-1

alsa-tools-1.1.7-1

alsa-utils-1.1.9-1

cairo-1.16.0-1

evince-3.30.3-1

expat-2.2.9-1

file-roller-3.30.1-1

gtk-doc-1.32-2

libplist-2.0.0-1

libsndfile-1.0.28-1

ncurses-6.1-2

openssh-8.1p1-1

python-2.7.16-5

python3-3.5.7-4

rsync-3.1.3-1

samba-4.10.9-1

sudo-1.8.28-1

sysstat-12.1.7-1

tix-8.4.3-5

zabbix-4.0.13-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.2.9
4%define release 1%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildRequires:  libtool
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          System Environment/Libraries
35
36
37%description -n lib%{name}
38This package contains the runtime, shared library of expat, the C
39library for parsing XML.
40
41%description -n lib%{name} -l ja
42Expat を動作させるために必用となるライブラリです.
43
44%package devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          Development/Libraries
48Requires:       lib%{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description devel
52Development environment for the expat XML parser
53
54%description devel -l ja
55expat XML パーサ用開発環境です.
56
57## to build compat32 for x86_64 architecture support
58%package -n compat32-lib%{name}
59Summary:        Runtime library of expat
60Summary(ja):    Expat のための実行ライブラリ
61Group:          System Environment/Libraries
62Requires:       lib%{name} = %{version}-%{release}
63
64%description -n compat32-lib%{name}
65This package contains the runtime, shared library of expat, the C
66library for parsing XML.
67
68%description -n compat32-lib%{name} -l ja
69Expat を動作させるために必用となるライブラリです.
70
71%package -n compat32-%{name}-devel
72Summary:        Development environment for the expat XML parser
73Summary(ja):    expat XML パーサ用開発環境
74Group:          Development/Libraries
75Requires:       %{name}-devel = %{version}-%{release}
76Requires:       compat32-lib%{name} = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79Development environment for the expat XML parser
80
81%description -n compat32-%{name}-devel -l ja
82expat XML パーサ用開発環境です.
83
84%prep
85%setup -q
86
87%build
88export CFLAGS="$RPM_OPT_FLAGS -fPIC"
89%configure --enable-shared
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95rm -f examples/*.dsp
96chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
97
98make DESTDIR=$RPM_BUILD_ROOT install
99rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
100
101rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
102
103mkdir -p %{buildroot}%{_mandir}/man1
104install -m644 doc/xmlwf.1 %{buildroot}%{_mandir}/man1/
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -n lib%{name} -p /sbin/ldconfig
110
111%postun -n lib%{name} -p /sbin/ldconfig
112
113%post -n compat32-lib%{name} -p /sbin/ldconfig
114
115%postun -n compat32-lib%{name} -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root)
119%license COPYING
120%doc AUTHORS Changes README.md
121%{_bindir}/xmlwf
122%{_mandir}/man1/xmlwf.1*
123
124%files -n lib%{name}
125%defattr(-,root,root)
126%license COPYING
127%doc AUTHORS Changes README.md
128%{_libdir}/libexpat.so.*
129
130%files devel
131%defattr(-,root,root)
132%license COPYING
133%doc AUTHORS Changes README.md
134%doc doc/* examples
135%{_includedir}/*
136%{_libdir}/libexpat.a
137%{_libdir}/libexpat.so
138%{_libdir}/pkgconfig/%{name}.pc
139
140## to build compat32 for x86_64 architecture support
141%if %{build_compat32}
142%files -n compat32-lib%{name}
143%defattr(-,root,root)
144%{_libdir}/libexpat.so.*
145
146%files -n compat32-%{name}-devel
147%defattr(-,root,root)
148%{_libdir}/libexpat.a
149%{_libdir}/libexpat.so
150%endif
151
152%changelog
153* Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
154- new upstream release.
155
156* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
157- new upstream release.
158
159* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
160- new upstream release.
161
162* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
163- new upstream release.
164
165* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
166- rebuild with VineSeed environment
167
168* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
169- update to 2.1.0
170- remove old patches
171
172* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
173- update patch100 to regrassion fix (same as debian bug #561658)
174- add Vendor and Distribution tags
175
176* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
177- rebuilt with rpm-4.8.1-3
178
179* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
180- rebuilt with gcc-4.4.3-3 on ppc
181
182* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
183- rebuilt with new toolchains (for VineSeed)
184
185* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
186- add patch110 for fix CVE-2009-3720 (xml parser)
187
188* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
189- add Patch100 for fix CVE-2009-3560 (xml parser)
190
191* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
192- added Requires: tag to compat32-* sub-packages.
193- removed unnecessary %%configure CC='gcc -m32' option
194
195* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
196- applied new versioning policy and spec in utf-8
197
198* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
199- removed %%if !%%{build_compat32} case condition
200
201* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
202- new upstream release
203- drop Patch0
204- drop .la
205- chmod 644 the documentation
206- strip DSP files from examples
207- update description and drop description-ja
208- add -fPIC
209
210* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
211- rebuilt
212
213* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
214- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
215
216* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
217- added compat32* packages for x86_64 architecture support
218
219* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
220- add missing header file (expat_external.h) to %%files.
221
222* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
223- updated/revised Patch1 (%%install will fail without this patch)
224
225* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
226- new upstream release
227        -- dropped patch1
228
229* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
230- updated to 1.95.7
231- changed URL and Group
232- fixed License to MIT/X (based on rpm package at sourceforge)
233
234* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
235- version up to 1.95.6
236- drop expat-xmlwf-dynamiclink.patch (Patch0)
237- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
238- add manpage (xmlwf.1)
239
240* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
241- fixed license ( s/MPL or GPL/distributable/ )
242- use License tag
243
244* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
245- new sub-package libexpat.
246- added BuildPreReq: libtool
247
248* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
249- updated to 1.95.2 release
250
251* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
252- 1.95.1-3vl1
253- based on 1.95.1-3mdk from Mandrake 8.0
254- added Japanese summary and description
255- modified spec macros for Vine
256
257* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
258- real version is 1.95.1
259- reenable optimisations
260
261* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
262- release .
263
264* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
265- Don't try to use optimizations
266- Bzip2 sources
267
268* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
269- first version
Note: See TracBrowser for help on using the repository browser.