source: projects/specs/trunk/e/expat/expat-vl.spec @ 12106

Revision 12106, 7.7 KB checked in by tomop, 5 years ago (diff)

expat-2.2.6-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.2.6
4%define release 1%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildRequires:  libtool
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          System Environment/Libraries
35
36
37%description -n lib%{name}
38This package contains the runtime, shared library of expat, the C
39library for parsing XML.
40
41%description -n lib%{name} -l ja
42Expat を動作させるために必用となるライブラリです.
43
44%package devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          Development/Libraries
48Requires:       lib%{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description devel
52Development environment for the expat XML parser
53
54%description devel -l ja
55expat XML パーサ用開発環境です.
56
57## to build compat32 for x86_64 architecture support
58%package -n compat32-lib%{name}
59Summary:        Runtime library of expat
60Summary(ja):    Expat のための実行ライブラリ
61Group:          System Environment/Libraries
62Requires:       lib%{name} = %{version}-%{release}
63
64%description -n compat32-lib%{name}
65This package contains the runtime, shared library of expat, the C
66library for parsing XML.
67
68%description -n compat32-lib%{name} -l ja
69Expat を動作させるために必用となるライブラリです.
70
71%package -n compat32-%{name}-devel
72Summary:        Development environment for the expat XML parser
73Summary(ja):    expat XML パーサ用開発環境
74Group:          Development/Libraries
75Requires:       %{name}-devel = %{version}-%{release}
76Requires:       compat32-lib%{name} = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79Development environment for the expat XML parser
80
81%description -n compat32-%{name}-devel -l ja
82expat XML パーサ用開発環境です.
83
84%prep
85%setup -q
86
87%build
88export CFLAGS="$RPM_OPT_FLAGS -fPIC"
89%configure --enable-shared
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95rm -f examples/*.dsp
96chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
97
98make DESTDIR=$RPM_BUILD_ROOT install
99rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
100
101rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -n lib%{name} -p /sbin/ldconfig
107
108%postun -n lib%{name} -p /sbin/ldconfig
109
110%post -n compat32-lib%{name} -p /sbin/ldconfig
111
112%postun -n compat32-lib%{name} -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root)
116%license COPYING
117%doc AUTHORS Changes README.md
118%{_bindir}/xmlwf
119%{_mandir}/man1/xmlwf.1*
120
121%files -n lib%{name}
122%defattr(-,root,root)
123%license COPYING
124%doc AUTHORS Changes README.md
125%{_libdir}/libexpat.so.*
126
127%files devel
128%defattr(-,root,root)
129%license COPYING
130%doc AUTHORS Changes README.md
131%doc doc/* examples
132%{_includedir}/*
133%{_libdir}/libexpat.a
134%{_libdir}/libexpat.so
135%{_libdir}/pkgconfig/%{name}.pc
136
137## to build compat32 for x86_64 architecture support
138%if %{build_compat32}
139%files -n compat32-lib%{name}
140%defattr(-,root,root)
141%{_libdir}/libexpat.so.*
142
143%files -n compat32-%{name}-devel
144%defattr(-,root,root)
145%{_libdir}/libexpat.a
146%{_libdir}/libexpat.so
147%endif
148
149%changelog
150* Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
151- new upstream release.
152
153* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
154- new upstream release.
155
156* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
157- new upstream release.
158
159* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
160- rebuild with VineSeed environment
161
162* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
163- update to 2.1.0
164- remove old patches
165
166* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
167- update patch100 to regrassion fix (same as debian bug #561658)
168- add Vendor and Distribution tags
169
170* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
171- rebuilt with rpm-4.8.1-3
172
173* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
174- rebuilt with gcc-4.4.3-3 on ppc
175
176* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
177- rebuilt with new toolchains (for VineSeed)
178
179* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
180- add patch110 for fix CVE-2009-3720 (xml parser)
181
182* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
183- add Patch100 for fix CVE-2009-3560 (xml parser)
184
185* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
186- added Requires: tag to compat32-* sub-packages.
187- removed unnecessary %%configure CC='gcc -m32' option
188
189* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
190- applied new versioning policy and spec in utf-8
191
192* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
193- removed %%if !%%{build_compat32} case condition
194
195* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
196- new upstream release
197- drop Patch0
198- drop .la
199- chmod 644 the documentation
200- strip DSP files from examples
201- update description and drop description-ja
202- add -fPIC
203
204* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
205- rebuilt
206
207* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
208- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
209
210* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
211- added compat32* packages for x86_64 architecture support
212
213* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
214- add missing header file (expat_external.h) to %%files.
215
216* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
217- updated/revised Patch1 (%%install will fail without this patch)
218
219* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
220- new upstream release
221        -- dropped patch1
222
223* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
224- updated to 1.95.7
225- changed URL and Group
226- fixed License to MIT/X (based on rpm package at sourceforge)
227
228* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
229- version up to 1.95.6
230- drop expat-xmlwf-dynamiclink.patch (Patch0)
231- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
232- add manpage (xmlwf.1)
233
234* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
235- fixed license ( s/MPL or GPL/distributable/ )
236- use License tag
237
238* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
239- new sub-package libexpat.
240- added BuildPreReq: libtool
241
242* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
243- updated to 1.95.2 release
244
245* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
246- 1.95.1-3vl1
247- based on 1.95.1-3mdk from Mandrake 8.0
248- added Japanese summary and description
249- modified spec macros for Vine
250
251* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
252- real version is 1.95.1
253- reenable optimisations
254
255* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
256- release .
257
258* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
259- Don't try to use optimizations
260- Bzip2 sources
261
262* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
263- first version
Note: See TracBrowser for help on using the repository browser.