source: projects/specs/trunk/e/expat/expat-vl.spec @ 11551

Revision 11551, 7.6 KB checked in by tomop, 6 years ago (diff)

expat-2.2.5-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.2.5
4%define release 1%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildRequires:  libtool
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          System Environment/Libraries
35
36
37%description -n lib%{name}
38This package contains the runtime, shared library of expat, the C
39library for parsing XML.
40
41%description -n lib%{name} -l ja
42Expat を動作させるために必用となるライブラリです.
43
44%package devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          Development/Libraries
48Requires:       lib%{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description devel
52Development environment for the expat XML parser
53
54%description devel -l ja
55expat XML パーサ用開発環境です.
56
57## to build compat32 for x86_64 architecture support
58%package -n compat32-lib%{name}
59Summary:        Runtime library of expat
60Summary(ja):    Expat のための実行ライブラリ
61Group:          System Environment/Libraries
62Requires:       lib%{name} = %{version}-%{release}
63
64%description -n compat32-lib%{name}
65This package contains the runtime, shared library of expat, the C
66library for parsing XML.
67
68%description -n compat32-lib%{name} -l ja
69Expat を動作させるために必用となるライブラリです.
70
71%package -n compat32-%{name}-devel
72Summary:        Development environment for the expat XML parser
73Summary(ja):    expat XML パーサ用開発環境
74Group:          Development/Libraries
75Requires:       %{name}-devel = %{version}-%{release}
76Requires:       compat32-lib%{name} = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79Development environment for the expat XML parser
80
81%description -n compat32-%{name}-devel -l ja
82expat XML パーサ用開発環境です.
83
84%prep
85%setup -q
86
87%build
88export CFLAGS="$RPM_OPT_FLAGS -fPIC"
89%configure --enable-shared
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95rm -f examples/*.dsp
96chmod 644 AUTHORS README.md COPYING Changes doc/* examples/*
97
98make DESTDIR=$RPM_BUILD_ROOT install
99rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
100
101rm -rf $RPM_BUILD_ROOT/%{_datadir}/doc/expat
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -n lib%{name} -p /sbin/ldconfig
107
108%postun -n lib%{name} -p /sbin/ldconfig
109
110%post -n compat32-lib%{name} -p /sbin/ldconfig
111
112%postun -n compat32-lib%{name} -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root)
116%doc AUTHORS COPYING Changes README.md
117%{_bindir}/xmlwf
118%{_mandir}/man1/xmlwf.1*
119
120%files -n lib%{name}
121%defattr(-,root,root)
122%doc AUTHORS COPYING Changes README.md
123%{_libdir}/libexpat.so.*
124
125%files devel
126%defattr(-,root,root)
127%doc AUTHORS COPYING Changes README.md
128%doc doc/* examples
129%{_includedir}/*
130%{_libdir}/libexpat.a
131%{_libdir}/libexpat.so
132%{_libdir}/pkgconfig/%{name}.pc
133
134## to build compat32 for x86_64 architecture support
135%if %{build_compat32}
136%files -n compat32-lib%{name}
137%defattr(-,root,root)
138%{_libdir}/libexpat.so.*
139
140%files -n compat32-%{name}-devel
141%defattr(-,root,root)
142%{_libdir}/libexpat.a
143%{_libdir}/libexpat.so
144%endif
145
146%changelog
147* Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
148- new upstream release.
149
150* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.0-1
151- new upstream release.
152
153* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
154- rebuild with VineSeed environment
155
156* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
157- update to 2.1.0
158- remove old patches
159
160* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
161- update patch100 to regrassion fix (same as debian bug #561658)
162- add Vendor and Distribution tags
163
164* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
165- rebuilt with rpm-4.8.1-3
166
167* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
168- rebuilt with gcc-4.4.3-3 on ppc
169
170* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
171- rebuilt with new toolchains (for VineSeed)
172
173* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
174- add patch110 for fix CVE-2009-3720 (xml parser)
175
176* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
177- add Patch100 for fix CVE-2009-3560 (xml parser)
178
179* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
180- added Requires: tag to compat32-* sub-packages.
181- removed unnecessary %%configure CC='gcc -m32' option
182
183* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
184- applied new versioning policy and spec in utf-8
185
186* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
187- removed %%if !%%{build_compat32} case condition
188
189* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
190- new upstream release
191- drop Patch0
192- drop .la
193- chmod 644 the documentation
194- strip DSP files from examples
195- update description and drop description-ja
196- add -fPIC
197
198* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
199- rebuilt
200
201* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
202- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
203
204* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
205- added compat32* packages for x86_64 architecture support
206
207* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
208- add missing header file (expat_external.h) to %%files.
209
210* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
211- updated/revised Patch1 (%%install will fail without this patch)
212
213* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
214- new upstream release
215        -- dropped patch1
216
217* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
218- updated to 1.95.7
219- changed URL and Group
220- fixed License to MIT/X (based on rpm package at sourceforge)
221
222* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
223- version up to 1.95.6
224- drop expat-xmlwf-dynamiclink.patch (Patch0)
225- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
226- add manpage (xmlwf.1)
227
228* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
229- fixed license ( s/MPL or GPL/distributable/ )
230- use License tag
231
232* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
233- new sub-package libexpat.
234- added BuildPreReq: libtool
235
236* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
237- updated to 1.95.2 release
238
239* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
240- 1.95.1-3vl1
241- based on 1.95.1-3mdk from Mandrake 8.0
242- added Japanese summary and description
243- modified spec macros for Vine
244
245* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
246- real version is 1.95.1
247- reenable optimisations
248
249* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
250- release .
251
252* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
253- Don't try to use optimizations
254- Bzip2 sources
255
256* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
257- first version
Note: See TracBrowser for help on using the repository browser.