source: projects/specs/trunk/e/expat/expat-vl.spec @ 8084

Revision 8084, 7.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.1.0
4%define release 2%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17Requires:       lib%{name} = %{version}-%{release}
18BuildRequires:  libtool
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This is Expat, a C library for parsing XML, written by James Clark.
25Expat is a stream-oriented XML parser.  This means that you register
26handlers with the parser before starting the parse.  These handlers
27are called when the parser discovers the associated structures in the
28document being parsed.  A start tag is an example of the kind of
29structures for which you may register handlers.
30
31%package -n lib%{name}
32Summary:        Runtime library of expat
33Summary(ja):    Expat のための実行ライブラリ
34Group:          System Environment/Libraries
35
36
37%description -n lib%{name}
38This package contains the runtime, shared library of expat, the C
39library for parsing XML.
40
41%description -n lib%{name} -l ja
42Expat を動作させるために必用となるライブラリです.
43
44%package devel
45Summary:        Development environment for the expat XML parser
46Summary(ja):    expat XML パーサ用開発環境
47Group:          Development/Libraries
48Requires:       lib%{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description devel
52Development environment for the expat XML parser
53
54%description devel -l ja
55expat XML パーサ用開発環境です.
56
57## to build compat32 for x86_64 architecture support
58%package -n compat32-lib%{name}
59Summary:        Runtime library of expat
60Summary(ja):    Expat のための実行ライブラリ
61Group:          System Environment/Libraries
62Requires:       lib%{name} = %{version}-%{release}
63
64%description -n compat32-lib%{name}
65This package contains the runtime, shared library of expat, the C
66library for parsing XML.
67
68%description -n compat32-lib%{name} -l ja
69Expat を動作させるために必用となるライブラリです.
70
71%package -n compat32-%{name}-devel
72Summary:        Development environment for the expat XML parser
73Summary(ja):    expat XML パーサ用開発環境
74Group:          Development/Libraries
75Requires:       %{name}-devel = %{version}-%{release}
76Requires:       compat32-lib%{name} = %{version}-%{release}
77
78%description -n compat32-%{name}-devel
79Development environment for the expat XML parser
80
81%description -n compat32-%{name}-devel -l ja
82expat XML パーサ用開発環境です.
83
84%prep
85%setup -q
86
87%build
88export CFLAGS="$RPM_OPT_FLAGS -fPIC"
89%configure --enable-shared
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95rm -f examples/*.dsp
96chmod 644 README COPYING Changes doc/* examples/*
97
98make DESTDIR=$RPM_BUILD_ROOT install
99rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post -n lib%{name} -p /sbin/ldconfig
105
106%postun -n lib%{name} -p /sbin/ldconfig
107
108%post -n compat32-lib%{name} -p /sbin/ldconfig
109
110%postun -n compat32-lib%{name} -p /sbin/ldconfig
111
112%files
113%defattr(-,root,root)
114%doc COPYING Changes README
115%{_bindir}/xmlwf
116%{_mandir}/man1/xmlwf.1*
117
118%files -n lib%{name}
119%defattr(-,root,root)
120%doc COPYING Changes README
121%{_libdir}/libexpat.so.*
122
123%files devel
124%defattr(-,root,root)
125%doc COPYING Changes README doc/* examples
126%{_includedir}/*
127%{_libdir}/libexpat.a
128%{_libdir}/libexpat.so
129%{_libdir}/pkgconfig/%{name}.pc
130
131## to build compat32 for x86_64 architecture support
132%if %{build_compat32}
133%files -n compat32-lib%{name}
134%defattr(-,root,root)
135%{_libdir}/libexpat.so.*
136
137%files -n compat32-%{name}-devel
138%defattr(-,root,root)
139%{_libdir}/libexpat.a
140%{_libdir}/libexpat.so
141%endif
142
143%changelog
144* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-2
145- rebuild with VineSeed environment
146
147* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
148- update to 2.1.0
149- remove old patches
150
151* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
152- update patch100 to regrassion fix (same as debian bug #561658)
153- add Vendor and Distribution tags
154
155* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
156- rebuilt with rpm-4.8.1-3
157
158* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
159- rebuilt with gcc-4.4.3-3 on ppc
160
161* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
162- rebuilt with new toolchains (for VineSeed)
163
164* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
165- add patch110 for fix CVE-2009-3720 (xml parser)
166
167* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
168- add Patch100 for fix CVE-2009-3560 (xml parser)
169
170* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
171- added Requires: tag to compat32-* sub-packages.
172- removed unnecessary %%configure CC='gcc -m32' option
173
174* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
175- applied new versioning policy and spec in utf-8
176
177* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
178- removed %%if !%%{build_compat32} case condition
179
180* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
181- new upstream release
182- drop Patch0
183- drop .la
184- chmod 644 the documentation
185- strip DSP files from examples
186- update description and drop description-ja
187- add -fPIC
188
189* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
190- rebuilt
191
192* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
193- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
194
195* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
196- added compat32* packages for x86_64 architecture support
197
198* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
199- add missing header file (expat_external.h) to %%files.
200
201* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
202- updated/revised Patch1 (%%install will fail without this patch)
203
204* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
205- new upstream release
206        -- dropped patch1
207
208* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
209- updated to 1.95.7
210- changed URL and Group
211- fixed License to MIT/X (based on rpm package at sourceforge)
212
213* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
214- version up to 1.95.6
215- drop expat-xmlwf-dynamiclink.patch (Patch0)
216- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
217- add manpage (xmlwf.1)
218
219* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
220- fixed license ( s/MPL or GPL/distributable/ )
221- use License tag
222
223* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
224- new sub-package libexpat.
225- added BuildPreReq: libtool
226
227* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
228- updated to 1.95.2 release
229
230* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
231- 1.95.1-3vl1
232- based on 1.95.1-3mdk from Mandrake 8.0
233- added Japanese summary and description
234- modified spec macros for Vine
235
236* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
237- real version is 1.95.1
238- reenable optimisations
239
240* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
241- release .
242
243* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
244- Don't try to use optimizations
245- Bzip2 sources
246
247* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
248- first version
Note: See TracBrowser for help on using the repository browser.