source: projects/specs/trunk/e/exiv2/exiv2-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: exiv2
2Version: 0.18.2
3Release: 1%{?_dist_release}
4Summary: Exif and IPTC metadata manipulation library
5Summary(ja): Exif, IPTC メタデータ操作ライブラリ
6License: GPL
7Group: System Environment/Libraries
8URL: http://www.exiv2.org/
9Source0: %{name}-%{version}.tar.gz
10Patch1: exiv2-0.18-deps.patch
11Patch2: exiv2-0.16-gcc43.patch
12Patch3: exiv2-0.18.1-visibility.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: expat-devel
16BuildRequires: zlib-devel
17Obsoletes: libexiv2 <= 0.13
18Provides:  libexiv2 = %{version}-%{release}
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24Exiv2 comprises of a C++ library and a command line utility to access image metadata. Exiv2 supports full read and write access to the Exif and Iptc metadata, Exif MakerNote support, extract and delete methods for Exif thumbnails, classes to access Ifd and so on.
25The command line utility allows you to:
26
27* print the Exif metadata of Jpeg images as summary info, interpreted values,
28or the plain data for each tag (here is a sample)
29* print the IPTC metadata of Jpeg images
30* print the Jpeg comment of Jpeg images
31* set, add and delete Exif and Iptc metadata of Jpeg images
32* adjust the Exif timestamp (that's how it all started...)
33* rename Exif image files according to the Exif timestamp
34* extract, insert and delete Exif metadata, IPTC metadata and Jpeg comments
35* extract, insert and delete the thumbnail image embedded in the Exif metadata
36
37%description -l ja
38Exiv2 は、イメージメタデータにアクセスするための C++ ライブラリと
39コマンドラインユーティリティにより構成されています.Exiv2 は Exif,
40IPTC メタデータの完全な読込み及び書込みアクセス,Exif MakerNote,
41Exif サムネイルを抽出/削除するためのメソッド,Ifd 等にアクセスする
42ためのクラス等をサポートします.
43
44コマンドラインユーティリティにより、次のようなことができます:
45
46* JPEG イメージの EXIF メタデータを各タグごとに表示する
47* JPEG イメージの IPTC メタデータを表示する
48* JPEG イメージのコメントを表示する
49* JPEG イメージに EXIF 情報や IPTC メタデータを設定/追加/削除する
50* EXIF タイムスタンプを調整する
51* EXIF タイムスタンプに基づいて EXIF イメージファイルをリネームする
52* EXIF メタデータ,IPTC メタデータ,JPEG コメントを抽出/挿入/削除する
53* EXIF メタデータ中のサムネイルイメージを抽出/挿入/削除する
54
55#'
56%package devel
57Summary: Header files, libraries and development documentation for exiv2
58Summary(ja): exiv2 の開発用ファイル
59Group: Development/Libraries
60Requires: %{name} = %{version}-%{release}
61Requires: pkgconfig
62Obsoletes: libexiv2-devel <= 0.13
63Provides: libexiv2-devel = %{version}-%{release}
64
65
66%description devel
67Header files, libraries and development documentation for exiv2
68
69%description -l ja
70exiv2 のためのヘッダファイル,ライブラリ,開発用のドキュメンテーションです.
71
72
73%prep
74%setup -q
75%patch1 -p1 -b .deps
76%patch2 -p1 -b .gcc43
77%patch3 -p1 -b .visibility
78
79
80%build
81(cd config; make -f config.make)
82%configure --disable-static --disable-rpath
83make %{?_smp_mflags}
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89make install DESTDIR=$RPM_BUILD_ROOT
90
91%find_lang exiv2
92
93# Unpackaged files
94rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
95
96# set eXecute bit on installed lib
97chmod a+x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
98
99## FIXME/TODO: patch installed exiv2-config to instead pull values from pkgconfig
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104
105%post -p /sbin/ldconfig
106
107%postun -p /sbin/ldconfig
108
109
110%files -f %{name}.lang
111%defattr(-,root,root,-)
112%doc COPYING README
113%{_bindir}/exiv2
114%{_libdir}/lib*.so.*
115%{_mandir}/man1/*
116
117
118%files devel
119%defattr(-,root,root,-)
120#doc doc/index.html doc/include
121#{_bindir}/exiv2-config
122%{_includedir}/exiv2/*
123%{_libdir}/libexiv2.so
124%{_libdir}/pkgconfig/exiv2.pc
125
126
127%changelog
128* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.2-1
129- new upstream release
130- updated Japanese description
131
132* Fri May  1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.18.1-2
133- add Patch3 not to use -fvisibility-inlines-hidden
134  (this will also fix build failure on ppc)
135  http://dev.exiv2.org/issues/show/627
136
137* Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.1-1
138- new upstream release
139
140* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.1-1vl5
141- new upstream release
142
143* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Wed Dec 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.15-0vl4
147- add patch100 for fix CVE-2007-6353 ("setDataArea()" Integer OF)
148
149* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-0vl3
150- add Obsoletes: libexiv2 <= 0.13 , libexiv2-devel <= 0.13
151  to upgrade from 0.13-0vl[12]
152  * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
153  - rebuild with new environment/toolchain
154  * Fri Mar 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl1
155  - initial build for Vine Linux
156 
157* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl2
158- rebuilt for VineSeed
159
160* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
161- new upstream release
162- remove Requires: kdelibs-devel at devel package
163
164* Fri Jan 5 2007 TOSHI <vine-jp@mail.goo.ne.jp> 0.12-0vl1
165- build for vine 4.0
166
167* Tue Nov 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.12-1
168- exiv2-0.12
169# end of file
170
Note: See TracBrowser for help on using the repository browser.