source: projects/specs/trunk/e/exiv2/exiv2-vl.spec @ 12310

Revision 12310, 6.7 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Name: exiv2
4Summary: Exif and IPTC metadata manipulation library
5Summary(ja): Exif, IPTC メタデータ操作ライブラリ
6Version: 0.27.2
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: GPLv2
11URL: https://www.exiv2.org/
12
13Source0: https://www.exiv2.org/builds/exiv2-%{version}-Source.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: cmake
17BuildRequires: expat-devel
18BuildRequires: gettext
19BuildRequires: pkgconfig
20BuildRequires: curl-devel
21BuildRequires: libssh-devel
22BuildRequires: zlib-devel
23
24Obsoletes: libexiv2 <= 0.13
25Provides:  libexiv2 = %{version}-%{release}
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Exiv2 comprises of a C++ library and a command line utility to access image metadata. Exiv2 supports full read and write access to the Exif and Iptc metadata, Exif MakerNote support, extract and delete methods for Exif thumbnails, classes to access Ifd and so on.
32The command line utility allows you to:
33
34* print the Exif metadata of Jpeg images as summary info, interpreted values,
35or the plain data for each tag (here is a sample)
36* print the IPTC metadata of Jpeg images
37* print the Jpeg comment of Jpeg images
38* set, add and delete Exif and Iptc metadata of Jpeg images
39* adjust the Exif timestamp (that's how it all started...)
40* rename Exif image files according to the Exif timestamp
41* extract, insert and delete Exif metadata, IPTC metadata and Jpeg comments
42* extract, insert and delete the thumbnail image embedded in the Exif metadata
43
44%description -l ja
45Exiv2 は、イメージメタデータにアクセスするための C++ ライブラリと
46コマンドラインユーティリティにより構成されています.Exiv2 は Exif,
47IPTC メタデータの完全な読込み及び書込みアクセス,Exif MakerNote,
48Exif サムネイルを抽出/削除するためのメソッド,Ifd 等にアクセスする
49ためのクラス等をサポートします.
50
51コマンドラインユーティリティにより、次のようなことができます:
52
53* JPEG イメージの EXIF メタデータを各タグごとに表示する
54* JPEG イメージの IPTC メタデータを表示する
55* JPEG イメージのコメントを表示する
56* JPEG イメージに EXIF 情報や IPTC メタデータを設定/追加/削除する
57* EXIF タイムスタンプを調整する
58* EXIF タイムスタンプに基づいて EXIF イメージファイルをリネームする
59* EXIF メタデータ,IPTC メタデータ,JPEG コメントを抽出/挿入/削除する
60* EXIF メタデータ中のサムネイルイメージを抽出/挿入/削除する
61
62#'
63%package devel
64Summary: Header files, libraries and development documentation for exiv2
65Summary(ja): exiv2 の開発用ファイル
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Obsoletes: libexiv2-devel <= 0.13
69Provides: libexiv2-devel = %{version}-%{release}
70
71
72%description devel
73Header files, libraries and development documentation for exiv2
74
75%description -l ja devel
76exiv2 用ヘッダファイル,ライブラリ,開発用ドキュメントです.
77
78
79%prep
80%setup -q -n %{name}-%{version}-Source
81
82
83%build
84%cmake \
85  -DEXIV2_ENABLE_NLS:BOOL=ON \
86  -DEXIV2_BUILD_PO:BOOL=ON \
87  -DEXIV2_BUILD_SAMPLES:BOOL=OFF \
88  -DEXIV2_ENABLE_LIBXMP:BOOL=ON \
89  .
90
91make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96make install/fast DESTDIR=%{buildroot}
97
98%find_lang exiv2 --with-man
99
100## unpackaged files
101rm -fv %{buildroot}%{_libdir}/libexiv2.la
102rm -fv %{buildroot}%{_libdir}/libxmp.a
103rm -fv %{buildroot}%{_libdir}/pkgconfig//exiv2.lsm
104
105# set eXecute bit on installed lib
106chmod a+x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
107
108## FIXME/TODO: patch installed exiv2-config to instead pull values from pkgconfig
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%license COPYING*
122%doc README*
123%{_bindir}/exiv2
124%{_libdir}/lib*.so.*
125%{_mandir}/man1/*
126
127
128%files devel
129%defattr(-,root,root,-)
130#doc doc/index.html doc/include
131#{_bindir}/exiv2-config
132%{_includedir}/exiv2/*
133%{_libdir}/libexiv2.so
134%{_libdir}/*.a
135%{_libdir}/pkgconfig/exiv2.pc
136%dir %{_libdir}/cmake
137%{_libdir}/cmake/*
138#{_datadir}/exiv2
139
140
141%changelog
142* Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27.2-1
143- new upstream release.
144
145* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.27-1
146- new upstream release.
147- dropprd all patches.
148
149* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.25-2
150- rebuilt with new toolchain.
151
152* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.25-1
153- new upstream release
154
155* Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24-1
156- new upstream release
157- add Patch3 (exiv2-0.24-visibility.patch)
158
159* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23-1
160- new upstream release
161
162* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-1
163- new upstream release
164
165* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21.1-1
166- new upstream release
167- updated Patch3
168
169* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-2
170- rebuilt with rpm-4.8.1 for pkg-config
171
172* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.19-1
173- new upstream release
174- updated Patch3
175
176* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.2-1
177- new upstream release
178- updated Japanese description
179
180* Fri May  1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.18.1-2
181- add Patch3 not to use -fvisibility-inlines-hidden
182  (this will also fix build failure on ppc)
183  http://dev.exiv2.org/issues/show/627
184
185* Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18.1-1
186- new upstream release
187
188* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.1-1vl5
189- new upstream release
190
191* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl5
192- applied new versioning policy, spec in utf-8
193
194* Wed Dec 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.15-0vl4
195- add patch100 for fix CVE-2007-6353 ("setDataArea()" Integer OF)
196
197* Sat Aug 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-0vl3
198- add Obsoletes: libexiv2 <= 0.13 , libexiv2-devel <= 0.13
199  to upgrade from 0.13-0vl[12]
200  * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl2
201  - rebuild with new environment/toolchain
202  * Fri Mar 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.13-0vl1
203  - initial build for Vine Linux
204 
205* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl2
206- rebuilt for VineSeed
207
208* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
209- new upstream release
210- remove Requires: kdelibs-devel at devel package
211
212* Fri Jan 5 2007 TOSHI <vine-jp@mail.goo.ne.jp> 0.12-0vl1
213- build for vine 4.0
214
215* Tue Nov 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.12-1
216- exiv2-0.12
217# end of file
218
Note: See TracBrowser for help on using the repository browser.