source: projects/specs/trunk/e/evolution-webcal/evolution-webcal-vl.spec @ 1443

Revision 1443, 4.3 KB checked in by Takemikaduchi, 14 years ago (diff)

pidgin: rebuild only, others: new upstream release

Line 
1%define libsoup_version 2.3.0
2%define eds_version 1.1.0
3
4%define gettext_package evolution-webcal
5
6Name: evolution-webcal
7Summary: A handler for webcal URIs
8Version: 2.28.1
9Release: 1%{?_dist_release}
10License: GPL
11Group: Applications/Internet
12Source0: %{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel >= 2.8.0
16BuildRequires: gtk2-devel >= 2.4.0
17BuildRequires: libsoup-devel >= %{libsoup_version}
18BuildRequires: evolution-data-server-devel >= %{eds_version}
19Requires: libsoup >= %{libsoup_version}
20Requires: evolution-data-server >=  %{eds_version}
21Requires(post): GConf2
22Requires(pre): GConf2
23Requires(preun): GConf2
24
25%description
26evolution-webcal is a small helper application that can be run when webcal URIs are clicked in web browsers.
27It adds the calendar to your evolution-data-server, which will make the calendar appear in Evolution and in the gnome-panel's calendar.
28
29%prep
30%setup -q
31
32%build
33%configure --disable-schemas-install
34make
35
36%install
37rm -rf %{buildroot}
38
39export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
40make DESTDIR=$RPM_BUILD_ROOT install
41unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
42
43%find_lang %{gettext_package}
44grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1
45
46%clean
47rm -rf %{buildroot}
48
49%post
50export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
51SCHEMAS="evolution-webcal.schemas"
52for S in $SCHEMAS; do
53  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
54done
55
56%pre
57if [ "$1" -gt 1 ]; then
58  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
59  SCHEMAS="evolution-webcal.schemas"
60  for S in $SCHEMAS; do
61    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
62  done
63fi
64
65%preun
66if [ "$1" -eq 0 ]; then
67  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
68  SCHEMAS="evolution-webcal.schemas"
69  for S in $SCHEMAS; do
70    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
71  done
72fi
73
74
75%files -f %{gettext_package}.lang
76%defattr(-,root,root)
77%{_sysconfdir}/gconf/schemas/evolution-webcal.schemas
78%{_libexecdir}/evolution-webcal
79
80
81%changelog
82* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.28.1-1
83- new upstream release
84
85* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-1
86- new upstream release
87
88* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
89- new upstream release
90- applied new versioning policy
91- built with evolution-data-server 2.24.2, libsoup 2.24.3
92
93* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.1-1vl2
94- rebuild with gnutls-1.4.1
95
96* Wed Nov  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.4.1-1vl1
97- rebuild for Vine Linux
98
99* Tue Oct 18 2005 David Malcolm <dmalcolm@redhat.com> - 2.4.1-1
100- 2.4.1
101
102* Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 2.4.0.1-2
103- rebuild for new e-d-s
104
105* Wed Sep  7 2005 David Malcolm <dmalcolm@redhat.com> - 2.4.0.1-1
106- 2.4.0.1
107
108* Mon Aug 22 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-3
109- rebuild
110
111* Mon Aug 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-2
112- rebuild
113
114* Tue Aug  9 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.91-1
115- 2.3.91
116
117* Mon Aug  8 2005 Tomas Mraz <tmraz@redhat.com> - 2.3.90-2
118- rebuild with new gnutls
119
120* Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 2.3.90-1
121- 2.3.90
122
123* Wed Mar  9 2005 David Malcolm <dmalcolm@redhat.com> - 2.2.0-1
124- updated from 2.1.92 to 2.2.0
125
126* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.92-1
127- updated from 2.1.91 to 2.1.92
128
129* Wed Feb  9 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.91-1
130- updated from 2.1.4 to 2.1.91
131
132* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.4-2
133- Exclude ppc64 build since mozilla is not supported, hence e-d-s is not supported
134
135* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 2.1.4-1
136- updated from 1.0.10 to 2.1.3
137- removed evolution-webcal.applications; this was removed in version 2.1.1
138- updated e-d-s requirement from 0.0.91 to 1.1.0
139
140* Fri Oct 29 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.10-2
141- added missing requirements on libgnomeui (#137554)
142
143* Wed Sep  1 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.10-1
144- updated from 1.0.9 to 1.0.10
145
146* Mon Aug 30 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.9-2
147- Converted dashes to underscores in version defines; usage should now match up with definition
148
149* Thu Aug 26 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.9-1
150- Initial build.
151
Note: See TracBrowser for help on using the repository browser.