source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9590

Revision 9590, 28.7 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.16
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.16.3
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.16/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: sqlite3-devel
67BuildRequires: libgweather-devel >= %{libgweather_version}
68BuildRequires: libical-devel >= %{libical_version}
69BuildRequires: gperf
70BuildRequires: krb5-devel
71BuildRequires: libgdata-devel >= %{libgdata_version}
72BuildRequires: gnome-online-accounts-devel
73BuildRequires: liboauth-devel
74BuildRequires: libsecret-devel
75BuildRequires: libicu-devel
76BuildRequires: gnome-common
77
78BuildRequires: vala
79BuildRequires: vala-tools
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104Obsoletes: %{name}-doc < 3.16.3
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110The evolution-data-server package provides a unified backend for
111programs that work with contacts, tasks, and calendar information.
112
113It was originally developed for Evolution (hence the name), but
114is now used by other packages.
115
116
117%package devel
118Summary: Development files for building against evolution-data-server
119Group: Development/Libraries
120Requires: %{name} = %{version}-%{release}
121Requires: pkgconfig
122Requires: sqlite3-devel
123Requires: libgnome-keyring-devel
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129
130%package        vala
131Summary:        Vala bindings for %{name}
132Summary(ja):    %{name} の Vala バインディング
133Group:          Development/Libraries
134Requires:       %{name} = %{version}-%{release}
135Requires:       vala
136
137%description    vala
138Vala bindings for %{name}.
139
140
141%prep
142%setup -q
143
144%patch12 -p1 -b .fix-64bit-acinclude
145
146mkdir -p krb5-fakeprefix/include
147mkdir -p krb5-fakeprefix/lib
148mkdir -p krb5-fakeprefix/%{_lib}
149
150%build
151%if %{ldap_support}
152
153%if %{static_ldap}
154%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
155# Set LIBS so that configure will be able to link with static LDAP libraries,
156# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
157if pkg-config libssl ; then
158        export LIBS="-lsasl2 `pkg-config --libs libssl`"
159else
160        export LIBS="-lsasl2 -lssl -lcrypto"
161fi
162%else
163%define ldap_flags --with-openldap=yes
164%endif
165
166%else
167%define ldap_flags --without-openldap
168%endif
169
170%if %{krb5_support}
171%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
172%else
173%define krb5_flags --without-krb5
174%endif
175
176%if %{nntp_support}
177%define nntp_flags --enable-nntp=yes
178%else
179%define nntp_flags --enable-nntp=no
180%endif
181
182%if %{use_nss}
183%define ssl_flags --enable-nss=yes --enable-smime=yes
184%else
185%define ssl_flags --enable-openssl=yes
186%endif
187
188%if %{use_nss}
189if ! pkg-config --exists nss; then
190  echo "Unable to find suitable version of nss to use!"
191  exit 1
192fi
193%endif
194
195%if %{use_gnome_keyring}
196%define keyring_flags --enable-gnome-keyring
197%else
198%define keyring flags --disable-gnome-keyring
199%endif
200
201%if %{support_imap4_provider}
202%define imap4_flags --enable-imap4=yes
203%else
204%define imap4_flags --enable-imap4=no
205%endif
206
207export CPPFLAGS="-I%{_includedir}/et"
208export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
209
210# Regenerate configure to pick up configure.in and acinclude.m4 changes.
211autoreconf -if
212
213# See Ross Burton's blog entry for why we want --with-libdb.
214# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
215
216%configure \
217        --with-libdb=/usr \
218        --disable-uoa \
219        --enable-file-locking=fcntl \
220        --enable-dot-locking=no \
221        --disable-gtk-doc \
222        --enable-introspection=yes \
223        --enable-vala-bindings \
224        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
225        %keyring_flags
226export tagname=CC
227make %{?_smp_mflags}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231export tagname=CC
232make DESTDIR=$RPM_BUILD_ROOT install
233
234# remove libtool archives for importers and the like
235find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
236find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
237
238# give the libraries some executable bits
239find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
240
241%find_lang %{name}-%{eds_base_version}
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post -p /sbin/ldconfig
247
248%postun
249/sbin/ldconfig
250if [ $1 -eq 0 ]; then
251  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
252fi
253
254%posttrans
255glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256
257
258%files -f %{name}-%{eds_base_version}.lang
259%defattr(-,root,root,-)
260%doc README COPYING ChangeLog NEWS AUTHORS
261%{_libdir}/*.so.*
262%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
263%{_libdir}/evolution-data-server/libedbus-private.so
264%{_libdir}/girepository-1.0/*.typelib
265%{_libexecdir}/evolution-addressbook-factory
266%{_libexecdir}/evolution-addressbook-factory-subprocess
267%{_libexecdir}/evolution-calendar-factory
268%{_libexecdir}/evolution-calendar-factory-subprocess
269%{_libexecdir}/evolution-scan-gconf-tree-xml
270%{_libexecdir}/evolution-source-registry
271%{_libexecdir}/evolution-user-prompter
272%{_libexecdir}/camel-index-control-%{eds_api_version}
273%{_libexecdir}/camel-lock-helper-%{eds_api_version}
274%{_datadir}/GConf/gsettings/evolution-data-server.convert
275%{_datadir}/dbus-1/services/*
276%{_datadir}/%{name}/evolutionperson.schema
277%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
278%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
279%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
280%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
281%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
282%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
283%{_datadir}/pixmaps/evolution-data-server
284
285%dir %{_libdir}/evolution-data-server
286%dir %{camel_provider_dir}
287%dir %{ebook_backends_dir}
288%dir %{ecal_backends_dir}
289%dir %{registry_modules_dir}
290
291%{camel_provider_dir}/libcamelimapx.so
292%{camel_provider_dir}/libcamelimapx.urls
293
294%{camel_provider_dir}/libcamellocal.so
295%{camel_provider_dir}/libcamellocal.urls
296
297%{camel_provider_dir}/libcamelnntp.so
298%{camel_provider_dir}/libcamelnntp.urls
299
300%{camel_provider_dir}/libcamelpop3.so
301%{camel_provider_dir}/libcamelpop3.urls
302
303%{camel_provider_dir}/libcamelsendmail.so
304%{camel_provider_dir}/libcamelsendmail.urls
305
306%{camel_provider_dir}/libcamelsmtp.so
307%{camel_provider_dir}/libcamelsmtp.urls
308
309# e-d-s extensions:
310%{ebook_backends_dir}/libebookbackendfile.so
311%{ebook_backends_dir}/libebookbackendgoogle.so
312%{ebook_backends_dir}/libebookbackendldap.so
313%{ebook_backends_dir}/libebookbackendwebdav.so
314
315%{ecal_backends_dir}/libecalbackendcaldav.so
316%{ecal_backends_dir}/libecalbackendcontacts.so
317%{ecal_backends_dir}/libecalbackendfile.so
318%{ecal_backends_dir}/libecalbackendgtasks.so
319%{ecal_backends_dir}/libecalbackendhttp.so
320%{ecal_backends_dir}/libecalbackendweather.so
321
322%{registry_modules_dir}/module-cache-reaper.so
323%{registry_modules_dir}/module-google-backend.so
324%{registry_modules_dir}/module-gnome-online-accounts.so
325%{registry_modules_dir}/module-outlook-backend.so
326%{registry_modules_dir}/module-owncloud-backend.so
327%{registry_modules_dir}/module-secret-monitor.so
328%{registry_modules_dir}/module-trust-prompt.so
329%{registry_modules_dir}/module-yahoo-backend.so
330
331%files devel
332%defattr(-,root,root,-)
333%{_includedir}/%{name}
334%{_libdir}/*.so
335%{_libdir}/pkgconfig/*.pc
336%{_datadir}/gir-1.0/*.gir
337
338%files vala
339%defattr(-,root,root,-)
340%{_datadir}/vala/vapi/libebook-1.2.deps
341%{_datadir}/vala/vapi/libebook-1.2.vapi
342%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
343%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
344%{_datadir}/vala/vapi/libedataserver-1.2.deps
345%{_datadir}/vala/vapi/libedataserver-1.2.vapi
346
347
348%changelog
349* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
350- new upstream release
351- remove %%{name}-doc subpackage
352
353* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
354- new upstream release
355
356* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
357- new upstream release
358
359* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
360- new upstream release
361
362* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
363- rebuilt with libical 1.0.1
364
365* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
366- new upstream release
367
368* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
369- new upstream release
370
371* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
372- new upstream release
373
374* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
375- new upstream release
376
377* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
378- new upstream release
379
380* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
381- new upstream release
382
383* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
384- new upstream release
385
386* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
387- new upstream release
388
389* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
390- new upstream release
391
392* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
393- new upstream release
394
395* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
396- new upstream release
397
398* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
399- new upstream release
400- add BuildRequires: libicu-devel
401
402* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
403- new upstream release
404
405* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
406- new upstream release
407
408* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
409- new upstream release
410
411* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
412- new upstream release
413
414* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
415- new upstream release
416
417* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
418- new upstream release
419
420* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
421- new upstream release
422- add configure option (--disable-uoa)
423- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
424- create %%{name}-vala subpackage
425
426* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
427- new upstream release
428
429* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
430- new upstream release
431
432* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
433- new upstream release
434
435* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
436- new upstream release
437
438* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
439- new upstream release
440
441* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
442- new upstream release
443
444* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
445- new upstream release
446
447* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
448- new upstream release
449
450* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
451- new upstream release
452- add BuildRequires: dbus-glib-devel
453
454* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
455- new upstream release
456
457* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
458- new upstream release
459
460* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
461- new upstream release
462
463* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
464- new upstream release
465
466* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
467- new upstream release
468- remove Patch101
469
470* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
471- new upstream release
472
473* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
474- new upstream release
475- change BuildRequires: gtk3-devel instead of gtk2-devel
476- BuildRequires: gnome-online-accounts-devel
477- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
478- fix %%files
479
480* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
481- new upstream release
482
483* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
484- rebuild with openssl-1.0.0c
485
486* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
487- new upstream release
488- remove Requires: gnome-vfs2, libglade2, libgnomeui
489- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
490- add BuildRequires: libgdata
491- add Requires: nspr-devel, nss-devel (devel package)
492- drop Patch11
493
494* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
495- rebuild with rpm-4.8.1 for pkg-config file
496
497* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
498- new upstream release
499
500* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
501- new upstream release
502
503* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
504- new upstream release
505- remove BuildRequires: libbonobo-devel
506- remove Requires: libbonobo
507- drop Patch10
508- add configure option (--with-krb5-libs, --with-krb5-includes)
509
510* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
511- rebuilt with db4-4.8
512
513* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
514- new upstream release
515
516* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
517- new upstream release
518
519* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
520- new upstream release
521
522* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
523- new upstream release
524
525* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
526- added Requires: libical-devel >= 0.43 to devel package
527
528* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
529- new upstream release
530- add BR: libgweather-devel >= 2.26.0
531- add BR: libical-devel >= 0.43
532
533* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
534- new upstream release
535- added BuildRequires: sqlite3-devel
536
537* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
538- enabled krb5 support
539
540* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
541- new upstream release
542
543* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
544- new upstream release
545
546* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
547- new upstream release
548
549* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
550- new upstream release
551
552* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
553- rebuilt with db4-4.6.21
554
555* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
556- new upstream release
557
558* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
559- new upstream release
560
561* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
562- new upstream release
563
564* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
565- new upstream release based on Fedora package 2.20.0-3.fc9
566  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
567  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
568  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
569  - Add patch for RH bug #296671 (GC servers may not support NTLM).
570  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
571  - Try removing the ancient "ldap-x86_64-hack" patch.
572  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
573  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
574- split doc subpackage
575
576* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
577- fixed dependancy
578
579* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
580- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
581  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
582  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
583  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
584  - Make the new ESourceComboBox widget work properly (RH bug #234760).
585  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
586  - Link to static evolution-openldap library (RH bug #210126).
587  - Require openssl-devel when statically linking against openldap.
588  - Add -Wdeclaration-after-statement to strict build settings.
589  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
590  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
591  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
592  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
593  - Update to 1.10.0
594  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
595  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
596  - Patch by Kenny Root.
597- rebuilt with nss-devel and nspr-devel
598
599* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
600- rebuilt with new toolchain and db4-4.3.x
601
602* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
603- new upstream release
604
605* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
606- new upstream release
607- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
608
609* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
610- new upstream release
611- rebuilt with openssl instead of mozilla-nss
612
613* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
614- rebuilt with openldap-2.3.24-0vl4
615
616* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
617- new upstream release
618- build with libsoap-2.2.7
619
620* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
621- new upstream release
622
623* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
624- new upstream release
625- added/removed Patches based on Fedora packages
626  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
627  - Updated patch 102 to fix further implicit function declarations
628  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
629  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
630    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
631  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
632  - Removed upstreamed patch:
633    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
634  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
635  - added patch to calendar/libecal/e-cal.c to fix missing declaration
636    of open_calendar
637- rebuilt with mozilla-1.7.12
638
639* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
640- rebuilt with mozilla-1.7.7
641
642* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
643- initial build for Vine Linux based on FC package
644- disable krb5 support
645
646* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
647- 1.2.1
648
649* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
650- Removed explicit run-time spec-file requirement on mozilla.
651  The Mozilla NSS API/ABI stabilised by version 1.7.3
652  The libraries are always located in the libdir
653  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
654  and so they move each time the mozilla version changes.
655  So we no longer have an explicit mozilla run-time requirement in the specfile;
656  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
657  We have an explicit, exact build-time version, so that we can find the headers (without
658  invoking an RPM query from the spec file; to do so is considered bad practice)
659- Introduced mozilla_build_version, to replace mozilla_version
660- Set mozilla_build_version to 1.7.6 to reflect current state of tree
661
662* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
663- Added a patch to deal with glibc defining a macro called "read"
664
665* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
666- 1.2.0
667- Removed patch for GCC 4 as this is now in upstream tarball
668
669* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
670- rebuild to fix library linking silliness
671
672* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
673- disabling gtk-doc on ia64 and s390x
674
675* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
676- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
677
678* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
679- extended patch to deal with camel-groupwise-store-summary.c
680
681* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
682- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
683
684* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
685- 1.1.6
686
687* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
688- rebuild
689
690* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
691- forgot to fix sources
692
693* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
694- 1.1.5
695
696* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
697- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
698
699* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
700- disable gtk-doc generation on ia64 for now
701
702* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
703- Exclude ppc64 due to missing mozilla dependency
704
705* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
706- Update from 1.0.3 to 1.1.4.1
707- Updated eds_major from 1.0 to 1.2; fixed translation search path.
708- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
709- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
710- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
711- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
712- Camel code from evolution is now in evolution-data-server:
713  - Added camel-index-control and camel-lock-helper to packaged files
714  - Added mozilla dependency code from the evolution package
715  - Ditto for LDAP
716  - Ditto for krb5
717  - Ditto for NNTP support handling
718  - Ditto for --enable-file-locking and --enable-dot-locking
719- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
720- Updated libsoup requirement from 2.2.1 to 2.2.2
721- Enabled gtk-doc
722
723* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
724- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
725
726* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
727- update from upstream 1.0.2 to 1.0.3:
728  * Address Book
729    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
730    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
731
732  * Calendar
733    #XB59904 - Speed up calendar queries (Rodrigo)
734    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
735    - fix libical build for automake 1.9 (Rodney)
736    - fix putenv usage for portability (Julio M. Merino Vidal)
737
738  * Updated Translations:
739    - sv (Christian Rose)
740
741- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
742
743* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
744- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
745http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
746(The groupwise part of that patch did not cleanly apply, so I removed it).
747
748* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
749- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
750optimisation patch posted to upstream development mailing list here:
751http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
752
753* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
754- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
755
756* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
757- added workaround for a backend leak that causes the "contacts" calendar
758backend to hold open an EBook for the local contacts (filed upstream at:
759http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
760never lose its last addressbook, and hence never quit.  We workaround this by
761detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
762
763* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
764- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
765
766* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
767- update from 1.0.1 to 1.0.2
768- increased libsoup requirement to 2.2.1 to match configuration script
769
770* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
771- update from 1.0.0 to 1.0.1
772- removed patch that fixed warnings in calendar code (now in upstream tarball)
773
774* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
775- fixed various warnings in the calendar code
776  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
777
778* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
779- update from 0.0.99 to 1.0.0
780- changed path in FTP source location from 0.0 to 1.0
781
782* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
783- update from 0.0.98 to 0.0.99
784- increased libsoup requirement to 2.2.0 to match configuration script
785
786* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
787- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
788
789* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
790- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
791
792* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
793- upgraded to 0.0.97; rewrote the package's description
794
795* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
796- rebuilt
797
798* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
799- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
800
801* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
802- 0.0.96; libsoup required is now 2.1.12
803
804* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
805- rebuilt
806
807* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
808- rebuilt
809
810* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
811- 0.0.95
812
813* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
814- 0.0.94.1
815
816* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
817- rebuilt
818
819* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
820- 0.0.94
821
822* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
823- added ORBit2 requirement
824
825* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
826- rebuild again
827
828* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
829- rebuilt
830
831* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
832- 0.0.93; libsoup required is now 2.1.10
833
834* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
835- Update to 0.0.92; added a define and a requirement on the libsoup version
836
837* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
838- 0.0.90
839
840* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
841- rebuilt
842
843* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
844- 0.0.6
845
846* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
847- better fix by using system libtool
848
849* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
850- add some libdb linkage to make the build on x86_64 happy
851
852* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
853- update to 0.0.5
854
855* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
856- Initial build.
Note: See TracBrowser for help on using the repository browser.