source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9520

Revision 9520, 28.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.16.1

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.16
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.16.1
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.16/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78
79BuildRequires: vala
80BuildRequires: vala-tools
81
82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
105Vendor: Project Vine
106Distribution: Vine Linux
107
108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: pkgconfig
121Requires: sqlite3-devel
122Requires: libgnome-keyring-devel
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
129%package        doc
130Summary:        Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:          Documentation
133Requires:       %{name} = %{version}-%{release}
134BuildArch:      noarch
135
136%description doc
137This package contains documentation for %{name}.
138
139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
221autoreconf -if
222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
228        --disable-uoa \
229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
232        --enable-introspection=yes \
233        --enable-vala-bindings \
234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
264
265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
273%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
274%{_libdir}/evolution-data-server/libedbus-private.so
275%{_libdir}/girepository-1.0/*.typelib
276%{_libexecdir}/evolution-addressbook-factory
277%{_libexecdir}/evolution-addressbook-factory-subprocess
278%{_libexecdir}/evolution-calendar-factory
279%{_libexecdir}/evolution-calendar-factory-subprocess
280%{_libexecdir}/evolution-scan-gconf-tree-xml
281%{_libexecdir}/evolution-source-registry
282%{_libexecdir}/evolution-user-prompter
283%{_libexecdir}/camel-index-control-%{eds_api_version}
284%{_libexecdir}/camel-lock-helper-%{eds_api_version}
285%{_datadir}/GConf/gsettings/evolution-data-server.convert
286%{_datadir}/dbus-1/services/*
287%{_datadir}/%{name}/evolutionperson.schema
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
289%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
290%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
291%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
292%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
293%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
294%{_datadir}/pixmaps/evolution-data-server
295
296%dir %{_libdir}/evolution-data-server
297%dir %{camel_provider_dir}
298%dir %{ebook_backends_dir}
299%dir %{ecal_backends_dir}
300%dir %{registry_modules_dir}
301
302%{camel_provider_dir}/libcamelimapx.so
303%{camel_provider_dir}/libcamelimapx.urls
304
305%{camel_provider_dir}/libcamellocal.so
306%{camel_provider_dir}/libcamellocal.urls
307
308%{camel_provider_dir}/libcamelnntp.so
309%{camel_provider_dir}/libcamelnntp.urls
310
311%{camel_provider_dir}/libcamelpop3.so
312%{camel_provider_dir}/libcamelpop3.urls
313
314%{camel_provider_dir}/libcamelsendmail.so
315%{camel_provider_dir}/libcamelsendmail.urls
316
317%{camel_provider_dir}/libcamelsmtp.so
318%{camel_provider_dir}/libcamelsmtp.urls
319
320# e-d-s extensions:
321%{ebook_backends_dir}/libebookbackendfile.so
322%{ebook_backends_dir}/libebookbackendgoogle.so
323%{ebook_backends_dir}/libebookbackendldap.so
324%{ebook_backends_dir}/libebookbackendwebdav.so
325
326%{ecal_backends_dir}/libecalbackendcaldav.so
327%{ecal_backends_dir}/libecalbackendcontacts.so
328%{ecal_backends_dir}/libecalbackendfile.so
329%{ecal_backends_dir}/libecalbackendgtasks.so
330%{ecal_backends_dir}/libecalbackendhttp.so
331%{ecal_backends_dir}/libecalbackendweather.so
332
333%{registry_modules_dir}/module-cache-reaper.so
334%{registry_modules_dir}/module-google-backend.so
335%{registry_modules_dir}/module-gnome-online-accounts.so
336%{registry_modules_dir}/module-outlook-backend.so
337%{registry_modules_dir}/module-owncloud-backend.so
338%{registry_modules_dir}/module-secret-monitor.so
339%{registry_modules_dir}/module-trust-prompt.so
340%{registry_modules_dir}/module-yahoo-backend.so
341
342%files devel
343%defattr(-,root,root,-)
344%{_includedir}/%{name}
345%{_libdir}/*.so
346%{_libdir}/pkgconfig/*.pc
347%{_datadir}/gir-1.0/*.gir
348
349%files doc
350%defattr(-,root,root,-)
351%{_datadir}/gtk-doc/html/camel
352%{_datadir}/gtk-doc/html/eds
353
354%files vala
355%defattr(-,root,root,-)
356%{_datadir}/vala/vapi/libebook-1.2.deps
357%{_datadir}/vala/vapi/libebook-1.2.vapi
358%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
359%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
360%{_datadir}/vala/vapi/libedataserver-1.2.deps
361%{_datadir}/vala/vapi/libedataserver-1.2.vapi
362
363
364%changelog
365* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
366- new upstream release
367
368* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
369- new upstream release
370
371* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
372- rebuilt with libical 1.0.1
373
374* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
375- new upstream release
376
377* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
378- new upstream release
379
380* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
381- new upstream release
382
383* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
384- new upstream release
385
386* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
387- new upstream release
388
389* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
390- new upstream release
391
392* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
393- new upstream release
394
395* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
396- new upstream release
397
398* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
399- new upstream release
400
401* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
402- new upstream release
403
404* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
405- new upstream release
406
407* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
408- new upstream release
409- add BuildRequires: libicu-devel
410
411* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
412- new upstream release
413
414* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
415- new upstream release
416
417* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
418- new upstream release
419
420* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
421- new upstream release
422
423* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
424- new upstream release
425
426* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
427- new upstream release
428
429* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
430- new upstream release
431- add configure option (--disable-uoa)
432- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
433- create %%{name}-vala subpackage
434
435* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
436- new upstream release
437
438* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
439- new upstream release
440
441* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
442- new upstream release
443
444* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
445- new upstream release
446
447* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
448- new upstream release
449
450* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
451- new upstream release
452
453* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
454- new upstream release
455
456* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
457- new upstream release
458
459* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
460- new upstream release
461- add BuildRequires: dbus-glib-devel
462
463* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
464- new upstream release
465
466* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
467- new upstream release
468
469* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
470- new upstream release
471
472* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
473- new upstream release
474
475* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
476- new upstream release
477- remove Patch101
478
479* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
480- new upstream release
481
482* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
483- new upstream release
484- change BuildRequires: gtk3-devel instead of gtk2-devel
485- BuildRequires: gnome-online-accounts-devel
486- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
487- fix %%files
488
489* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
490- new upstream release
491
492* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
493- rebuild with openssl-1.0.0c
494
495* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
496- new upstream release
497- remove Requires: gnome-vfs2, libglade2, libgnomeui
498- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
499- add BuildRequires: libgdata
500- add Requires: nspr-devel, nss-devel (devel package)
501- drop Patch11
502
503* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
504- rebuild with rpm-4.8.1 for pkg-config file
505
506* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
507- new upstream release
508
509* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
510- new upstream release
511
512* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
513- new upstream release
514- remove BuildRequires: libbonobo-devel
515- remove Requires: libbonobo
516- drop Patch10
517- add configure option (--with-krb5-libs, --with-krb5-includes)
518
519* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
520- rebuilt with db4-4.8
521
522* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
523- new upstream release
524
525* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
526- new upstream release
527
528* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
529- new upstream release
530
531* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
532- new upstream release
533
534* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
535- added Requires: libical-devel >= 0.43 to devel package
536
537* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
538- new upstream release
539- add BR: libgweather-devel >= 2.26.0
540- add BR: libical-devel >= 0.43
541
542* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
543- new upstream release
544- added BuildRequires: sqlite3-devel
545
546* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
547- enabled krb5 support
548
549* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
550- new upstream release
551
552* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
553- new upstream release
554
555* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
556- new upstream release
557
558* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
559- new upstream release
560
561* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
562- rebuilt with db4-4.6.21
563
564* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
565- new upstream release
566
567* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
568- new upstream release
569
570* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
571- new upstream release
572
573* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
574- new upstream release based on Fedora package 2.20.0-3.fc9
575  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
576  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
577  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
578  - Add patch for RH bug #296671 (GC servers may not support NTLM).
579  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
580  - Try removing the ancient "ldap-x86_64-hack" patch.
581  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
582  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
583- split doc subpackage
584
585* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
586- fixed dependancy
587
588* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
589- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
590  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
591  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
592  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
593  - Make the new ESourceComboBox widget work properly (RH bug #234760).
594  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
595  - Link to static evolution-openldap library (RH bug #210126).
596  - Require openssl-devel when statically linking against openldap.
597  - Add -Wdeclaration-after-statement to strict build settings.
598  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
599  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
600  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
601  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
602  - Update to 1.10.0
603  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
604  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
605  - Patch by Kenny Root.
606- rebuilt with nss-devel and nspr-devel
607
608* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
609- rebuilt with new toolchain and db4-4.3.x
610
611* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
612- new upstream release
613
614* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
615- new upstream release
616- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
617
618* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
619- new upstream release
620- rebuilt with openssl instead of mozilla-nss
621
622* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
623- rebuilt with openldap-2.3.24-0vl4
624
625* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
626- new upstream release
627- build with libsoap-2.2.7
628
629* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
630- new upstream release
631
632* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
633- new upstream release
634- added/removed Patches based on Fedora packages
635  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
636  - Updated patch 102 to fix further implicit function declarations
637  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
638  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
639    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
640  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
641  - Removed upstreamed patch:
642    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
643  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
644  - added patch to calendar/libecal/e-cal.c to fix missing declaration
645    of open_calendar
646- rebuilt with mozilla-1.7.12
647
648* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
649- rebuilt with mozilla-1.7.7
650
651* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
652- initial build for Vine Linux based on FC package
653- disable krb5 support
654
655* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
656- 1.2.1
657
658* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
659- Removed explicit run-time spec-file requirement on mozilla.
660  The Mozilla NSS API/ABI stabilised by version 1.7.3
661  The libraries are always located in the libdir
662  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
663  and so they move each time the mozilla version changes.
664  So we no longer have an explicit mozilla run-time requirement in the specfile;
665  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
666  We have an explicit, exact build-time version, so that we can find the headers (without
667  invoking an RPM query from the spec file; to do so is considered bad practice)
668- Introduced mozilla_build_version, to replace mozilla_version
669- Set mozilla_build_version to 1.7.6 to reflect current state of tree
670
671* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
672- Added a patch to deal with glibc defining a macro called "read"
673
674* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
675- 1.2.0
676- Removed patch for GCC 4 as this is now in upstream tarball
677
678* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
679- rebuild to fix library linking silliness
680
681* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
682- disabling gtk-doc on ia64 and s390x
683
684* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
685- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
686
687* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
688- extended patch to deal with camel-groupwise-store-summary.c
689
690* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
691- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
692
693* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
694- 1.1.6
695
696* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
697- rebuild
698
699* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
700- forgot to fix sources
701
702* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
703- 1.1.5
704
705* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
706- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
707
708* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
709- disable gtk-doc generation on ia64 for now
710
711* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
712- Exclude ppc64 due to missing mozilla dependency
713
714* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
715- Update from 1.0.3 to 1.1.4.1
716- Updated eds_major from 1.0 to 1.2; fixed translation search path.
717- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
718- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
719- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
720- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
721- Camel code from evolution is now in evolution-data-server:
722  - Added camel-index-control and camel-lock-helper to packaged files
723  - Added mozilla dependency code from the evolution package
724  - Ditto for LDAP
725  - Ditto for krb5
726  - Ditto for NNTP support handling
727  - Ditto for --enable-file-locking and --enable-dot-locking
728- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
729- Updated libsoup requirement from 2.2.1 to 2.2.2
730- Enabled gtk-doc
731
732* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
733- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
734
735* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
736- update from upstream 1.0.2 to 1.0.3:
737  * Address Book
738    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
739    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
740
741  * Calendar
742    #XB59904 - Speed up calendar queries (Rodrigo)
743    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
744    - fix libical build for automake 1.9 (Rodney)
745    - fix putenv usage for portability (Julio M. Merino Vidal)
746
747  * Updated Translations:
748    - sv (Christian Rose)
749
750- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
751
752* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
753- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
754http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
755(The groupwise part of that patch did not cleanly apply, so I removed it).
756
757* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
758- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
759optimisation patch posted to upstream development mailing list here:
760http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
761
762* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
763- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
764
765* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
766- added workaround for a backend leak that causes the "contacts" calendar
767backend to hold open an EBook for the local contacts (filed upstream at:
768http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
769never lose its last addressbook, and hence never quit.  We workaround this by
770detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
771
772* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
773- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
774
775* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
776- update from 1.0.1 to 1.0.2
777- increased libsoup requirement to 2.2.1 to match configuration script
778
779* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
780- update from 1.0.0 to 1.0.1
781- removed patch that fixed warnings in calendar code (now in upstream tarball)
782
783* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
784- fixed various warnings in the calendar code
785  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
786
787* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
788- update from 0.0.99 to 1.0.0
789- changed path in FTP source location from 0.0 to 1.0
790
791* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
792- update from 0.0.98 to 0.0.99
793- increased libsoup requirement to 2.2.0 to match configuration script
794
795* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
796- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
797
798* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
799- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
800
801* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
802- upgraded to 0.0.97; rewrote the package's description
803
804* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
805- rebuilt
806
807* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
808- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
809
810* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
811- 0.0.96; libsoup required is now 2.1.12
812
813* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
814- rebuilt
815
816* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
817- rebuilt
818
819* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
820- 0.0.95
821
822* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
823- 0.0.94.1
824
825* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
826- rebuilt
827
828* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
829- 0.0.94
830
831* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
832- added ORBit2 requirement
833
834* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
835- rebuild again
836
837* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
838- rebuilt
839
840* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
841- 0.0.93; libsoup required is now 2.1.10
842
843* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
844- Update to 0.0.92; added a define and a requirement on the libsoup version
845
846* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
847- 0.0.90
848
849* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
850- rebuilt
851
852* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
853- 0.0.6
854
855* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
856- better fix by using system libtool
857
858* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
859- add some libdb linkage to make the build on x86_64 happy
860
861* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
862- update to 0.0.5
863
864* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
865- Initial build.
Note: See TracBrowser for help on using the repository browser.