source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9371

Revision 9371, 28.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.12
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.12.11
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.12/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78
79BuildRequires: vala
80BuildRequires: vala-tools
81
82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
105Vendor: Project Vine
106Distribution: Vine Linux
107
108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
115
116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Requires: pkgconfig
121Requires: sqlite3-devel
122Requires: libgnome-keyring-devel
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
129%package                doc
130Summary:                Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:                  Documentation
133Requires:               %{name} = %{version}-%{release}
134BuildArch:              noarch
135
136%description doc
137This package contains documentation for %{name}.
138
139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
221autoreconf -if
222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
228        --disable-uoa \
229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
232        --enable-introspection=yes \
233        --enable-vala-bindings \
234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
264
265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
273%{_libdir}/girepository-1.0/*.typelib
274%{_libexecdir}/evolution-addressbook-factory
275%{_libexecdir}/evolution-calendar-factory
276%{_libexecdir}/evolution-scan-gconf-tree-xml
277%{_libexecdir}/evolution-source-registry
278%{_libexecdir}/evolution-user-prompter
279%{_libexecdir}/camel-index-control-%{eds_api_version}
280%{_libexecdir}/camel-lock-helper-%{eds_api_version}
281%{_datadir}/GConf/gsettings/evolution-data-server.convert
282%{_datadir}/dbus-1/services/*
283%{_datadir}/%{name}/evolutionperson.schema
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
289%{_datadir}/pixmaps/evolution-data-server
290
291%dir %{_libdir}/evolution-data-server
292%dir %{camel_provider_dir}
293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
295%dir %{registry_modules_dir}
296
297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
320
321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
324%{ecal_backends_dir}/libecalbackendgtasks.so
325%{ecal_backends_dir}/libecalbackendhttp.so
326%{ecal_backends_dir}/libecalbackendweather.so
327
328%{registry_modules_dir}/module-cache-reaper.so
329%{registry_modules_dir}/module-google-backend.so
330%{registry_modules_dir}/module-gnome-online-accounts.so
331%{registry_modules_dir}/module-outlook-backend.so
332%{registry_modules_dir}/module-owncloud-backend.so
333%{registry_modules_dir}/module-secret-monitor.so
334%{registry_modules_dir}/module-trust-prompt.so
335%{registry_modules_dir}/module-yahoo-backend.so
336
337%files devel
338%defattr(-,root,root,-)
339%{_includedir}/%{name}
340%{_libdir}/*.so
341%{_libdir}/pkgconfig/*.pc
342%{_datadir}/gir-1.0/*.gir
343
344%files doc
345%defattr(-,root,root,-)
346%{_datadir}/gtk-doc/html/camel
347%{_datadir}/gtk-doc/html/eds
348
349%files vala
350%defattr(-,root,root,-)
351%{_datadir}/vala/vapi/libebook-1.2.deps
352%{_datadir}/vala/vapi/libebook-1.2.vapi
353%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
354%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
355%{_datadir}/vala/vapi/libedataserver-1.2.deps
356%{_datadir}/vala/vapi/libedataserver-1.2.vapi
357
358
359%changelog
360* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
361- new upstream release
362
363* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
364- new upstream release
365
366* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
367- new upstream release
368
369* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
370- new upstream release
371
372* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
373- new upstream release
374
375* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
376- new upstream release
377
378* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
379- new upstream release
380
381* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
382- new upstream release
383
384* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
385- new upstream release
386
387* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
388- new upstream release
389
390* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
391- new upstream release
392
393* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
394- new upstream release
395- add BuildRequires: libicu-devel
396
397* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
398- new upstream release
399
400* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
401- new upstream release
402
403* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
404- new upstream release
405
406* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
407- new upstream release
408
409* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
410- new upstream release
411
412* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
413- new upstream release
414
415* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
416- new upstream release
417- add configure option (--disable-uoa)
418- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
419- create %%{name}-vala subpackage
420
421* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
422- new upstream release
423
424* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
425- new upstream release
426
427* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
428- new upstream release
429
430* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
431- new upstream release
432
433* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
434- new upstream release
435
436* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
437- new upstream release
438
439* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
440- new upstream release
441
442* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
443- new upstream release
444
445* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
446- new upstream release
447- add BuildRequires: dbus-glib-devel
448
449* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
450- new upstream release
451
452* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
453- new upstream release
454
455* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
456- new upstream release
457
458* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
459- new upstream release
460
461* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
462- new upstream release
463- remove Patch101
464
465* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
466- new upstream release
467
468* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
469- new upstream release
470- change BuildRequires: gtk3-devel instead of gtk2-devel
471- BuildRequires: gnome-online-accounts-devel
472- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
473- fix %%files
474
475* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
476- new upstream release
477
478* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
479- rebuild with openssl-1.0.0c
480
481* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
482- new upstream release
483- remove Requires: gnome-vfs2, libglade2, libgnomeui
484- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
485- add BuildRequires: libgdata
486- add Requires: nspr-devel, nss-devel (devel package)
487- drop Patch11
488
489* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
490- rebuild with rpm-4.8.1 for pkg-config file
491
492* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
493- new upstream release
494
495* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
496- new upstream release
497
498* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
499- new upstream release
500- remove BuildRequires: libbonobo-devel
501- remove Requires: libbonobo
502- drop Patch10
503- add configure option (--with-krb5-libs, --with-krb5-includes)
504
505* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
506- rebuilt with db4-4.8
507
508* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
509- new upstream release
510
511* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
512- new upstream release
513
514* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
515- new upstream release
516
517* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
518- new upstream release
519
520* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
521- added Requires: libical-devel >= 0.43 to devel package
522
523* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
524- new upstream release
525- add BR: libgweather-devel >= 2.26.0
526- add BR: libical-devel >= 0.43
527
528* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
529- new upstream release
530- added BuildRequires: sqlite3-devel
531
532* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
533- enabled krb5 support
534
535* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
536- new upstream release
537
538* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
539- new upstream release
540
541* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
542- new upstream release
543
544* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
545- new upstream release
546
547* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
548- rebuilt with db4-4.6.21
549
550* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
551- new upstream release
552
553* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
554- new upstream release
555
556* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
557- new upstream release
558
559* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
560- new upstream release based on Fedora package 2.20.0-3.fc9
561  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
562  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
563  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
564  - Add patch for RH bug #296671 (GC servers may not support NTLM).
565  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
566  - Try removing the ancient "ldap-x86_64-hack" patch.
567  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
568  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
569- split doc subpackage
570
571* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
572- fixed dependancy
573
574* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
575- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
576  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
577  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
578  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
579  - Make the new ESourceComboBox widget work properly (RH bug #234760).
580  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
581  - Link to static evolution-openldap library (RH bug #210126).
582  - Require openssl-devel when statically linking against openldap.
583  - Add -Wdeclaration-after-statement to strict build settings.
584  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
585  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
586  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
587  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
588  - Update to 1.10.0
589  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
590  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
591  - Patch by Kenny Root.
592- rebuilt with nss-devel and nspr-devel
593
594* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
595- rebuilt with new toolchain and db4-4.3.x
596
597* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
598- new upstream release
599
600* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
601- new upstream release
602- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
603
604* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
605- new upstream release
606- rebuilt with openssl instead of mozilla-nss
607
608* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
609- rebuilt with openldap-2.3.24-0vl4
610
611* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
612- new upstream release
613- build with libsoap-2.2.7
614
615* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
616- new upstream release
617
618* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
619- new upstream release
620- added/removed Patches based on Fedora packages
621  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
622  - Updated patch 102 to fix further implicit function declarations
623  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
624  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
625    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
626  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
627  - Removed upstreamed patch:
628    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
629  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
630  - added patch to calendar/libecal/e-cal.c to fix missing declaration
631    of open_calendar
632- rebuilt with mozilla-1.7.12
633
634* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
635- rebuilt with mozilla-1.7.7
636
637* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
638- initial build for Vine Linux based on FC package
639- disable krb5 support
640
641* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
642- 1.2.1
643
644* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
645- Removed explicit run-time spec-file requirement on mozilla.
646  The Mozilla NSS API/ABI stabilised by version 1.7.3
647  The libraries are always located in the libdir
648  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
649  and so they move each time the mozilla version changes.
650  So we no longer have an explicit mozilla run-time requirement in the specfile;
651  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
652  We have an explicit, exact build-time version, so that we can find the headers (without
653  invoking an RPM query from the spec file; to do so is considered bad practice)
654- Introduced mozilla_build_version, to replace mozilla_version
655- Set mozilla_build_version to 1.7.6 to reflect current state of tree
656
657* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
658- Added a patch to deal with glibc defining a macro called "read"
659
660* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
661- 1.2.0
662- Removed patch for GCC 4 as this is now in upstream tarball
663
664* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
665- rebuild to fix library linking silliness
666
667* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
668- disabling gtk-doc on ia64 and s390x
669
670* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
671- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
672
673* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
674- extended patch to deal with camel-groupwise-store-summary.c
675
676* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
677- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
678
679* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
680- 1.1.6
681
682* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
683- rebuild
684
685* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
686- forgot to fix sources
687
688* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
689- 1.1.5
690
691* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
692- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
693
694* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
695- disable gtk-doc generation on ia64 for now
696
697* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
698- Exclude ppc64 due to missing mozilla dependency
699
700* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
701- Update from 1.0.3 to 1.1.4.1
702- Updated eds_major from 1.0 to 1.2; fixed translation search path.
703- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
704- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
705- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
706- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
707- Camel code from evolution is now in evolution-data-server:
708  - Added camel-index-control and camel-lock-helper to packaged files
709  - Added mozilla dependency code from the evolution package
710  - Ditto for LDAP
711  - Ditto for krb5
712  - Ditto for NNTP support handling
713  - Ditto for --enable-file-locking and --enable-dot-locking
714- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
715- Updated libsoup requirement from 2.2.1 to 2.2.2
716- Enabled gtk-doc
717
718* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
719- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
720
721* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
722- update from upstream 1.0.2 to 1.0.3:
723  * Address Book
724    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
725    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
726
727  * Calendar
728    #XB59904 - Speed up calendar queries (Rodrigo)
729    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
730    - fix libical build for automake 1.9 (Rodney)
731    - fix putenv usage for portability (Julio M. Merino Vidal)
732
733  * Updated Translations:
734    - sv (Christian Rose)
735
736- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
737
738* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
739- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
740http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
741(The groupwise part of that patch did not cleanly apply, so I removed it).
742
743* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
744- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
745optimisation patch posted to upstream development mailing list here:
746http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
747
748* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
749- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
750
751* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
752- added workaround for a backend leak that causes the "contacts" calendar
753backend to hold open an EBook for the local contacts (filed upstream at:
754http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
755never lose its last addressbook, and hence never quit.  We workaround this by
756detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
757
758* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
759- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
760
761* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
762- update from 1.0.1 to 1.0.2
763- increased libsoup requirement to 2.2.1 to match configuration script
764
765* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
766- update from 1.0.0 to 1.0.1
767- removed patch that fixed warnings in calendar code (now in upstream tarball)
768
769* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
770- fixed various warnings in the calendar code
771  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
772
773* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
774- update from 0.0.99 to 1.0.0
775- changed path in FTP source location from 0.0 to 1.0
776
777* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
778- update from 0.0.98 to 0.0.99
779- increased libsoup requirement to 2.2.0 to match configuration script
780
781* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
782- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
783
784* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
785- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
786
787* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
788- upgraded to 0.0.97; rewrote the package's description
789
790* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
791- rebuilt
792
793* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
794- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
795
796* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
797- 0.0.96; libsoup required is now 2.1.12
798
799* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
800- rebuilt
801
802* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
803- rebuilt
804
805* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
806- 0.0.95
807
808* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
809- 0.0.94.1
810
811* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
812- rebuilt
813
814* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
815- 0.0.94
816
817* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
818- added ORBit2 requirement
819
820* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
821- rebuild again
822
823* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
824- rebuilt
825
826* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
827- 0.0.93; libsoup required is now 2.1.10
828
829* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
830- Update to 0.0.92; added a define and a requirement on the libsoup version
831
832* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
833- 0.0.90
834
835* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
836- rebuilt
837
838* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
839- 0.0.6
840
841* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
842- better fix by using system libtool
843
844* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
845- add some libdb linkage to make the build on x86_64 happy
846
847* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
848- update to 0.0.5
849
850* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
851- Initial build.
Note: See TracBrowser for help on using the repository browser.