source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 8060

Revision 8060, 27.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.10
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.10.3
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.10/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: gnome-common
77
78BuildRequires: vala
79BuildRequires: vala-tools
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104Vendor: Project Vine
105Distribution: Vine Linux
106
107%description
108The evolution-data-server package provides a unified backend for
109programs that work with contacts, tasks, and calendar information.
110
111It was originally developed for Evolution (hence the name), but
112is now used by other packages.
113
114
115%package devel
116Summary: Development files for building against evolution-data-server
117Group: Development/Libraries
118Requires: %{name} = %{version}-%{release}
119Requires: pkgconfig
120Requires: sqlite3-devel
121Requires: libgnome-keyring-devel
122
123%description devel
124Development files needed for building things which link against
125evolution-data-server.
126
127
128%package                doc
129Summary:                Documentation for %{name}
130Summary(ja):    %{name} 用のドキュメント
131Group:                  Documentation
132Requires:               %{name} = %{version}-%{release}
133BuildArch:              noarch
134
135%description doc
136This package contains documentation for %{name}.
137
138
139%package        vala
140Summary:        Vala bindings for %{name}
141Summary(ja):    %{name} の Vala バインディング
142Group:          Development/Libraries
143Requires:       %{name} = %{version}-%{release}
144Requires:       vala
145
146%description    vala
147Vala bindings for %{name}.
148
149
150%prep
151%setup -q
152
153%patch12 -p1 -b .fix-64bit-acinclude
154
155mkdir -p krb5-fakeprefix/include
156mkdir -p krb5-fakeprefix/lib
157mkdir -p krb5-fakeprefix/%{_lib}
158
159%build
160%if %{ldap_support}
161
162%if %{static_ldap}
163%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
164# Set LIBS so that configure will be able to link with static LDAP libraries,
165# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
166if pkg-config libssl ; then
167        export LIBS="-lsasl2 `pkg-config --libs libssl`"
168else
169        export LIBS="-lsasl2 -lssl -lcrypto"
170fi
171%else
172%define ldap_flags --with-openldap=yes
173%endif
174
175%else
176%define ldap_flags --without-openldap
177%endif
178
179%if %{krb5_support}
180%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
181%else
182%define krb5_flags --without-krb5
183%endif
184
185%if %{nntp_support}
186%define nntp_flags --enable-nntp=yes
187%else
188%define nntp_flags --enable-nntp=no
189%endif
190
191%if %{use_nss}
192%define ssl_flags --enable-nss=yes --enable-smime=yes
193%else
194%define ssl_flags --enable-openssl=yes
195%endif
196
197%if %{use_nss}
198if ! pkg-config --exists nss; then
199  echo "Unable to find suitable version of nss to use!"
200  exit 1
201fi
202%endif
203
204%if %{use_gnome_keyring}
205%define keyring_flags --enable-gnome-keyring
206%else
207%define keyring flags --disable-gnome-keyring
208%endif
209
210%if %{support_imap4_provider}
211%define imap4_flags --enable-imap4=yes
212%else
213%define imap4_flags --enable-imap4=no
214%endif
215
216export CPPFLAGS="-I%{_includedir}/et"
217export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
218
219# Regenerate configure to pick up configure.in and acinclude.m4 changes.
220autoreconf -if
221
222# See Ross Burton's blog entry for why we want --with-libdb.
223# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
224
225%configure \
226        --with-libdb=/usr \
227        --disable-uoa \
228        --enable-file-locking=fcntl \
229        --enable-dot-locking=no \
230        --enable-gtk-doc \
231        --enable-introspection=yes \
232        --enable-vala-bindings \
233        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
234        %keyring_flags
235export tagname=CC
236#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
237make LIBTOOL=/usr/bin/libtool
238
239%install
240rm -rf $RPM_BUILD_ROOT
241export tagname=CC
242make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
243
244# remove libtool archives for importers and the like
245find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
247
248# give the libraries some executable bits
249find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
250
251%find_lang %{name}-%{eds_base_version}
252
253%clean
254rm -rf $RPM_BUILD_ROOT
255
256%post -p /sbin/ldconfig
257
258%postun
259/sbin/ldconfig
260if [ $1 -eq 0 ]; then
261  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
262fi
263
264%posttrans
265glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
266
267
268%files -f %{name}-%{eds_base_version}.lang
269%defattr(-,root,root,-)
270%doc README COPYING ChangeLog NEWS AUTHORS
271%{_libdir}/*.so.*
272%{_libdir}/girepository-1.0/*.typelib
273%{_libexecdir}/evolution-addressbook-factory
274%{_libexecdir}/evolution-calendar-factory
275%{_libexecdir}/evolution-scan-gconf-tree-xml
276%{_libexecdir}/evolution-source-registry
277%{_libexecdir}/evolution-user-prompter
278%{_libexecdir}/camel-index-control-%{eds_api_version}
279%{_libexecdir}/camel-lock-helper-%{eds_api_version}
280%{_datadir}/GConf/gsettings/evolution-data-server.convert
281%{_datadir}/GConf/gsettings/libedataserver.convert
282%{_datadir}/dbus-1/services/*
283%{_datadir}/%{name}/evolutionperson.schema
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
289%{_datadir}/pixmaps/evolution-data-server
290
291%dir %{_libdir}/evolution-data-server
292%dir %{camel_provider_dir}
293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
295%dir %{registry_modules_dir}
296
297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
320
321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326
327%{registry_modules_dir}/module-cache-reaper.so
328%{registry_modules_dir}/module-google-backend.so
329%{registry_modules_dir}/module-gnome-online-accounts.so
330%{registry_modules_dir}/module-outlook-backend.so
331%{registry_modules_dir}/module-owncloud-backend.so
332%{registry_modules_dir}/module-trust-prompt.so
333%{registry_modules_dir}/module-yahoo-backend.so
334
335%files devel
336%defattr(-,root,root,-)
337%{_includedir}/%{name}
338%{_libdir}/*.so
339%{_libdir}/pkgconfig/*.pc
340%{_datadir}/gir-1.0/*.gir
341
342%files doc
343%defattr(-,root,root,-)
344%{_datadir}/gtk-doc/html/camel
345%{_datadir}/gtk-doc/html/libebackend
346%{_datadir}/gtk-doc/html/libebook
347%{_datadir}/gtk-doc/html/libebook-contacts
348%{_datadir}/gtk-doc/html/libecal
349%{_datadir}/gtk-doc/html/libedata-book
350%{_datadir}/gtk-doc/html/libedata-cal
351%{_datadir}/gtk-doc/html/libedataserver
352
353%files vala
354%defattr(-,root,root,-)
355%{_datadir}/vala/vapi/libebook-1.2.deps
356%{_datadir}/vala/vapi/libebook-1.2.vapi
357%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
358%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
359%{_datadir}/vala/vapi/libedataserver-1.2.deps
360%{_datadir}/vala/vapi/libedataserver-1.2.vapi
361
362
363%changelog
364* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
365- new upstream release
366
367* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
368- new upstream release
369
370* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
371- new upstream release
372
373* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
374- new upstream release
375
376* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
377- new upstream release
378
379* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
380- new upstream release
381
382* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
383- new upstream release
384- add configure option (--disable-uoa)
385- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
386- create %%{name}-vala subpackage
387
388* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
389- new upstream release
390
391* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
392- new upstream release
393
394* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
395- new upstream release
396
397* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
398- new upstream release
399
400* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
401- new upstream release
402
403* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
404- new upstream release
405
406* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
407- new upstream release
408
409* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
410- new upstream release
411
412* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
413- new upstream release
414- add BuildRequires: dbus-glib-devel
415
416* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
417- new upstream release
418
419* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
420- new upstream release
421
422* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
423- new upstream release
424
425* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
426- new upstream release
427
428* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
429- new upstream release
430- remove Patch101
431
432* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
433- new upstream release
434
435* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
436- new upstream release
437- change BuildRequires: gtk3-devel instead of gtk2-devel
438- BuildRequires: gnome-online-accounts-devel
439- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
440- fix %%files
441
442* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
443- new upstream release
444
445* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
446- rebuild with openssl-1.0.0c
447
448* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
449- new upstream release
450- remove Requires: gnome-vfs2, libglade2, libgnomeui
451- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
452- add BuildRequires: libgdata
453- add Requires: nspr-devel, nss-devel (devel package)
454- drop Patch11
455
456* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
457- rebuild with rpm-4.8.1 for pkg-config file
458
459* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
460- new upstream release
461
462* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
463- new upstream release
464
465* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
466- new upstream release
467- remove BuildRequires: libbonobo-devel
468- remove Requires: libbonobo
469- drop Patch10
470- add configure option (--with-krb5-libs, --with-krb5-includes)
471
472* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
473- rebuilt with db4-4.8
474
475* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
476- new upstream release
477
478* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
479- new upstream release
480
481* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
482- new upstream release
483
484* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
485- new upstream release
486
487* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
488- added Requires: libical-devel >= 0.43 to devel package
489
490* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
491- new upstream release
492- add BR: libgweather-devel >= 2.26.0
493- add BR: libical-devel >= 0.43
494
495* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
496- new upstream release
497- added BuildRequires: sqlite3-devel
498
499* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
500- enabled krb5 support
501
502* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
503- new upstream release
504
505* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
506- new upstream release
507
508* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
509- new upstream release
510
511* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
512- new upstream release
513
514* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
515- rebuilt with db4-4.6.21
516
517* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
518- new upstream release
519
520* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
521- new upstream release
522
523* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
524- new upstream release
525
526* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
527- new upstream release based on Fedora package 2.20.0-3.fc9
528  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
529  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
530  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
531  - Add patch for RH bug #296671 (GC servers may not support NTLM).
532  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
533  - Try removing the ancient "ldap-x86_64-hack" patch.
534  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
535  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
536- split doc subpackage
537
538* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
539- fixed dependancy
540
541* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
542- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
543  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
544  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
545  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
546  - Make the new ESourceComboBox widget work properly (RH bug #234760).
547  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
548  - Link to static evolution-openldap library (RH bug #210126).
549  - Require openssl-devel when statically linking against openldap.
550  - Add -Wdeclaration-after-statement to strict build settings.
551  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
552  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
553  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
554  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
555  - Update to 1.10.0
556  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
557  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
558  - Patch by Kenny Root.
559- rebuilt with nss-devel and nspr-devel
560
561* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
562- rebuilt with new toolchain and db4-4.3.x
563
564* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
565- new upstream release
566
567* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
568- new upstream release
569- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
570
571* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
572- new upstream release
573- rebuilt with openssl instead of mozilla-nss
574
575* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
576- rebuilt with openldap-2.3.24-0vl4
577
578* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
579- new upstream release
580- build with libsoap-2.2.7
581
582* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
583- new upstream release
584
585* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
586- new upstream release
587- added/removed Patches based on Fedora packages
588  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
589  - Updated patch 102 to fix further implicit function declarations
590  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
591  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
592    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
593  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
594  - Removed upstreamed patch:
595    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
596  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
597  - added patch to calendar/libecal/e-cal.c to fix missing declaration
598    of open_calendar
599- rebuilt with mozilla-1.7.12
600
601* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
602- rebuilt with mozilla-1.7.7
603
604* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
605- initial build for Vine Linux based on FC package
606- disable krb5 support
607
608* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
609- 1.2.1
610
611* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
612- Removed explicit run-time spec-file requirement on mozilla.
613  The Mozilla NSS API/ABI stabilised by version 1.7.3
614  The libraries are always located in the libdir
615  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
616  and so they move each time the mozilla version changes.
617  So we no longer have an explicit mozilla run-time requirement in the specfile;
618  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
619  We have an explicit, exact build-time version, so that we can find the headers (without
620  invoking an RPM query from the spec file; to do so is considered bad practice)
621- Introduced mozilla_build_version, to replace mozilla_version
622- Set mozilla_build_version to 1.7.6 to reflect current state of tree
623
624* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
625- Added a patch to deal with glibc defining a macro called "read"
626
627* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
628- 1.2.0
629- Removed patch for GCC 4 as this is now in upstream tarball
630
631* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
632- rebuild to fix library linking silliness
633
634* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
635- disabling gtk-doc on ia64 and s390x
636
637* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
638- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
639
640* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
641- extended patch to deal with camel-groupwise-store-summary.c
642
643* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
644- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
645
646* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
647- 1.1.6
648
649* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
650- rebuild
651
652* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
653- forgot to fix sources
654
655* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
656- 1.1.5
657
658* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
659- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
660
661* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
662- disable gtk-doc generation on ia64 for now
663
664* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
665- Exclude ppc64 due to missing mozilla dependency
666
667* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
668- Update from 1.0.3 to 1.1.4.1
669- Updated eds_major from 1.0 to 1.2; fixed translation search path.
670- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
671- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
672- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
673- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
674- Camel code from evolution is now in evolution-data-server:
675  - Added camel-index-control and camel-lock-helper to packaged files
676  - Added mozilla dependency code from the evolution package
677  - Ditto for LDAP
678  - Ditto for krb5
679  - Ditto for NNTP support handling
680  - Ditto for --enable-file-locking and --enable-dot-locking
681- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
682- Updated libsoup requirement from 2.2.1 to 2.2.2
683- Enabled gtk-doc
684
685* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
686- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
687
688* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
689- update from upstream 1.0.2 to 1.0.3:
690  * Address Book
691    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
692    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
693
694  * Calendar
695    #XB59904 - Speed up calendar queries (Rodrigo)
696    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
697    - fix libical build for automake 1.9 (Rodney)
698    - fix putenv usage for portability (Julio M. Merino Vidal)
699
700  * Updated Translations:
701    - sv (Christian Rose)
702
703- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
704
705* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
706- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
707http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
708(The groupwise part of that patch did not cleanly apply, so I removed it).
709
710* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
711- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
712optimisation patch posted to upstream development mailing list here:
713http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
714
715* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
716- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
717
718* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
719- added workaround for a backend leak that causes the "contacts" calendar
720backend to hold open an EBook for the local contacts (filed upstream at:
721http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
722never lose its last addressbook, and hence never quit.  We workaround this by
723detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
724
725* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
726- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
727
728* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
729- update from 1.0.1 to 1.0.2
730- increased libsoup requirement to 2.2.1 to match configuration script
731
732* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
733- update from 1.0.0 to 1.0.1
734- removed patch that fixed warnings in calendar code (now in upstream tarball)
735
736* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
737- fixed various warnings in the calendar code
738  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
739
740* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
741- update from 0.0.99 to 1.0.0
742- changed path in FTP source location from 0.0 to 1.0
743
744* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
745- update from 0.0.98 to 0.0.99
746- increased libsoup requirement to 2.2.0 to match configuration script
747
748* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
749- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
750
751* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
752- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
753
754* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
755- upgraded to 0.0.97; rewrote the package's description
756
757* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
758- rebuilt
759
760* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
761- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
762
763* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
764- 0.0.96; libsoup required is now 2.1.12
765
766* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
767- rebuilt
768
769* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
770- rebuilt
771
772* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
773- 0.0.95
774
775* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
776- 0.0.94.1
777
778* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
779- rebuilt
780
781* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
782- 0.0.94
783
784* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
785- added ORBit2 requirement
786
787* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
788- rebuild again
789
790* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
791- rebuilt
792
793* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
794- 0.0.93; libsoup required is now 2.1.10
795
796* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
797- Update to 0.0.92; added a define and a requirement on the libsoup version
798
799* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
800- 0.0.90
801
802* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
803- rebuilt
804
805* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
806- 0.0.6
807
808* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
809- better fix by using system libtool
810
811* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
812- add some libdb linkage to make the build on x86_64 happy
813
814* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
815- update to 0.0.5
816
817* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
818- Initial build.
Note: See TracBrowser for help on using the repository browser.