source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 7119

Revision 7119, 25.7 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.6.2

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.6
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.6.2
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.6/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75
76%if %{use_nss}
77BuildRequires: nspr-devel
78BuildRequires: nss-devel
79%else
80BuildRequires: openssl-devel
81%endif
82
83%if %{ldap_support}
84%if %{static_ldap}
85BuildRequires: openldap-evolution-devel
86BuildRequires: openssl-devel
87%else
88BuildRequires: openldap-devel >= 2.0.11
89%endif
90%endif
91
92%if %{krb5_support}
93BuildRequires: krb5-devel
94# tweak for krb5 1.2 vs 1.3
95%define krb5dir /usr/kerberos
96#define krb5dir `pwd`/krb5-fakeprefix
97%endif
98
99Vendor: Project Vine
100Distribution: Vine Linux
101
102%description
103The evolution-data-server package provides a unified backend for
104programs that work with contacts, tasks, and calendar information.
105
106It was originally developed for Evolution (hence the name), but
107is now used by other packages.
108
109%package devel
110Summary: Development files for building against evolution-data-server
111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113Requires: pkgconfig
114Requires: sqlite3-devel
115Requires: libgnome-keyring-devel
116
117%description devel
118Development files needed for building things which link against
119evolution-data-server.
120
121%package doc
122Summary: Documentation files for %{name}
123Group: Applications/Documentation
124
125%description doc
126This package contains developer documentation for %{name}.
127
128%prep
129%setup -q
130
131%patch12 -p1 -b .fix-64bit-acinclude
132
133mkdir -p krb5-fakeprefix/include
134mkdir -p krb5-fakeprefix/lib
135mkdir -p krb5-fakeprefix/%{_lib}
136
137%build
138%if %{ldap_support}
139
140%if %{static_ldap}
141%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
142# Set LIBS so that configure will be able to link with static LDAP libraries,
143# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
144if pkg-config libssl ; then
145        export LIBS="-lsasl2 `pkg-config --libs libssl`"
146else
147        export LIBS="-lsasl2 -lssl -lcrypto"
148fi
149%else
150%define ldap_flags --with-openldap=yes
151%endif
152
153%else
154%define ldap_flags --without-openldap
155%endif
156
157%if %{krb5_support}
158%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
159%else
160%define krb5_flags --without-krb5
161%endif
162
163%if %{nntp_support}
164%define nntp_flags --enable-nntp=yes
165%else
166%define nntp_flags --enable-nntp=no
167%endif
168
169%if %{use_nss}
170%define ssl_flags --enable-nss=yes --enable-smime=yes
171%else
172%define ssl_flags --enable-openssl=yes
173%endif
174
175%if %{use_nss}
176if ! pkg-config --exists nss; then
177  echo "Unable to find suitable version of nss to use!"
178  exit 1
179fi
180%endif
181
182%if %{use_gnome_keyring}
183%define keyring_flags --enable-gnome-keyring
184%else
185%define keyring flags --disable-gnome-keyring
186%endif
187
188%if %{support_imap4_provider}
189%define imap4_flags --enable-imap4=yes
190%else
191%define imap4_flags --enable-imap4=no
192%endif
193
194export CPPFLAGS="-I%{_includedir}/et"
195export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
196
197# Regenerate configure to pick up configure.in and acinclude.m4 changes.
198aclocal -I m4
199autoheader
200automake
201libtoolize
202intltoolize --force
203autoconf
204
205# See Ross Burton's blog entry for why we want --with-libdb.
206# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
207
208%configure \
209        --with-libdb=/usr \
210        --enable-file-locking=fcntl \
211        --enable-dot-locking=no \
212        --enable-gtk-doc \
213        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
214        %keyring_flags
215export tagname=CC
216#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
217make LIBTOOL=/usr/bin/libtool
218
219%install
220rm -rf $RPM_BUILD_ROOT
221export tagname=CC
222make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
223
224# remove libtool archives for importers and the like
225find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
226find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
227
228# give the libraries some executable bits
229find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
230
231%find_lang %{name}-%{eds_base_version}
232
233%clean
234rm -rf $RPM_BUILD_ROOT
235
236%post -p /sbin/ldconfig
237
238%postun
239/sbin/ldconfig
240if [ $1 -eq 0 ]; then
241  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
242fi
243
244%posttrans
245glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
246
247
248%files -f %{name}-%{eds_base_version}.lang
249%defattr(-,root,root,-)
250%doc README COPYING ChangeLog NEWS AUTHORS
251%{_libdir}/*.so.*
252%{_libdir}/girepository-1.0/*.typelib
253%{_libexecdir}/evolution-addressbook-factory
254%{_libexecdir}/evolution-calendar-factory
255%{_libexecdir}/evolution-source-registry
256%{_libexecdir}/camel-index-control-%{eds_api_version}
257%{_libexecdir}/camel-lock-helper-%{eds_api_version}
258%{_datadir}/GConf/gsettings/evolution-data-server.convert
259%{_datadir}/GConf/gsettings/libedataserver.convert
260%{_datadir}/evolution-data-server-%{eds_base_version}
261%{_datadir}/dbus-1/services/*
262%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
263%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
264%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
265%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
266%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
267%{_datadir}/pixmaps/evolution-data-server
268
269%dir %{_libdir}/evolution-data-server
270%dir %{camel_provider_dir}
271%dir %{ebook_backends_dir}
272%dir %{ecal_backends_dir}
273%dir %{registry_modules_dir}
274
275# Camel providers:
276%{camel_provider_dir}/libcamelimap.so
277%{camel_provider_dir}/libcamelimap.urls
278
279%{camel_provider_dir}/libcamelimapx.so
280%{camel_provider_dir}/libcamelimapx.urls
281
282%{camel_provider_dir}/libcamellocal.so
283%{camel_provider_dir}/libcamellocal.urls
284
285%{camel_provider_dir}/libcamelnntp.so
286%{camel_provider_dir}/libcamelnntp.urls
287
288%{camel_provider_dir}/libcamelpop3.so
289%{camel_provider_dir}/libcamelpop3.urls
290
291%{camel_provider_dir}/libcamelsendmail.so
292%{camel_provider_dir}/libcamelsendmail.urls
293
294%{camel_provider_dir}/libcamelsmtp.so
295%{camel_provider_dir}/libcamelsmtp.urls
296
297# e-d-s extensions:
298%{ebook_backends_dir}/libebookbackendfile.so
299%{ebook_backends_dir}/libebookbackendgoogle.so
300%{ebook_backends_dir}/libebookbackendldap.so
301%{ebook_backends_dir}/libebookbackendvcf.so
302%{ebook_backends_dir}/libebookbackendwebdav.so
303
304%{ecal_backends_dir}/libecalbackendcaldav.so
305%{ecal_backends_dir}/libecalbackendcontacts.so
306%{ecal_backends_dir}/libecalbackendfile.so
307%{ecal_backends_dir}/libecalbackendhttp.so
308%{ecal_backends_dir}/libecalbackendweather.so
309
310%{registry_modules_dir}/module-cache-reaper.so
311%{registry_modules_dir}/module-google-backend.so
312%{registry_modules_dir}/module-online-accounts.so
313%{registry_modules_dir}/module-yahoo-backend.so
314
315%files devel
316%defattr(-,root,root,-)
317%{_includedir}/evolution-data-server-%{eds_base_version}
318%{_libdir}/*.so
319%{_libdir}/pkgconfig/*.pc
320%{_datadir}/gir-1.0/*.gir
321
322%files doc
323%defattr(-,root,root,-)
324%{_datadir}/gtk-doc/html/camel
325%{_datadir}/gtk-doc/html/libebackend
326%{_datadir}/gtk-doc/html/libebook
327%{_datadir}/gtk-doc/html/libecal
328%{_datadir}/gtk-doc/html/libedata-book
329%{_datadir}/gtk-doc/html/libedata-cal
330%{_datadir}/gtk-doc/html/libedataserver
331%{_datadir}/gtk-doc/html/libedataserverui
332
333%changelog
334* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
335- new upstream release
336
337* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
338- new upstream release
339
340* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
341- new upstream release
342
343* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
344- new upstream release
345
346* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
347- new upstream release
348
349* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
350- new upstream release
351
352* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
353- new upstream release
354- add BuildRequires: dbus-glib-devel
355
356* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
357- new upstream release
358
359* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
360- new upstream release
361
362* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
363- new upstream release
364
365* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
366- new upstream release
367
368* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
369- new upstream release
370- remove Patch101
371
372* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
373- new upstream release
374
375* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
376- new upstream release
377- change BuildRequires: gtk3-devel instead of gtk2-devel
378- BuildRequires: gnome-online-accounts-devel
379- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
380- fix %%files
381
382* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
383- new upstream release
384
385* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
386- rebuild with openssl-1.0.0c
387
388* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
389- new upstream release
390- remove Requires: gnome-vfs2, libglade2, libgnomeui
391- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
392- add BuildRequires: libgdata
393- add Requires: nspr-devel, nss-devel (devel package)
394- drop Patch11
395
396* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
397- rebuild with rpm-4.8.1 for pkg-config file
398
399* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
400- new upstream release
401
402* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
403- new upstream release
404
405* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
406- new upstream release
407- remove BuildRequires: libbonobo-devel
408- remove Requires: libbonobo
409- drop Patch10
410- add configure option (--with-krb5-libs, --with-krb5-includes)
411
412* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
413- rebuilt with db4-4.8
414
415* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
416- new upstream release
417
418* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
419- new upstream release
420
421* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
422- new upstream release
423
424* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
425- new upstream release
426
427* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
428- added Requires: libical-devel >= 0.43 to devel package
429
430* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
431- new upstream release
432- add BR: libgweather-devel >= 2.26.0
433- add BR: libical-devel >= 0.43
434
435* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
436- new upstream release
437- added BuildRequires: sqlite3-devel
438
439* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
440- enabled krb5 support
441
442* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
443- new upstream release
444
445* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
446- new upstream release
447
448* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
449- new upstream release
450
451* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
452- new upstream release
453
454* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
455- rebuilt with db4-4.6.21
456
457* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
458- new upstream release
459
460* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
461- new upstream release
462
463* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
464- new upstream release
465
466* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
467- new upstream release based on Fedora package 2.20.0-3.fc9
468  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
469  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
470  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
471  - Add patch for RH bug #296671 (GC servers may not support NTLM).
472  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
473  - Try removing the ancient "ldap-x86_64-hack" patch.
474  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
475  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
476- split doc subpackage
477
478* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
479- fixed dependancy
480
481* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
482- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
483  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
484  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
485  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
486  - Make the new ESourceComboBox widget work properly (RH bug #234760).
487  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
488  - Link to static evolution-openldap library (RH bug #210126).
489  - Require openssl-devel when statically linking against openldap.
490  - Add -Wdeclaration-after-statement to strict build settings.
491  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
492  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
493  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
494  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
495  - Update to 1.10.0
496  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
497  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
498  - Patch by Kenny Root.
499- rebuilt with nss-devel and nspr-devel
500
501* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
502- rebuilt with new toolchain and db4-4.3.x
503
504* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
505- new upstream release
506
507* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
508- new upstream release
509- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
510
511* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
512- new upstream release
513- rebuilt with openssl instead of mozilla-nss
514
515* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
516- rebuilt with openldap-2.3.24-0vl4
517
518* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
519- new upstream release
520- build with libsoap-2.2.7
521
522* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
523- new upstream release
524
525* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
526- new upstream release
527- added/removed Patches based on Fedora packages
528  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
529  - Updated patch 102 to fix further implicit function declarations
530  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
531  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
532    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
533  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
534  - Removed upstreamed patch:
535    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
536  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
537  - added patch to calendar/libecal/e-cal.c to fix missing declaration
538    of open_calendar
539- rebuilt with mozilla-1.7.12
540
541* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
542- rebuilt with mozilla-1.7.7
543
544* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
545- initial build for Vine Linux based on FC package
546- disable krb5 support
547
548* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
549- 1.2.1
550
551* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
552- Removed explicit run-time spec-file requirement on mozilla.
553  The Mozilla NSS API/ABI stabilised by version 1.7.3
554  The libraries are always located in the libdir
555  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
556  and so they move each time the mozilla version changes.
557  So we no longer have an explicit mozilla run-time requirement in the specfile;
558  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
559  We have an explicit, exact build-time version, so that we can find the headers (without
560  invoking an RPM query from the spec file; to do so is considered bad practice)
561- Introduced mozilla_build_version, to replace mozilla_version
562- Set mozilla_build_version to 1.7.6 to reflect current state of tree
563
564* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
565- Added a patch to deal with glibc defining a macro called "read"
566
567* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
568- 1.2.0
569- Removed patch for GCC 4 as this is now in upstream tarball
570
571* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
572- rebuild to fix library linking silliness
573
574* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
575- disabling gtk-doc on ia64 and s390x
576
577* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
578- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
579
580* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
581- extended patch to deal with camel-groupwise-store-summary.c
582
583* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
584- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
585
586* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
587- 1.1.6
588
589* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
590- rebuild
591
592* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
593- forgot to fix sources
594
595* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
596- 1.1.5
597
598* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
599- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
600
601* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
602- disable gtk-doc generation on ia64 for now
603
604* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
605- Exclude ppc64 due to missing mozilla dependency
606
607* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
608- Update from 1.0.3 to 1.1.4.1
609- Updated eds_major from 1.0 to 1.2; fixed translation search path.
610- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
611- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
612- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
613- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
614- Camel code from evolution is now in evolution-data-server:
615  - Added camel-index-control and camel-lock-helper to packaged files
616  - Added mozilla dependency code from the evolution package
617  - Ditto for LDAP
618  - Ditto for krb5
619  - Ditto for NNTP support handling
620  - Ditto for --enable-file-locking and --enable-dot-locking
621- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
622- Updated libsoup requirement from 2.2.1 to 2.2.2
623- Enabled gtk-doc
624
625* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
626- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
627
628* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
629- update from upstream 1.0.2 to 1.0.3:
630  * Address Book
631    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
632    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
633
634  * Calendar
635    #XB59904 - Speed up calendar queries (Rodrigo)
636    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
637    - fix libical build for automake 1.9 (Rodney)
638    - fix putenv usage for portability (Julio M. Merino Vidal)
639
640  * Updated Translations:
641    - sv (Christian Rose)
642
643- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
644
645* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
646- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
647http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
648(The groupwise part of that patch did not cleanly apply, so I removed it).
649
650* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
651- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
652optimisation patch posted to upstream development mailing list here:
653http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
654
655* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
656- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
657
658* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
659- added workaround for a backend leak that causes the "contacts" calendar
660backend to hold open an EBook for the local contacts (filed upstream at:
661http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
662never lose its last addressbook, and hence never quit.  We workaround this by
663detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
664
665* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
666- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
667
668* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
669- update from 1.0.1 to 1.0.2
670- increased libsoup requirement to 2.2.1 to match configuration script
671
672* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
673- update from 1.0.0 to 1.0.1
674- removed patch that fixed warnings in calendar code (now in upstream tarball)
675
676* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
677- fixed various warnings in the calendar code
678  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
679
680* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
681- update from 0.0.99 to 1.0.0
682- changed path in FTP source location from 0.0 to 1.0
683
684* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
685- update from 0.0.98 to 0.0.99
686- increased libsoup requirement to 2.2.0 to match configuration script
687
688* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
689- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
690
691* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
692- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
693
694* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
695- upgraded to 0.0.97; rewrote the package's description
696
697* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
698- rebuilt
699
700* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
701- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
702
703* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
704- 0.0.96; libsoup required is now 2.1.12
705
706* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
707- rebuilt
708
709* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
710- rebuilt
711
712* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
713- 0.0.95
714
715* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
716- 0.0.94.1
717
718* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
719- rebuilt
720
721* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
722- 0.0.94
723
724* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
725- added ORBit2 requirement
726
727* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
728- rebuild again
729
730* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
731- rebuilt
732
733* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
734- 0.0.93; libsoup required is now 2.1.10
735
736* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
737- Update to 0.0.92; added a define and a requirement on the libsoup version
738
739* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
740- 0.0.90
741
742* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
743- rebuilt
744
745* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
746- 0.0.6
747
748* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
749- better fix by using system libtool
750
751* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
752- add some libdb linkage to make the build on x86_64 happy
753
754* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
755- update to 0.0.5
756
757* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
758- Initial build.
Note: See TracBrowser for help on using the repository browser.