source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 6401

Revision 6401, 25.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.32.0
8%define gtk3_version 3.4.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.4
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.4.3
33Release: 1%{?_dist_release}
34License: LGPL
35Group: System Environment/Libraries
36URL: http://www.gnome.org/projects/evolution/
37Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.4/%{name}-%{version}.tar.xz
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40### Patches ###
41
42# RH bug #243296
43Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
44
45### Dependencies ###
46
47Requires: GConf2
48Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53BuildRequires: GConf2-devel
54BuildRequires: ORBit2-devel >= %{orbit2_version}
55BuildRequires: bison
56BuildRequires: db4-devel
57BuildRequires: flex
58BuildRequires: gettext
59BuildRequires: glib2-devel
60BuildRequires: gtk3-devel
61BuildRequires: dbus-glib-devel
62BuildRequires: gnutls-devel
63BuildRequires: intltool >= %{intltool_version}
64BuildRequires: libsoup-devel >= %{soup_version}
65BuildRequires: libtool
66BuildRequires: libgnome-keyring-devel
67BuildRequires: gtk-doc >= 1.14
68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
71BuildRequires: gperf
72BuildRequires: krb5-devel
73BuildRequires: libgdata-devel >= %{libgdata_version}
74BuildRequires: gnome-online-accounts-devel
75BuildRequires: liboauth-devel
76
77%if %{use_nss}
78BuildRequires: nspr-devel
79BuildRequires: nss-devel
80%else
81BuildRequires: openssl-devel
82%endif
83
84%if %{ldap_support}
85%if %{static_ldap}
86BuildRequires: openldap-evolution-devel
87BuildRequires: openssl-devel
88%else
89BuildRequires: openldap-devel >= 2.0.11
90%endif
91%endif
92
93%if %{krb5_support}
94BuildRequires: krb5-devel
95# tweak for krb5 1.2 vs 1.3
96%define krb5dir /usr/kerberos
97#define krb5dir `pwd`/krb5-fakeprefix
98%endif
99
100Vendor: Project Vine
101Distribution: Vine Linux
102
103%description
104The evolution-data-server package provides a unified backend for
105programs that work with contacts, tasks, and calendar information.
106
107It was originally developed for Evolution (hence the name), but
108is now used by other packages.
109
110%package devel
111Summary: Development files for building against evolution-data-server
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114Requires: libgnome-devel
115Requires: libgweather-devel
116Requires: libsoup-devel
117Requires: libical-devel >= %{libical_version}
118Requires: sqlite3-devel
119%if %{use_nss}
120Requires: nspr-devel
121Requires: nss-devel
122%endif
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128%package doc
129Summary: Documentation files for %{name}
130Group: Applications/Documentation
131
132%description doc
133This package contains developer documentation for %{name}.
134
135%prep
136%setup -q
137
138%patch12 -p1 -b .fix-64bit-acinclude
139
140mkdir -p krb5-fakeprefix/include
141mkdir -p krb5-fakeprefix/lib
142mkdir -p krb5-fakeprefix/%{_lib}
143
144%build
145%if %{ldap_support}
146
147%if %{static_ldap}
148%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
149# Set LIBS so that configure will be able to link with static LDAP libraries,
150# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
151if pkg-config libssl ; then
152        export LIBS="-lsasl2 `pkg-config --libs libssl`"
153else
154        export LIBS="-lsasl2 -lssl -lcrypto"
155fi
156%else
157%define ldap_flags --with-openldap=yes
158%endif
159
160%else
161%define ldap_flags --without-openldap
162%endif
163
164%if %{krb5_support}
165%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
166%else
167%define krb5_flags --without-krb5
168%endif
169
170%if %{nntp_support}
171%define nntp_flags --enable-nntp=yes
172%else
173%define nntp_flags --enable-nntp=no
174%endif
175
176%if %{use_nss}
177%define ssl_flags --enable-nss=yes --enable-smime=yes
178%else
179%define ssl_flags --enable-openssl=yes
180%endif
181
182%if %{use_nss}
183if ! pkg-config --exists nss; then
184  echo "Unable to find suitable version of nss to use!"
185  exit 1
186fi
187%endif
188
189%if %{use_gnome_keyring}
190%define keyring_flags --enable-gnome-keyring
191%else
192%define keyring flags --disable-gnome-keyring
193%endif
194
195%if %{support_imap4_provider}
196%define imap4_flags --enable-imap4=yes
197%else
198%define imap4_flags --enable-imap4=no
199%endif
200
201export CPPFLAGS="-I%{_includedir}/et"
202export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
203
204# Regenerate configure to pick up configure.in and acinclude.m4 changes.
205aclocal -I m4
206autoheader
207automake
208libtoolize
209intltoolize --force
210autoconf
211
212# See Ross Burton's blog entry for why we want --with-libdb.
213# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
214
215%configure \
216        --with-libdb=/usr \
217        --enable-file-locking=fcntl \
218        --enable-dot-locking=no \
219        --enable-gtk-doc \
220        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
221        %keyring_flags
222export tagname=CC
223#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
224make LIBTOOL=/usr/bin/libtool
225
226%install
227rm -rf $RPM_BUILD_ROOT
228export tagname=CC
229make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
230
231# remove libtool archives for importers and the like
232find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
233rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
234rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/camel-providers/*.a
235rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/addressbook-backends/*.a
236rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/calendar-backends/*.a
237
238# give the libraries some executable bits
239find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
240
241%find_lang %{name}-%{eds_base_version}
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post -p /sbin/ldconfig
247
248%postun
249/sbin/ldconfig
250if [ $1 -eq 0 ]; then
251  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
252fi
253
254%posttrans
255glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256
257
258%files -f %{name}-%{eds_base_version}.lang
259%defattr(-,root,root,-)
260%doc README COPYING ChangeLog NEWS AUTHORS
261%{_libdir}/*.so.*
262%{_libdir}/girepository-1.0/*.typelib
263%{_libexecdir}/evolution-addressbook-factory
264%{_libexecdir}/evolution-calendar-factory
265%{_libexecdir}/camel-index-control-%{eds_api_version}
266%{_libexecdir}/camel-lock-helper-%{eds_api_version}
267%{_datadir}/GConf/gsettings/libedataserver.convert
268%{_datadir}/evolution-data-server-%{eds_base_version}
269%{_datadir}/dbus-1/services/*
270%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
271%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
272%{_datadir}/pixmaps/evolution-data-server
273
274%dir %{_libdir}/evolution-data-server
275%dir %{camel_provider_dir}
276%dir %{ebook_backends_dir}
277%dir %{ecal_backends_dir}
278
279# Camel providers:
280%{camel_provider_dir}/libcamelimap.so
281%{camel_provider_dir}/libcamelimap.urls
282
283%{camel_provider_dir}/libcamelimapx.so
284%{camel_provider_dir}/libcamelimapx.urls
285
286%{camel_provider_dir}/libcamellocal.so
287%{camel_provider_dir}/libcamellocal.urls
288
289%{camel_provider_dir}/libcamelnntp.so
290%{camel_provider_dir}/libcamelnntp.urls
291
292%{camel_provider_dir}/libcamelpop3.so
293%{camel_provider_dir}/libcamelpop3.urls
294
295%{camel_provider_dir}/libcamelsendmail.so
296%{camel_provider_dir}/libcamelsendmail.urls
297
298%{camel_provider_dir}/libcamelsmtp.so
299%{camel_provider_dir}/libcamelsmtp.urls
300
301# e-d-s extensions:
302%{ebook_backends_dir}/libebookbackendfile.so
303%{ebook_backends_dir}/libebookbackendgoogle.so
304%{ebook_backends_dir}/libebookbackendldap.so
305%{ebook_backends_dir}/libebookbackendvcf.so
306%{ebook_backends_dir}/libebookbackendwebdav.so
307
308%{ecal_backends_dir}/libecalbackendcaldav.so
309%{ecal_backends_dir}/libecalbackendcontacts.so
310%{ecal_backends_dir}/libecalbackendfile.so
311%{ecal_backends_dir}/libecalbackendhttp.so
312%{ecal_backends_dir}/libecalbackendweather.so
313
314%files devel
315%defattr(-,root,root,-)
316%{_includedir}/evolution-data-server-%{eds_base_version}
317%{_libdir}/*.so
318%{_libdir}/pkgconfig/*.pc
319%{_datadir}/gir-1.0/*.gir
320
321%files doc
322%defattr(-,root,root,-)
323%{_datadir}/gtk-doc/html/camel
324%{_datadir}/gtk-doc/html/libebackend
325%{_datadir}/gtk-doc/html/libebook
326%{_datadir}/gtk-doc/html/libecal
327%{_datadir}/gtk-doc/html/libedata-book
328%{_datadir}/gtk-doc/html/libedata-cal
329%{_datadir}/gtk-doc/html/libedataserver
330%{_datadir}/gtk-doc/html/libedataserverui
331
332%changelog
333* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
334- new upstream release
335
336* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
337- new upstream release
338
339* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
340- new upstream release
341- add BuildRequires: dbus-glib-devel
342
343* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
344- new upstream release
345
346* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
347- new upstream release
348
349* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
350- new upstream release
351
352* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
353- new upstream release
354
355* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
356- new upstream release
357- remove Patch101
358
359* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
360- new upstream release
361
362* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
363- new upstream release
364- change BuildRequires: gtk3-devel instead of gtk2-devel
365- BuildRequires: gnome-online-accounts-devel
366- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
367- fix %%files
368
369* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
370- new upstream release
371
372* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
373- rebuild with openssl-1.0.0c
374
375* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
376- new upstream release
377- remove Requires: gnome-vfs2, libglade2, libgnomeui
378- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
379- add BuildRequires: libgdata
380- add Requires: nspr-devel, nss-devel (devel package)
381- drop Patch11
382
383* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
384- rebuild with rpm-4.8.1 for pkg-config file
385
386* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
387- new upstream release
388
389* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
390- new upstream release
391
392* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
393- new upstream release
394- remove BuildRequires: libbonobo-devel
395- remove Requires: libbonobo
396- drop Patch10
397- add configure option (--with-krb5-libs, --with-krb5-includes)
398
399* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
400- rebuilt with db4-4.8
401
402* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
403- new upstream release
404
405* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
406- new upstream release
407
408* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
409- new upstream release
410
411* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
412- new upstream release
413
414* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
415- added Requires: libical-devel >= 0.43 to devel package
416
417* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
418- new upstream release
419- add BR: libgweather-devel >= 2.26.0
420- add BR: libical-devel >= 0.43
421
422* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
423- new upstream release
424- added BuildRequires: sqlite3-devel
425
426* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
427- enabled krb5 support
428
429* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
430- new upstream release
431
432* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
433- new upstream release
434
435* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
436- new upstream release
437
438* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
439- new upstream release
440
441* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
442- rebuilt with db4-4.6.21
443
444* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
445- new upstream release
446
447* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
448- new upstream release
449
450* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
451- new upstream release
452
453* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
454- new upstream release based on Fedora package 2.20.0-3.fc9
455  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
456  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
457  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
458  - Add patch for RH bug #296671 (GC servers may not support NTLM).
459  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
460  - Try removing the ancient "ldap-x86_64-hack" patch.
461  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
462  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
463- split doc subpackage
464
465* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
466- fixed dependancy
467
468* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
469- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
470  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
471  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
472  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
473  - Make the new ESourceComboBox widget work properly (RH bug #234760).
474  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
475  - Link to static evolution-openldap library (RH bug #210126).
476  - Require openssl-devel when statically linking against openldap.
477  - Add -Wdeclaration-after-statement to strict build settings.
478  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
479  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
480  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
481  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
482  - Update to 1.10.0
483  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
484  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
485  - Patch by Kenny Root.
486- rebuilt with nss-devel and nspr-devel
487
488* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
489- rebuilt with new toolchain and db4-4.3.x
490
491* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
492- new upstream release
493
494* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
495- new upstream release
496- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
497
498* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
499- new upstream release
500- rebuilt with openssl instead of mozilla-nss
501
502* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
503- rebuilt with openldap-2.3.24-0vl4
504
505* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
506- new upstream release
507- build with libsoap-2.2.7
508
509* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
510- new upstream release
511
512* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
513- new upstream release
514- added/removed Patches based on Fedora packages
515  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
516  - Updated patch 102 to fix further implicit function declarations
517  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
518  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
519    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
520  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
521  - Removed upstreamed patch:
522    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
523  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
524  - added patch to calendar/libecal/e-cal.c to fix missing declaration
525    of open_calendar
526- rebuilt with mozilla-1.7.12
527
528* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
529- rebuilt with mozilla-1.7.7
530
531* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
532- initial build for Vine Linux based on FC package
533- disable krb5 support
534
535* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
536- 1.2.1
537
538* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
539- Removed explicit run-time spec-file requirement on mozilla.
540  The Mozilla NSS API/ABI stabilised by version 1.7.3
541  The libraries are always located in the libdir
542  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
543  and so they move each time the mozilla version changes.
544  So we no longer have an explicit mozilla run-time requirement in the specfile;
545  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
546  We have an explicit, exact build-time version, so that we can find the headers (without
547  invoking an RPM query from the spec file; to do so is considered bad practice)
548- Introduced mozilla_build_version, to replace mozilla_version
549- Set mozilla_build_version to 1.7.6 to reflect current state of tree
550
551* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
552- Added a patch to deal with glibc defining a macro called "read"
553
554* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
555- 1.2.0
556- Removed patch for GCC 4 as this is now in upstream tarball
557
558* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
559- rebuild to fix library linking silliness
560
561* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
562- disabling gtk-doc on ia64 and s390x
563
564* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
565- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
566
567* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
568- extended patch to deal with camel-groupwise-store-summary.c
569
570* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
571- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
572
573* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
574- 1.1.6
575
576* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
577- rebuild
578
579* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
580- forgot to fix sources
581
582* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
583- 1.1.5
584
585* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
586- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
587
588* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
589- disable gtk-doc generation on ia64 for now
590
591* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
592- Exclude ppc64 due to missing mozilla dependency
593
594* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
595- Update from 1.0.3 to 1.1.4.1
596- Updated eds_major from 1.0 to 1.2; fixed translation search path.
597- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
598- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
599- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
600- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
601- Camel code from evolution is now in evolution-data-server:
602  - Added camel-index-control and camel-lock-helper to packaged files
603  - Added mozilla dependency code from the evolution package
604  - Ditto for LDAP
605  - Ditto for krb5
606  - Ditto for NNTP support handling
607  - Ditto for --enable-file-locking and --enable-dot-locking
608- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
609- Updated libsoup requirement from 2.2.1 to 2.2.2
610- Enabled gtk-doc
611
612* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
613- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
614
615* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
616- update from upstream 1.0.2 to 1.0.3:
617  * Address Book
618    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
619    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
620
621  * Calendar
622    #XB59904 - Speed up calendar queries (Rodrigo)
623    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
624    - fix libical build for automake 1.9 (Rodney)
625    - fix putenv usage for portability (Julio M. Merino Vidal)
626
627  * Updated Translations:
628    - sv (Christian Rose)
629
630- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
631
632* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
633- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
634http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
635(The groupwise part of that patch did not cleanly apply, so I removed it).
636
637* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
638- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
639optimisation patch posted to upstream development mailing list here:
640http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
641
642* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
643- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
644
645* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
646- added workaround for a backend leak that causes the "contacts" calendar
647backend to hold open an EBook for the local contacts (filed upstream at:
648http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
649never lose its last addressbook, and hence never quit.  We workaround this by
650detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
651
652* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
653- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
654
655* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
656- update from 1.0.1 to 1.0.2
657- increased libsoup requirement to 2.2.1 to match configuration script
658
659* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
660- update from 1.0.0 to 1.0.1
661- removed patch that fixed warnings in calendar code (now in upstream tarball)
662
663* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
664- fixed various warnings in the calendar code
665  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
666
667* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
668- update from 0.0.99 to 1.0.0
669- changed path in FTP source location from 0.0 to 1.0
670
671* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
672- update from 0.0.98 to 0.0.99
673- increased libsoup requirement to 2.2.0 to match configuration script
674
675* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
676- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
677
678* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
679- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
680
681* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
682- upgraded to 0.0.97; rewrote the package's description
683
684* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
685- rebuilt
686
687* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
688- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
689
690* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
691- 0.0.96; libsoup required is now 2.1.12
692
693* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
694- rebuilt
695
696* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
697- rebuilt
698
699* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
700- 0.0.95
701
702* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
703- 0.0.94.1
704
705* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
706- rebuilt
707
708* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
709- 0.0.94
710
711* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
712- added ORBit2 requirement
713
714* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
715- rebuild again
716
717* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
718- rebuilt
719
720* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
721- 0.0.93; libsoup required is now 2.1.10
722
723* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
724- Update to 0.0.92; added a define and a requirement on the libsoup version
725
726* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
727- 0.0.90
728
729* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
730- rebuilt
731
732* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
733- 0.0.6
734
735* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
736- better fix by using system libtool
737
738* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
739- add some libdb linkage to make the build on x86_64 happy
740
741* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
742- update to 0.0.5
743
744* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
745- Initial build.
Note: See TracBrowser for help on using the repository browser.