source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 4616

Revision 4616, 24.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.28.6
8%define gtk3_version 3.0.9
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.32.0
13%define libgweather_version 2.30.3
14%define libical_version 0.44
15%define libgdata_version 0.9.1
16
17%define eds_base_version 3.2
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.1.4
33Release: 1%{?_dist_release}
34License: LGPL
35Group: System Environment/Libraries
36URL: http://www.gnome.org/projects/evolution/
37Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.1/%{name}-%{version}.tar.xz
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40### Patches ###
41
42# RH bug #243296
43Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
44
45Patch101: evolution-data-server-3.1.3-build-with-glib-2.29.14.patch
46
47### Dependencies ###
48
49Requires: GConf2
50Requires: ORBit2 >= %{orbit2_version}
51Requires: libsoup >= %{soup_version}
52
53### Build Dependencies ###
54
55BuildRequires: GConf2-devel
56BuildRequires: ORBit2-devel >= %{orbit2_version}
57BuildRequires: bison
58BuildRequires: db4-devel
59BuildRequires: flex
60BuildRequires: gettext
61BuildRequires: glib2-devel
62BuildRequires: gtk3-devel
63BuildRequires: gnutls-devel
64BuildRequires: intltool >= %{intltool_version}
65BuildRequires: libsoup-devel >= %{soup_version}
66BuildRequires: libtool
67BuildRequires: libgnome-keyring-devel
68BuildRequires: gtk-doc >= 1.14
69BuildRequires: sqlite3-devel
70BuildRequires: libgweather-devel >= %{libgweather_version}
71BuildRequires: libical-devel >= %{libical_version}
72BuildRequires: gperf
73BuildRequires: krb5-devel
74BuildRequires: libgdata-devel >= %{libgdata_version}
75BuildRequires: gnome-online-accounts-devel
76BuildRequires: liboauth-devel
77
78%if %{use_nss}
79BuildRequires: nspr-devel
80BuildRequires: nss-devel
81%else
82BuildRequires: openssl-devel
83%endif
84
85%if %{ldap_support}
86%if %{static_ldap}
87BuildRequires: openldap-evolution-devel
88BuildRequires: openssl-devel
89%else
90BuildRequires: openldap-devel >= 2.0.11
91%endif
92%endif
93
94%if %{krb5_support}
95BuildRequires: krb5-devel
96# tweak for krb5 1.2 vs 1.3
97%define krb5dir /usr/kerberos
98#define krb5dir `pwd`/krb5-fakeprefix
99%endif
100
101Vendor: Project Vine
102Distribution: Vine Linux
103
104%description
105The evolution-data-server package provides a unified backend for
106programs that work with contacts, tasks, and calendar information.
107
108It was originally developed for Evolution (hence the name), but
109is now used by other packages.
110
111%package devel
112Summary: Development files for building against evolution-data-server
113Group: Development/Libraries
114Requires: %{name} = %{version}-%{release}
115Requires: libgnome-devel
116Requires: libgweather-devel
117Requires: libsoup-devel
118Requires: libical-devel >= %{libical_version}
119Requires: sqlite3-devel
120%if %{use_nss}
121Requires: nspr-devel
122Requires: nss-devel
123%endif
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129%package doc
130Summary: Documentation files for %{name}
131Group: Applications/Documentation
132
133%description doc
134This package contains developer documentation for %{name}.
135
136%prep
137%setup -q
138
139%patch12 -p1 -b .fix-64bit-acinclude
140%patch101 -p1 -b .glib-2.29.14
141
142mkdir -p krb5-fakeprefix/include
143mkdir -p krb5-fakeprefix/lib
144mkdir -p krb5-fakeprefix/%{_lib}
145
146%build
147%if %{ldap_support}
148
149%if %{static_ldap}
150%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
151# Set LIBS so that configure will be able to link with static LDAP libraries,
152# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
153if pkg-config libssl ; then
154        export LIBS="-lsasl2 `pkg-config --libs libssl`"
155else
156        export LIBS="-lsasl2 -lssl -lcrypto"
157fi
158%else
159%define ldap_flags --with-openldap=yes
160%endif
161
162%else
163%define ldap_flags --without-openldap
164%endif
165
166%if %{krb5_support}
167%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
168%else
169%define krb5_flags --without-krb5
170%endif
171
172%if %{nntp_support}
173%define nntp_flags --enable-nntp=yes
174%else
175%define nntp_flags --enable-nntp=no
176%endif
177
178%if %{use_nss}
179%define ssl_flags --enable-nss=yes --enable-smime=yes
180%else
181%define ssl_flags --enable-openssl=yes
182%endif
183
184%if %{use_nss}
185if ! pkg-config --exists nss; then
186  echo "Unable to find suitable version of nss to use!"
187  exit 1
188fi
189%endif
190
191%if %{use_gnome_keyring}
192%define keyring_flags --enable-gnome-keyring
193%else
194%define keyring flags --disable-gnome-keyring
195%endif
196
197%if %{support_imap4_provider}
198%define imap4_flags --enable-imap4=yes
199%else
200%define imap4_flags --enable-imap4=no
201%endif
202
203export CPPFLAGS="-I%{_includedir}/et"
204export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
205
206# Regenerate configure to pick up configure.in and acinclude.m4 changes.
207aclocal -I m4
208autoheader
209automake
210libtoolize
211intltoolize --force
212autoconf
213
214# See Ross Burton's blog entry for why we want --with-libdb.
215# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
216
217%configure \
218        --with-libdb=/usr \
219        --enable-file-locking=fcntl \
220        --enable-dot-locking=no \
221        --enable-gtk-doc \
222        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
223        %keyring_flags
224export tagname=CC
225#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
226make LIBTOOL=/usr/bin/libtool
227
228%install
229rm -rf $RPM_BUILD_ROOT
230export tagname=CC
231make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
232
233# remove libtool archives for importers and the like
234find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
235rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
236rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/camel-providers/*.a
237rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/addressbook-backends/*.a
238rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/calendar-backends/*.a
239
240# give the libraries some executable bits
241find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
242
243%find_lang %{name}-%{eds_base_version}
244
245%clean
246rm -rf $RPM_BUILD_ROOT
247
248%post -p /sbin/ldconfig
249
250%postun -p /sbin/ldconfig
251
252%files -f %{name}-%{eds_base_version}.lang
253%defattr(-,root,root,-)
254%doc README COPYING ChangeLog NEWS AUTHORS
255%{_libdir}/*.so.*
256%{_libdir}/girepository-1.0/*.typelib
257%{_libexecdir}/e-addressbook-factory
258%{_libexecdir}/e-calendar-factory
259%{_libexecdir}/camel-index-control-%{eds_api_version}
260%{_libexecdir}/camel-lock-helper-%{eds_api_version}
261%{_datadir}/evolution-data-server-%{eds_base_version}
262%{_datadir}/pixmaps/evolution-data-server
263%{_datadir}/dbus-1/services/*
264
265%dir %{_libdir}/evolution-data-server
266%dir %{camel_provider_dir}
267%dir %{ebook_backends_dir}
268%dir %{ecal_backends_dir}
269
270# Camel providers:
271%{camel_provider_dir}/libcamelimap.so
272%{camel_provider_dir}/libcamelimap.urls
273
274%{camel_provider_dir}/libcamelimapx.so
275%{camel_provider_dir}/libcamelimapx.urls
276
277%{camel_provider_dir}/libcamellocal.so
278%{camel_provider_dir}/libcamellocal.urls
279
280%{camel_provider_dir}/libcamelnntp.so
281%{camel_provider_dir}/libcamelnntp.urls
282
283%{camel_provider_dir}/libcamelpop3.so
284%{camel_provider_dir}/libcamelpop3.urls
285
286%{camel_provider_dir}/libcamelsendmail.so
287%{camel_provider_dir}/libcamelsendmail.urls
288
289%{camel_provider_dir}/libcamelsmtp.so
290%{camel_provider_dir}/libcamelsmtp.urls
291
292# e-d-s extensions:
293%{ebook_backends_dir}/libebookbackendfile.so
294%{ebook_backends_dir}/libebookbackendgoogle.so
295%{ebook_backends_dir}/libebookbackendldap.so
296%{ebook_backends_dir}/libebookbackendvcf.so
297%{ebook_backends_dir}/libebookbackendwebdav.so
298
299%{ecal_backends_dir}/libecalbackendcaldav.so
300%{ecal_backends_dir}/libecalbackendcontacts.so
301%{ecal_backends_dir}/libecalbackendfile.so
302%{ecal_backends_dir}/libecalbackendhttp.so
303%{ecal_backends_dir}/libecalbackendweather.so
304
305%files devel
306%defattr(-,root,root,-)
307%{_includedir}/evolution-data-server-%{eds_base_version}
308%{_libdir}/*.so
309%{_libdir}/pkgconfig/*.pc
310%{_datadir}/gir-1.0/*.gir
311
312%files doc
313%defattr(-,root,root,-)
314%{_datadir}/gtk-doc/html/camel
315%{_datadir}/gtk-doc/html/libebackend
316%{_datadir}/gtk-doc/html/libebook
317%{_datadir}/gtk-doc/html/libecal
318%{_datadir}/gtk-doc/html/libedata-book
319%{_datadir}/gtk-doc/html/libedata-cal
320%{_datadir}/gtk-doc/html/libedataserver
321%{_datadir}/gtk-doc/html/libedataserverui
322
323%changelog
324* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
325- new upstream release
326- change BuildRequires: gtk3-devel instead of gtk2-devel
327- BuildRequires: gnome-online-accounts-devel
328- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
329- fix %%files
330
331* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
332- new upstream release
333
334* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
335- rebuild with openssl-1.0.0c
336
337* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
338- new upstream release
339- remove Requires: gnome-vfs2, libglade2, libgnomeui
340- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
341- add BuildRequires: libgdata
342- add Requires: nspr-devel, nss-devel (devel package)
343- drop Patch11
344
345* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
346- rebuild with rpm-4.8.1 for pkg-config file
347
348* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
349- new upstream release
350
351* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
352- new upstream release
353
354* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
355- new upstream release
356- remove BuildRequires: libbonobo-devel
357- remove Requires: libbonobo
358- drop Patch10
359- add configure option (--with-krb5-libs, --with-krb5-includes)
360
361* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
362- rebuilt with db4-4.8
363
364* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
365- new upstream release
366
367* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
368- new upstream release
369
370* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
371- new upstream release
372
373* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
374- new upstream release
375
376* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
377- added Requires: libical-devel >= 0.43 to devel package
378
379* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
380- new upstream release
381- add BR: libgweather-devel >= 2.26.0
382- add BR: libical-devel >= 0.43
383
384* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
385- new upstream release
386- added BuildRequires: sqlite3-devel
387
388* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
389- enabled krb5 support
390
391* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
392- new upstream release
393
394* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
395- new upstream release
396
397* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
398- new upstream release
399
400* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
401- new upstream release
402
403* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
404- rebuilt with db4-4.6.21
405
406* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
407- new upstream release
408
409* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
410- new upstream release
411
412* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
413- new upstream release
414
415* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
416- new upstream release based on Fedora package 2.20.0-3.fc9
417  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
418  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
419  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
420  - Add patch for RH bug #296671 (GC servers may not support NTLM).
421  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
422  - Try removing the ancient "ldap-x86_64-hack" patch.
423  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
424  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
425- split doc subpackage
426
427* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
428- fixed dependancy
429
430* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
431- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
432  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
433  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
434  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
435  - Make the new ESourceComboBox widget work properly (RH bug #234760).
436  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
437  - Link to static evolution-openldap library (RH bug #210126).
438  - Require openssl-devel when statically linking against openldap.
439  - Add -Wdeclaration-after-statement to strict build settings.
440  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
441  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
442  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
443  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
444  - Update to 1.10.0
445  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
446  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
447  - Patch by Kenny Root.
448- rebuilt with nss-devel and nspr-devel
449
450* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
451- rebuilt with new toolchain and db4-4.3.x
452
453* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
454- new upstream release
455
456* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
457- new upstream release
458- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
459
460* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
461- new upstream release
462- rebuilt with openssl instead of mozilla-nss
463
464* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
465- rebuilt with openldap-2.3.24-0vl4
466
467* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
468- new upstream release
469- build with libsoap-2.2.7
470
471* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
472- new upstream release
473
474* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
475- new upstream release
476- added/removed Patches based on Fedora packages
477  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
478  - Updated patch 102 to fix further implicit function declarations
479  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
480  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
481    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
482  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
483  - Removed upstreamed patch:
484    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
485  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
486  - added patch to calendar/libecal/e-cal.c to fix missing declaration
487    of open_calendar
488- rebuilt with mozilla-1.7.12
489
490* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
491- rebuilt with mozilla-1.7.7
492
493* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
494- initial build for Vine Linux based on FC package
495- disable krb5 support
496
497* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
498- 1.2.1
499
500* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
501- Removed explicit run-time spec-file requirement on mozilla.
502  The Mozilla NSS API/ABI stabilised by version 1.7.3
503  The libraries are always located in the libdir
504  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
505  and so they move each time the mozilla version changes.
506  So we no longer have an explicit mozilla run-time requirement in the specfile;
507  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
508  We have an explicit, exact build-time version, so that we can find the headers (without
509  invoking an RPM query from the spec file; to do so is considered bad practice)
510- Introduced mozilla_build_version, to replace mozilla_version
511- Set mozilla_build_version to 1.7.6 to reflect current state of tree
512
513* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
514- Added a patch to deal with glibc defining a macro called "read"
515
516* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
517- 1.2.0
518- Removed patch for GCC 4 as this is now in upstream tarball
519
520* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
521- rebuild to fix library linking silliness
522
523* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
524- disabling gtk-doc on ia64 and s390x
525
526* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
527- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
528
529* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
530- extended patch to deal with camel-groupwise-store-summary.c
531
532* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
533- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
534
535* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
536- 1.1.6
537
538* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
539- rebuild
540
541* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
542- forgot to fix sources
543
544* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
545- 1.1.5
546
547* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
548- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
549
550* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
551- disable gtk-doc generation on ia64 for now
552
553* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
554- Exclude ppc64 due to missing mozilla dependency
555
556* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
557- Update from 1.0.3 to 1.1.4.1
558- Updated eds_major from 1.0 to 1.2; fixed translation search path.
559- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
560- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
561- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
562- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
563- Camel code from evolution is now in evolution-data-server:
564  - Added camel-index-control and camel-lock-helper to packaged files
565  - Added mozilla dependency code from the evolution package
566  - Ditto for LDAP
567  - Ditto for krb5
568  - Ditto for NNTP support handling
569  - Ditto for --enable-file-locking and --enable-dot-locking
570- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
571- Updated libsoup requirement from 2.2.1 to 2.2.2
572- Enabled gtk-doc
573
574* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
575- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
576
577* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
578- update from upstream 1.0.2 to 1.0.3:
579  * Address Book
580    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
581    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
582
583  * Calendar
584    #XB59904 - Speed up calendar queries (Rodrigo)
585    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
586    - fix libical build for automake 1.9 (Rodney)
587    - fix putenv usage for portability (Julio M. Merino Vidal)
588
589  * Updated Translations:
590    - sv (Christian Rose)
591
592- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
593
594* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
595- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
596http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
597(The groupwise part of that patch did not cleanly apply, so I removed it).
598
599* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
600- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
601optimisation patch posted to upstream development mailing list here:
602http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
603
604* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
605- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
606
607* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
608- added workaround for a backend leak that causes the "contacts" calendar
609backend to hold open an EBook for the local contacts (filed upstream at:
610http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
611never lose its last addressbook, and hence never quit.  We workaround this by
612detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
613
614* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
615- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
616
617* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
618- update from 1.0.1 to 1.0.2
619- increased libsoup requirement to 2.2.1 to match configuration script
620
621* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
622- update from 1.0.0 to 1.0.1
623- removed patch that fixed warnings in calendar code (now in upstream tarball)
624
625* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
626- fixed various warnings in the calendar code
627  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
628
629* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
630- update from 0.0.99 to 1.0.0
631- changed path in FTP source location from 0.0 to 1.0
632
633* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
634- update from 0.0.98 to 0.0.99
635- increased libsoup requirement to 2.2.0 to match configuration script
636
637* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
638- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
639
640* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
641- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
642
643* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
644- upgraded to 0.0.97; rewrote the package's description
645
646* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
647- rebuilt
648
649* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
650- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
651
652* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
653- 0.0.96; libsoup required is now 2.1.12
654
655* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
656- rebuilt
657
658* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
659- rebuilt
660
661* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
662- 0.0.95
663
664* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
665- 0.0.94.1
666
667* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
668- rebuilt
669
670* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
671- 0.0.94
672
673* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
674- added ORBit2 requirement
675
676* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
677- rebuild again
678
679* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
680- rebuilt
681
682* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
683- 0.0.93; libsoup required is now 2.1.10
684
685* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
686- Update to 0.0.92; added a define and a requirement on the libsoup version
687
688* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
689- 0.0.90
690
691* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
692- rebuilt
693
694* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
695- 0.0.6
696
697* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
698- better fix by using system libtool
699
700* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
701- add some libdb linkage to make the build on x86_64 happy
702
703* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
704- update to 0.0.5
705
706* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
707- Initial build.
Note: See TracBrowser for help on using the repository browser.