source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 12386

Revision 12386, 30.4 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

Line 
1%define ldap_support 1
2%define static_ldap 0
3%define krb5_support 1
4%define largefile_support 1
5%{!?with_docs: %global with_docs 0}
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define use_gnome_keyring 1
18%define support_imap4_provider 0
19
20%define credential_modules_dir %{_libdir}/evolution-data-server/credential-modules
21%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
22%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
23%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
24%define modules_dir %{_libdir}/evolution-data-server/registry-modules
25%define uimodules_dir %{_libdir}/evolution-data-server/ui-modules
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.30.5
33Release: 3%{?_dist_release}
34Group: System Environment/Libraries
35Vendor: Project Vine
36Distribution: Vine Linux
37
38License: LGPL
39URL: http://www.gnome.org/projects/evolution/
40%define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
41Source0: https://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/%{shortver}/%{name}-%{version}.tar.xz
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43
44### Patches ###
45Patch0: evolution-data-server-strstr.patch
46
47### Dependencies ###
48
49#Requires: ORBit2 >= %{orbit2_version}
50Requires: libsoup >= %{soup_version}
51
52### Build Dependencies ###
53
54#BuildRequires: ORBit2-devel >= %{orbit2_version}
55BuildRequires: cmake
56BuildRequires: libdb-devel
57BuildRequires: flex
58BuildRequires: gettext
59BuildRequires: glib2-devel
60BuildRequires: gtk3-devel
61BuildRequires: webkitgtk4-devel
62BuildRequires: json-glib-devel
63BuildRequires: dbus-glib-devel
64BuildRequires: gnutls-devel
65BuildRequires: intltool >= %{intltool_version}
66BuildRequires: libsoup-devel >= %{soup_version}
67BuildRequires: libtool
68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
71BuildRequires: gperf
72BuildRequires: krb5-devel
73BuildRequires: libgdata-devel >= %{libgdata_version}
74BuildRequires: gnome-online-accounts-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78BuildRequires: gcr-devel
79BuildRequires: libaccounts-glib-devel
80BuildRequires: libcanberra-gtk3-devel
81
82BuildRequires: vala
83BuildRequires: vala-tools
84
85BuildRequires: nspr-devel
86BuildRequires: nss-devel
87
88%if %{ldap_support}
89BuildRequires: openldap-devel >= 2.0.11
90%if %{static_ldap}
91BuildRequires: pkgconfig(openssl)
92%endif
93%endif
94
95%if %{krb5_support}
96BuildRequires: krb5-devel
97# tweak for krb5 1.2 vs 1.3
98%define krb5dir /usr/kerberos
99#define krb5dir `pwd`/krb5-fakeprefix
100%endif
101
102%description
103The evolution-data-server package provides a unified backend for
104programs that work with contacts, tasks, and calendar information.
105
106It was originally developed for Evolution (hence the name), but
107is now used by other packages.
108
109
110%package devel
111Summary: Development files for building against evolution-data-server
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114Requires: pkgconfig
115Requires: pkgconfig(goa-1.0)
116Requires: pkgconfig(libgdata)
117Requires: pkgconfig(gweather-3.0)
118Requires: pkgconfig(libical)
119Requires: pkgconfig(libsecret-unstable)
120Requires: pkgconfig(libsoup-2.4)
121Requires: pkgconfig(sqlite3)
122Requires: pkgconfig(webkit2gtk-4.0)
123Requires: pkgconfig(json-glib-1.0)
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129
130%package        vala
131Summary:        Vala bindings for %{name}
132Summary(ja):    %{name} の Vala バインディング
133Group:          Development/Libraries
134Requires:       %{name} = %{version}-%{release}
135Requires:       vala
136
137%description    vala
138Vala bindings for %{name}.
139
140
141%prep
142%setup -q
143%patch0 -p1
144
145%build
146
147mkdir -p _build
148cd _build
149
150%if %{ldap_support}
151
152%if %{static_ldap}
153%define ldap_flags -DWITH_OPENLDAP=ON -DWITH_STATIC_LDAP=ON
154# Set LIBS so that configure will be able to link with static LDAP libraries,
155# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
156if pkg-config openssl ; then
157        export LIBS="-lsasl2 `pkg-config --libs openssl`"
158else
159        export LIBS="-lsasl2 -lssl -lcrypto"
160fi
161# newer versions of openldap are built with Mozilla NSS crypto, so also need
162# those libs to link with the static ldap libs
163if pkg-config nss ; then
164    export LIBS="$LIBS `pkg-config --libs nss`"
165else
166    export LIBS="$LIBS -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4"
167fi
168%else
169%define ldap_flags -DWITH_OPENLDAP=ON
170%endif
171
172%else
173%define ldap_flags -DWITH_OPENLDAP=OFF
174%endif
175
176%if %{krb5_support}
177%define krb5_flags -DWITH_KRB5=ON
178%else
179%define krb5_flags -DWITH_KRB5=OFF
180%endif
181
182%if %{largefile_support}
183%define largefile_flags -DENABLE_LARGEFILE=ON
184%else
185%define largefile_flags -DENABLE_LARGEFILE=OFF
186%endif
187
188%define ssl_flags -DENABLE_SMIME=ON
189
190%if %{with_docs}
191%define gtkdoc_flags -DENABLE_GTK_DOC=ON
192%else
193%define gtkdoc_flags -DENABLE_GTK_DOC=OFF
194%endif
195
196if ! pkg-config --exists nss; then
197  echo "Unable to find suitable version of nss to use!"
198  exit 1
199fi
200
201export CPPFLAGS="-I%{_includedir}/et"
202export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et -Wno-deprecated-declarations"
203
204# See Ross Burton's blog entry for why we want --with-libdb.
205# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
206
207%cmake -G "Unix Makefiles" \
208        -DENABLE_MAINTAINER_MODE=OFF \
209        -DWITH_LIBDB=/usr \
210        -DENABLE_FILE_LOCKING=fcntl \
211        -DENABLE_DOT_LOCKING=OFF \
212        -DENABLE_INTROSPECTION=ON \
213        -DENABLE_VALA_BINDINGS=ON \
214        -DBUILD_TESTING=OFF \
215        -DENABLE_INSTALLED_TESTS=OFF \
216        -DENABLE_UOA=OFF \
217        %ldap_flags %krb5_flags %ssl_flags \
218        %largefile_flags %gtkdoc_flags \
219        ..
220
221make %{?_smp_mflags}
222
223%install
224cd _build
225rm -rf $RPM_BUILD_ROOT
226
227make DESTDIR=$RPM_BUILD_ROOT install
228
229# make sure the directory exists, because it's owned by eds
230mkdir $RPM_BUILD_ROOT/%{uimodules_dir} || :
231
232# give the libraries some executable bits
233find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
234
235# remove unused files
236rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
237
238%find_lang %{name}
239
240%clean
241rm -rf $RPM_BUILD_ROOT
242
243%post -p /sbin/ldconfig
244
245%postun
246/sbin/ldconfig
247if [ $1 -eq 0 ]; then
248  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
249fi
250
251%posttrans
252glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
253
254
255%files -f _build/%{name}.lang
256%defattr(-,root,root,-)
257%license COPYING
258%doc README ChangeLog NEWS
259%{_libdir}/*.so.*
260%{_libdir}/girepository-1.0/*.typelib
261%{_libexecdir}/camel-gpg-photo-saver
262%{_libexecdir}/camel-index-control-1.2
263%{_libexecdir}/camel-lock-helper-1.2
264%{_libexecdir}/evolution-addressbook-factory
265%{_libexecdir}/evolution-addressbook-factory-subprocess
266%{_libexecdir}/evolution-calendar-factory
267%{_libexecdir}/evolution-calendar-factory-subprocess
268%{_libexecdir}/evolution-scan-gconf-tree-xml
269%{_libexecdir}/evolution-source-registry
270%{_libexecdir}/evolution-user-prompter
271%dir %{_libexecdir}/evolution-data-server
272%{_libexecdir}/evolution-data-server/*
273%{_sysconfdir}/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop
274%{_datadir}/applications/org.gnome.Evolution-alarm-notify.desktop
275%{_datadir}/GConf/gsettings/evolution-data-server.convert
276%{_datadir}/glib-2.0/schemas/*
277%{_datadir}/evolution-data-server
278%{_datadir}/dbus-1/services/*
279%{_datadir}/pixmaps/evolution-data-server
280
281%dir %{_libdir}/evolution-data-server
282%dir %{credential_modules_dir}
283%dir %{camel_provider_dir}
284%dir %{ebook_backends_dir}
285%dir %{ecal_backends_dir}
286%dir %{modules_dir}
287%dir %{uimodules_dir}
288
289%{_libdir}/evolution-data-server/libedbus-private.so
290
291# Camel providers:
292%{camel_provider_dir}/libcamelimapx.so
293%{camel_provider_dir}/libcamelimapx.urls
294
295%{camel_provider_dir}/libcamellocal.so
296%{camel_provider_dir}/libcamellocal.urls
297
298%{camel_provider_dir}/libcamelnntp.so
299%{camel_provider_dir}/libcamelnntp.urls
300
301%{camel_provider_dir}/libcamelpop3.so
302%{camel_provider_dir}/libcamelpop3.urls
303
304%{camel_provider_dir}/libcamelsendmail.so
305%{camel_provider_dir}/libcamelsendmail.urls
306
307%{camel_provider_dir}/libcamelsmtp.so
308%{camel_provider_dir}/libcamelsmtp.urls
309
310# e-d-s extensions:
311%{credential_modules_dir}/module-credentials-goa.so
312%{ebook_backends_dir}/libebookbackendcarddav.so
313%{ebook_backends_dir}/libebookbackendfile.so
314%{ebook_backends_dir}/libebookbackendgoogle.so
315%{ebook_backends_dir}/libebookbackendldap.so
316%{ecal_backends_dir}/libecalbackendcaldav.so
317%{ecal_backends_dir}/libecalbackendcontacts.so
318%{ecal_backends_dir}/libecalbackendfile.so
319%{ecal_backends_dir}/libecalbackendgtasks.so
320%{ecal_backends_dir}/libecalbackendhttp.so
321%{ecal_backends_dir}/libecalbackendweather.so
322%{modules_dir}/module-cache-reaper.so
323%{modules_dir}/module-google-backend.so
324%{modules_dir}/module-gnome-online-accounts.so
325%{modules_dir}/module-oauth2-services.so
326%{modules_dir}/module-outlook-backend.so
327%{modules_dir}/module-secret-monitor.so
328%{modules_dir}/module-trust-prompt.so
329%{modules_dir}/module-webdav-backend.so
330%{modules_dir}/module-yahoo-backend.so
331
332%files devel
333%defattr(-,root,root,-)
334%{_includedir}/%{name}
335%{_libdir}/*.so
336%{_libdir}/pkgconfig/*.pc
337%{_datadir}/gir-1.0/*.gir
338
339%files vala
340%defattr(-,root,root,-)
341%{_datadir}/vala/vapi/libebook-1.2.deps
342%{_datadir}/vala/vapi/libebook-1.2.vapi
343%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
344%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
345%{_datadir}/vala/vapi/libedataserver-1.2.deps
346%{_datadir}/vala/vapi/libedataserver-1.2.vapi
347%{_datadir}/vala/vapi/libedataserverui-1.2.deps
348%{_datadir}/vala/vapi/libedataserverui-1.2.vapi
349%{_datadir}/vala/vapi/camel-1.2.deps
350%{_datadir}/vala/vapi/camel-1.2.vapi
351
352%changelog
353* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-3
354- rebuilt with icu-67.
355
356* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-2
357- rebuilt with icu-66.
358
359* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-1
360- new upstream release.
361- built with icu-65.
362
363* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.3-1
364- new upstream release.
365
366* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.7-1
367- new upstream release.
368
369* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-2
370- rebuilt with libicu-60.2.
371
372* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.4-1
373- new upstream release
374- add BuildRequires: WebKit3-gtk-devel, json-glib-devel
375
376* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
377- rebuild with gcc-5.4.0
378
379* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
380- new upstream release
381
382* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
383- new upstream release
384
385* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
386- new upstream release
387
388* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
389- new upstream release
390
391* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
392- new upstream release
393
394* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
395- new upstream release
396
397* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
398- new upstream release
399
400* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
401- new upstream release
402- remove %%{name}-doc subpackage
403
404* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
405- new upstream release
406
407* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
408- new upstream release
409
410* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
411- new upstream release
412
413* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
414- rebuilt with libical 1.0.1
415
416* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
417- new upstream release
418
419* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
420- new upstream release
421
422* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
423- new upstream release
424
425* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
426- new upstream release
427
428* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
429- new upstream release
430
431* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
432- new upstream release
433
434* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
435- new upstream release
436
437* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
438- new upstream release
439
440* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
441- new upstream release
442
443* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
444- new upstream release
445
446* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
447- new upstream release
448
449* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
450- new upstream release
451- add BuildRequires: libicu-devel
452
453* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
454- new upstream release
455
456* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
457- new upstream release
458
459* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
460- new upstream release
461
462* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
463- new upstream release
464
465* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
466- new upstream release
467
468* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
469- new upstream release
470
471* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
472- new upstream release
473- add configure option (--disable-uoa)
474- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
475- create %%{name}-vala subpackage
476
477* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
478- new upstream release
479
480* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
481- new upstream release
482
483* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
484- new upstream release
485
486* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
487- new upstream release
488
489* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
490- new upstream release
491
492* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
493- new upstream release
494
495* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
496- new upstream release
497
498* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
499- new upstream release
500
501* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
502- new upstream release
503- add BuildRequires: dbus-glib-devel
504
505* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
506- new upstream release
507
508* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
509- new upstream release
510
511* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
512- new upstream release
513
514* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
515- new upstream release
516
517* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
518- new upstream release
519- remove Patch101
520
521* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
522- new upstream release
523
524* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
525- new upstream release
526- change BuildRequires: gtk3-devel instead of gtk2-devel
527- BuildRequires: gnome-online-accounts-devel
528- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
529- fix %%files
530
531* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
532- new upstream release
533
534* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
535- rebuild with openssl-1.0.0c
536
537* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
538- new upstream release
539- remove Requires: gnome-vfs2, libglade2, libgnomeui
540- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
541- add BuildRequires: libgdata
542- add Requires: nspr-devel, nss-devel (devel package)
543- drop Patch11
544
545* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
546- rebuild with rpm-4.8.1 for pkg-config file
547
548* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
549- new upstream release
550
551* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
552- new upstream release
553
554* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
555- new upstream release
556- remove BuildRequires: libbonobo-devel
557- remove Requires: libbonobo
558- drop Patch10
559- add configure option (--with-krb5-libs, --with-krb5-includes)
560
561* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
562- rebuilt with db4-4.8
563
564* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
565- new upstream release
566
567* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
568- new upstream release
569
570* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
571- new upstream release
572
573* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
574- new upstream release
575
576* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
577- added Requires: libical-devel >= 0.43 to devel package
578
579* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
580- new upstream release
581- add BR: libgweather-devel >= 2.26.0
582- add BR: libical-devel >= 0.43
583
584* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
585- new upstream release
586- added BuildRequires: sqlite3-devel
587
588* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
589- enabled krb5 support
590
591* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
592- new upstream release
593
594* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
595- new upstream release
596
597* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
598- new upstream release
599
600* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
601- new upstream release
602
603* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
604- rebuilt with db4-4.6.21
605
606* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
607- new upstream release
608
609* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
610- new upstream release
611
612* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
613- new upstream release
614
615* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
616- new upstream release based on Fedora package 2.20.0-3.fc9
617  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
618  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
619  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
620  - Add patch for RH bug #296671 (GC servers may not support NTLM).
621  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
622  - Try removing the ancient "ldap-x86_64-hack" patch.
623  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
624  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
625- split doc subpackage
626
627* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
628- fixed dependancy
629
630* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
631- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
632  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
633  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
634  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
635  - Make the new ESourceComboBox widget work properly (RH bug #234760).
636  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
637  - Link to static evolution-openldap library (RH bug #210126).
638  - Require openssl-devel when statically linking against openldap.
639  - Add -Wdeclaration-after-statement to strict build settings.
640  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
641  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
642  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
643  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
644  - Update to 1.10.0
645  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
646  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
647  - Patch by Kenny Root.
648- rebuilt with nss-devel and nspr-devel
649
650* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
651- rebuilt with new toolchain and db4-4.3.x
652
653* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
654- new upstream release
655
656* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
657- new upstream release
658- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
659
660* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
661- new upstream release
662- rebuilt with openssl instead of mozilla-nss
663
664* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
665- rebuilt with openldap-2.3.24-0vl4
666
667* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
668- new upstream release
669- build with libsoap-2.2.7
670
671* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
672- new upstream release
673
674* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
675- new upstream release
676- added/removed Patches based on Fedora packages
677  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
678  - Updated patch 102 to fix further implicit function declarations
679  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
680  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
681    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
682  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
683  - Removed upstreamed patch:
684    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
685  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
686  - added patch to calendar/libecal/e-cal.c to fix missing declaration
687    of open_calendar
688- rebuilt with mozilla-1.7.12
689
690* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
691- rebuilt with mozilla-1.7.7
692
693* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
694- initial build for Vine Linux based on FC package
695- disable krb5 support
696
697* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
698- 1.2.1
699
700* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
701- Removed explicit run-time spec-file requirement on mozilla.
702  The Mozilla NSS API/ABI stabilised by version 1.7.3
703  The libraries are always located in the libdir
704  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
705  and so they move each time the mozilla version changes.
706  So we no longer have an explicit mozilla run-time requirement in the specfile;
707  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
708  We have an explicit, exact build-time version, so that we can find the headers (without
709  invoking an RPM query from the spec file; to do so is considered bad practice)
710- Introduced mozilla_build_version, to replace mozilla_version
711- Set mozilla_build_version to 1.7.6 to reflect current state of tree
712
713* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
714- Added a patch to deal with glibc defining a macro called "read"
715
716* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
717- 1.2.0
718- Removed patch for GCC 4 as this is now in upstream tarball
719
720* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
721- rebuild to fix library linking silliness
722
723* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
724- disabling gtk-doc on ia64 and s390x
725
726* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
727- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
728
729* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
730- extended patch to deal with camel-groupwise-store-summary.c
731
732* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
733- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
734
735* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
736- 1.1.6
737
738* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
739- rebuild
740
741* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
742- forgot to fix sources
743
744* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
745- 1.1.5
746
747* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
748- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
749
750* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
751- disable gtk-doc generation on ia64 for now
752
753* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
754- Exclude ppc64 due to missing mozilla dependency
755
756* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
757- Update from 1.0.3 to 1.1.4.1
758- Updated eds_major from 1.0 to 1.2; fixed translation search path.
759- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
760- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
761- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
762- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
763- Camel code from evolution is now in evolution-data-server:
764  - Added camel-index-control and camel-lock-helper to packaged files
765  - Added mozilla dependency code from the evolution package
766  - Ditto for LDAP
767  - Ditto for krb5
768  - Ditto for NNTP support handling
769  - Ditto for --enable-file-locking and --enable-dot-locking
770- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
771- Updated libsoup requirement from 2.2.1 to 2.2.2
772- Enabled gtk-doc
773
774* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
775- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
776
777* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
778- update from upstream 1.0.2 to 1.0.3:
779  * Address Book
780    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
781    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
782
783  * Calendar
784    #XB59904 - Speed up calendar queries (Rodrigo)
785    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
786    - fix libical build for automake 1.9 (Rodney)
787    - fix putenv usage for portability (Julio M. Merino Vidal)
788
789  * Updated Translations:
790    - sv (Christian Rose)
791
792- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
793
794* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
795- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
796http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
797(The groupwise part of that patch did not cleanly apply, so I removed it).
798
799* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
800- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
801optimisation patch posted to upstream development mailing list here:
802http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
803
804* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
805- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
806
807* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
808- added workaround for a backend leak that causes the "contacts" calendar
809backend to hold open an EBook for the local contacts (filed upstream at:
810http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
811never lose its last addressbook, and hence never quit.  We workaround this by
812detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
813
814* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
815- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
816
817* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
818- update from 1.0.1 to 1.0.2
819- increased libsoup requirement to 2.2.1 to match configuration script
820
821* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
822- update from 1.0.0 to 1.0.1
823- removed patch that fixed warnings in calendar code (now in upstream tarball)
824
825* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
826- fixed various warnings in the calendar code
827  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
828
829* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
830- update from 0.0.99 to 1.0.0
831- changed path in FTP source location from 0.0 to 1.0
832
833* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
834- update from 0.0.98 to 0.0.99
835- increased libsoup requirement to 2.2.0 to match configuration script
836
837* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
838- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
839
840* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
841- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
842
843* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
844- upgraded to 0.0.97; rewrote the package's description
845
846* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
847- rebuilt
848
849* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
850- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
851
852* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
853- 0.0.96; libsoup required is now 2.1.12
854
855* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
856- rebuilt
857
858* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
859- rebuilt
860
861* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
862- 0.0.95
863
864* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
865- 0.0.94.1
866
867* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
868- rebuilt
869
870* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
871- 0.0.94
872
873* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
874- added ORBit2 requirement
875
876* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
877- rebuild again
878
879* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
880- rebuilt
881
882* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
883- 0.0.93; libsoup required is now 2.1.10
884
885* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
886- Update to 0.0.92; added a define and a requirement on the libsoup version
887
888* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
889- 0.0.90
890
891* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
892- rebuilt
893
894* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
895- 0.0.6
896
897* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
898- better fix by using system libtool
899
900* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
901- add some libdb linkage to make the build on x86_64 happy
902
903* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
904- update to 0.0.5
905
906* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
907- Initial build.
Note: See TracBrowser for help on using the repository browser.