source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 12344

Revision 12344, 30.3 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

epiphany-3.30.5-2

evolution-data-server-3.30.5-2

gnucash-3.8b-1

harfbuzz-2.6.4-1

libboost-1.66.0-5

tracker-miners-2.3.3-1

tracker-2.2.2-3

webkitgtk4-2.28.0-2

xfsdump-3.1.9-1

xfsprogs-5.5.0-1

Line 
1%define ldap_support 1
2%define static_ldap 0
3%define krb5_support 1
4%define largefile_support 1
5%{!?with_docs: %global with_docs 0}
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define use_gnome_keyring 1
18%define support_imap4_provider 0
19
20%define credential_modules_dir %{_libdir}/evolution-data-server/credential-modules
21%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
22%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
23%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
24%define modules_dir %{_libdir}/evolution-data-server/registry-modules
25%define uimodules_dir %{_libdir}/evolution-data-server/ui-modules
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.30.5
33Release: 2%{?_dist_release}
34Group: System Environment/Libraries
35License: LGPL
36
37URL: http://www.gnome.org/projects/evolution/
38%define shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
39Source0: https://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/%{shortver}/%{name}-%{version}.tar.xz
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42### Patches ###
43Patch0: evolution-data-server-strstr.patch
44
45### Dependencies ###
46
47#Requires: ORBit2 >= %{orbit2_version}
48Requires: libsoup >= %{soup_version}
49
50### Build Dependencies ###
51
52#BuildRequires: ORBit2-devel >= %{orbit2_version}
53BuildRequires: cmake
54BuildRequires: libdb-devel
55BuildRequires: flex
56BuildRequires: gettext
57BuildRequires: glib2-devel
58BuildRequires: gtk3-devel
59BuildRequires: webkitgtk4-devel
60BuildRequires: json-glib-devel
61BuildRequires: dbus-glib-devel
62BuildRequires: gnutls-devel
63BuildRequires: intltool >= %{intltool_version}
64BuildRequires: libsoup-devel >= %{soup_version}
65BuildRequires: libtool
66BuildRequires: sqlite3-devel
67BuildRequires: libgweather-devel >= %{libgweather_version}
68BuildRequires: libical-devel >= %{libical_version}
69BuildRequires: gperf
70BuildRequires: krb5-devel
71BuildRequires: libgdata-devel >= %{libgdata_version}
72BuildRequires: gnome-online-accounts-devel
73BuildRequires: libsecret-devel
74BuildRequires: libicu-devel
75BuildRequires: gnome-common
76BuildRequires: gcr-devel
77BuildRequires: libaccounts-glib-devel
78BuildRequires: libcanberra-gtk3-devel
79
80BuildRequires: vala
81BuildRequires: vala-tools
82
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85
86%if %{ldap_support}
87BuildRequires: openldap-devel >= 2.0.11
88%if %{static_ldap}
89BuildRequires: pkgconfig(openssl)
90%endif
91%endif
92
93%if %{krb5_support}
94BuildRequires: krb5-devel
95# tweak for krb5 1.2 vs 1.3
96%define krb5dir /usr/kerberos
97#define krb5dir `pwd`/krb5-fakeprefix
98%endif
99
100Vendor: Project Vine
101Distribution: Vine Linux
102
103
104%description
105The evolution-data-server package provides a unified backend for
106programs that work with contacts, tasks, and calendar information.
107
108It was originally developed for Evolution (hence the name), but
109is now used by other packages.
110
111
112%package devel
113Summary: Development files for building against evolution-data-server
114Group: Development/Libraries
115Requires: %{name} = %{version}-%{release}
116Requires: pkgconfig
117Requires: pkgconfig(goa-1.0)
118Requires: pkgconfig(libgdata)
119Requires: pkgconfig(gweather-3.0)
120Requires: pkgconfig(libical)
121Requires: pkgconfig(libsecret-unstable)
122Requires: pkgconfig(libsoup-2.4)
123Requires: pkgconfig(sqlite3)
124Requires: pkgconfig(webkit2gtk-4.0)
125Requires: pkgconfig(json-glib-1.0)
126
127%description devel
128Development files needed for building things which link against
129evolution-data-server.
130
131
132%package        vala
133Summary:        Vala bindings for %{name}
134Summary(ja):    %{name} の Vala バインディング
135Group:          Development/Libraries
136Requires:       %{name} = %{version}-%{release}
137Requires:       vala
138
139%description    vala
140Vala bindings for %{name}.
141
142
143%prep
144%setup -q
145%patch0 -p1
146
147%build
148
149mkdir -p _build
150cd _build
151
152%if %{ldap_support}
153
154%if %{static_ldap}
155%define ldap_flags -DWITH_OPENLDAP=ON -DWITH_STATIC_LDAP=ON
156# Set LIBS so that configure will be able to link with static LDAP libraries,
157# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
158if pkg-config openssl ; then
159        export LIBS="-lsasl2 `pkg-config --libs openssl`"
160else
161        export LIBS="-lsasl2 -lssl -lcrypto"
162fi
163# newer versions of openldap are built with Mozilla NSS crypto, so also need
164# those libs to link with the static ldap libs
165if pkg-config nss ; then
166    export LIBS="$LIBS `pkg-config --libs nss`"
167else
168    export LIBS="$LIBS -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4"
169fi
170%else
171%define ldap_flags -DWITH_OPENLDAP=ON
172%endif
173
174%else
175%define ldap_flags -DWITH_OPENLDAP=OFF
176%endif
177
178%if %{krb5_support}
179%define krb5_flags -DWITH_KRB5=ON
180%else
181%define krb5_flags -DWITH_KRB5=OFF
182%endif
183
184%if %{largefile_support}
185%define largefile_flags -DENABLE_LARGEFILE=ON
186%else
187%define largefile_flags -DENABLE_LARGEFILE=OFF
188%endif
189
190%define ssl_flags -DENABLE_SMIME=ON
191
192%if %{with_docs}
193%define gtkdoc_flags -DENABLE_GTK_DOC=ON
194%else
195%define gtkdoc_flags -DENABLE_GTK_DOC=OFF
196%endif
197
198if ! pkg-config --exists nss; then
199  echo "Unable to find suitable version of nss to use!"
200  exit 1
201fi
202
203export CPPFLAGS="-I%{_includedir}/et"
204export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et -Wno-deprecated-declarations"
205
206# See Ross Burton's blog entry for why we want --with-libdb.
207# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
208
209%cmake -G "Unix Makefiles" \
210        -DENABLE_MAINTAINER_MODE=OFF \
211        -DWITH_LIBDB=/usr \
212        -DENABLE_FILE_LOCKING=fcntl \
213        -DENABLE_DOT_LOCKING=OFF \
214        -DENABLE_INTROSPECTION=ON \
215        -DENABLE_VALA_BINDINGS=ON \
216        -DBUILD_TESTING=OFF \
217        -DENABLE_INSTALLED_TESTS=OFF \
218        -DENABLE_UOA=OFF \
219        %ldap_flags %krb5_flags %ssl_flags \
220        %largefile_flags %gtkdoc_flags \
221        ..
222
223make %{?_smp_mflags}
224
225%install
226cd _build
227rm -rf $RPM_BUILD_ROOT
228
229make DESTDIR=$RPM_BUILD_ROOT install
230
231# make sure the directory exists, because it's owned by eds
232mkdir $RPM_BUILD_ROOT/%{uimodules_dir} || :
233
234# give the libraries some executable bits
235find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
236
237# remove unused files
238rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
239
240%find_lang %{name}
241
242%clean
243rm -rf $RPM_BUILD_ROOT
244
245%post -p /sbin/ldconfig
246
247%postun
248/sbin/ldconfig
249if [ $1 -eq 0 ]; then
250  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
251fi
252
253%posttrans
254glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
255
256
257%files -f _build/%{name}.lang
258%defattr(-,root,root,-)
259%license COPYING
260%doc README ChangeLog NEWS
261%{_libdir}/*.so.*
262%{_libdir}/girepository-1.0/*.typelib
263%{_libexecdir}/camel-gpg-photo-saver
264%{_libexecdir}/camel-index-control-1.2
265%{_libexecdir}/camel-lock-helper-1.2
266%{_libexecdir}/evolution-addressbook-factory
267%{_libexecdir}/evolution-addressbook-factory-subprocess
268%{_libexecdir}/evolution-calendar-factory
269%{_libexecdir}/evolution-calendar-factory-subprocess
270%{_libexecdir}/evolution-scan-gconf-tree-xml
271%{_libexecdir}/evolution-source-registry
272%{_libexecdir}/evolution-user-prompter
273%dir %{_libexecdir}/evolution-data-server
274%{_libexecdir}/evolution-data-server/*
275%{_sysconfdir}/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop
276%{_datadir}/applications/org.gnome.Evolution-alarm-notify.desktop
277%{_datadir}/GConf/gsettings/evolution-data-server.convert
278%{_datadir}/glib-2.0/schemas/*
279%{_datadir}/evolution-data-server
280%{_datadir}/dbus-1/services/*
281%{_datadir}/pixmaps/evolution-data-server
282
283%dir %{_libdir}/evolution-data-server
284%dir %{credential_modules_dir}
285%dir %{camel_provider_dir}
286%dir %{ebook_backends_dir}
287%dir %{ecal_backends_dir}
288%dir %{modules_dir}
289%dir %{uimodules_dir}
290
291%{_libdir}/evolution-data-server/libedbus-private.so
292
293# Camel providers:
294%{camel_provider_dir}/libcamelimapx.so
295%{camel_provider_dir}/libcamelimapx.urls
296
297%{camel_provider_dir}/libcamellocal.so
298%{camel_provider_dir}/libcamellocal.urls
299
300%{camel_provider_dir}/libcamelnntp.so
301%{camel_provider_dir}/libcamelnntp.urls
302
303%{camel_provider_dir}/libcamelpop3.so
304%{camel_provider_dir}/libcamelpop3.urls
305
306%{camel_provider_dir}/libcamelsendmail.so
307%{camel_provider_dir}/libcamelsendmail.urls
308
309%{camel_provider_dir}/libcamelsmtp.so
310%{camel_provider_dir}/libcamelsmtp.urls
311
312# e-d-s extensions:
313%{credential_modules_dir}/module-credentials-goa.so
314%{ebook_backends_dir}/libebookbackendcarddav.so
315%{ebook_backends_dir}/libebookbackendfile.so
316%{ebook_backends_dir}/libebookbackendgoogle.so
317%{ebook_backends_dir}/libebookbackendldap.so
318%{ecal_backends_dir}/libecalbackendcaldav.so
319%{ecal_backends_dir}/libecalbackendcontacts.so
320%{ecal_backends_dir}/libecalbackendfile.so
321%{ecal_backends_dir}/libecalbackendgtasks.so
322%{ecal_backends_dir}/libecalbackendhttp.so
323%{ecal_backends_dir}/libecalbackendweather.so
324%{modules_dir}/module-cache-reaper.so
325%{modules_dir}/module-google-backend.so
326%{modules_dir}/module-gnome-online-accounts.so
327%{modules_dir}/module-oauth2-services.so
328%{modules_dir}/module-outlook-backend.so
329%{modules_dir}/module-secret-monitor.so
330%{modules_dir}/module-trust-prompt.so
331%{modules_dir}/module-webdav-backend.so
332%{modules_dir}/module-yahoo-backend.so
333
334%files devel
335%defattr(-,root,root,-)
336%{_includedir}/%{name}
337%{_libdir}/*.so
338%{_libdir}/pkgconfig/*.pc
339%{_datadir}/gir-1.0/*.gir
340
341%files vala
342%defattr(-,root,root,-)
343%{_datadir}/vala/vapi/libebook-1.2.deps
344%{_datadir}/vala/vapi/libebook-1.2.vapi
345%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
346%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
347%{_datadir}/vala/vapi/libedataserver-1.2.deps
348%{_datadir}/vala/vapi/libedataserver-1.2.vapi
349%{_datadir}/vala/vapi/libedataserverui-1.2.deps
350%{_datadir}/vala/vapi/libedataserverui-1.2.vapi
351%{_datadir}/vala/vapi/camel-1.2.deps
352%{_datadir}/vala/vapi/camel-1.2.vapi
353
354%changelog
355* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-2
356- rebuilt with icu-66.
357
358* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.5-1
359- new upstream release.
360- built with icu-65.
361
362* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.3-1
363- new upstream release.
364
365* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.7-1
366- new upstream release.
367
368* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-2
369- rebuilt with libicu-60.2.
370
371* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.4-1
372- new upstream release
373- add BuildRequires: WebKit3-gtk-devel, json-glib-devel
374
375* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
376- rebuild with gcc-5.4.0
377
378* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
379- new upstream release
380
381* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
382- new upstream release
383
384* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
385- new upstream release
386
387* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
388- new upstream release
389
390* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
391- new upstream release
392
393* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
394- new upstream release
395
396* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
397- new upstream release
398
399* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
400- new upstream release
401- remove %%{name}-doc subpackage
402
403* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
404- new upstream release
405
406* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
407- new upstream release
408
409* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
410- new upstream release
411
412* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
413- rebuilt with libical 1.0.1
414
415* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
416- new upstream release
417
418* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
419- new upstream release
420
421* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
422- new upstream release
423
424* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
425- new upstream release
426
427* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
428- new upstream release
429
430* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
431- new upstream release
432
433* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
434- new upstream release
435
436* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
437- new upstream release
438
439* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
440- new upstream release
441
442* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
443- new upstream release
444
445* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
446- new upstream release
447
448* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
449- new upstream release
450- add BuildRequires: libicu-devel
451
452* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
453- new upstream release
454
455* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
456- new upstream release
457
458* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
459- new upstream release
460
461* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
462- new upstream release
463
464* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
465- new upstream release
466
467* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
468- new upstream release
469
470* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
471- new upstream release
472- add configure option (--disable-uoa)
473- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
474- create %%{name}-vala subpackage
475
476* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
477- new upstream release
478
479* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
480- new upstream release
481
482* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
483- new upstream release
484
485* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
486- new upstream release
487
488* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
489- new upstream release
490
491* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
492- new upstream release
493
494* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
495- new upstream release
496
497* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
498- new upstream release
499
500* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
501- new upstream release
502- add BuildRequires: dbus-glib-devel
503
504* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
505- new upstream release
506
507* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
508- new upstream release
509
510* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
511- new upstream release
512
513* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
514- new upstream release
515
516* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
517- new upstream release
518- remove Patch101
519
520* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
521- new upstream release
522
523* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
524- new upstream release
525- change BuildRequires: gtk3-devel instead of gtk2-devel
526- BuildRequires: gnome-online-accounts-devel
527- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
528- fix %%files
529
530* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
531- new upstream release
532
533* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
534- rebuild with openssl-1.0.0c
535
536* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
537- new upstream release
538- remove Requires: gnome-vfs2, libglade2, libgnomeui
539- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
540- add BuildRequires: libgdata
541- add Requires: nspr-devel, nss-devel (devel package)
542- drop Patch11
543
544* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
545- rebuild with rpm-4.8.1 for pkg-config file
546
547* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
548- new upstream release
549
550* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
551- new upstream release
552
553* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
554- new upstream release
555- remove BuildRequires: libbonobo-devel
556- remove Requires: libbonobo
557- drop Patch10
558- add configure option (--with-krb5-libs, --with-krb5-includes)
559
560* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
561- rebuilt with db4-4.8
562
563* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
564- new upstream release
565
566* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
567- new upstream release
568
569* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
570- new upstream release
571
572* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
573- new upstream release
574
575* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
576- added Requires: libical-devel >= 0.43 to devel package
577
578* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
579- new upstream release
580- add BR: libgweather-devel >= 2.26.0
581- add BR: libical-devel >= 0.43
582
583* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
584- new upstream release
585- added BuildRequires: sqlite3-devel
586
587* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
588- enabled krb5 support
589
590* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
591- new upstream release
592
593* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
594- new upstream release
595
596* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
597- new upstream release
598
599* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
600- new upstream release
601
602* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
603- rebuilt with db4-4.6.21
604
605* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
606- new upstream release
607
608* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
609- new upstream release
610
611* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
612- new upstream release
613
614* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
615- new upstream release based on Fedora package 2.20.0-3.fc9
616  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
617  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
618  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
619  - Add patch for RH bug #296671 (GC servers may not support NTLM).
620  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
621  - Try removing the ancient "ldap-x86_64-hack" patch.
622  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
623  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
624- split doc subpackage
625
626* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
627- fixed dependancy
628
629* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
630- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
631  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
632  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
633  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
634  - Make the new ESourceComboBox widget work properly (RH bug #234760).
635  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
636  - Link to static evolution-openldap library (RH bug #210126).
637  - Require openssl-devel when statically linking against openldap.
638  - Add -Wdeclaration-after-statement to strict build settings.
639  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
640  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
641  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
642  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
643  - Update to 1.10.0
644  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
645  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
646  - Patch by Kenny Root.
647- rebuilt with nss-devel and nspr-devel
648
649* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
650- rebuilt with new toolchain and db4-4.3.x
651
652* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
653- new upstream release
654
655* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
656- new upstream release
657- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
658
659* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
660- new upstream release
661- rebuilt with openssl instead of mozilla-nss
662
663* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
664- rebuilt with openldap-2.3.24-0vl4
665
666* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
667- new upstream release
668- build with libsoap-2.2.7
669
670* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
671- new upstream release
672
673* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
674- new upstream release
675- added/removed Patches based on Fedora packages
676  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
677  - Updated patch 102 to fix further implicit function declarations
678  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
679  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
680    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
681  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
682  - Removed upstreamed patch:
683    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
684  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
685  - added patch to calendar/libecal/e-cal.c to fix missing declaration
686    of open_calendar
687- rebuilt with mozilla-1.7.12
688
689* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
690- rebuilt with mozilla-1.7.7
691
692* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
693- initial build for Vine Linux based on FC package
694- disable krb5 support
695
696* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
697- 1.2.1
698
699* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
700- Removed explicit run-time spec-file requirement on mozilla.
701  The Mozilla NSS API/ABI stabilised by version 1.7.3
702  The libraries are always located in the libdir
703  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
704  and so they move each time the mozilla version changes.
705  So we no longer have an explicit mozilla run-time requirement in the specfile;
706  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
707  We have an explicit, exact build-time version, so that we can find the headers (without
708  invoking an RPM query from the spec file; to do so is considered bad practice)
709- Introduced mozilla_build_version, to replace mozilla_version
710- Set mozilla_build_version to 1.7.6 to reflect current state of tree
711
712* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
713- Added a patch to deal with glibc defining a macro called "read"
714
715* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
716- 1.2.0
717- Removed patch for GCC 4 as this is now in upstream tarball
718
719* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
720- rebuild to fix library linking silliness
721
722* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
723- disabling gtk-doc on ia64 and s390x
724
725* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
726- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
727
728* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
729- extended patch to deal with camel-groupwise-store-summary.c
730
731* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
732- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
733
734* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
735- 1.1.6
736
737* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
738- rebuild
739
740* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
741- forgot to fix sources
742
743* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
744- 1.1.5
745
746* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
747- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
748
749* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
750- disable gtk-doc generation on ia64 for now
751
752* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
753- Exclude ppc64 due to missing mozilla dependency
754
755* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
756- Update from 1.0.3 to 1.1.4.1
757- Updated eds_major from 1.0 to 1.2; fixed translation search path.
758- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
759- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
760- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
761- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
762- Camel code from evolution is now in evolution-data-server:
763  - Added camel-index-control and camel-lock-helper to packaged files
764  - Added mozilla dependency code from the evolution package
765  - Ditto for LDAP
766  - Ditto for krb5
767  - Ditto for NNTP support handling
768  - Ditto for --enable-file-locking and --enable-dot-locking
769- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
770- Updated libsoup requirement from 2.2.1 to 2.2.2
771- Enabled gtk-doc
772
773* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
774- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
775
776* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
777- update from upstream 1.0.2 to 1.0.3:
778  * Address Book
779    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
780    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
781
782  * Calendar
783    #XB59904 - Speed up calendar queries (Rodrigo)
784    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
785    - fix libical build for automake 1.9 (Rodney)
786    - fix putenv usage for portability (Julio M. Merino Vidal)
787
788  * Updated Translations:
789    - sv (Christian Rose)
790
791- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
792
793* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
794- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
795http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
796(The groupwise part of that patch did not cleanly apply, so I removed it).
797
798* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
799- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
800optimisation patch posted to upstream development mailing list here:
801http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
802
803* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
804- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
805
806* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
807- added workaround for a backend leak that causes the "contacts" calendar
808backend to hold open an EBook for the local contacts (filed upstream at:
809http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
810never lose its last addressbook, and hence never quit.  We workaround this by
811detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
812
813* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
814- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
815
816* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
817- update from 1.0.1 to 1.0.2
818- increased libsoup requirement to 2.2.1 to match configuration script
819
820* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
821- update from 1.0.0 to 1.0.1
822- removed patch that fixed warnings in calendar code (now in upstream tarball)
823
824* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
825- fixed various warnings in the calendar code
826  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
827
828* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
829- update from 0.0.99 to 1.0.0
830- changed path in FTP source location from 0.0 to 1.0
831
832* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
833- update from 0.0.98 to 0.0.99
834- increased libsoup requirement to 2.2.0 to match configuration script
835
836* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
837- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
838
839* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
840- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
841
842* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
843- upgraded to 0.0.97; rewrote the package's description
844
845* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
846- rebuilt
847
848* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
849- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
850
851* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
852- 0.0.96; libsoup required is now 2.1.12
853
854* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
855- rebuilt
856
857* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
858- rebuilt
859
860* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
861- 0.0.95
862
863* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
864- 0.0.94.1
865
866* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
867- rebuilt
868
869* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
870- 0.0.94
871
872* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
873- added ORBit2 requirement
874
875* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
876- rebuild again
877
878* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
879- rebuilt
880
881* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
882- 0.0.93; libsoup required is now 2.1.10
883
884* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
885- Update to 0.0.92; added a define and a requirement on the libsoup version
886
887* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
888- 0.0.90
889
890* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
891- rebuilt
892
893* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
894- 0.0.6
895
896* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
897- better fix by using system libtool
898
899* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
900- add some libdb linkage to make the build on x86_64 happy
901
902* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
903- update to 0.0.5
904
905* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
906- Initial build.
Note: See TracBrowser for help on using the repository browser.