source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 12005

Revision 12005, 30.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define ldap_support 1
2%define static_ldap 0
3%define krb5_support 1
4%define largefile_support 1
5%{!?with_docs: %global with_docs 0}
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.22
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define credential_modules_dir %{_libdir}/evolution-data-server/credential-modules
24%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
25%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
26%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
27%define modules_dir %{_libdir}/evolution-data-server/registry-modules
28%define uimodules_dir %{_libdir}/evolution-data-server/ui-modules
29
30### Abstract ###
31
32Summary: Backend data server for evolution
33Summary(ja): Evolution バックエンドデータサーバ
34Name: evolution-data-server
35Version: 3.30.3
36Release: 1%{?_dist_release}
37License: LGPL
38Group: System Environment/Libraries
39URL: http://www.gnome.org/projects/evolution/
40Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/%{eds_base_version}/%{name}-%{version}.tar.xz
41BuildRoot: %{_tmppath}/%{name}-%{version}-root
42
43### Patches ###
44Patch0: evolution-data-server-strstr.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: cmake
55BuildRequires: libdb-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60#BuildRequires: WebKit3-gtk-devel
61BuildRequires: webkitgtk4-devel
62BuildRequires: json-glib-devel
63BuildRequires: dbus-glib-devel
64BuildRequires: gnutls-devel
65BuildRequires: intltool >= %{intltool_version}
66BuildRequires: libsoup-devel >= %{soup_version}
67BuildRequires: libtool
68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
71BuildRequires: gperf
72BuildRequires: krb5-devel
73BuildRequires: libgdata-devel >= %{libgdata_version}
74BuildRequires: gnome-online-accounts-devel
75BuildRequires: libsecret-devel
76BuildRequires: libicu-devel
77BuildRequires: gnome-common
78BuildRequires: gcr-devel
79BuildRequires: libaccounts-glib-devel
80BuildRequires: libcanberra-gtk3-devel
81
82BuildRequires: vala
83BuildRequires: vala-tools
84
85BuildRequires: nspr-devel
86BuildRequires: nss-devel
87
88%if %{ldap_support}
89BuildRequires: openldap-devel >= 2.0.11
90%if %{static_ldap}
91BuildRequires: pkgconfig(openssl)
92%endif
93%endif
94
95%if %{krb5_support}
96BuildRequires: krb5-devel
97# tweak for krb5 1.2 vs 1.3
98%define krb5dir /usr/kerberos
99#define krb5dir `pwd`/krb5-fakeprefix
100%endif
101
102Vendor: Project Vine
103Distribution: Vine Linux
104
105
106%description
107The evolution-data-server package provides a unified backend for
108programs that work with contacts, tasks, and calendar information.
109
110It was originally developed for Evolution (hence the name), but
111is now used by other packages.
112
113
114%package devel
115Summary: Development files for building against evolution-data-server
116Group: Development/Libraries
117Requires: %{name} = %{version}-%{release}
118Requires: pkgconfig
119Requires: pkgconfig(goa-1.0)
120Requires: pkgconfig(libgdata)
121Requires: pkgconfig(gweather-3.0)
122Requires: pkgconfig(libical)
123Requires: pkgconfig(libsecret-unstable)
124Requires: pkgconfig(libsoup-2.4)
125Requires: pkgconfig(sqlite3)
126Requires: pkgconfig(webkit2gtk-4.0)
127Requires: pkgconfig(json-glib-1.0)
128
129%description devel
130Development files needed for building things which link against
131evolution-data-server.
132
133
134%package        vala
135Summary:        Vala bindings for %{name}
136Summary(ja):    %{name} の Vala バインディング
137Group:          Development/Libraries
138Requires:       %{name} = %{version}-%{release}
139Requires:       vala
140
141%description    vala
142Vala bindings for %{name}.
143
144
145%prep
146%setup -q
147%patch0 -p1
148
149%build
150
151mkdir -p _build
152cd _build
153
154%if %{ldap_support}
155
156%if %{static_ldap}
157%define ldap_flags -DWITH_OPENLDAP=ON -DWITH_STATIC_LDAP=ON
158# Set LIBS so that configure will be able to link with static LDAP libraries,
159# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
160if pkg-config openssl ; then
161        export LIBS="-lsasl2 `pkg-config --libs openssl`"
162else
163        export LIBS="-lsasl2 -lssl -lcrypto"
164fi
165# newer versions of openldap are built with Mozilla NSS crypto, so also need
166# those libs to link with the static ldap libs
167if pkg-config nss ; then
168    export LIBS="$LIBS `pkg-config --libs nss`"
169else
170    export LIBS="$LIBS -lssl3 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4"
171fi
172%else
173%define ldap_flags -DWITH_OPENLDAP=ON
174%endif
175
176%else
177%define ldap_flags -DWITH_OPENLDAP=OFF
178%endif
179
180%if %{krb5_support}
181%define krb5_flags -DWITH_KRB5=ON
182%else
183%define krb5_flags -DWITH_KRB5=OFF
184%endif
185
186%if %{largefile_support}
187%define largefile_flags -DENABLE_LARGEFILE=ON
188%else
189%define largefile_flags -DENABLE_LARGEFILE=OFF
190%endif
191
192%define ssl_flags -DENABLE_SMIME=ON
193
194%if %{with_docs}
195%define gtkdoc_flags -DENABLE_GTK_DOC=ON
196%else
197%define gtkdoc_flags -DENABLE_GTK_DOC=OFF
198%endif
199
200if ! pkg-config --exists nss; then
201  echo "Unable to find suitable version of nss to use!"
202  exit 1
203fi
204
205export CPPFLAGS="-I%{_includedir}/et"
206export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et -Wno-deprecated-declarations"
207
208# See Ross Burton's blog entry for why we want --with-libdb.
209# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
210
211%cmake -G "Unix Makefiles" \
212        -DENABLE_MAINTAINER_MODE=OFF \
213        -DWITH_LIBDB=/usr \
214        -DENABLE_FILE_LOCKING=fcntl \
215        -DENABLE_DOT_LOCKING=OFF \
216        -DENABLE_INTROSPECTION=ON \
217        -DENABLE_VALA_BINDINGS=ON \
218        -DBUILD_TESTING=OFF \
219        -DENABLE_INSTALLED_TESTS=OFF \
220        -DENABLE_UOA=OFF \
221        %ldap_flags %krb5_flags %ssl_flags \
222        %largefile_flags %gtkdoc_flags \
223        ..
224
225make %{?_smp_mflags}
226
227%install
228cd _build
229rm -rf $RPM_BUILD_ROOT
230
231make DESTDIR=$RPM_BUILD_ROOT install
232
233# make sure the directory exists, because it's owned by eds
234mkdir $RPM_BUILD_ROOT/%{uimodules_dir} || :
235
236# give the libraries some executable bits
237find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
238
239# remove unused files
240rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
241
242%find_lang %{name}
243
244%clean
245rm -rf $RPM_BUILD_ROOT
246
247%post -p /sbin/ldconfig
248
249%postun
250/sbin/ldconfig
251if [ $1 -eq 0 ]; then
252  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
253fi
254
255%posttrans
256glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
257
258
259%files -f _build/%{name}.lang
260%defattr(-,root,root,-)
261%license COPYING
262%doc README ChangeLog NEWS
263%{_libdir}/*.so.*
264%{_libdir}/girepository-1.0/*.typelib
265%{_libexecdir}/camel-gpg-photo-saver
266%{_libexecdir}/camel-index-control-1.2
267%{_libexecdir}/camel-lock-helper-1.2
268%{_libexecdir}/evolution-addressbook-factory
269%{_libexecdir}/evolution-addressbook-factory-subprocess
270%{_libexecdir}/evolution-calendar-factory
271%{_libexecdir}/evolution-calendar-factory-subprocess
272%{_libexecdir}/evolution-scan-gconf-tree-xml
273%{_libexecdir}/evolution-source-registry
274%{_libexecdir}/evolution-user-prompter
275%dir %{_libexecdir}/evolution-data-server
276%{_libexecdir}/evolution-data-server/*
277%{_sysconfdir}/xdg/autostart/org.gnome.Evolution-alarm-notify.desktop
278%{_datadir}/applications/org.gnome.Evolution-alarm-notify.desktop
279%{_datadir}/GConf/gsettings/evolution-data-server.convert
280%{_datadir}/glib-2.0/schemas/*
281%{_datadir}/evolution-data-server
282%{_datadir}/dbus-1/services/*
283%{_datadir}/pixmaps/evolution-data-server
284
285%dir %{_libdir}/evolution-data-server
286%dir %{credential_modules_dir}
287%dir %{camel_provider_dir}
288%dir %{ebook_backends_dir}
289%dir %{ecal_backends_dir}
290%dir %{modules_dir}
291%dir %{uimodules_dir}
292
293%{_libdir}/evolution-data-server/libedbus-private.so
294
295# Camel providers:
296%{camel_provider_dir}/libcamelimapx.so
297%{camel_provider_dir}/libcamelimapx.urls
298
299%{camel_provider_dir}/libcamellocal.so
300%{camel_provider_dir}/libcamellocal.urls
301
302%{camel_provider_dir}/libcamelnntp.so
303%{camel_provider_dir}/libcamelnntp.urls
304
305%{camel_provider_dir}/libcamelpop3.so
306%{camel_provider_dir}/libcamelpop3.urls
307
308%{camel_provider_dir}/libcamelsendmail.so
309%{camel_provider_dir}/libcamelsendmail.urls
310
311%{camel_provider_dir}/libcamelsmtp.so
312%{camel_provider_dir}/libcamelsmtp.urls
313
314# e-d-s extensions:
315%{credential_modules_dir}/module-credentials-goa.so
316%{ebook_backends_dir}/libebookbackendcarddav.so
317%{ebook_backends_dir}/libebookbackendfile.so
318%{ebook_backends_dir}/libebookbackendgoogle.so
319%{ebook_backends_dir}/libebookbackendldap.so
320%{ecal_backends_dir}/libecalbackendcaldav.so
321%{ecal_backends_dir}/libecalbackendcontacts.so
322%{ecal_backends_dir}/libecalbackendfile.so
323%{ecal_backends_dir}/libecalbackendgtasks.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326%{modules_dir}/module-cache-reaper.so
327%{modules_dir}/module-google-backend.so
328%{modules_dir}/module-gnome-online-accounts.so
329%{modules_dir}/module-oauth2-services.so
330%{modules_dir}/module-outlook-backend.so
331%{modules_dir}/module-secret-monitor.so
332%{modules_dir}/module-trust-prompt.so
333%{modules_dir}/module-webdav-backend.so
334%{modules_dir}/module-yahoo-backend.so
335
336%files devel
337%defattr(-,root,root,-)
338%{_includedir}/%{name}
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
341%{_datadir}/gir-1.0/*.gir
342
343%files vala
344%defattr(-,root,root,-)
345%{_datadir}/vala/vapi/libebook-1.2.deps
346%{_datadir}/vala/vapi/libebook-1.2.vapi
347%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
348%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
349%{_datadir}/vala/vapi/libedataserver-1.2.deps
350%{_datadir}/vala/vapi/libedataserver-1.2.vapi
351%{_datadir}/vala/vapi/libedataserverui-1.2.deps
352%{_datadir}/vala/vapi/libedataserverui-1.2.vapi
353%{_datadir}/vala/vapi/camel-1.2.deps
354%{_datadir}/vala/vapi/camel-1.2.vapi
355
356%changelog
357* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.3-1
358- new upstream release.
359
360* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.7-1
361- new upstream release.
362
363* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-2
364- rebuilt with libicu-60.2.
365
366* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.4-1
367- new upstream release
368- add BuildRequires: WebKit3-gtk-devel, json-glib-devel
369
370* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
371- rebuild with gcc-5.4.0
372
373* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
374- new upstream release
375
376* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
377- new upstream release
378
379* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
380- new upstream release
381
382* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
383- new upstream release
384
385* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
386- new upstream release
387
388* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
389- new upstream release
390
391* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
392- new upstream release
393
394* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
395- new upstream release
396- remove %%{name}-doc subpackage
397
398* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
399- new upstream release
400
401* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
402- new upstream release
403
404* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
405- new upstream release
406
407* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
408- rebuilt with libical 1.0.1
409
410* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
411- new upstream release
412
413* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
414- new upstream release
415
416* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
417- new upstream release
418
419* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
420- new upstream release
421
422* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
423- new upstream release
424
425* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
426- new upstream release
427
428* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
429- new upstream release
430
431* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
432- new upstream release
433
434* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
435- new upstream release
436
437* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
438- new upstream release
439
440* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
441- new upstream release
442
443* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
444- new upstream release
445- add BuildRequires: libicu-devel
446
447* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
448- new upstream release
449
450* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
451- new upstream release
452
453* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
454- new upstream release
455
456* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
457- new upstream release
458
459* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
460- new upstream release
461
462* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
463- new upstream release
464
465* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
466- new upstream release
467- add configure option (--disable-uoa)
468- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
469- create %%{name}-vala subpackage
470
471* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
472- new upstream release
473
474* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
475- new upstream release
476
477* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
478- new upstream release
479
480* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
481- new upstream release
482
483* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
484- new upstream release
485
486* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
487- new upstream release
488
489* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
490- new upstream release
491
492* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
493- new upstream release
494
495* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
496- new upstream release
497- add BuildRequires: dbus-glib-devel
498
499* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
500- new upstream release
501
502* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
503- new upstream release
504
505* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
506- new upstream release
507
508* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
509- new upstream release
510
511* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
512- new upstream release
513- remove Patch101
514
515* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
516- new upstream release
517
518* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
519- new upstream release
520- change BuildRequires: gtk3-devel instead of gtk2-devel
521- BuildRequires: gnome-online-accounts-devel
522- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
523- fix %%files
524
525* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
526- new upstream release
527
528* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
529- rebuild with openssl-1.0.0c
530
531* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
532- new upstream release
533- remove Requires: gnome-vfs2, libglade2, libgnomeui
534- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
535- add BuildRequires: libgdata
536- add Requires: nspr-devel, nss-devel (devel package)
537- drop Patch11
538
539* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
540- rebuild with rpm-4.8.1 for pkg-config file
541
542* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
543- new upstream release
544
545* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
546- new upstream release
547
548* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
549- new upstream release
550- remove BuildRequires: libbonobo-devel
551- remove Requires: libbonobo
552- drop Patch10
553- add configure option (--with-krb5-libs, --with-krb5-includes)
554
555* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
556- rebuilt with db4-4.8
557
558* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
559- new upstream release
560
561* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
562- new upstream release
563
564* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
565- new upstream release
566
567* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
568- new upstream release
569
570* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
571- added Requires: libical-devel >= 0.43 to devel package
572
573* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
574- new upstream release
575- add BR: libgweather-devel >= 2.26.0
576- add BR: libical-devel >= 0.43
577
578* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
579- new upstream release
580- added BuildRequires: sqlite3-devel
581
582* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
583- enabled krb5 support
584
585* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
586- new upstream release
587
588* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
589- new upstream release
590
591* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
592- new upstream release
593
594* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
595- new upstream release
596
597* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
598- rebuilt with db4-4.6.21
599
600* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
601- new upstream release
602
603* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
604- new upstream release
605
606* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
607- new upstream release
608
609* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
610- new upstream release based on Fedora package 2.20.0-3.fc9
611  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
612  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
613  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
614  - Add patch for RH bug #296671 (GC servers may not support NTLM).
615  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
616  - Try removing the ancient "ldap-x86_64-hack" patch.
617  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
618  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
619- split doc subpackage
620
621* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
622- fixed dependancy
623
624* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
625- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
626  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
627  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
628  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
629  - Make the new ESourceComboBox widget work properly (RH bug #234760).
630  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
631  - Link to static evolution-openldap library (RH bug #210126).
632  - Require openssl-devel when statically linking against openldap.
633  - Add -Wdeclaration-after-statement to strict build settings.
634  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
635  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
636  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
637  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
638  - Update to 1.10.0
639  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
640  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
641  - Patch by Kenny Root.
642- rebuilt with nss-devel and nspr-devel
643
644* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
645- rebuilt with new toolchain and db4-4.3.x
646
647* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
648- new upstream release
649
650* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
651- new upstream release
652- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
653
654* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
655- new upstream release
656- rebuilt with openssl instead of mozilla-nss
657
658* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
659- rebuilt with openldap-2.3.24-0vl4
660
661* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
662- new upstream release
663- build with libsoap-2.2.7
664
665* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
666- new upstream release
667
668* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
669- new upstream release
670- added/removed Patches based on Fedora packages
671  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
672  - Updated patch 102 to fix further implicit function declarations
673  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
674  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
675    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
676  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
677  - Removed upstreamed patch:
678    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
679  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
680  - added patch to calendar/libecal/e-cal.c to fix missing declaration
681    of open_calendar
682- rebuilt with mozilla-1.7.12
683
684* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
685- rebuilt with mozilla-1.7.7
686
687* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
688- initial build for Vine Linux based on FC package
689- disable krb5 support
690
691* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
692- 1.2.1
693
694* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
695- Removed explicit run-time spec-file requirement on mozilla.
696  The Mozilla NSS API/ABI stabilised by version 1.7.3
697  The libraries are always located in the libdir
698  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
699  and so they move each time the mozilla version changes.
700  So we no longer have an explicit mozilla run-time requirement in the specfile;
701  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
702  We have an explicit, exact build-time version, so that we can find the headers (without
703  invoking an RPM query from the spec file; to do so is considered bad practice)
704- Introduced mozilla_build_version, to replace mozilla_version
705- Set mozilla_build_version to 1.7.6 to reflect current state of tree
706
707* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
708- Added a patch to deal with glibc defining a macro called "read"
709
710* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
711- 1.2.0
712- Removed patch for GCC 4 as this is now in upstream tarball
713
714* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
715- rebuild to fix library linking silliness
716
717* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
718- disabling gtk-doc on ia64 and s390x
719
720* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
721- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
722
723* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
724- extended patch to deal with camel-groupwise-store-summary.c
725
726* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
727- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
728
729* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
730- 1.1.6
731
732* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
733- rebuild
734
735* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
736- forgot to fix sources
737
738* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
739- 1.1.5
740
741* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
742- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
743
744* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
745- disable gtk-doc generation on ia64 for now
746
747* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
748- Exclude ppc64 due to missing mozilla dependency
749
750* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
751- Update from 1.0.3 to 1.1.4.1
752- Updated eds_major from 1.0 to 1.2; fixed translation search path.
753- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
754- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
755- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
756- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
757- Camel code from evolution is now in evolution-data-server:
758  - Added camel-index-control and camel-lock-helper to packaged files
759  - Added mozilla dependency code from the evolution package
760  - Ditto for LDAP
761  - Ditto for krb5
762  - Ditto for NNTP support handling
763  - Ditto for --enable-file-locking and --enable-dot-locking
764- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
765- Updated libsoup requirement from 2.2.1 to 2.2.2
766- Enabled gtk-doc
767
768* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
769- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
770
771* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
772- update from upstream 1.0.2 to 1.0.3:
773  * Address Book
774    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
775    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
776
777  * Calendar
778    #XB59904 - Speed up calendar queries (Rodrigo)
779    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
780    - fix libical build for automake 1.9 (Rodney)
781    - fix putenv usage for portability (Julio M. Merino Vidal)
782
783  * Updated Translations:
784    - sv (Christian Rose)
785
786- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
787
788* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
789- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
790http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
791(The groupwise part of that patch did not cleanly apply, so I removed it).
792
793* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
794- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
795optimisation patch posted to upstream development mailing list here:
796http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
797
798* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
799- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
800
801* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
802- added workaround for a backend leak that causes the "contacts" calendar
803backend to hold open an EBook for the local contacts (filed upstream at:
804http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
805never lose its last addressbook, and hence never quit.  We workaround this by
806detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
807
808* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
809- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
810
811* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
812- update from 1.0.1 to 1.0.2
813- increased libsoup requirement to 2.2.1 to match configuration script
814
815* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
816- update from 1.0.0 to 1.0.1
817- removed patch that fixed warnings in calendar code (now in upstream tarball)
818
819* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
820- fixed various warnings in the calendar code
821  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
822
823* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
824- update from 0.0.99 to 1.0.0
825- changed path in FTP source location from 0.0 to 1.0
826
827* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
828- update from 0.0.98 to 0.0.99
829- increased libsoup requirement to 2.2.0 to match configuration script
830
831* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
832- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
833
834* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
835- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
836
837* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
838- upgraded to 0.0.97; rewrote the package's description
839
840* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
841- rebuilt
842
843* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
844- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
845
846* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
847- 0.0.96; libsoup required is now 2.1.12
848
849* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
850- rebuilt
851
852* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
853- rebuilt
854
855* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
856- 0.0.95
857
858* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
859- 0.0.94.1
860
861* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
862- rebuilt
863
864* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
865- 0.0.94
866
867* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
868- added ORBit2 requirement
869
870* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
871- rebuild again
872
873* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
874- rebuilt
875
876* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
877- 0.0.93; libsoup required is now 2.1.10
878
879* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
880- Update to 0.0.92; added a define and a requirement on the libsoup version
881
882* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
883- 0.0.90
884
885* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
886- rebuilt
887
888* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
889- 0.0.6
890
891* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
892- better fix by using system libtool
893
894* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
895- add some libdb linkage to make the build on x86_64 happy
896
897* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
898- update to 0.0.5
899
900* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
901- Initial build.
Note: See TracBrowser for help on using the repository browser.