source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 11375

Revision 11375, 29.9 KB checked in by tomop, 6 years ago (diff)

evolution-data-server-3.20.4-2

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 0
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.20
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.20.4
34Release: 2%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.20/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: WebKit3-gtk-devel
61BuildRequires: json-glib-devel
62BuildRequires: dbus-glib-devel
63BuildRequires: gnutls-devel
64BuildRequires: intltool >= %{intltool_version}
65BuildRequires: libsoup-devel >= %{soup_version}
66BuildRequires: libtool
67BuildRequires: libgnome-keyring-devel
68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
71BuildRequires: gperf
72BuildRequires: krb5-devel
73BuildRequires: libgdata-devel >= %{libgdata_version}
74BuildRequires: gnome-online-accounts-devel
75BuildRequires: liboauth-devel
76BuildRequires: libsecret-devel
77BuildRequires: libicu-devel
78BuildRequires: gnome-common
79
80BuildRequires: vala
81BuildRequires: vala-tools
82
83%if %{use_nss}
84BuildRequires: nspr-devel
85BuildRequires: nss-devel
86%else
87BuildRequires: openssl-devel
88%endif
89
90%if %{ldap_support}
91%if %{static_ldap}
92BuildRequires: openldap-evolution-devel
93BuildRequires: openssl-devel
94%else
95BuildRequires: openldap-devel >= 2.0.11
96%endif
97%endif
98
99%if %{krb5_support}
100BuildRequires: krb5-devel
101# tweak for krb5 1.2 vs 1.3
102%define krb5dir /usr/kerberos
103#define krb5dir `pwd`/krb5-fakeprefix
104%endif
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109
110%description
111The evolution-data-server package provides a unified backend for
112programs that work with contacts, tasks, and calendar information.
113
114It was originally developed for Evolution (hence the name), but
115is now used by other packages.
116
117
118%package devel
119Summary: Development files for building against evolution-data-server
120Group: Development/Libraries
121Requires: %{name} = %{version}-%{release}
122Requires: pkgconfig
123Requires: sqlite3-devel
124Requires: libgnome-keyring-devel
125
126%description devel
127Development files needed for building things which link against
128evolution-data-server.
129
130
131%package        vala
132Summary:        Vala bindings for %{name}
133Summary(ja):    %{name} の Vala バインディング
134Group:          Development/Libraries
135Requires:       %{name} = %{version}-%{release}
136Requires:       vala
137
138%description    vala
139Vala bindings for %{name}.
140
141
142%prep
143%setup -q
144
145%patch12 -p1 -b .fix-64bit-acinclude
146
147mkdir -p krb5-fakeprefix/include
148mkdir -p krb5-fakeprefix/lib
149mkdir -p krb5-fakeprefix/%{_lib}
150
151%build
152%if %{ldap_support}
153
154%if %{static_ldap}
155%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
156# Set LIBS so that configure will be able to link with static LDAP libraries,
157# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
158if pkg-config libssl ; then
159        export LIBS="-lsasl2 `pkg-config --libs libssl`"
160else
161        export LIBS="-lsasl2 -lssl -lcrypto"
162fi
163%else
164%define ldap_flags --with-openldap=yes
165%endif
166
167%else
168%define ldap_flags --without-openldap
169%endif
170
171%if %{krb5_support}
172%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
173%else
174%define krb5_flags --without-krb5
175%endif
176
177%if %{nntp_support}
178%define nntp_flags --enable-nntp=yes
179%else
180%define nntp_flags --enable-nntp=no
181%endif
182
183%if %{use_nss}
184%define ssl_flags --enable-nss=yes --enable-smime=yes
185%else
186%define ssl_flags --enable-openssl=yes
187%endif
188
189%if %{use_nss}
190if ! pkg-config --exists nss; then
191  echo "Unable to find suitable version of nss to use!"
192  exit 1
193fi
194%endif
195
196%if %{use_gnome_keyring}
197%define keyring_flags --enable-gnome-keyring
198%else
199%define keyring flags --disable-gnome-keyring
200%endif
201
202%if %{support_imap4_provider}
203%define imap4_flags --enable-imap4=yes
204%else
205%define imap4_flags --enable-imap4=no
206%endif
207
208export CPPFLAGS="-I%{_includedir}/et"
209export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
210
211# Regenerate configure to pick up configure.in and acinclude.m4 changes.
212autoreconf -if
213
214# See Ross Burton's blog entry for why we want --with-libdb.
215# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
216
217CXXFLAGS="%{optflags} -fpermissive --std=c++11" \
218%configure \
219        --with-libdb=/usr \
220        --disable-uoa \
221        --enable-file-locking=fcntl \
222        --enable-dot-locking=no \
223        --disable-gtk-doc \
224        --enable-introspection=yes \
225        --enable-vala-bindings \
226        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
227        %keyring_flags
228export tagname=CC
229make %{?_smp_mflags}
230
231%install
232rm -rf $RPM_BUILD_ROOT
233export tagname=CC
234make DESTDIR=$RPM_BUILD_ROOT install
235
236# remove libtool archives for importers and the like
237find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
238find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
239
240# give the libraries some executable bits
241find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
242
243# remove unused files
244rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
245
246%find_lang %{name}-%{eds_base_version}
247
248%clean
249rm -rf $RPM_BUILD_ROOT
250
251%post -p /sbin/ldconfig
252
253%postun
254/sbin/ldconfig
255if [ $1 -eq 0 ]; then
256  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
257fi
258
259%posttrans
260glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
261
262
263%files -f %{name}-%{eds_base_version}.lang
264%defattr(-,root,root,-)
265%doc README COPYING ChangeLog NEWS AUTHORS
266%{_libdir}/*.so.*
267%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
268%{_libdir}/evolution-data-server/libedbus-private.so
269%{_libdir}/girepository-1.0/*.typelib
270%{_libexecdir}/evolution-addressbook-factory
271%{_libexecdir}/evolution-addressbook-factory-subprocess
272%{_libexecdir}/evolution-calendar-factory
273%{_libexecdir}/evolution-calendar-factory-subprocess
274%{_libexecdir}/evolution-scan-gconf-tree-xml
275%{_libexecdir}/evolution-source-registry
276%{_libexecdir}/evolution-user-prompter
277%{_libexecdir}/camel-index-control-%{eds_api_version}
278%{_libexecdir}/camel-lock-helper-%{eds_api_version}
279%{_datadir}/GConf/gsettings/evolution-data-server.convert
280%{_datadir}/dbus-1/services/*
281%{_datadir}/%{name}/evolutionperson.schema
282%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
283%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
288%{_datadir}/pixmaps/evolution-data-server
289
290%dir %{_libdir}/evolution-data-server
291%dir %{camel_provider_dir}
292%dir %{ebook_backends_dir}
293%dir %{ecal_backends_dir}
294%dir %{registry_modules_dir}
295
296%{camel_provider_dir}/libcamelimapx.so
297%{camel_provider_dir}/libcamelimapx.urls
298
299%{camel_provider_dir}/libcamellocal.so
300%{camel_provider_dir}/libcamellocal.urls
301
302%{camel_provider_dir}/libcamelnntp.so
303%{camel_provider_dir}/libcamelnntp.urls
304
305%{camel_provider_dir}/libcamelpop3.so
306%{camel_provider_dir}/libcamelpop3.urls
307
308%{camel_provider_dir}/libcamelsendmail.so
309%{camel_provider_dir}/libcamelsendmail.urls
310
311%{camel_provider_dir}/libcamelsmtp.so
312%{camel_provider_dir}/libcamelsmtp.urls
313
314# e-d-s extensions:
315%{ebook_backends_dir}/libebookbackendfile.so
316%{ebook_backends_dir}/libebookbackendgoogle.so
317%{ebook_backends_dir}/libebookbackendldap.so
318%{ebook_backends_dir}/libebookbackendwebdav.so
319
320%{ecal_backends_dir}/libecalbackendcaldav.so
321%{ecal_backends_dir}/libecalbackendcontacts.so
322%{ecal_backends_dir}/libecalbackendfile.so
323%{ecal_backends_dir}/libecalbackendgtasks.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326
327%{registry_modules_dir}/module-cache-reaper.so
328%{registry_modules_dir}/module-google-backend.so
329%{registry_modules_dir}/module-gnome-online-accounts.so
330%{registry_modules_dir}/module-outlook-backend.so
331%{registry_modules_dir}/module-owncloud-backend.so
332%{registry_modules_dir}/module-secret-monitor.so
333%{registry_modules_dir}/module-trust-prompt.so
334%{registry_modules_dir}/module-yahoo-backend.so
335
336%files devel
337%defattr(-,root,root,-)
338%{_includedir}/%{name}
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
341%{_datadir}/gir-1.0/*.gir
342
343%files vala
344%defattr(-,root,root,-)
345%{_datadir}/vala/vapi/libebook-1.2.deps
346%{_datadir}/vala/vapi/libebook-1.2.vapi
347%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
348%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
349%{_datadir}/vala/vapi/libedataserver-1.2.deps
350%{_datadir}/vala/vapi/libedataserver-1.2.vapi
351%{_datadir}/vala/vapi/camel-1.2.deps
352%{_datadir}/vala/vapi/camel-1.2.vapi
353
354
355%changelog
356* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.4-2
357- rebuilt with libicu-60.2.
358
359* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.4-1
360- new upstream release
361- add BuildRequires: WebKit3-gtk-devel, json-glib-devel
362
363* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-2
364- rebuild with gcc-5.4.0
365
366* Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.5-1
367- new upstream release
368
369* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.4-1
370- new upstream release
371
372* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
373- new upstream release
374
375* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
376- new upstream release
377
378* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
379- new upstream release
380
381* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
382- new upstream release
383
384* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
385- new upstream release
386
387* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
388- new upstream release
389- remove %%{name}-doc subpackage
390
391* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
392- new upstream release
393
394* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
395- new upstream release
396
397* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
398- new upstream release
399
400* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
401- rebuilt with libical 1.0.1
402
403* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
404- new upstream release
405
406* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
407- new upstream release
408
409* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
410- new upstream release
411
412* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
413- new upstream release
414
415* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
416- new upstream release
417
418* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
419- new upstream release
420
421* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
422- new upstream release
423
424* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
425- new upstream release
426
427* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
428- new upstream release
429
430* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
431- new upstream release
432
433* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
434- new upstream release
435
436* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
437- new upstream release
438- add BuildRequires: libicu-devel
439
440* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
441- new upstream release
442
443* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
444- new upstream release
445
446* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
447- new upstream release
448
449* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
450- new upstream release
451
452* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
453- new upstream release
454
455* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
456- new upstream release
457
458* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
459- new upstream release
460- add configure option (--disable-uoa)
461- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
462- create %%{name}-vala subpackage
463
464* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
465- new upstream release
466
467* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
468- new upstream release
469
470* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
471- new upstream release
472
473* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
474- new upstream release
475
476* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
477- new upstream release
478
479* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
480- new upstream release
481
482* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
483- new upstream release
484
485* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
486- new upstream release
487
488* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
489- new upstream release
490- add BuildRequires: dbus-glib-devel
491
492* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
493- new upstream release
494
495* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
496- new upstream release
497
498* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
499- new upstream release
500
501* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
502- new upstream release
503
504* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
505- new upstream release
506- remove Patch101
507
508* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
509- new upstream release
510
511* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
512- new upstream release
513- change BuildRequires: gtk3-devel instead of gtk2-devel
514- BuildRequires: gnome-online-accounts-devel
515- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
516- fix %%files
517
518* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
519- new upstream release
520
521* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
522- rebuild with openssl-1.0.0c
523
524* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
525- new upstream release
526- remove Requires: gnome-vfs2, libglade2, libgnomeui
527- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
528- add BuildRequires: libgdata
529- add Requires: nspr-devel, nss-devel (devel package)
530- drop Patch11
531
532* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
533- rebuild with rpm-4.8.1 for pkg-config file
534
535* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
536- new upstream release
537
538* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
539- new upstream release
540
541* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
542- new upstream release
543- remove BuildRequires: libbonobo-devel
544- remove Requires: libbonobo
545- drop Patch10
546- add configure option (--with-krb5-libs, --with-krb5-includes)
547
548* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
549- rebuilt with db4-4.8
550
551* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
552- new upstream release
553
554* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
555- new upstream release
556
557* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
558- new upstream release
559
560* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
561- new upstream release
562
563* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
564- added Requires: libical-devel >= 0.43 to devel package
565
566* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
567- new upstream release
568- add BR: libgweather-devel >= 2.26.0
569- add BR: libical-devel >= 0.43
570
571* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
572- new upstream release
573- added BuildRequires: sqlite3-devel
574
575* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
576- enabled krb5 support
577
578* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
579- new upstream release
580
581* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
582- new upstream release
583
584* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
585- new upstream release
586
587* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
588- new upstream release
589
590* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
591- rebuilt with db4-4.6.21
592
593* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
594- new upstream release
595
596* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
597- new upstream release
598
599* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
600- new upstream release
601
602* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
603- new upstream release based on Fedora package 2.20.0-3.fc9
604  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
605  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
606  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
607  - Add patch for RH bug #296671 (GC servers may not support NTLM).
608  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
609  - Try removing the ancient "ldap-x86_64-hack" patch.
610  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
611  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
612- split doc subpackage
613
614* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
615- fixed dependancy
616
617* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
618- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
619  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
620  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
621  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
622  - Make the new ESourceComboBox widget work properly (RH bug #234760).
623  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
624  - Link to static evolution-openldap library (RH bug #210126).
625  - Require openssl-devel when statically linking against openldap.
626  - Add -Wdeclaration-after-statement to strict build settings.
627  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
628  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
629  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
630  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
631  - Update to 1.10.0
632  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
633  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
634  - Patch by Kenny Root.
635- rebuilt with nss-devel and nspr-devel
636
637* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
638- rebuilt with new toolchain and db4-4.3.x
639
640* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
641- new upstream release
642
643* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
644- new upstream release
645- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
646
647* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
648- new upstream release
649- rebuilt with openssl instead of mozilla-nss
650
651* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
652- rebuilt with openldap-2.3.24-0vl4
653
654* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
655- new upstream release
656- build with libsoap-2.2.7
657
658* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
659- new upstream release
660
661* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
662- new upstream release
663- added/removed Patches based on Fedora packages
664  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
665  - Updated patch 102 to fix further implicit function declarations
666  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
667  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
668    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
669  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
670  - Removed upstreamed patch:
671    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
672  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
673  - added patch to calendar/libecal/e-cal.c to fix missing declaration
674    of open_calendar
675- rebuilt with mozilla-1.7.12
676
677* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
678- rebuilt with mozilla-1.7.7
679
680* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
681- initial build for Vine Linux based on FC package
682- disable krb5 support
683
684* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
685- 1.2.1
686
687* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
688- Removed explicit run-time spec-file requirement on mozilla.
689  The Mozilla NSS API/ABI stabilised by version 1.7.3
690  The libraries are always located in the libdir
691  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
692  and so they move each time the mozilla version changes.
693  So we no longer have an explicit mozilla run-time requirement in the specfile;
694  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
695  We have an explicit, exact build-time version, so that we can find the headers (without
696  invoking an RPM query from the spec file; to do so is considered bad practice)
697- Introduced mozilla_build_version, to replace mozilla_version
698- Set mozilla_build_version to 1.7.6 to reflect current state of tree
699
700* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
701- Added a patch to deal with glibc defining a macro called "read"
702
703* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
704- 1.2.0
705- Removed patch for GCC 4 as this is now in upstream tarball
706
707* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
708- rebuild to fix library linking silliness
709
710* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
711- disabling gtk-doc on ia64 and s390x
712
713* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
714- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
715
716* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
717- extended patch to deal with camel-groupwise-store-summary.c
718
719* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
720- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
721
722* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
723- 1.1.6
724
725* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
726- rebuild
727
728* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
729- forgot to fix sources
730
731* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
732- 1.1.5
733
734* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
735- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
736
737* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
738- disable gtk-doc generation on ia64 for now
739
740* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
741- Exclude ppc64 due to missing mozilla dependency
742
743* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
744- Update from 1.0.3 to 1.1.4.1
745- Updated eds_major from 1.0 to 1.2; fixed translation search path.
746- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
747- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
748- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
749- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
750- Camel code from evolution is now in evolution-data-server:
751  - Added camel-index-control and camel-lock-helper to packaged files
752  - Added mozilla dependency code from the evolution package
753  - Ditto for LDAP
754  - Ditto for krb5
755  - Ditto for NNTP support handling
756  - Ditto for --enable-file-locking and --enable-dot-locking
757- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
758- Updated libsoup requirement from 2.2.1 to 2.2.2
759- Enabled gtk-doc
760
761* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
762- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
763
764* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
765- update from upstream 1.0.2 to 1.0.3:
766  * Address Book
767    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
768    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
769
770  * Calendar
771    #XB59904 - Speed up calendar queries (Rodrigo)
772    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
773    - fix libical build for automake 1.9 (Rodney)
774    - fix putenv usage for portability (Julio M. Merino Vidal)
775
776  * Updated Translations:
777    - sv (Christian Rose)
778
779- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
780
781* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
782- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
783http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
784(The groupwise part of that patch did not cleanly apply, so I removed it).
785
786* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
787- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
788optimisation patch posted to upstream development mailing list here:
789http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
790
791* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
792- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
793
794* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
795- added workaround for a backend leak that causes the "contacts" calendar
796backend to hold open an EBook for the local contacts (filed upstream at:
797http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
798never lose its last addressbook, and hence never quit.  We workaround this by
799detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
800
801* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
802- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
803
804* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
805- update from 1.0.1 to 1.0.2
806- increased libsoup requirement to 2.2.1 to match configuration script
807
808* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
809- update from 1.0.0 to 1.0.1
810- removed patch that fixed warnings in calendar code (now in upstream tarball)
811
812* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
813- fixed various warnings in the calendar code
814  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
815
816* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
817- update from 0.0.99 to 1.0.0
818- changed path in FTP source location from 0.0 to 1.0
819
820* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
821- update from 0.0.98 to 0.0.99
822- increased libsoup requirement to 2.2.0 to match configuration script
823
824* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
825- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
826
827* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
828- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
829
830* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
831- upgraded to 0.0.97; rewrote the package's description
832
833* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
834- rebuilt
835
836* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
837- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
838
839* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
840- 0.0.96; libsoup required is now 2.1.12
841
842* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
843- rebuilt
844
845* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
846- rebuilt
847
848* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
849- 0.0.95
850
851* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
852- 0.0.94.1
853
854* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
855- rebuilt
856
857* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
858- 0.0.94
859
860* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
861- added ORBit2 requirement
862
863* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
864- rebuild again
865
866* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
867- rebuilt
868
869* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
870- 0.0.93; libsoup required is now 2.1.10
871
872* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
873- Update to 0.0.92; added a define and a requirement on the libsoup version
874
875* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
876- 0.0.90
877
878* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
879- rebuilt
880
881* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
882- 0.0.6
883
884* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
885- better fix by using system libtool
886
887* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
888- add some libdb linkage to make the build on x86_64 happy
889
890* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
891- update to 0.0.5
892
893* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
894- Initial build.
Note: See TracBrowser for help on using the repository browser.