source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9724

Revision 9724, 28.9 KB checked in by Takemikaduchi, 9 years ago (diff)

NEW: vine-sleep-helper
mate-session-manager,mate-power-manager: add R: vine-sleep-helper
others: new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.43
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.16
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.16.5
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.16/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: sqlite3-devel
67BuildRequires: libgweather-devel >= %{libgweather_version}
68BuildRequires: libical-devel >= %{libical_version}
69BuildRequires: gperf
70BuildRequires: krb5-devel
71BuildRequires: libgdata-devel >= %{libgdata_version}
72BuildRequires: gnome-online-accounts-devel
73BuildRequires: liboauth-devel
74BuildRequires: libsecret-devel
75BuildRequires: libicu-devel
76BuildRequires: gnome-common
77
78BuildRequires: vala
79BuildRequires: vala-tools
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104Obsoletes: %{name}-doc < 3.16.3
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110The evolution-data-server package provides a unified backend for
111programs that work with contacts, tasks, and calendar information.
112
113It was originally developed for Evolution (hence the name), but
114is now used by other packages.
115
116
117%package devel
118Summary: Development files for building against evolution-data-server
119Group: Development/Libraries
120Requires: %{name} = %{version}-%{release}
121Requires: pkgconfig
122Requires: sqlite3-devel
123Requires: libgnome-keyring-devel
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129
130%package        vala
131Summary:        Vala bindings for %{name}
132Summary(ja):    %{name} の Vala バインディング
133Group:          Development/Libraries
134Requires:       %{name} = %{version}-%{release}
135Requires:       vala
136
137%description    vala
138Vala bindings for %{name}.
139
140
141%prep
142%setup -q
143
144%patch12 -p1 -b .fix-64bit-acinclude
145
146mkdir -p krb5-fakeprefix/include
147mkdir -p krb5-fakeprefix/lib
148mkdir -p krb5-fakeprefix/%{_lib}
149
150%build
151%if %{ldap_support}
152
153%if %{static_ldap}
154%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
155# Set LIBS so that configure will be able to link with static LDAP libraries,
156# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
157if pkg-config libssl ; then
158        export LIBS="-lsasl2 `pkg-config --libs libssl`"
159else
160        export LIBS="-lsasl2 -lssl -lcrypto"
161fi
162%else
163%define ldap_flags --with-openldap=yes
164%endif
165
166%else
167%define ldap_flags --without-openldap
168%endif
169
170%if %{krb5_support}
171%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
172%else
173%define krb5_flags --without-krb5
174%endif
175
176%if %{nntp_support}
177%define nntp_flags --enable-nntp=yes
178%else
179%define nntp_flags --enable-nntp=no
180%endif
181
182%if %{use_nss}
183%define ssl_flags --enable-nss=yes --enable-smime=yes
184%else
185%define ssl_flags --enable-openssl=yes
186%endif
187
188%if %{use_nss}
189if ! pkg-config --exists nss; then
190  echo "Unable to find suitable version of nss to use!"
191  exit 1
192fi
193%endif
194
195%if %{use_gnome_keyring}
196%define keyring_flags --enable-gnome-keyring
197%else
198%define keyring flags --disable-gnome-keyring
199%endif
200
201%if %{support_imap4_provider}
202%define imap4_flags --enable-imap4=yes
203%else
204%define imap4_flags --enable-imap4=no
205%endif
206
207export CPPFLAGS="-I%{_includedir}/et"
208export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
209
210# Regenerate configure to pick up configure.in and acinclude.m4 changes.
211autoreconf -if
212
213# See Ross Burton's blog entry for why we want --with-libdb.
214# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
215
216%configure \
217        --with-libdb=/usr \
218        --disable-uoa \
219        --enable-file-locking=fcntl \
220        --enable-dot-locking=no \
221        --disable-gtk-doc \
222        --enable-introspection=yes \
223        --enable-vala-bindings \
224        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
225        %keyring_flags
226export tagname=CC
227make %{?_smp_mflags}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231export tagname=CC
232make DESTDIR=$RPM_BUILD_ROOT install
233
234# remove libtool archives for importers and the like
235find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
236find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
237
238# give the libraries some executable bits
239find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
240
241%find_lang %{name}-%{eds_base_version}
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post -p /sbin/ldconfig
247
248%postun
249/sbin/ldconfig
250if [ $1 -eq 0 ]; then
251  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
252fi
253
254%posttrans
255glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256
257
258%files -f %{name}-%{eds_base_version}.lang
259%defattr(-,root,root,-)
260%doc README COPYING ChangeLog NEWS AUTHORS
261%{_libdir}/*.so.*
262%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
263%{_libdir}/evolution-data-server/libedbus-private.so
264%{_libdir}/girepository-1.0/*.typelib
265%{_libexecdir}/evolution-addressbook-factory
266%{_libexecdir}/evolution-addressbook-factory-subprocess
267%{_libexecdir}/evolution-calendar-factory
268%{_libexecdir}/evolution-calendar-factory-subprocess
269%{_libexecdir}/evolution-scan-gconf-tree-xml
270%{_libexecdir}/evolution-source-registry
271%{_libexecdir}/evolution-user-prompter
272%{_libexecdir}/camel-index-control-%{eds_api_version}
273%{_libexecdir}/camel-lock-helper-%{eds_api_version}
274%{_datadir}/GConf/gsettings/evolution-data-server.convert
275%{_datadir}/dbus-1/services/*
276%{_datadir}/%{name}/evolutionperson.schema
277%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
278%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
279%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
280%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
281%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
282%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
283%{_datadir}/pixmaps/evolution-data-server
284
285%dir %{_libdir}/evolution-data-server
286%dir %{camel_provider_dir}
287%dir %{ebook_backends_dir}
288%dir %{ecal_backends_dir}
289%dir %{registry_modules_dir}
290
291%{camel_provider_dir}/libcamelimapx.so
292%{camel_provider_dir}/libcamelimapx.urls
293
294%{camel_provider_dir}/libcamellocal.so
295%{camel_provider_dir}/libcamellocal.urls
296
297%{camel_provider_dir}/libcamelnntp.so
298%{camel_provider_dir}/libcamelnntp.urls
299
300%{camel_provider_dir}/libcamelpop3.so
301%{camel_provider_dir}/libcamelpop3.urls
302
303%{camel_provider_dir}/libcamelsendmail.so
304%{camel_provider_dir}/libcamelsendmail.urls
305
306%{camel_provider_dir}/libcamelsmtp.so
307%{camel_provider_dir}/libcamelsmtp.urls
308
309# e-d-s extensions:
310%{ebook_backends_dir}/libebookbackendfile.so
311%{ebook_backends_dir}/libebookbackendgoogle.so
312%{ebook_backends_dir}/libebookbackendldap.so
313%{ebook_backends_dir}/libebookbackendwebdav.so
314
315%{ecal_backends_dir}/libecalbackendcaldav.so
316%{ecal_backends_dir}/libecalbackendcontacts.so
317%{ecal_backends_dir}/libecalbackendfile.so
318%{ecal_backends_dir}/libecalbackendgtasks.so
319%{ecal_backends_dir}/libecalbackendhttp.so
320%{ecal_backends_dir}/libecalbackendweather.so
321
322%{registry_modules_dir}/module-cache-reaper.so
323%{registry_modules_dir}/module-google-backend.so
324%{registry_modules_dir}/module-gnome-online-accounts.so
325%{registry_modules_dir}/module-outlook-backend.so
326%{registry_modules_dir}/module-owncloud-backend.so
327%{registry_modules_dir}/module-secret-monitor.so
328%{registry_modules_dir}/module-trust-prompt.so
329%{registry_modules_dir}/module-yahoo-backend.so
330
331%files devel
332%defattr(-,root,root,-)
333%{_includedir}/%{name}
334%{_libdir}/*.so
335%{_libdir}/pkgconfig/*.pc
336%{_datadir}/gir-1.0/*.gir
337
338%files vala
339%defattr(-,root,root,-)
340%{_datadir}/vala/vapi/libebook-1.2.deps
341%{_datadir}/vala/vapi/libebook-1.2.vapi
342%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
343%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
344%{_datadir}/vala/vapi/libedataserver-1.2.deps
345%{_datadir}/vala/vapi/libedataserver-1.2.vapi
346
347
348%changelog
349* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.5-1
350- new upstream release
351
352* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
353- new upstream release
354
355* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
356- new upstream release
357- remove %%{name}-doc subpackage
358
359* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
360- new upstream release
361
362* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
363- new upstream release
364
365* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
366- new upstream release
367
368* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
369- rebuilt with libical 1.0.1
370
371* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
372- new upstream release
373
374* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
375- new upstream release
376
377* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
378- new upstream release
379
380* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
381- new upstream release
382
383* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
384- new upstream release
385
386* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
387- new upstream release
388
389* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
390- new upstream release
391
392* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
393- new upstream release
394
395* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
396- new upstream release
397
398* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
399- new upstream release
400
401* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
402- new upstream release
403
404* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
405- new upstream release
406- add BuildRequires: libicu-devel
407
408* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
409- new upstream release
410
411* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
412- new upstream release
413
414* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
415- new upstream release
416
417* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
418- new upstream release
419
420* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
421- new upstream release
422
423* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
424- new upstream release
425
426* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
427- new upstream release
428- add configure option (--disable-uoa)
429- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
430- create %%{name}-vala subpackage
431
432* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
433- new upstream release
434
435* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
436- new upstream release
437
438* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
439- new upstream release
440
441* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
442- new upstream release
443
444* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
445- new upstream release
446
447* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
448- new upstream release
449
450* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
451- new upstream release
452
453* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
454- new upstream release
455
456* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
457- new upstream release
458- add BuildRequires: dbus-glib-devel
459
460* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
461- new upstream release
462
463* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
464- new upstream release
465
466* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
467- new upstream release
468
469* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
470- new upstream release
471
472* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
473- new upstream release
474- remove Patch101
475
476* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
477- new upstream release
478
479* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
480- new upstream release
481- change BuildRequires: gtk3-devel instead of gtk2-devel
482- BuildRequires: gnome-online-accounts-devel
483- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
484- fix %%files
485
486* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
487- new upstream release
488
489* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
490- rebuild with openssl-1.0.0c
491
492* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
493- new upstream release
494- remove Requires: gnome-vfs2, libglade2, libgnomeui
495- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
496- add BuildRequires: libgdata
497- add Requires: nspr-devel, nss-devel (devel package)
498- drop Patch11
499
500* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
501- rebuild with rpm-4.8.1 for pkg-config file
502
503* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
504- new upstream release
505
506* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
507- new upstream release
508
509* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
510- new upstream release
511- remove BuildRequires: libbonobo-devel
512- remove Requires: libbonobo
513- drop Patch10
514- add configure option (--with-krb5-libs, --with-krb5-includes)
515
516* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
517- rebuilt with db4-4.8
518
519* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
520- new upstream release
521
522* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
523- new upstream release
524
525* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
526- new upstream release
527
528* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
529- new upstream release
530
531* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
532- added Requires: libical-devel >= 0.43 to devel package
533
534* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
535- new upstream release
536- add BR: libgweather-devel >= 2.26.0
537- add BR: libical-devel >= 0.43
538
539* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
540- new upstream release
541- added BuildRequires: sqlite3-devel
542
543* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
544- enabled krb5 support
545
546* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
547- new upstream release
548
549* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
550- new upstream release
551
552* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
553- new upstream release
554
555* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
556- new upstream release
557
558* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
559- rebuilt with db4-4.6.21
560
561* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
562- new upstream release
563
564* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
565- new upstream release
566
567* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
568- new upstream release
569
570* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
571- new upstream release based on Fedora package 2.20.0-3.fc9
572  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
573  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
574  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
575  - Add patch for RH bug #296671 (GC servers may not support NTLM).
576  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
577  - Try removing the ancient "ldap-x86_64-hack" patch.
578  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
579  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
580- split doc subpackage
581
582* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
583- fixed dependancy
584
585* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
586- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
587  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
588  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
589  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
590  - Make the new ESourceComboBox widget work properly (RH bug #234760).
591  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
592  - Link to static evolution-openldap library (RH bug #210126).
593  - Require openssl-devel when statically linking against openldap.
594  - Add -Wdeclaration-after-statement to strict build settings.
595  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
596  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
597  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
598  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
599  - Update to 1.10.0
600  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
601  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
602  - Patch by Kenny Root.
603- rebuilt with nss-devel and nspr-devel
604
605* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
606- rebuilt with new toolchain and db4-4.3.x
607
608* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
609- new upstream release
610
611* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
612- new upstream release
613- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
614
615* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
616- new upstream release
617- rebuilt with openssl instead of mozilla-nss
618
619* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
620- rebuilt with openldap-2.3.24-0vl4
621
622* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
623- new upstream release
624- build with libsoap-2.2.7
625
626* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
627- new upstream release
628
629* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
630- new upstream release
631- added/removed Patches based on Fedora packages
632  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
633  - Updated patch 102 to fix further implicit function declarations
634  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
635  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
636    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
637  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
638  - Removed upstreamed patch:
639    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
640  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
641  - added patch to calendar/libecal/e-cal.c to fix missing declaration
642    of open_calendar
643- rebuilt with mozilla-1.7.12
644
645* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
646- rebuilt with mozilla-1.7.7
647
648* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
649- initial build for Vine Linux based on FC package
650- disable krb5 support
651
652* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
653- 1.2.1
654
655* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
656- Removed explicit run-time spec-file requirement on mozilla.
657  The Mozilla NSS API/ABI stabilised by version 1.7.3
658  The libraries are always located in the libdir
659  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
660  and so they move each time the mozilla version changes.
661  So we no longer have an explicit mozilla run-time requirement in the specfile;
662  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
663  We have an explicit, exact build-time version, so that we can find the headers (without
664  invoking an RPM query from the spec file; to do so is considered bad practice)
665- Introduced mozilla_build_version, to replace mozilla_version
666- Set mozilla_build_version to 1.7.6 to reflect current state of tree
667
668* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
669- Added a patch to deal with glibc defining a macro called "read"
670
671* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
672- 1.2.0
673- Removed patch for GCC 4 as this is now in upstream tarball
674
675* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
676- rebuild to fix library linking silliness
677
678* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
679- disabling gtk-doc on ia64 and s390x
680
681* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
682- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
683
684* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
685- extended patch to deal with camel-groupwise-store-summary.c
686
687* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
688- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
689
690* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
691- 1.1.6
692
693* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
694- rebuild
695
696* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
697- forgot to fix sources
698
699* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
700- 1.1.5
701
702* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
703- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
704
705* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
706- disable gtk-doc generation on ia64 for now
707
708* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
709- Exclude ppc64 due to missing mozilla dependency
710
711* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
712- Update from 1.0.3 to 1.1.4.1
713- Updated eds_major from 1.0 to 1.2; fixed translation search path.
714- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
715- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
716- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
717- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
718- Camel code from evolution is now in evolution-data-server:
719  - Added camel-index-control and camel-lock-helper to packaged files
720  - Added mozilla dependency code from the evolution package
721  - Ditto for LDAP
722  - Ditto for krb5
723  - Ditto for NNTP support handling
724  - Ditto for --enable-file-locking and --enable-dot-locking
725- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
726- Updated libsoup requirement from 2.2.1 to 2.2.2
727- Enabled gtk-doc
728
729* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
730- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
731
732* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
733- update from upstream 1.0.2 to 1.0.3:
734  * Address Book
735    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
736    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
737
738  * Calendar
739    #XB59904 - Speed up calendar queries (Rodrigo)
740    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
741    - fix libical build for automake 1.9 (Rodney)
742    - fix putenv usage for portability (Julio M. Merino Vidal)
743
744  * Updated Translations:
745    - sv (Christian Rose)
746
747- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
748
749* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
750- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
751http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
752(The groupwise part of that patch did not cleanly apply, so I removed it).
753
754* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
755- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
756optimisation patch posted to upstream development mailing list here:
757http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
758
759* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
760- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
761
762* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
763- added workaround for a backend leak that causes the "contacts" calendar
764backend to hold open an EBook for the local contacts (filed upstream at:
765http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
766never lose its last addressbook, and hence never quit.  We workaround this by
767detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
768
769* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
770- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
771
772* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
773- update from 1.0.1 to 1.0.2
774- increased libsoup requirement to 2.2.1 to match configuration script
775
776* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
777- update from 1.0.0 to 1.0.1
778- removed patch that fixed warnings in calendar code (now in upstream tarball)
779
780* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
781- fixed various warnings in the calendar code
782  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
783
784* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
785- update from 0.0.99 to 1.0.0
786- changed path in FTP source location from 0.0 to 1.0
787
788* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
789- update from 0.0.98 to 0.0.99
790- increased libsoup requirement to 2.2.0 to match configuration script
791
792* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
793- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
794
795* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
796- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
797
798* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
799- upgraded to 0.0.97; rewrote the package's description
800
801* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
802- rebuilt
803
804* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
805- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
806
807* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
808- 0.0.96; libsoup required is now 2.1.12
809
810* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
811- rebuilt
812
813* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
814- rebuilt
815
816* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
817- 0.0.95
818
819* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
820- 0.0.94.1
821
822* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
823- rebuilt
824
825* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
826- 0.0.94
827
828* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
829- added ORBit2 requirement
830
831* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
832- rebuild again
833
834* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
835- rebuilt
836
837* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
838- 0.0.93; libsoup required is now 2.1.10
839
840* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
841- Update to 0.0.92; added a define and a requirement on the libsoup version
842
843* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
844- 0.0.90
845
846* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
847- rebuilt
848
849* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
850- 0.0.6
851
852* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
853- better fix by using system libtool
854
855* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
856- add some libdb linkage to make the build on x86_64 happy
857
858* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
859- update to 0.0.5
860
861* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
862- Initial build.
Note: See TracBrowser for help on using the repository browser.