source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 7938

Revision 7938, 27.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.10
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
33Version: 3.10.1
34Release: 1%{?_dist_release}
35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.10/%{name}-%{version}.tar.xz
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
48#Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53#BuildRequires: ORBit2-devel >= %{orbit2_version}
54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
59BuildRequires: gtk3-devel
60BuildRequires: dbus-glib-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75BuildRequires: libsecret-devel
76BuildRequires: gnome-common
77
78BuildRequires: vala
79BuildRequires: vala-tools
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104Vendor: Project Vine
105Distribution: Vine Linux
106
107%description
108The evolution-data-server package provides a unified backend for
109programs that work with contacts, tasks, and calendar information.
110
111It was originally developed for Evolution (hence the name), but
112is now used by other packages.
113
114
115%package devel
116Summary: Development files for building against evolution-data-server
117Group: Development/Libraries
118Requires: %{name} = %{version}-%{release}
119Requires: pkgconfig
120Requires: sqlite3-devel
121Requires: libgnome-keyring-devel
122
123%description devel
124Development files needed for building things which link against
125evolution-data-server.
126
127
128%package                doc
129Summary:                Documentation for %{name}
130Summary(ja):    %{name} 用のドキュメント
131Group:                  Documentation
132Requires:               %{name} = %{version}-%{release}
133BuildArch:              noarch
134
135%description doc
136This package contains documentation for %{name}.
137
138
139%package        vala
140Summary:        Vala bindings for %{name}
141Summary(ja):    %{name} の Vala バインディング
142Group:          Development/Libraries
143Requires:       %{name} = %{version}-%{release}
144Requires:       vala
145
146%description    vala
147Vala bindings for %{name}.
148
149
150%prep
151%setup -q
152
153%patch12 -p1 -b .fix-64bit-acinclude
154
155mkdir -p krb5-fakeprefix/include
156mkdir -p krb5-fakeprefix/lib
157mkdir -p krb5-fakeprefix/%{_lib}
158
159%build
160%if %{ldap_support}
161
162%if %{static_ldap}
163%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
164# Set LIBS so that configure will be able to link with static LDAP libraries,
165# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
166if pkg-config libssl ; then
167        export LIBS="-lsasl2 `pkg-config --libs libssl`"
168else
169        export LIBS="-lsasl2 -lssl -lcrypto"
170fi
171%else
172%define ldap_flags --with-openldap=yes
173%endif
174
175%else
176%define ldap_flags --without-openldap
177%endif
178
179%if %{krb5_support}
180%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
181%else
182%define krb5_flags --without-krb5
183%endif
184
185%if %{nntp_support}
186%define nntp_flags --enable-nntp=yes
187%else
188%define nntp_flags --enable-nntp=no
189%endif
190
191%if %{use_nss}
192%define ssl_flags --enable-nss=yes --enable-smime=yes
193%else
194%define ssl_flags --enable-openssl=yes
195%endif
196
197%if %{use_nss}
198if ! pkg-config --exists nss; then
199  echo "Unable to find suitable version of nss to use!"
200  exit 1
201fi
202%endif
203
204%if %{use_gnome_keyring}
205%define keyring_flags --enable-gnome-keyring
206%else
207%define keyring flags --disable-gnome-keyring
208%endif
209
210%if %{support_imap4_provider}
211%define imap4_flags --enable-imap4=yes
212%else
213%define imap4_flags --enable-imap4=no
214%endif
215
216export CPPFLAGS="-I%{_includedir}/et"
217export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
218
219# Regenerate configure to pick up configure.in and acinclude.m4 changes.
220autoreconf -if
221
222# See Ross Burton's blog entry for why we want --with-libdb.
223# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
224
225%configure \
226        --with-libdb=/usr \
227        --disable-uoa \
228        --enable-file-locking=fcntl \
229        --enable-dot-locking=no \
230        --enable-gtk-doc \
231        --enable-introspection=yes \
232        --enable-vala-bindings \
233        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
234        %keyring_flags
235export tagname=CC
236#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
237make LIBTOOL=/usr/bin/libtool
238
239%install
240rm -rf $RPM_BUILD_ROOT
241export tagname=CC
242make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
243
244# remove libtool archives for importers and the like
245find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
247
248# give the libraries some executable bits
249find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
250
251%find_lang %{name}-%{eds_base_version}
252
253%clean
254rm -rf $RPM_BUILD_ROOT
255
256%post -p /sbin/ldconfig
257
258%postun
259/sbin/ldconfig
260if [ $1 -eq 0 ]; then
261  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
262fi
263
264%posttrans
265glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
266
267
268%files -f %{name}-%{eds_base_version}.lang
269%defattr(-,root,root,-)
270%doc README COPYING ChangeLog NEWS AUTHORS
271%{_libdir}/*.so.*
272%{_libdir}/girepository-1.0/*.typelib
273%{_libexecdir}/evolution-addressbook-factory
274%{_libexecdir}/evolution-calendar-factory
275%{_libexecdir}/evolution-source-registry
276%{_libexecdir}/evolution-user-prompter
277%{_libexecdir}/camel-index-control-%{eds_api_version}
278%{_libexecdir}/camel-lock-helper-%{eds_api_version}
279%{_datadir}/GConf/gsettings/evolution-data-server.convert
280%{_datadir}/GConf/gsettings/libedataserver.convert
281%{_datadir}/dbus-1/services/*
282%{_datadir}/%{name}/evolutionperson.schema
283%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
286%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
288%{_datadir}/pixmaps/evolution-data-server
289
290%dir %{_libdir}/evolution-data-server
291%dir %{camel_provider_dir}
292%dir %{ebook_backends_dir}
293%dir %{ecal_backends_dir}
294%dir %{registry_modules_dir}
295
296%{camel_provider_dir}/libcamelimapx.so
297%{camel_provider_dir}/libcamelimapx.urls
298
299%{camel_provider_dir}/libcamellocal.so
300%{camel_provider_dir}/libcamellocal.urls
301
302%{camel_provider_dir}/libcamelnntp.so
303%{camel_provider_dir}/libcamelnntp.urls
304
305%{camel_provider_dir}/libcamelpop3.so
306%{camel_provider_dir}/libcamelpop3.urls
307
308%{camel_provider_dir}/libcamelsendmail.so
309%{camel_provider_dir}/libcamelsendmail.urls
310
311%{camel_provider_dir}/libcamelsmtp.so
312%{camel_provider_dir}/libcamelsmtp.urls
313
314# e-d-s extensions:
315%{ebook_backends_dir}/libebookbackendfile.so
316%{ebook_backends_dir}/libebookbackendgoogle.so
317%{ebook_backends_dir}/libebookbackendldap.so
318%{ebook_backends_dir}/libebookbackendwebdav.so
319
320%{ecal_backends_dir}/libecalbackendcaldav.so
321%{ecal_backends_dir}/libecalbackendcontacts.so
322%{ecal_backends_dir}/libecalbackendfile.so
323%{ecal_backends_dir}/libecalbackendhttp.so
324%{ecal_backends_dir}/libecalbackendweather.so
325
326%{registry_modules_dir}/module-cache-reaper.so
327%{registry_modules_dir}/module-google-backend.so
328%{registry_modules_dir}/module-gnome-online-accounts.so
329%{registry_modules_dir}/module-outlook-backend.so
330%{registry_modules_dir}/module-owncloud-backend.so
331%{registry_modules_dir}/module-trust-prompt.so
332%{registry_modules_dir}/module-yahoo-backend.so
333
334%files devel
335%defattr(-,root,root,-)
336%{_includedir}/%{name}
337%{_libdir}/*.so
338%{_libdir}/pkgconfig/*.pc
339%{_datadir}/gir-1.0/*.gir
340
341%files doc
342%defattr(-,root,root,-)
343%{_datadir}/gtk-doc/html/camel
344%{_datadir}/gtk-doc/html/libebackend
345%{_datadir}/gtk-doc/html/libebook
346%{_datadir}/gtk-doc/html/libebook-contacts
347%{_datadir}/gtk-doc/html/libecal
348%{_datadir}/gtk-doc/html/libedata-book
349%{_datadir}/gtk-doc/html/libedata-cal
350%{_datadir}/gtk-doc/html/libedataserver
351
352%files vala
353%defattr(-,root,root,-)
354%{_datadir}/vala/vapi/libebook-1.2.deps
355%{_datadir}/vala/vapi/libebook-1.2.vapi
356%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
357%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
358%{_datadir}/vala/vapi/libedataserver-1.2.deps
359%{_datadir}/vala/vapi/libedataserver-1.2.vapi
360
361
362%changelog
363* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
364- new upstream release
365
366* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
367- new upstream release
368
369* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
370- new upstream release
371
372* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
373- new upstream release
374
375* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
376- new upstream release
377- add configure option (--disable-uoa)
378- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
379- create %%{name}-vala subpackage
380
381* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
382- new upstream release
383
384* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
385- new upstream release
386
387* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
388- new upstream release
389
390* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
391- new upstream release
392
393* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
394- new upstream release
395
396* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
397- new upstream release
398
399* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
400- new upstream release
401
402* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
403- new upstream release
404
405* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
406- new upstream release
407- add BuildRequires: dbus-glib-devel
408
409* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
410- new upstream release
411
412* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
413- new upstream release
414
415* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
416- new upstream release
417
418* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
419- new upstream release
420
421* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
422- new upstream release
423- remove Patch101
424
425* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
426- new upstream release
427
428* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
429- new upstream release
430- change BuildRequires: gtk3-devel instead of gtk2-devel
431- BuildRequires: gnome-online-accounts-devel
432- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
433- fix %%files
434
435* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
436- new upstream release
437
438* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
439- rebuild with openssl-1.0.0c
440
441* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
442- new upstream release
443- remove Requires: gnome-vfs2, libglade2, libgnomeui
444- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
445- add BuildRequires: libgdata
446- add Requires: nspr-devel, nss-devel (devel package)
447- drop Patch11
448
449* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
450- rebuild with rpm-4.8.1 for pkg-config file
451
452* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
453- new upstream release
454
455* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
456- new upstream release
457
458* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
459- new upstream release
460- remove BuildRequires: libbonobo-devel
461- remove Requires: libbonobo
462- drop Patch10
463- add configure option (--with-krb5-libs, --with-krb5-includes)
464
465* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
466- rebuilt with db4-4.8
467
468* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
469- new upstream release
470
471* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
472- new upstream release
473
474* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
475- new upstream release
476
477* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
478- new upstream release
479
480* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
481- added Requires: libical-devel >= 0.43 to devel package
482
483* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
484- new upstream release
485- add BR: libgweather-devel >= 2.26.0
486- add BR: libical-devel >= 0.43
487
488* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
489- new upstream release
490- added BuildRequires: sqlite3-devel
491
492* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
493- enabled krb5 support
494
495* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
496- new upstream release
497
498* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
499- new upstream release
500
501* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
502- new upstream release
503
504* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
505- new upstream release
506
507* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
508- rebuilt with db4-4.6.21
509
510* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
511- new upstream release
512
513* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
514- new upstream release
515
516* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
517- new upstream release
518
519* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
520- new upstream release based on Fedora package 2.20.0-3.fc9
521  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
522  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
523  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
524  - Add patch for RH bug #296671 (GC servers may not support NTLM).
525  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
526  - Try removing the ancient "ldap-x86_64-hack" patch.
527  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
528  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
529- split doc subpackage
530
531* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
532- fixed dependancy
533
534* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
535- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
536  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
537  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
538  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
539  - Make the new ESourceComboBox widget work properly (RH bug #234760).
540  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
541  - Link to static evolution-openldap library (RH bug #210126).
542  - Require openssl-devel when statically linking against openldap.
543  - Add -Wdeclaration-after-statement to strict build settings.
544  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
545  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
546  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
547  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
548  - Update to 1.10.0
549  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
550  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
551  - Patch by Kenny Root.
552- rebuilt with nss-devel and nspr-devel
553
554* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
555- rebuilt with new toolchain and db4-4.3.x
556
557* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
558- new upstream release
559
560* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
561- new upstream release
562- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
563
564* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
565- new upstream release
566- rebuilt with openssl instead of mozilla-nss
567
568* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
569- rebuilt with openldap-2.3.24-0vl4
570
571* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
572- new upstream release
573- build with libsoap-2.2.7
574
575* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
576- new upstream release
577
578* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
579- new upstream release
580- added/removed Patches based on Fedora packages
581  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
582  - Updated patch 102 to fix further implicit function declarations
583  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
584  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
585    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
586  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
587  - Removed upstreamed patch:
588    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
589  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
590  - added patch to calendar/libecal/e-cal.c to fix missing declaration
591    of open_calendar
592- rebuilt with mozilla-1.7.12
593
594* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
595- rebuilt with mozilla-1.7.7
596
597* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
598- initial build for Vine Linux based on FC package
599- disable krb5 support
600
601* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
602- 1.2.1
603
604* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
605- Removed explicit run-time spec-file requirement on mozilla.
606  The Mozilla NSS API/ABI stabilised by version 1.7.3
607  The libraries are always located in the libdir
608  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
609  and so they move each time the mozilla version changes.
610  So we no longer have an explicit mozilla run-time requirement in the specfile;
611  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
612  We have an explicit, exact build-time version, so that we can find the headers (without
613  invoking an RPM query from the spec file; to do so is considered bad practice)
614- Introduced mozilla_build_version, to replace mozilla_version
615- Set mozilla_build_version to 1.7.6 to reflect current state of tree
616
617* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
618- Added a patch to deal with glibc defining a macro called "read"
619
620* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
621- 1.2.0
622- Removed patch for GCC 4 as this is now in upstream tarball
623
624* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
625- rebuild to fix library linking silliness
626
627* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
628- disabling gtk-doc on ia64 and s390x
629
630* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
631- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
632
633* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
634- extended patch to deal with camel-groupwise-store-summary.c
635
636* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
637- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
638
639* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
640- 1.1.6
641
642* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
643- rebuild
644
645* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
646- forgot to fix sources
647
648* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
649- 1.1.5
650
651* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
652- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
653
654* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
655- disable gtk-doc generation on ia64 for now
656
657* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
658- Exclude ppc64 due to missing mozilla dependency
659
660* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
661- Update from 1.0.3 to 1.1.4.1
662- Updated eds_major from 1.0 to 1.2; fixed translation search path.
663- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
664- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
665- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
666- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
667- Camel code from evolution is now in evolution-data-server:
668  - Added camel-index-control and camel-lock-helper to packaged files
669  - Added mozilla dependency code from the evolution package
670  - Ditto for LDAP
671  - Ditto for krb5
672  - Ditto for NNTP support handling
673  - Ditto for --enable-file-locking and --enable-dot-locking
674- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
675- Updated libsoup requirement from 2.2.1 to 2.2.2
676- Enabled gtk-doc
677
678* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
679- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
680
681* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
682- update from upstream 1.0.2 to 1.0.3:
683  * Address Book
684    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
685    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
686
687  * Calendar
688    #XB59904 - Speed up calendar queries (Rodrigo)
689    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
690    - fix libical build for automake 1.9 (Rodney)
691    - fix putenv usage for portability (Julio M. Merino Vidal)
692
693  * Updated Translations:
694    - sv (Christian Rose)
695
696- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
697
698* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
699- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
700http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
701(The groupwise part of that patch did not cleanly apply, so I removed it).
702
703* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
704- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
705optimisation patch posted to upstream development mailing list here:
706http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
707
708* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
709- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
710
711* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
712- added workaround for a backend leak that causes the "contacts" calendar
713backend to hold open an EBook for the local contacts (filed upstream at:
714http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
715never lose its last addressbook, and hence never quit.  We workaround this by
716detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
717
718* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
719- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
720
721* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
722- update from 1.0.1 to 1.0.2
723- increased libsoup requirement to 2.2.1 to match configuration script
724
725* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
726- update from 1.0.0 to 1.0.1
727- removed patch that fixed warnings in calendar code (now in upstream tarball)
728
729* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
730- fixed various warnings in the calendar code
731  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
732
733* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
734- update from 0.0.99 to 1.0.0
735- changed path in FTP source location from 0.0 to 1.0
736
737* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
738- update from 0.0.98 to 0.0.99
739- increased libsoup requirement to 2.2.0 to match configuration script
740
741* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
742- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
743
744* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
745- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
746
747* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
748- upgraded to 0.0.97; rewrote the package's description
749
750* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
751- rebuilt
752
753* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
754- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
755
756* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
757- 0.0.96; libsoup required is now 2.1.12
758
759* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
760- rebuilt
761
762* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
763- rebuilt
764
765* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
766- 0.0.95
767
768* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
769- 0.0.94.1
770
771* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
772- rebuilt
773
774* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
775- 0.0.94
776
777* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
778- added ORBit2 requirement
779
780* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
781- rebuild again
782
783* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
784- rebuilt
785
786* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
787- 0.0.93; libsoup required is now 2.1.10
788
789* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
790- Update to 0.0.92; added a define and a requirement on the libsoup version
791
792* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
793- 0.0.90
794
795* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
796- rebuilt
797
798* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
799- 0.0.6
800
801* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
802- better fix by using system libtool
803
804* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
805- add some libdb linkage to make the build on x86_64 happy
806
807* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
808- update to 0.0.5
809
810* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
811- Initial build.
Note: See TracBrowser for help on using the repository browser.