source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 6739

Revision 6739, 25.2 KB checked in by Takemikaduchi, 12 years ago (diff)

vpnc: rebuild
libgnomeprint: fix R:libxml2
others: new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.32.0
8%define gtk3_version 3.4.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.4
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.4.4
33Release: 1%{?_dist_release}
34License: LGPL
35Group: System Environment/Libraries
36URL: http://www.gnome.org/projects/evolution/
37Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.4/%{name}-%{version}.tar.xz
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40### Patches ###
41
42# RH bug #243296
43Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
44
45### Dependencies ###
46
47Requires: GConf2
48Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53BuildRequires: GConf2-devel
54BuildRequires: ORBit2-devel >= %{orbit2_version}
55BuildRequires: bison
56BuildRequires: db4-devel
57BuildRequires: flex
58BuildRequires: gettext
59BuildRequires: glib2-devel
60BuildRequires: gtk3-devel
61BuildRequires: dbus-glib-devel
62BuildRequires: gnutls-devel
63BuildRequires: intltool >= %{intltool_version}
64BuildRequires: libsoup-devel >= %{soup_version}
65BuildRequires: libtool
66BuildRequires: libgnome-keyring-devel
67BuildRequires: gtk-doc >= 1.14
68BuildRequires: sqlite3-devel
69BuildRequires: libgweather-devel >= %{libgweather_version}
70BuildRequires: libical-devel >= %{libical_version}
71BuildRequires: gperf
72BuildRequires: krb5-devel
73BuildRequires: libgdata-devel >= %{libgdata_version}
74BuildRequires: gnome-online-accounts-devel
75BuildRequires: liboauth-devel
76
77%if %{use_nss}
78BuildRequires: nspr-devel
79BuildRequires: nss-devel
80%else
81BuildRequires: openssl-devel
82%endif
83
84%if %{ldap_support}
85%if %{static_ldap}
86BuildRequires: openldap-evolution-devel
87BuildRequires: openssl-devel
88%else
89BuildRequires: openldap-devel >= 2.0.11
90%endif
91%endif
92
93%if %{krb5_support}
94BuildRequires: krb5-devel
95# tweak for krb5 1.2 vs 1.3
96%define krb5dir /usr/kerberos
97#define krb5dir `pwd`/krb5-fakeprefix
98%endif
99
100Vendor: Project Vine
101Distribution: Vine Linux
102
103%description
104The evolution-data-server package provides a unified backend for
105programs that work with contacts, tasks, and calendar information.
106
107It was originally developed for Evolution (hence the name), but
108is now used by other packages.
109
110%package devel
111Summary: Development files for building against evolution-data-server
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114Requires: libgnome-devel
115Requires: libgweather-devel
116Requires: libsoup-devel
117Requires: libical-devel >= %{libical_version}
118Requires: sqlite3-devel
119%if %{use_nss}
120Requires: nspr-devel
121Requires: nss-devel
122%endif
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128%package doc
129Summary: Documentation files for %{name}
130Group: Applications/Documentation
131
132%description doc
133This package contains developer documentation for %{name}.
134
135%prep
136%setup -q
137
138%patch12 -p1 -b .fix-64bit-acinclude
139
140mkdir -p krb5-fakeprefix/include
141mkdir -p krb5-fakeprefix/lib
142mkdir -p krb5-fakeprefix/%{_lib}
143
144%build
145%if %{ldap_support}
146
147%if %{static_ldap}
148%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
149# Set LIBS so that configure will be able to link with static LDAP libraries,
150# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
151if pkg-config libssl ; then
152        export LIBS="-lsasl2 `pkg-config --libs libssl`"
153else
154        export LIBS="-lsasl2 -lssl -lcrypto"
155fi
156%else
157%define ldap_flags --with-openldap=yes
158%endif
159
160%else
161%define ldap_flags --without-openldap
162%endif
163
164%if %{krb5_support}
165%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
166%else
167%define krb5_flags --without-krb5
168%endif
169
170%if %{nntp_support}
171%define nntp_flags --enable-nntp=yes
172%else
173%define nntp_flags --enable-nntp=no
174%endif
175
176%if %{use_nss}
177%define ssl_flags --enable-nss=yes --enable-smime=yes
178%else
179%define ssl_flags --enable-openssl=yes
180%endif
181
182%if %{use_nss}
183if ! pkg-config --exists nss; then
184  echo "Unable to find suitable version of nss to use!"
185  exit 1
186fi
187%endif
188
189%if %{use_gnome_keyring}
190%define keyring_flags --enable-gnome-keyring
191%else
192%define keyring flags --disable-gnome-keyring
193%endif
194
195%if %{support_imap4_provider}
196%define imap4_flags --enable-imap4=yes
197%else
198%define imap4_flags --enable-imap4=no
199%endif
200
201export CPPFLAGS="-I%{_includedir}/et"
202export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
203
204# Regenerate configure to pick up configure.in and acinclude.m4 changes.
205aclocal -I m4
206autoheader
207automake
208libtoolize
209intltoolize --force
210autoconf
211
212# See Ross Burton's blog entry for why we want --with-libdb.
213# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
214
215%configure \
216        --with-libdb=/usr \
217        --enable-file-locking=fcntl \
218        --enable-dot-locking=no \
219        --enable-gtk-doc \
220        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
221        %keyring_flags
222export tagname=CC
223#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
224make LIBTOOL=/usr/bin/libtool
225
226%install
227rm -rf $RPM_BUILD_ROOT
228export tagname=CC
229make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
230
231# remove libtool archives for importers and the like
232find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
233rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
234rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/camel-providers/*.a
235rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/addressbook-backends/*.a
236rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/calendar-backends/*.a
237
238# give the libraries some executable bits
239find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
240
241%find_lang %{name}-%{eds_base_version}
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post -p /sbin/ldconfig
247
248%postun
249/sbin/ldconfig
250if [ $1 -eq 0 ]; then
251  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
252fi
253
254%posttrans
255glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256
257
258%files -f %{name}-%{eds_base_version}.lang
259%defattr(-,root,root,-)
260%doc README COPYING ChangeLog NEWS AUTHORS
261%{_libdir}/*.so.*
262%{_libdir}/girepository-1.0/*.typelib
263%{_libexecdir}/evolution-addressbook-factory
264%{_libexecdir}/evolution-calendar-factory
265%{_libexecdir}/camel-index-control-%{eds_api_version}
266%{_libexecdir}/camel-lock-helper-%{eds_api_version}
267%{_datadir}/GConf/gsettings/libedataserver.convert
268%{_datadir}/evolution-data-server-%{eds_base_version}
269%{_datadir}/dbus-1/services/*
270%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
271%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
272%{_datadir}/pixmaps/evolution-data-server
273
274%dir %{_libdir}/evolution-data-server
275%dir %{camel_provider_dir}
276%dir %{ebook_backends_dir}
277%dir %{ecal_backends_dir}
278
279# Camel providers:
280%{camel_provider_dir}/libcamelimap.so
281%{camel_provider_dir}/libcamelimap.urls
282
283%{camel_provider_dir}/libcamelimapx.so
284%{camel_provider_dir}/libcamelimapx.urls
285
286%{camel_provider_dir}/libcamellocal.so
287%{camel_provider_dir}/libcamellocal.urls
288
289%{camel_provider_dir}/libcamelnntp.so
290%{camel_provider_dir}/libcamelnntp.urls
291
292%{camel_provider_dir}/libcamelpop3.so
293%{camel_provider_dir}/libcamelpop3.urls
294
295%{camel_provider_dir}/libcamelsendmail.so
296%{camel_provider_dir}/libcamelsendmail.urls
297
298%{camel_provider_dir}/libcamelsmtp.so
299%{camel_provider_dir}/libcamelsmtp.urls
300
301# e-d-s extensions:
302%{ebook_backends_dir}/libebookbackendfile.so
303%{ebook_backends_dir}/libebookbackendgoogle.so
304%{ebook_backends_dir}/libebookbackendldap.so
305%{ebook_backends_dir}/libebookbackendvcf.so
306%{ebook_backends_dir}/libebookbackendwebdav.so
307
308%{ecal_backends_dir}/libecalbackendcaldav.so
309%{ecal_backends_dir}/libecalbackendcontacts.so
310%{ecal_backends_dir}/libecalbackendfile.so
311%{ecal_backends_dir}/libecalbackendhttp.so
312%{ecal_backends_dir}/libecalbackendweather.so
313
314%files devel
315%defattr(-,root,root,-)
316%{_includedir}/evolution-data-server-%{eds_base_version}
317%{_libdir}/*.so
318%{_libdir}/pkgconfig/*.pc
319%{_datadir}/gir-1.0/*.gir
320
321%files doc
322%defattr(-,root,root,-)
323%{_datadir}/gtk-doc/html/camel
324%{_datadir}/gtk-doc/html/libebackend
325%{_datadir}/gtk-doc/html/libebook
326%{_datadir}/gtk-doc/html/libecal
327%{_datadir}/gtk-doc/html/libedata-book
328%{_datadir}/gtk-doc/html/libedata-cal
329%{_datadir}/gtk-doc/html/libedataserver
330%{_datadir}/gtk-doc/html/libedataserverui
331
332%changelog
333* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
334- new upstream release
335
336* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
337- new upstream release
338
339* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
340- new upstream release
341
342* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
343- new upstream release
344- add BuildRequires: dbus-glib-devel
345
346* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
347- new upstream release
348
349* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
350- new upstream release
351
352* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
353- new upstream release
354
355* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
356- new upstream release
357
358* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
359- new upstream release
360- remove Patch101
361
362* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
363- new upstream release
364
365* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
366- new upstream release
367- change BuildRequires: gtk3-devel instead of gtk2-devel
368- BuildRequires: gnome-online-accounts-devel
369- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
370- fix %%files
371
372* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
373- new upstream release
374
375* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
376- rebuild with openssl-1.0.0c
377
378* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
379- new upstream release
380- remove Requires: gnome-vfs2, libglade2, libgnomeui
381- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
382- add BuildRequires: libgdata
383- add Requires: nspr-devel, nss-devel (devel package)
384- drop Patch11
385
386* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
387- rebuild with rpm-4.8.1 for pkg-config file
388
389* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
390- new upstream release
391
392* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
393- new upstream release
394
395* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
396- new upstream release
397- remove BuildRequires: libbonobo-devel
398- remove Requires: libbonobo
399- drop Patch10
400- add configure option (--with-krb5-libs, --with-krb5-includes)
401
402* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
403- rebuilt with db4-4.8
404
405* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
406- new upstream release
407
408* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
409- new upstream release
410
411* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
412- new upstream release
413
414* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
415- new upstream release
416
417* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
418- added Requires: libical-devel >= 0.43 to devel package
419
420* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
421- new upstream release
422- add BR: libgweather-devel >= 2.26.0
423- add BR: libical-devel >= 0.43
424
425* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
426- new upstream release
427- added BuildRequires: sqlite3-devel
428
429* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
430- enabled krb5 support
431
432* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
433- new upstream release
434
435* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
436- new upstream release
437
438* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
439- new upstream release
440
441* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
442- new upstream release
443
444* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
445- rebuilt with db4-4.6.21
446
447* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
448- new upstream release
449
450* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
451- new upstream release
452
453* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
454- new upstream release
455
456* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
457- new upstream release based on Fedora package 2.20.0-3.fc9
458  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
459  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
460  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
461  - Add patch for RH bug #296671 (GC servers may not support NTLM).
462  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
463  - Try removing the ancient "ldap-x86_64-hack" patch.
464  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
465  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
466- split doc subpackage
467
468* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
469- fixed dependancy
470
471* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
472- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
473  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
474  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
475  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
476  - Make the new ESourceComboBox widget work properly (RH bug #234760).
477  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
478  - Link to static evolution-openldap library (RH bug #210126).
479  - Require openssl-devel when statically linking against openldap.
480  - Add -Wdeclaration-after-statement to strict build settings.
481  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
482  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
483  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
484  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
485  - Update to 1.10.0
486  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
487  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
488  - Patch by Kenny Root.
489- rebuilt with nss-devel and nspr-devel
490
491* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
492- rebuilt with new toolchain and db4-4.3.x
493
494* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
495- new upstream release
496
497* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
498- new upstream release
499- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
500
501* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
502- new upstream release
503- rebuilt with openssl instead of mozilla-nss
504
505* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
506- rebuilt with openldap-2.3.24-0vl4
507
508* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
509- new upstream release
510- build with libsoap-2.2.7
511
512* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
513- new upstream release
514
515* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
516- new upstream release
517- added/removed Patches based on Fedora packages
518  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
519  - Updated patch 102 to fix further implicit function declarations
520  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
521  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
522    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
523  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
524  - Removed upstreamed patch:
525    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
526  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
527  - added patch to calendar/libecal/e-cal.c to fix missing declaration
528    of open_calendar
529- rebuilt with mozilla-1.7.12
530
531* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
532- rebuilt with mozilla-1.7.7
533
534* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
535- initial build for Vine Linux based on FC package
536- disable krb5 support
537
538* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
539- 1.2.1
540
541* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
542- Removed explicit run-time spec-file requirement on mozilla.
543  The Mozilla NSS API/ABI stabilised by version 1.7.3
544  The libraries are always located in the libdir
545  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
546  and so they move each time the mozilla version changes.
547  So we no longer have an explicit mozilla run-time requirement in the specfile;
548  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
549  We have an explicit, exact build-time version, so that we can find the headers (without
550  invoking an RPM query from the spec file; to do so is considered bad practice)
551- Introduced mozilla_build_version, to replace mozilla_version
552- Set mozilla_build_version to 1.7.6 to reflect current state of tree
553
554* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
555- Added a patch to deal with glibc defining a macro called "read"
556
557* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
558- 1.2.0
559- Removed patch for GCC 4 as this is now in upstream tarball
560
561* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
562- rebuild to fix library linking silliness
563
564* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
565- disabling gtk-doc on ia64 and s390x
566
567* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
568- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
569
570* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
571- extended patch to deal with camel-groupwise-store-summary.c
572
573* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
574- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
575
576* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
577- 1.1.6
578
579* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
580- rebuild
581
582* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
583- forgot to fix sources
584
585* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
586- 1.1.5
587
588* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
589- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
590
591* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
592- disable gtk-doc generation on ia64 for now
593
594* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
595- Exclude ppc64 due to missing mozilla dependency
596
597* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
598- Update from 1.0.3 to 1.1.4.1
599- Updated eds_major from 1.0 to 1.2; fixed translation search path.
600- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
601- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
602- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
603- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
604- Camel code from evolution is now in evolution-data-server:
605  - Added camel-index-control and camel-lock-helper to packaged files
606  - Added mozilla dependency code from the evolution package
607  - Ditto for LDAP
608  - Ditto for krb5
609  - Ditto for NNTP support handling
610  - Ditto for --enable-file-locking and --enable-dot-locking
611- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
612- Updated libsoup requirement from 2.2.1 to 2.2.2
613- Enabled gtk-doc
614
615* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
616- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
617
618* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
619- update from upstream 1.0.2 to 1.0.3:
620  * Address Book
621    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
622    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
623
624  * Calendar
625    #XB59904 - Speed up calendar queries (Rodrigo)
626    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
627    - fix libical build for automake 1.9 (Rodney)
628    - fix putenv usage for portability (Julio M. Merino Vidal)
629
630  * Updated Translations:
631    - sv (Christian Rose)
632
633- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
634
635* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
636- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
637http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
638(The groupwise part of that patch did not cleanly apply, so I removed it).
639
640* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
641- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
642optimisation patch posted to upstream development mailing list here:
643http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
644
645* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
646- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
647
648* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
649- added workaround for a backend leak that causes the "contacts" calendar
650backend to hold open an EBook for the local contacts (filed upstream at:
651http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
652never lose its last addressbook, and hence never quit.  We workaround this by
653detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
654
655* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
656- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
657
658* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
659- update from 1.0.1 to 1.0.2
660- increased libsoup requirement to 2.2.1 to match configuration script
661
662* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
663- update from 1.0.0 to 1.0.1
664- removed patch that fixed warnings in calendar code (now in upstream tarball)
665
666* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
667- fixed various warnings in the calendar code
668  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
669
670* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
671- update from 0.0.99 to 1.0.0
672- changed path in FTP source location from 0.0 to 1.0
673
674* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
675- update from 0.0.98 to 0.0.99
676- increased libsoup requirement to 2.2.0 to match configuration script
677
678* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
679- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
680
681* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
682- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
683
684* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
685- upgraded to 0.0.97; rewrote the package's description
686
687* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
688- rebuilt
689
690* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
691- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
692
693* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
694- 0.0.96; libsoup required is now 2.1.12
695
696* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
697- rebuilt
698
699* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
700- rebuilt
701
702* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
703- 0.0.95
704
705* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
706- 0.0.94.1
707
708* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
709- rebuilt
710
711* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
712- 0.0.94
713
714* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
715- added ORBit2 requirement
716
717* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
718- rebuild again
719
720* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
721- rebuilt
722
723* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
724- 0.0.93; libsoup required is now 2.1.10
725
726* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
727- Update to 0.0.92; added a define and a requirement on the libsoup version
728
729* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
730- 0.0.90
731
732* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
733- rebuilt
734
735* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
736- 0.0.6
737
738* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
739- better fix by using system libtool
740
741* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
742- add some libdb linkage to make the build on x86_64 happy
743
744* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
745- update to 0.0.5
746
747* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
748- Initial build.
Note: See TracBrowser for help on using the repository browser.