source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 5402

Revision 5402, 24.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.30.0
8%define gtk3_version 3.2.0
9%define gtk_doc_version 1.18
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
14%define libical_version 0.44
15%define libgdata_version 0.10.1
16
17%define eds_base_version 3.2
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
26
27### Abstract ###
28
29Summary: Backend data server for evolution
30Summary(ja): Evolution バックエンドデータサーバ
31Name: evolution-data-server
32Version: 3.2.3
33Release: 1%{?_dist_release}
34License: LGPL
35Group: System Environment/Libraries
36URL: http://www.gnome.org/projects/evolution/
37Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.2/%{name}-%{version}.tar.xz
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39
40### Patches ###
41
42# RH bug #243296
43Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
44
45### Dependencies ###
46
47Requires: GConf2
48Requires: ORBit2 >= %{orbit2_version}
49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
53BuildRequires: GConf2-devel
54BuildRequires: ORBit2-devel >= %{orbit2_version}
55BuildRequires: bison
56BuildRequires: db4-devel
57BuildRequires: flex
58BuildRequires: gettext
59BuildRequires: glib2-devel
60BuildRequires: gtk3-devel
61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
70BuildRequires: gperf
71BuildRequires: krb5-devel
72BuildRequires: libgdata-devel >= %{libgdata_version}
73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
75
76%if %{use_nss}
77BuildRequires: nspr-devel
78BuildRequires: nss-devel
79%else
80BuildRequires: openssl-devel
81%endif
82
83%if %{ldap_support}
84%if %{static_ldap}
85BuildRequires: openldap-evolution-devel
86BuildRequires: openssl-devel
87%else
88BuildRequires: openldap-devel >= 2.0.11
89%endif
90%endif
91
92%if %{krb5_support}
93BuildRequires: krb5-devel
94# tweak for krb5 1.2 vs 1.3
95%define krb5dir /usr/kerberos
96#define krb5dir `pwd`/krb5-fakeprefix
97%endif
98
99Vendor: Project Vine
100Distribution: Vine Linux
101
102%description
103The evolution-data-server package provides a unified backend for
104programs that work with contacts, tasks, and calendar information.
105
106It was originally developed for Evolution (hence the name), but
107is now used by other packages.
108
109%package devel
110Summary: Development files for building against evolution-data-server
111Group: Development/Libraries
112Requires: %{name} = %{version}-%{release}
113Requires: libgnome-devel
114Requires: libgweather-devel
115Requires: libsoup-devel
116Requires: libical-devel >= %{libical_version}
117Requires: sqlite3-devel
118%if %{use_nss}
119Requires: nspr-devel
120Requires: nss-devel
121%endif
122
123%description devel
124Development files needed for building things which link against
125evolution-data-server.
126
127%package doc
128Summary: Documentation files for %{name}
129Group: Applications/Documentation
130
131%description doc
132This package contains developer documentation for %{name}.
133
134%prep
135%setup -q
136
137%patch12 -p1 -b .fix-64bit-acinclude
138
139mkdir -p krb5-fakeprefix/include
140mkdir -p krb5-fakeprefix/lib
141mkdir -p krb5-fakeprefix/%{_lib}
142
143%build
144%if %{ldap_support}
145
146%if %{static_ldap}
147%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
148# Set LIBS so that configure will be able to link with static LDAP libraries,
149# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
150if pkg-config libssl ; then
151        export LIBS="-lsasl2 `pkg-config --libs libssl`"
152else
153        export LIBS="-lsasl2 -lssl -lcrypto"
154fi
155%else
156%define ldap_flags --with-openldap=yes
157%endif
158
159%else
160%define ldap_flags --without-openldap
161%endif
162
163%if %{krb5_support}
164%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
165%else
166%define krb5_flags --without-krb5
167%endif
168
169%if %{nntp_support}
170%define nntp_flags --enable-nntp=yes
171%else
172%define nntp_flags --enable-nntp=no
173%endif
174
175%if %{use_nss}
176%define ssl_flags --enable-nss=yes --enable-smime=yes
177%else
178%define ssl_flags --enable-openssl=yes
179%endif
180
181%if %{use_nss}
182if ! pkg-config --exists nss; then
183  echo "Unable to find suitable version of nss to use!"
184  exit 1
185fi
186%endif
187
188%if %{use_gnome_keyring}
189%define keyring_flags --enable-gnome-keyring
190%else
191%define keyring flags --disable-gnome-keyring
192%endif
193
194%if %{support_imap4_provider}
195%define imap4_flags --enable-imap4=yes
196%else
197%define imap4_flags --enable-imap4=no
198%endif
199
200export CPPFLAGS="-I%{_includedir}/et"
201export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
202
203# Regenerate configure to pick up configure.in and acinclude.m4 changes.
204aclocal -I m4
205autoheader
206automake
207libtoolize
208intltoolize --force
209autoconf
210
211# See Ross Burton's blog entry for why we want --with-libdb.
212# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
213
214%configure \
215        --with-libdb=/usr \
216        --enable-file-locking=fcntl \
217        --enable-dot-locking=no \
218        --enable-gtk-doc \
219        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
220        %keyring_flags
221export tagname=CC
222#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
223make LIBTOOL=/usr/bin/libtool
224
225%install
226rm -rf $RPM_BUILD_ROOT
227export tagname=CC
228make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
229
230# remove libtool archives for importers and the like
231find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
232rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
233rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/camel-providers/*.a
234rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/addressbook-backends/*.a
235rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server/calendar-backends/*.a
236
237# give the libraries some executable bits
238find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
239
240%find_lang %{name}-%{eds_base_version}
241
242%clean
243rm -rf $RPM_BUILD_ROOT
244
245%post -p /sbin/ldconfig
246
247%postun -p /sbin/ldconfig
248
249%files -f %{name}-%{eds_base_version}.lang
250%defattr(-,root,root,-)
251%doc README COPYING ChangeLog NEWS AUTHORS
252%{_libdir}/*.so.*
253%{_libdir}/girepository-1.0/*.typelib
254%{_libexecdir}/e-addressbook-factory
255%{_libexecdir}/e-calendar-factory
256%{_libexecdir}/camel-index-control-%{eds_api_version}
257%{_libexecdir}/camel-lock-helper-%{eds_api_version}
258%{_datadir}/evolution-data-server-%{eds_base_version}
259%{_datadir}/pixmaps/evolution-data-server
260%{_datadir}/dbus-1/services/*
261
262%dir %{_libdir}/evolution-data-server
263%dir %{camel_provider_dir}
264%dir %{ebook_backends_dir}
265%dir %{ecal_backends_dir}
266
267# Camel providers:
268%{camel_provider_dir}/libcamelimap.so
269%{camel_provider_dir}/libcamelimap.urls
270
271%{camel_provider_dir}/libcamelimapx.so
272%{camel_provider_dir}/libcamelimapx.urls
273
274%{camel_provider_dir}/libcamellocal.so
275%{camel_provider_dir}/libcamellocal.urls
276
277%{camel_provider_dir}/libcamelnntp.so
278%{camel_provider_dir}/libcamelnntp.urls
279
280%{camel_provider_dir}/libcamelpop3.so
281%{camel_provider_dir}/libcamelpop3.urls
282
283%{camel_provider_dir}/libcamelsendmail.so
284%{camel_provider_dir}/libcamelsendmail.urls
285
286%{camel_provider_dir}/libcamelsmtp.so
287%{camel_provider_dir}/libcamelsmtp.urls
288
289# e-d-s extensions:
290%{ebook_backends_dir}/libebookbackendfile.so
291%{ebook_backends_dir}/libebookbackendgoogle.so
292%{ebook_backends_dir}/libebookbackendldap.so
293%{ebook_backends_dir}/libebookbackendvcf.so
294%{ebook_backends_dir}/libebookbackendwebdav.so
295
296%{ecal_backends_dir}/libecalbackendcaldav.so
297%{ecal_backends_dir}/libecalbackendcontacts.so
298%{ecal_backends_dir}/libecalbackendfile.so
299%{ecal_backends_dir}/libecalbackendhttp.so
300%{ecal_backends_dir}/libecalbackendweather.so
301
302%files devel
303%defattr(-,root,root,-)
304%{_includedir}/evolution-data-server-%{eds_base_version}
305%{_libdir}/*.so
306%{_libdir}/pkgconfig/*.pc
307%{_datadir}/gir-1.0/*.gir
308
309%files doc
310%defattr(-,root,root,-)
311%{_datadir}/gtk-doc/html/camel
312%{_datadir}/gtk-doc/html/libebackend
313%{_datadir}/gtk-doc/html/libebook
314%{_datadir}/gtk-doc/html/libecal
315%{_datadir}/gtk-doc/html/libedata-book
316%{_datadir}/gtk-doc/html/libedata-cal
317%{_datadir}/gtk-doc/html/libedataserver
318%{_datadir}/gtk-doc/html/libedataserverui
319
320%changelog
321* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
322- new upstream release
323
324* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
325- new upstream release
326
327* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
328- new upstream release
329
330* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
331- new upstream release
332
333* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
334- new upstream release
335- remove Patch101
336
337* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
338- new upstream release
339
340* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
341- new upstream release
342- change BuildRequires: gtk3-devel instead of gtk2-devel
343- BuildRequires: gnome-online-accounts-devel
344- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
345- fix %%files
346
347* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
348- new upstream release
349
350* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
351- rebuild with openssl-1.0.0c
352
353* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
354- new upstream release
355- remove Requires: gnome-vfs2, libglade2, libgnomeui
356- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
357- add BuildRequires: libgdata
358- add Requires: nspr-devel, nss-devel (devel package)
359- drop Patch11
360
361* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
362- rebuild with rpm-4.8.1 for pkg-config file
363
364* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
365- new upstream release
366
367* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
368- new upstream release
369
370* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
371- new upstream release
372- remove BuildRequires: libbonobo-devel
373- remove Requires: libbonobo
374- drop Patch10
375- add configure option (--with-krb5-libs, --with-krb5-includes)
376
377* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
378- rebuilt with db4-4.8
379
380* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
381- new upstream release
382
383* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
384- new upstream release
385
386* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
387- new upstream release
388
389* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
390- new upstream release
391
392* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
393- added Requires: libical-devel >= 0.43 to devel package
394
395* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
396- new upstream release
397- add BR: libgweather-devel >= 2.26.0
398- add BR: libical-devel >= 0.43
399
400* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
401- new upstream release
402- added BuildRequires: sqlite3-devel
403
404* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
405- enabled krb5 support
406
407* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
408- new upstream release
409
410* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
411- new upstream release
412
413* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
414- new upstream release
415
416* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
417- new upstream release
418
419* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
420- rebuilt with db4-4.6.21
421
422* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
423- new upstream release
424
425* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
426- new upstream release
427
428* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
429- new upstream release
430
431* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
432- new upstream release based on Fedora package 2.20.0-3.fc9
433  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
434  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
435  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
436  - Add patch for RH bug #296671 (GC servers may not support NTLM).
437  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
438  - Try removing the ancient "ldap-x86_64-hack" patch.
439  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
440  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
441- split doc subpackage
442
443* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
444- fixed dependancy
445
446* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
447- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
448  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
449  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
450  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
451  - Make the new ESourceComboBox widget work properly (RH bug #234760).
452  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
453  - Link to static evolution-openldap library (RH bug #210126).
454  - Require openssl-devel when statically linking against openldap.
455  - Add -Wdeclaration-after-statement to strict build settings.
456  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
457  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
458  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
459  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
460  - Update to 1.10.0
461  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
462  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
463  - Patch by Kenny Root.
464- rebuilt with nss-devel and nspr-devel
465
466* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
467- rebuilt with new toolchain and db4-4.3.x
468
469* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
470- new upstream release
471
472* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
473- new upstream release
474- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
475
476* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
477- new upstream release
478- rebuilt with openssl instead of mozilla-nss
479
480* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
481- rebuilt with openldap-2.3.24-0vl4
482
483* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
484- new upstream release
485- build with libsoap-2.2.7
486
487* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
488- new upstream release
489
490* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
491- new upstream release
492- added/removed Patches based on Fedora packages
493  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
494  - Updated patch 102 to fix further implicit function declarations
495  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
496  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
497    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
498  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
499  - Removed upstreamed patch:
500    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
501  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
502  - added patch to calendar/libecal/e-cal.c to fix missing declaration
503    of open_calendar
504- rebuilt with mozilla-1.7.12
505
506* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
507- rebuilt with mozilla-1.7.7
508
509* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
510- initial build for Vine Linux based on FC package
511- disable krb5 support
512
513* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
514- 1.2.1
515
516* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
517- Removed explicit run-time spec-file requirement on mozilla.
518  The Mozilla NSS API/ABI stabilised by version 1.7.3
519  The libraries are always located in the libdir
520  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
521  and so they move each time the mozilla version changes.
522  So we no longer have an explicit mozilla run-time requirement in the specfile;
523  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
524  We have an explicit, exact build-time version, so that we can find the headers (without
525  invoking an RPM query from the spec file; to do so is considered bad practice)
526- Introduced mozilla_build_version, to replace mozilla_version
527- Set mozilla_build_version to 1.7.6 to reflect current state of tree
528
529* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
530- Added a patch to deal with glibc defining a macro called "read"
531
532* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
533- 1.2.0
534- Removed patch for GCC 4 as this is now in upstream tarball
535
536* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
537- rebuild to fix library linking silliness
538
539* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
540- disabling gtk-doc on ia64 and s390x
541
542* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
543- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
544
545* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
546- extended patch to deal with camel-groupwise-store-summary.c
547
548* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
549- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
550
551* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
552- 1.1.6
553
554* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
555- rebuild
556
557* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
558- forgot to fix sources
559
560* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
561- 1.1.5
562
563* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
564- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
565
566* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
567- disable gtk-doc generation on ia64 for now
568
569* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
570- Exclude ppc64 due to missing mozilla dependency
571
572* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
573- Update from 1.0.3 to 1.1.4.1
574- Updated eds_major from 1.0 to 1.2; fixed translation search path.
575- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
576- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
577- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
578- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
579- Camel code from evolution is now in evolution-data-server:
580  - Added camel-index-control and camel-lock-helper to packaged files
581  - Added mozilla dependency code from the evolution package
582  - Ditto for LDAP
583  - Ditto for krb5
584  - Ditto for NNTP support handling
585  - Ditto for --enable-file-locking and --enable-dot-locking
586- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
587- Updated libsoup requirement from 2.2.1 to 2.2.2
588- Enabled gtk-doc
589
590* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
591- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
592
593* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
594- update from upstream 1.0.2 to 1.0.3:
595  * Address Book
596    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
597    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
598
599  * Calendar
600    #XB59904 - Speed up calendar queries (Rodrigo)
601    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
602    - fix libical build for automake 1.9 (Rodney)
603    - fix putenv usage for portability (Julio M. Merino Vidal)
604
605  * Updated Translations:
606    - sv (Christian Rose)
607
608- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
609
610* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
611- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
612http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
613(The groupwise part of that patch did not cleanly apply, so I removed it).
614
615* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
616- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
617optimisation patch posted to upstream development mailing list here:
618http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
619
620* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
621- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
622
623* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
624- added workaround for a backend leak that causes the "contacts" calendar
625backend to hold open an EBook for the local contacts (filed upstream at:
626http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
627never lose its last addressbook, and hence never quit.  We workaround this by
628detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
629
630* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
631- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
632
633* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
634- update from 1.0.1 to 1.0.2
635- increased libsoup requirement to 2.2.1 to match configuration script
636
637* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
638- update from 1.0.0 to 1.0.1
639- removed patch that fixed warnings in calendar code (now in upstream tarball)
640
641* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
642- fixed various warnings in the calendar code
643  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
644
645* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
646- update from 0.0.99 to 1.0.0
647- changed path in FTP source location from 0.0 to 1.0
648
649* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
650- update from 0.0.98 to 0.0.99
651- increased libsoup requirement to 2.2.0 to match configuration script
652
653* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
654- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
655
656* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
657- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
658
659* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
660- upgraded to 0.0.97; rewrote the package's description
661
662* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
663- rebuilt
664
665* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
666- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
667
668* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
669- 0.0.96; libsoup required is now 2.1.12
670
671* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
672- rebuilt
673
674* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
675- rebuilt
676
677* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
678- 0.0.95
679
680* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
681- 0.0.94.1
682
683* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
684- rebuilt
685
686* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
687- 0.0.94
688
689* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
690- added ORBit2 requirement
691
692* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
693- rebuild again
694
695* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
696- rebuilt
697
698* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
699- 0.0.93; libsoup required is now 2.1.10
700
701* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
702- Update to 0.0.92; added a define and a requirement on the libsoup version
703
704* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
705- 0.0.90
706
707* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
708- rebuilt
709
710* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
711- 0.0.6
712
713* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
714- better fix by using system libtool
715
716* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
717- add some libdb linkage to make the build on x86_64 happy
718
719* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
720- update to 0.0.5
721
722* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
723- Initial build.
Note: See TracBrowser for help on using the repository browser.