source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 2483

Revision 2483, 24.7 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.26.1
8%define gtk2_version 2.22.1
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.32.0
13%define libgweather_version 2.30.3
14%define libical_version 0.44
15%define libgdata_version 0.6.5
16
17%define eds_base_version 2.32
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
24%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
25
26# Use stricter build settings than required by upstream.
27%define strict_build_settings 1
28
29### Abstract ###
30
31Summary: Backend data server for evolution
32Summary(ja): Evolution バックエンドデータサーバ
33Name: evolution-data-server
34Version: 2.32.1
35Release: 2%{?_dist_release}
36License: LGPL
37Group: System Environment/Libraries
38URL: http://www.gnome.org/projects/evolution/
39Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/2.32/%{name}-%{version}.tar.bz2
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42### Patches ###
43
44# RH bug #215702 / GNOME bug #487988
45Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
46
47# GNOME bug #373146
48Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
49
50# RH bug #243296
51Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
52
53### Dependencies ###
54
55Requires: GConf2
56Requires: ORBit2 >= %{orbit2_version}
57Requires: libsoup >= %{soup_version}
58
59### Build Dependencies ###
60
61BuildRequires: GConf2-devel
62BuildRequires: ORBit2-devel >= %{orbit2_version}
63BuildRequires: bison
64BuildRequires: db4-devel
65BuildRequires: flex
66BuildRequires: gettext
67BuildRequires: glib2-devel
68BuildRequires: gnutls-devel
69BuildRequires: intltool >= %{intltool_version}
70BuildRequires: libsoup-devel >= %{soup_version}
71BuildRequires: libtool
72BuildRequires: libgnome-keyring-devel
73BuildRequires: gtk-doc >= 1.14
74BuildRequires: sqlite3-devel
75BuildRequires: libgweather-devel >= %{libgweather_version}
76BuildRequires: libical-devel >= %{libical_version}
77BuildRequires: gperf
78BuildRequires: krb5-devel
79BuildRequires: libgdata-devel >= %{libgdata_version}
80
81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
104%description
105The evolution-data-server package provides a unified backend for
106programs that work with contacts, tasks, and calendar information.
107
108It was originally developed for Evolution (hence the name), but
109is now used by other packages.
110
111%package devel
112Summary: Development files for building against evolution-data-server
113Group: Development/Libraries
114Requires: %{name} = %{version}-%{release}
115Requires: libgnome-devel
116Requires: libgweather-devel
117Requires: libsoup-devel
118Requires: libical-devel >= %{libical_version}
119Requires: sqlite3-devel
120%if %{use_nss}
121Requires: nspr-devel
122Requires: nss-devel
123%endif
124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129%package doc
130Summary: Documentation files for %{name}
131Group: Applications/Documentation
132
133%description doc
134This package contains developer documentation for %{name}.
135
136%prep
137%setup -q
138
139## %patch10 -p1 -b .fix-ldap-query
140##%patch11 -p1 -b .camel-folder-summary-crash
141%patch12 -p1 -b .fix-64bit-acinclude
142
143mkdir -p krb5-fakeprefix/include
144mkdir -p krb5-fakeprefix/lib
145mkdir -p krb5-fakeprefix/%{_lib}
146
147%build
148%if %{ldap_support}
149
150%if %{static_ldap}
151%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
152# Set LIBS so that configure will be able to link with static LDAP libraries,
153# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
154if pkg-config libssl ; then
155        export LIBS="-lsasl2 `pkg-config --libs libssl`"
156else
157        export LIBS="-lsasl2 -lssl -lcrypto"
158fi
159%else
160%define ldap_flags --with-openldap=yes
161%endif
162
163%else
164%define ldap_flags --without-openldap
165%endif
166
167%if %{krb5_support}
168%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
169%else
170%define krb5_flags --without-krb5
171%endif
172
173%if %{nntp_support}
174%define nntp_flags --enable-nntp=yes
175%else
176%define nntp_flags --enable-nntp=no
177%endif
178
179%if %{use_nss}
180%define ssl_flags --enable-nss=yes --enable-smime=yes
181%else
182%define ssl_flags --enable-openssl=yes
183%endif
184
185%if %{use_nss}
186if ! pkg-config --exists nss; then
187  echo "Unable to find suitable version of nss to use!"
188  exit 1
189fi
190%endif
191
192%if %{use_gnome_keyring}
193%define keyring_flags --enable-gnome-keyring
194%else
195%define keyring flags --disable-gnome-keyring
196%endif
197
198%if %{support_imap4_provider}
199%define imap4_flags --enable-imap4=yes
200%else
201%define imap4_flags --enable-imap4=no
202%endif
203
204export CPPFLAGS="-I%{_includedir}/et"
205export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
206%if ! %{use_nss}
207if pkg-config openssl ; then
208        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
209        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
210fi
211%endif
212
213# Add stricter build settings here as the source code gets cleaned up.
214# We want to make sure things like compiler warnings and avoiding deprecated
215# functions in the GNOME/GTK+ libraries stay fixed.
216#
217# Please file a bug report at bugzilla.gnome.org if these settings break
218# compilation, and encourage the upstream developers to use them.
219
220%if %{strict_build_settings}
221CFLAGS="$CFLAGS \
222        -DG_DISABLE_DEPRECATED=1 \
223        -DPANGO_DISABLE_DEPRECATED=1 \
224        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
225        -DGDK_DISABLE_DEPRECATED=1 \
226        -Wdeclaration-after-statement \
227        -Werror-implicit-function-declaration"
228%endif
229
230# Regenerate configure to pick up configure.in and acinclude.m4 changes.
231aclocal -I m4
232autoheader
233automake
234libtoolize
235intltoolize --force
236autoconf
237
238# See Ross Burton's blog entry for why we want --with-libdb.
239# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
240
241%configure \
242        --with-libdb=/usr \
243        --enable-file-locking=fcntl \
244        --enable-dot-locking=no \
245        --enable-gtk-doc \
246        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
247        %keyring_flags
248export tagname=CC
249make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
250
251%install
252rm -rf $RPM_BUILD_ROOT
253export tagname=CC
254make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
255
256# remove libtool archives for importers and the like
257find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
258rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
259rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
260rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
261
262# give the libraries some executable bits
263find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
264
265%find_lang %{name}-%{eds_base_version}
266
267%clean
268rm -rf $RPM_BUILD_ROOT
269
270%post -p /sbin/ldconfig
271
272%postun -p /sbin/ldconfig
273
274%files -f %{name}-%{eds_base_version}.lang
275%defattr(-,root,root,-)
276%doc README COPYING ChangeLog NEWS AUTHORS
277%{_libdir}/*.so.*
278%{_libexecdir}/e-addressbook-factory
279%{_libexecdir}/e-calendar-factory
280%{_libexecdir}/camel-index-control-%{eds_api_version}
281%{_libexecdir}/camel-lock-helper-%{eds_api_version}
282%{_datadir}/evolution-data-server-%{eds_base_version}
283## %{_datadir}/idl/evolution-data-server-%{eds_api_version}
284%{_datadir}/pixmaps/evolution-data-server
285#{_libdir}/evolution-data-server-%{eds_api_version}
286%{_datadir}/dbus-1/services/*
287
288%dir %{_libdir}/evolution-data-server-%{eds_api_version}
289%dir %{camel_provider_dir}
290%dir %{eds_extensions_dir}
291
292# Camel providers:
293%{camel_provider_dir}/libcamelgroupwise.so
294%{camel_provider_dir}/libcamelgroupwise.urls
295
296%{camel_provider_dir}/libcamelimap.so
297%{camel_provider_dir}/libcamelimap.urls
298
299%if %{support_imap4_provider}
300%{camel_provider_dir}/libcamelimap4.so
301%{camel_provider_dir}/libcamelimap4.urls
302%endif
303
304%{camel_provider_dir}/libcamellocal.so
305%{camel_provider_dir}/libcamellocal.urls
306
307%{camel_provider_dir}/libcamelnntp.so
308%{camel_provider_dir}/libcamelnntp.urls
309
310%{camel_provider_dir}/libcamelpop3.so
311%{camel_provider_dir}/libcamelpop3.urls
312
313%{camel_provider_dir}/libcamelsendmail.so
314%{camel_provider_dir}/libcamelsendmail.urls
315
316%{camel_provider_dir}/libcamelsmtp.so
317%{camel_provider_dir}/libcamelsmtp.urls
318
319%{camel_provider_dir}/libcamelimapx.so
320%{camel_provider_dir}/libcamelimapx.urls
321
322# e-d-s extensions:
323%{eds_extensions_dir}/libebookbackendfile.so
324%{eds_extensions_dir}/libebookbackendgoogle.so
325%{eds_extensions_dir}/libebookbackendgroupwise.so
326%{eds_extensions_dir}/libebookbackendldap.so
327%{eds_extensions_dir}/libebookbackendvcf.so
328%{eds_extensions_dir}/libebookbackendwebdav.so
329%{eds_extensions_dir}/libecalbackendcontacts.so
330%{eds_extensions_dir}/libecalbackendfile.so
331%{eds_extensions_dir}/libecalbackendgroupwise.so
332%{eds_extensions_dir}/libecalbackendhttp.so
333%{eds_extensions_dir}/libecalbackendweather.so
334%{eds_extensions_dir}/libecalbackendcaldav.so
335## %{eds_extensions_dir}/libecalbackendgoogle.so
336
337%files devel
338%defattr(-,root,root,-)
339%{_includedir}/evolution-data-server-%{eds_base_version}
340%{_libdir}/*.so
341%{_libdir}/pkgconfig/*.pc
342
343%files doc
344%defattr(-,root,root,-)
345%{_datadir}/gtk-doc/html/camel
346%{_datadir}/gtk-doc/html/libebackend
347%{_datadir}/gtk-doc/html/libebook
348%{_datadir}/gtk-doc/html/libecal
349%{_datadir}/gtk-doc/html/libedata-book
350%{_datadir}/gtk-doc/html/libedata-cal
351%{_datadir}/gtk-doc/html/libedataserver
352%{_datadir}/gtk-doc/html/libedataserverui
353
354%changelog
355* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
356- rebuild with openssl-1.0.0c
357
358* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
359- new upstream release
360- remove Requires: gnome-vfs2, libglade2, libgnomeui
361- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
362- add BuildRequires: libgdata
363- add Requires: nspr-devel, nss-devel (devel package)
364- drop Patch11
365
366* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
367- rebuild with rpm-4.8.1 for pkg-config file
368
369* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
370- new upstream release
371
372* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
373- new upstream release
374
375* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
376- new upstream release
377- remove BuildRequires: libbonobo-devel
378- remove Requires: libbonobo
379- drop Patch10
380- add configure option (--with-krb5-libs, --with-krb5-includes)
381
382* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
383- rebuilt with db4-4.8
384
385* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
386- new upstream release
387
388* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
389- new upstream release
390
391* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
392- new upstream release
393
394* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
395- new upstream release
396
397* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
398- added Requires: libical-devel >= 0.43 to devel package
399
400* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
401- new upstream release
402- add BR: libgweather-devel >= 2.26.0
403- add BR: libical-devel >= 0.43
404
405* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
406- new upstream release
407- added BuildRequires: sqlite3-devel
408
409* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
410- enabled krb5 support
411
412* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
413- new upstream release
414
415* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
416- new upstream release
417
418* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
419- new upstream release
420
421* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
422- new upstream release
423
424* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
425- rebuilt with db4-4.6.21
426
427* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
428- new upstream release
429
430* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
431- new upstream release
432
433* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
434- new upstream release
435
436* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
437- new upstream release based on Fedora package 2.20.0-3.fc9
438  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
439  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
440  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
441  - Add patch for RH bug #296671 (GC servers may not support NTLM).
442  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
443  - Try removing the ancient "ldap-x86_64-hack" patch.
444  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
445  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
446- split doc subpackage
447
448* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
449- fixed dependancy
450
451* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
452- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
453  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
454  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
455  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
456  - Make the new ESourceComboBox widget work properly (RH bug #234760).
457  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
458  - Link to static evolution-openldap library (RH bug #210126).
459  - Require openssl-devel when statically linking against openldap.
460  - Add -Wdeclaration-after-statement to strict build settings.
461  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
462  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
463  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
464  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
465  - Update to 1.10.0
466  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
467  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
468  - Patch by Kenny Root.
469- rebuilt with nss-devel and nspr-devel
470
471* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
472- rebuilt with new toolchain and db4-4.3.x
473
474* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
475- new upstream release
476
477* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
478- new upstream release
479- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
480
481* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
482- new upstream release
483- rebuilt with openssl instead of mozilla-nss
484
485* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
486- rebuilt with openldap-2.3.24-0vl4
487
488* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
489- new upstream release
490- build with libsoap-2.2.7
491
492* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
493- new upstream release
494
495* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
496- new upstream release
497- added/removed Patches based on Fedora packages
498  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
499  - Updated patch 102 to fix further implicit function declarations
500  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
501  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
502    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
503  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
504  - Removed upstreamed patch:
505    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
506  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
507  - added patch to calendar/libecal/e-cal.c to fix missing declaration
508    of open_calendar
509- rebuilt with mozilla-1.7.12
510
511* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
512- rebuilt with mozilla-1.7.7
513
514* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
515- initial build for Vine Linux based on FC package
516- disable krb5 support
517
518* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
519- 1.2.1
520
521* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
522- Removed explicit run-time spec-file requirement on mozilla.
523  The Mozilla NSS API/ABI stabilised by version 1.7.3
524  The libraries are always located in the libdir
525  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
526  and so they move each time the mozilla version changes.
527  So we no longer have an explicit mozilla run-time requirement in the specfile;
528  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
529  We have an explicit, exact build-time version, so that we can find the headers (without
530  invoking an RPM query from the spec file; to do so is considered bad practice)
531- Introduced mozilla_build_version, to replace mozilla_version
532- Set mozilla_build_version to 1.7.6 to reflect current state of tree
533
534* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
535- Added a patch to deal with glibc defining a macro called "read"
536
537* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
538- 1.2.0
539- Removed patch for GCC 4 as this is now in upstream tarball
540
541* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
542- rebuild to fix library linking silliness
543
544* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
545- disabling gtk-doc on ia64 and s390x
546
547* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
548- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
549
550* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
551- extended patch to deal with camel-groupwise-store-summary.c
552
553* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
554- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
555
556* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
557- 1.1.6
558
559* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
560- rebuild
561
562* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
563- forgot to fix sources
564
565* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
566- 1.1.5
567
568* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
569- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
570
571* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
572- disable gtk-doc generation on ia64 for now
573
574* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
575- Exclude ppc64 due to missing mozilla dependency
576
577* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
578- Update from 1.0.3 to 1.1.4.1
579- Updated eds_major from 1.0 to 1.2; fixed translation search path.
580- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
581- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
582- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
583- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
584- Camel code from evolution is now in evolution-data-server:
585  - Added camel-index-control and camel-lock-helper to packaged files
586  - Added mozilla dependency code from the evolution package
587  - Ditto for LDAP
588  - Ditto for krb5
589  - Ditto for NNTP support handling
590  - Ditto for --enable-file-locking and --enable-dot-locking
591- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
592- Updated libsoup requirement from 2.2.1 to 2.2.2
593- Enabled gtk-doc
594
595* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
596- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
597
598* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
599- update from upstream 1.0.2 to 1.0.3:
600  * Address Book
601    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
602    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
603
604  * Calendar
605    #XB59904 - Speed up calendar queries (Rodrigo)
606    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
607    - fix libical build for automake 1.9 (Rodney)
608    - fix putenv usage for portability (Julio M. Merino Vidal)
609
610  * Updated Translations:
611    - sv (Christian Rose)
612
613- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
614
615* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
616- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
617http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
618(The groupwise part of that patch did not cleanly apply, so I removed it).
619
620* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
621- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
622optimisation patch posted to upstream development mailing list here:
623http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
624
625* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
626- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
627
628* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
629- added workaround for a backend leak that causes the "contacts" calendar
630backend to hold open an EBook for the local contacts (filed upstream at:
631http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
632never lose its last addressbook, and hence never quit.  We workaround this by
633detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
634
635* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
636- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
637
638* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
639- update from 1.0.1 to 1.0.2
640- increased libsoup requirement to 2.2.1 to match configuration script
641
642* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
643- update from 1.0.0 to 1.0.1
644- removed patch that fixed warnings in calendar code (now in upstream tarball)
645
646* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
647- fixed various warnings in the calendar code
648  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
649
650* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
651- update from 0.0.99 to 1.0.0
652- changed path in FTP source location from 0.0 to 1.0
653
654* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
655- update from 0.0.98 to 0.0.99
656- increased libsoup requirement to 2.2.0 to match configuration script
657
658* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
659- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
660
661* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
662- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
663
664* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
665- upgraded to 0.0.97; rewrote the package's description
666
667* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
668- rebuilt
669
670* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
671- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
672
673* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
674- 0.0.96; libsoup required is now 2.1.12
675
676* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
677- rebuilt
678
679* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
680- rebuilt
681
682* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
683- 0.0.95
684
685* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
686- 0.0.94.1
687
688* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
689- rebuilt
690
691* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
692- 0.0.94
693
694* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
695- added ORBit2 requirement
696
697* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
698- rebuild again
699
700* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
701- rebuilt
702
703* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
704- 0.0.93; libsoup required is now 2.1.10
705
706* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
707- Update to 0.0.92; added a define and a requirement on the libsoup version
708
709* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
710- 0.0.90
711
712* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
713- rebuilt
714
715* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
716- 0.0.6
717
718* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
719- better fix by using system libtool
720
721* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
722- add some libdb linkage to make the build on x86_64 happy
723
724* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
725- update to 0.0.5
726
727* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
728- Initial build.
Note: See TracBrowser for help on using the repository browser.