source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9672

Revision 9672, 28.8 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

RevLine 
[521]1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
[6890]7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
[4850]9%define gtk_doc_version 1.18
[521]10%define intltool_version 0.35.5
[2041]11%define orbit2_version 2.14.19
[4850]12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
[9376]14%define libical_version 0.43
[4850]15%define libgdata_version 0.10.1
[521]16
[9475]17%define eds_base_version 3.16
[521]18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
[4616]23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
[6890]26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
[521]27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
[9672]33Version: 3.16.4
[9475]34Release: 1%{?_dist_release}
[521]35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
[9475]38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.16/%{name}-%{version}.tar.xz
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
[6890]48#Requires: ORBit2 >= %{orbit2_version}
[521]49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
[6890]53#BuildRequires: ORBit2-devel >= %{orbit2_version}
[521]54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
[4616]59BuildRequires: gtk3-devel
[6011]60BuildRequires: dbus-glib-devel
[521]61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
[805]65BuildRequires: libgnome-keyring-devel
[521]66BuildRequires: sqlite3-devel
67BuildRequires: libgweather-devel >= %{libgweather_version}
68BuildRequires: libical-devel >= %{libical_version}
[805]69BuildRequires: gperf
[4616]70BuildRequires: krb5-devel
[2041]71BuildRequires: libgdata-devel >= %{libgdata_version}
[4616]72BuildRequires: gnome-online-accounts-devel
73BuildRequires: liboauth-devel
[7633]74BuildRequires: libsecret-devel
[8353]75BuildRequires: libicu-devel
[7633]76BuildRequires: gnome-common
[521]77
[7633]78BuildRequires: vala
79BuildRequires: vala-tools
80
[521]81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
[9590]104Obsoletes: %{name}-doc < 3.16.3
105
[4616]106Vendor: Project Vine
107Distribution: Vine Linux
108
[521]109%description
110The evolution-data-server package provides a unified backend for
111programs that work with contacts, tasks, and calendar information.
112
113It was originally developed for Evolution (hence the name), but
114is now used by other packages.
115
[7633]116
[521]117%package devel
118Summary: Development files for building against evolution-data-server
119Group: Development/Libraries
120Requires: %{name} = %{version}-%{release}
[6890]121Requires: pkgconfig
[521]122Requires: sqlite3-devel
[6890]123Requires: libgnome-keyring-devel
[521]124
125%description devel
126Development files needed for building things which link against
127evolution-data-server.
128
129
[7633]130%package        vala
131Summary:        Vala bindings for %{name}
132Summary(ja):    %{name} の Vala バインディング
133Group:          Development/Libraries
134Requires:       %{name} = %{version}-%{release}
135Requires:       vala
136
137%description    vala
138Vala bindings for %{name}.
139
140
[521]141%prep
142%setup -q
143
144%patch12 -p1 -b .fix-64bit-acinclude
145
146mkdir -p krb5-fakeprefix/include
147mkdir -p krb5-fakeprefix/lib
148mkdir -p krb5-fakeprefix/%{_lib}
149
150%build
151%if %{ldap_support}
152
153%if %{static_ldap}
154%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
155# Set LIBS so that configure will be able to link with static LDAP libraries,
156# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
[805]157if pkg-config libssl ; then
158        export LIBS="-lsasl2 `pkg-config --libs libssl`"
[521]159else
160        export LIBS="-lsasl2 -lssl -lcrypto"
161fi
162%else
163%define ldap_flags --with-openldap=yes
164%endif
165
166%else
167%define ldap_flags --without-openldap
168%endif
169
170%if %{krb5_support}
[805]171%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
[521]172%else
173%define krb5_flags --without-krb5
174%endif
175
176%if %{nntp_support}
177%define nntp_flags --enable-nntp=yes
178%else
179%define nntp_flags --enable-nntp=no
180%endif
181
182%if %{use_nss}
183%define ssl_flags --enable-nss=yes --enable-smime=yes
184%else
185%define ssl_flags --enable-openssl=yes
186%endif
187
188%if %{use_nss}
189if ! pkg-config --exists nss; then
190  echo "Unable to find suitable version of nss to use!"
191  exit 1
192fi
193%endif
194
195%if %{use_gnome_keyring}
196%define keyring_flags --enable-gnome-keyring
197%else
198%define keyring flags --disable-gnome-keyring
199%endif
200
201%if %{support_imap4_provider}
202%define imap4_flags --enable-imap4=yes
203%else
204%define imap4_flags --enable-imap4=no
205%endif
206
207export CPPFLAGS="-I%{_includedir}/et"
208export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
209
210# Regenerate configure to pick up configure.in and acinclude.m4 changes.
[7938]211autoreconf -if
[521]212
213# See Ross Burton's blog entry for why we want --with-libdb.
214# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
215
216%configure \
217        --with-libdb=/usr \
[7633]218        --disable-uoa \
[521]219        --enable-file-locking=fcntl \
220        --enable-dot-locking=no \
[9569]221        --disable-gtk-doc \
[7633]222        --enable-introspection=yes \
223        --enable-vala-bindings \
[521]224        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
225        %keyring_flags
226export tagname=CC
[9569]227make %{?_smp_mflags}
[521]228
229%install
230rm -rf $RPM_BUILD_ROOT
231export tagname=CC
[9569]232make DESTDIR=$RPM_BUILD_ROOT install
[521]233
234# remove libtool archives for importers and the like
235find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
[6890]236find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
[521]237
238# give the libraries some executable bits
239find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
240
241%find_lang %{name}-%{eds_base_version}
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post -p /sbin/ldconfig
247
[6011]248%postun
249/sbin/ldconfig
250if [ $1 -eq 0 ]; then
251  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
252fi
[521]253
[6011]254%posttrans
255glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
256
257
[521]258%files -f %{name}-%{eds_base_version}.lang
259%defattr(-,root,root,-)
260%doc README COPYING ChangeLog NEWS AUTHORS
261%{_libdir}/*.so.*
[9475]262%{_libdir}/evolution-data-server/credential-modules/module-credentials-goa.so
263%{_libdir}/evolution-data-server/libedbus-private.so
[4616]264%{_libdir}/girepository-1.0/*.typelib
[6011]265%{_libexecdir}/evolution-addressbook-factory
[9475]266%{_libexecdir}/evolution-addressbook-factory-subprocess
[6011]267%{_libexecdir}/evolution-calendar-factory
[9475]268%{_libexecdir}/evolution-calendar-factory-subprocess
[8011]269%{_libexecdir}/evolution-scan-gconf-tree-xml
[6890]270%{_libexecdir}/evolution-source-registry
[7633]271%{_libexecdir}/evolution-user-prompter
[521]272%{_libexecdir}/camel-index-control-%{eds_api_version}
273%{_libexecdir}/camel-lock-helper-%{eds_api_version}
[6890]274%{_datadir}/GConf/gsettings/evolution-data-server.convert
[6011]275%{_datadir}/dbus-1/services/*
[7633]276%{_datadir}/%{name}/evolutionperson.schema
[9475]277%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.gschema.xml
[6011]278%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
279%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
[6890]280%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
281%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
282%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
[521]283%{_datadir}/pixmaps/evolution-data-server
284
[4616]285%dir %{_libdir}/evolution-data-server
[521]286%dir %{camel_provider_dir}
[4616]287%dir %{ebook_backends_dir}
288%dir %{ecal_backends_dir}
[6890]289%dir %{registry_modules_dir}
[521]290
[4616]291%{camel_provider_dir}/libcamelimapx.so
292%{camel_provider_dir}/libcamelimapx.urls
[521]293
294%{camel_provider_dir}/libcamellocal.so
295%{camel_provider_dir}/libcamellocal.urls
296
297%{camel_provider_dir}/libcamelnntp.so
298%{camel_provider_dir}/libcamelnntp.urls
299
300%{camel_provider_dir}/libcamelpop3.so
301%{camel_provider_dir}/libcamelpop3.urls
302
303%{camel_provider_dir}/libcamelsendmail.so
304%{camel_provider_dir}/libcamelsendmail.urls
305
306%{camel_provider_dir}/libcamelsmtp.so
307%{camel_provider_dir}/libcamelsmtp.urls
308
309# e-d-s extensions:
[4616]310%{ebook_backends_dir}/libebookbackendfile.so
311%{ebook_backends_dir}/libebookbackendgoogle.so
312%{ebook_backends_dir}/libebookbackendldap.so
313%{ebook_backends_dir}/libebookbackendwebdav.so
[521]314
[4616]315%{ecal_backends_dir}/libecalbackendcaldav.so
316%{ecal_backends_dir}/libecalbackendcontacts.so
317%{ecal_backends_dir}/libecalbackendfile.so
[9073]318%{ecal_backends_dir}/libecalbackendgtasks.so
[4616]319%{ecal_backends_dir}/libecalbackendhttp.so
320%{ecal_backends_dir}/libecalbackendweather.so
321
[6890]322%{registry_modules_dir}/module-cache-reaper.so
323%{registry_modules_dir}/module-google-backend.so
[7633]324%{registry_modules_dir}/module-gnome-online-accounts.so
[7938]325%{registry_modules_dir}/module-outlook-backend.so
[7633]326%{registry_modules_dir}/module-owncloud-backend.so
[8353]327%{registry_modules_dir}/module-secret-monitor.so
[7633]328%{registry_modules_dir}/module-trust-prompt.so
[6890]329%{registry_modules_dir}/module-yahoo-backend.so
330
[521]331%files devel
332%defattr(-,root,root,-)
[7633]333%{_includedir}/%{name}
[521]334%{_libdir}/*.so
335%{_libdir}/pkgconfig/*.pc
[4616]336%{_datadir}/gir-1.0/*.gir
[521]337
[7633]338%files vala
339%defattr(-,root,root,-)
340%{_datadir}/vala/vapi/libebook-1.2.deps
341%{_datadir}/vala/vapi/libebook-1.2.vapi
342%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
343%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
344%{_datadir}/vala/vapi/libedataserver-1.2.deps
345%{_datadir}/vala/vapi/libedataserver-1.2.vapi
346
347
[521]348%changelog
[9672]349* Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
350- new upstream release
351
[9590]352* Wed Jun 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
353- new upstream release
354- remove %%{name}-doc subpackage
355
[9569]356* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
357- new upstream release
358
[9520]359* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
360- new upstream release
361
[9475]362* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
363- new upstream release
364
[9376]365* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.12.11-2
366- rebuilt with libical 1.0.1
367
[9371]368* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.11-1
369- new upstream release
370
[9313]371* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.10-1
372- new upstream release
373
[9178]374* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
375- new upstream release
376
[9102]377* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
378- new upstream release
379
[9073]380* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
381- new upstream release
382
[8949]383* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
384- new upstream release
385
[8912]386* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
387- new upstream release
388
[8836]389* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
390- new upstream release
391
[8545]392* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
393- new upstream release
394
[8447]395* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
396- new upstream release
397
[8369]398* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
399- new upstream release
400
[8353]401* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
402- new upstream release
403- add BuildRequires: libicu-devel
404
[8060]405* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
406- new upstream release
407
[8011]408* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
409- new upstream release
410
[7938]411* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
412- new upstream release
413
[7756]414* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
415- new upstream release
416
[7712]417* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
418- new upstream release
419
[7681]420* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
421- new upstream release
422
[7633]423* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
424- new upstream release
425- add configure option (--disable-uoa)
426- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
427- create %%{name}-vala subpackage
428
[7538]429* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
430- new upstream release
431
[7474]432* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
433- new upstream release
434
[7119]435* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
436- new upstream release
437
[6933]438* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
439- new upstream release
440
[6890]441* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
442- new upstream release
443
[6739]444* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
445- new upstream release
446
[6401]447* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
448- new upstream release
449
[6201]450* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
451- new upstream release
452
[6078]453* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]454- new upstream release
455- add BuildRequires: dbus-glib-devel
456
[5402]457* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
458- new upstream release
459
[5168]460* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
461- new upstream release
462
[5038]463* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
464- new upstream release
465
[4850]466* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
467- new upstream release
468
[4812]469* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
470- new upstream release
471- remove Patch101
472
[4704]473* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
474- new upstream release
475
[4616]476* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
[3801]477- new upstream release
[4616]478- change BuildRequires: gtk3-devel instead of gtk2-devel
479- BuildRequires: gnome-online-accounts-devel
480- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
481- fix %%files
[3801]482
[2661]483* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
484- new upstream release
485
[2483]486* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
487- rebuild with openssl-1.0.0c
[2219]488
[2041]489* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
490- new upstream release
491- remove Requires: gnome-vfs2, libglade2, libgnomeui
492- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
493- add BuildRequires: libgdata
494- add Requires: nspr-devel, nss-devel (devel package)
495- drop Patch11
496
[1883]497* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
498- rebuild with rpm-4.8.1 for pkg-config file
499
[1231]500* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
501- new upstream release
502
[926]503* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
504- new upstream release
505
[805]506* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
507- new upstream release
508- remove BuildRequires: libbonobo-devel
509- remove Requires: libbonobo
510- drop Patch10
511- add configure option (--with-krb5-libs, --with-krb5-includes)
512
[521]513* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
514- rebuilt with db4-4.8
515
516* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
517- new upstream release
518
519* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
520- new upstream release
521
522* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
523- new upstream release
524
525* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
526- new upstream release
527
528* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
529- added Requires: libical-devel >= 0.43 to devel package
530
531* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
532- new upstream release
533- add BR: libgweather-devel >= 2.26.0
534- add BR: libical-devel >= 0.43
535
536* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
537- new upstream release
538- added BuildRequires: sqlite3-devel
539
540* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
541- enabled krb5 support
542
543* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
544- new upstream release
545
546* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
547- new upstream release
548
549* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
550- new upstream release
551
552* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
553- new upstream release
554
555* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
556- rebuilt with db4-4.6.21
557
558* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
559- new upstream release
560
561* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
562- new upstream release
563
564* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
565- new upstream release
566
567* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
568- new upstream release based on Fedora package 2.20.0-3.fc9
569  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
570  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
571  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
572  - Add patch for RH bug #296671 (GC servers may not support NTLM).
573  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
574  - Try removing the ancient "ldap-x86_64-hack" patch.
575  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
576  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
577- split doc subpackage
578
579* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
580- fixed dependancy
581
582* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
583- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
584  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
585  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
586  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
587  - Make the new ESourceComboBox widget work properly (RH bug #234760).
588  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
589  - Link to static evolution-openldap library (RH bug #210126).
590  - Require openssl-devel when statically linking against openldap.
591  - Add -Wdeclaration-after-statement to strict build settings.
592  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
593  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
594  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
595  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
596  - Update to 1.10.0
597  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
598  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
599  - Patch by Kenny Root.
600- rebuilt with nss-devel and nspr-devel
601
602* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
603- rebuilt with new toolchain and db4-4.3.x
604
605* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
606- new upstream release
607
608* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
609- new upstream release
610- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
611
612* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
613- new upstream release
614- rebuilt with openssl instead of mozilla-nss
615
616* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
617- rebuilt with openldap-2.3.24-0vl4
618
619* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
620- new upstream release
621- build with libsoap-2.2.7
622
623* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
624- new upstream release
625
626* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
627- new upstream release
628- added/removed Patches based on Fedora packages
629  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
630  - Updated patch 102 to fix further implicit function declarations
631  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
632  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
633    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
634  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
635  - Removed upstreamed patch:
636    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
637  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
638  - added patch to calendar/libecal/e-cal.c to fix missing declaration
639    of open_calendar
640- rebuilt with mozilla-1.7.12
641
[7633]642* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
[521]643- rebuilt with mozilla-1.7.7
644
645* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
646- initial build for Vine Linux based on FC package
647- disable krb5 support
648
649* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
650- 1.2.1
651
652* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
653- Removed explicit run-time spec-file requirement on mozilla.
654  The Mozilla NSS API/ABI stabilised by version 1.7.3
655  The libraries are always located in the libdir
656  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
657  and so they move each time the mozilla version changes.
658  So we no longer have an explicit mozilla run-time requirement in the specfile;
659  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
660  We have an explicit, exact build-time version, so that we can find the headers (without
661  invoking an RPM query from the spec file; to do so is considered bad practice)
662- Introduced mozilla_build_version, to replace mozilla_version
663- Set mozilla_build_version to 1.7.6 to reflect current state of tree
664
665* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
666- Added a patch to deal with glibc defining a macro called "read"
667
668* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
669- 1.2.0
670- Removed patch for GCC 4 as this is now in upstream tarball
671
672* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
673- rebuild to fix library linking silliness
674
675* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
676- disabling gtk-doc on ia64 and s390x
677
678* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
679- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
680
681* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
682- extended patch to deal with camel-groupwise-store-summary.c
683
684* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
685- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
686
687* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
688- 1.1.6
689
690* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
691- rebuild
692
693* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
694- forgot to fix sources
695
696* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
697- 1.1.5
698
699* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
700- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
701
702* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
703- disable gtk-doc generation on ia64 for now
704
705* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
706- Exclude ppc64 due to missing mozilla dependency
707
708* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
709- Update from 1.0.3 to 1.1.4.1
710- Updated eds_major from 1.0 to 1.2; fixed translation search path.
711- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
712- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
713- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
714- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
715- Camel code from evolution is now in evolution-data-server:
716  - Added camel-index-control and camel-lock-helper to packaged files
717  - Added mozilla dependency code from the evolution package
718  - Ditto for LDAP
719  - Ditto for krb5
720  - Ditto for NNTP support handling
721  - Ditto for --enable-file-locking and --enable-dot-locking
722- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
723- Updated libsoup requirement from 2.2.1 to 2.2.2
724- Enabled gtk-doc
725
726* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
727- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
728
729* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
730- update from upstream 1.0.2 to 1.0.3:
731  * Address Book
732    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
733    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
734
735  * Calendar
736    #XB59904 - Speed up calendar queries (Rodrigo)
737    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
738    - fix libical build for automake 1.9 (Rodney)
739    - fix putenv usage for portability (Julio M. Merino Vidal)
740
741  * Updated Translations:
742    - sv (Christian Rose)
743
744- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
745
746* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
747- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
748http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
749(The groupwise part of that patch did not cleanly apply, so I removed it).
750
751* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
752- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
753optimisation patch posted to upstream development mailing list here:
754http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
755
756* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
757- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
758
759* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
760- added workaround for a backend leak that causes the "contacts" calendar
761backend to hold open an EBook for the local contacts (filed upstream at:
762http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
763never lose its last addressbook, and hence never quit.  We workaround this by
764detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
765
766* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
767- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
768
769* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
770- update from 1.0.1 to 1.0.2
771- increased libsoup requirement to 2.2.1 to match configuration script
772
773* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
774- update from 1.0.0 to 1.0.1
775- removed patch that fixed warnings in calendar code (now in upstream tarball)
776
777* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
778- fixed various warnings in the calendar code
779  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
780
781* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
782- update from 0.0.99 to 1.0.0
783- changed path in FTP source location from 0.0 to 1.0
784
785* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
786- update from 0.0.98 to 0.0.99
787- increased libsoup requirement to 2.2.0 to match configuration script
788
789* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
790- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
791
792* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
793- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
794
795* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
796- upgraded to 0.0.97; rewrote the package's description
797
798* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
799- rebuilt
800
801* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
802- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
803
804* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
805- 0.0.96; libsoup required is now 2.1.12
806
807* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
808- rebuilt
809
810* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
811- rebuilt
812
813* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
814- 0.0.95
815
816* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
817- 0.0.94.1
818
819* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
820- rebuilt
821
822* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
823- 0.0.94
824
825* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
826- added ORBit2 requirement
827
828* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
829- rebuild again
830
831* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
832- rebuilt
833
834* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
835- 0.0.93; libsoup required is now 2.1.10
836
837* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
838- Update to 0.0.92; added a define and a requirement on the libsoup version
839
840* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
841- 0.0.90
842
843* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
844- rebuilt
845
846* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
847- 0.0.6
848
849* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
850- better fix by using system libtool
851
852* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
853- add some libdb linkage to make the build on x86_64 happy
854
855* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
856- update to 0.0.5
857
858* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
859- Initial build.
Note: See TracBrowser for help on using the repository browser.