source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 9178

Revision 9178, 28.2 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

RevLine 
[521]1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
[6890]7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
[4850]9%define gtk_doc_version 1.18
[521]10%define intltool_version 0.35.5
[2041]11%define orbit2_version 2.14.19
[4850]12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
[2041]14%define libical_version 0.44
[4850]15%define libgdata_version 0.10.1
[521]16
[8353]17%define eds_base_version 3.12
[521]18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
[4616]23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
[6890]26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
[521]27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
[9178]33Version: 3.12.9
[3801]34Release: 1%{?_dist_release}
[521]35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
[8353]38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.12/%{name}-%{version}.tar.xz
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
[6890]48#Requires: ORBit2 >= %{orbit2_version}
[521]49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
[6890]53#BuildRequires: ORBit2-devel >= %{orbit2_version}
[521]54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
[4616]59BuildRequires: gtk3-devel
[6011]60BuildRequires: dbus-glib-devel
[521]61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
[805]65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
[521]67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
[805]70BuildRequires: gperf
[4616]71BuildRequires: krb5-devel
[2041]72BuildRequires: libgdata-devel >= %{libgdata_version}
[4616]73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
[7633]75BuildRequires: libsecret-devel
[8353]76BuildRequires: libicu-devel
[7633]77BuildRequires: gnome-common
[521]78
[7633]79BuildRequires: vala
80BuildRequires: vala-tools
81
[521]82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
[4616]105Vendor: Project Vine
106Distribution: Vine Linux
107
[521]108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
[7633]115
[521]116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
[6890]120Requires: pkgconfig
[521]121Requires: sqlite3-devel
[6890]122Requires: libgnome-keyring-devel
[521]123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
[7633]129%package                doc
130Summary:                Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:                  Documentation
133Requires:               %{name} = %{version}-%{release}
134BuildArch:              noarch
135
[521]136%description doc
[7633]137This package contains documentation for %{name}.
[521]138
[7633]139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
[521]151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
[805]167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
[521]169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
[805]181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
[521]182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
[7938]221autoreconf -if
[521]222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
[7633]228        --disable-uoa \
[521]229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
[7633]232        --enable-introspection=yes \
233        --enable-vala-bindings \
[521]234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
[4616]237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
[521]239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
[6890]247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
[521]248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
[6011]259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
[521]264
[6011]265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
[521]269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
[4616]273%{_libdir}/girepository-1.0/*.typelib
[6011]274%{_libexecdir}/evolution-addressbook-factory
275%{_libexecdir}/evolution-calendar-factory
[8011]276%{_libexecdir}/evolution-scan-gconf-tree-xml
[6890]277%{_libexecdir}/evolution-source-registry
[7633]278%{_libexecdir}/evolution-user-prompter
[521]279%{_libexecdir}/camel-index-control-%{eds_api_version}
280%{_libexecdir}/camel-lock-helper-%{eds_api_version}
[6890]281%{_datadir}/GConf/gsettings/evolution-data-server.convert
[6011]282%{_datadir}/dbus-1/services/*
[7633]283%{_datadir}/%{name}/evolutionperson.schema
[6011]284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
[6890]286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
[521]289%{_datadir}/pixmaps/evolution-data-server
290
[4616]291%dir %{_libdir}/evolution-data-server
[521]292%dir %{camel_provider_dir}
[4616]293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
[6890]295%dir %{registry_modules_dir}
[521]296
[4616]297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
[521]299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
[4616]316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
[521]320
[4616]321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
[9073]324%{ecal_backends_dir}/libecalbackendgtasks.so
[4616]325%{ecal_backends_dir}/libecalbackendhttp.so
326%{ecal_backends_dir}/libecalbackendweather.so
327
[6890]328%{registry_modules_dir}/module-cache-reaper.so
329%{registry_modules_dir}/module-google-backend.so
[7633]330%{registry_modules_dir}/module-gnome-online-accounts.so
[7938]331%{registry_modules_dir}/module-outlook-backend.so
[7633]332%{registry_modules_dir}/module-owncloud-backend.so
[8353]333%{registry_modules_dir}/module-secret-monitor.so
[7633]334%{registry_modules_dir}/module-trust-prompt.so
[6890]335%{registry_modules_dir}/module-yahoo-backend.so
336
[521]337%files devel
338%defattr(-,root,root,-)
[7633]339%{_includedir}/%{name}
[521]340%{_libdir}/*.so
341%{_libdir}/pkgconfig/*.pc
[4616]342%{_datadir}/gir-1.0/*.gir
[521]343
344%files doc
345%defattr(-,root,root,-)
346%{_datadir}/gtk-doc/html/camel
[8353]347%{_datadir}/gtk-doc/html/eds
[521]348
[7633]349%files vala
350%defattr(-,root,root,-)
351%{_datadir}/vala/vapi/libebook-1.2.deps
352%{_datadir}/vala/vapi/libebook-1.2.vapi
353%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
354%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
355%{_datadir}/vala/vapi/libedataserver-1.2.deps
356%{_datadir}/vala/vapi/libedataserver-1.2.vapi
357
358
[521]359%changelog
[9178]360* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.9-1
361- new upstream release
362
[9102]363* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.8-1
364- new upstream release
365
[9073]366* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.7-1
367- new upstream release
368
[8949]369* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-1
370- new upstream release
371
[8912]372* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.5-1
373- new upstream release
374
[8836]375* Fri Jul 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
376- new upstream release
377
[8545]378* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.3-1
379- new upstream release
380
[8447]381* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
382- new upstream release
383
[8369]384* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
385- new upstream release
386
[8353]387* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
388- new upstream release
389- add BuildRequires: libicu-devel
390
[8060]391* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
392- new upstream release
393
[8011]394* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
395- new upstream release
396
[7938]397* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
398- new upstream release
399
[7756]400* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
401- new upstream release
402
[7712]403* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
404- new upstream release
405
[7681]406* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
407- new upstream release
408
[7633]409* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
410- new upstream release
411- add configure option (--disable-uoa)
412- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
413- create %%{name}-vala subpackage
414
[7538]415* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
416- new upstream release
417
[7474]418* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
419- new upstream release
420
[7119]421* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
422- new upstream release
423
[6933]424* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
425- new upstream release
426
[6890]427* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
428- new upstream release
429
[6739]430* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
431- new upstream release
432
[6401]433* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
434- new upstream release
435
[6201]436* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
437- new upstream release
438
[6078]439* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]440- new upstream release
441- add BuildRequires: dbus-glib-devel
442
[5402]443* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
444- new upstream release
445
[5168]446* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
447- new upstream release
448
[5038]449* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
450- new upstream release
451
[4850]452* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
453- new upstream release
454
[4812]455* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
456- new upstream release
457- remove Patch101
458
[4704]459* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
460- new upstream release
461
[4616]462* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
[3801]463- new upstream release
[4616]464- change BuildRequires: gtk3-devel instead of gtk2-devel
465- BuildRequires: gnome-online-accounts-devel
466- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
467- fix %%files
[3801]468
[2661]469* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
470- new upstream release
471
[2483]472* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
473- rebuild with openssl-1.0.0c
[2219]474
[2041]475* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
476- new upstream release
477- remove Requires: gnome-vfs2, libglade2, libgnomeui
478- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
479- add BuildRequires: libgdata
480- add Requires: nspr-devel, nss-devel (devel package)
481- drop Patch11
482
[1883]483* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
484- rebuild with rpm-4.8.1 for pkg-config file
485
[1231]486* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
487- new upstream release
488
[926]489* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
490- new upstream release
491
[805]492* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
493- new upstream release
494- remove BuildRequires: libbonobo-devel
495- remove Requires: libbonobo
496- drop Patch10
497- add configure option (--with-krb5-libs, --with-krb5-includes)
498
[521]499* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
500- rebuilt with db4-4.8
501
502* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
503- new upstream release
504
505* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
506- new upstream release
507
508* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
509- new upstream release
510
511* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
512- new upstream release
513
514* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
515- added Requires: libical-devel >= 0.43 to devel package
516
517* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
518- new upstream release
519- add BR: libgweather-devel >= 2.26.0
520- add BR: libical-devel >= 0.43
521
522* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
523- new upstream release
524- added BuildRequires: sqlite3-devel
525
526* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
527- enabled krb5 support
528
529* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
530- new upstream release
531
532* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
533- new upstream release
534
535* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
536- new upstream release
537
538* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
539- new upstream release
540
541* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
542- rebuilt with db4-4.6.21
543
544* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
545- new upstream release
546
547* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
548- new upstream release
549
550* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
551- new upstream release
552
553* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
554- new upstream release based on Fedora package 2.20.0-3.fc9
555  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
556  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
557  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
558  - Add patch for RH bug #296671 (GC servers may not support NTLM).
559  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
560  - Try removing the ancient "ldap-x86_64-hack" patch.
561  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
562  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
563- split doc subpackage
564
565* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
566- fixed dependancy
567
568* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
569- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
570  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
571  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
572  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
573  - Make the new ESourceComboBox widget work properly (RH bug #234760).
574  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
575  - Link to static evolution-openldap library (RH bug #210126).
576  - Require openssl-devel when statically linking against openldap.
577  - Add -Wdeclaration-after-statement to strict build settings.
578  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
579  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
580  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
581  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
582  - Update to 1.10.0
583  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
584  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
585  - Patch by Kenny Root.
586- rebuilt with nss-devel and nspr-devel
587
588* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
589- rebuilt with new toolchain and db4-4.3.x
590
591* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
592- new upstream release
593
594* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
595- new upstream release
596- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
597
598* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
599- new upstream release
600- rebuilt with openssl instead of mozilla-nss
601
602* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
603- rebuilt with openldap-2.3.24-0vl4
604
605* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
606- new upstream release
607- build with libsoap-2.2.7
608
609* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
610- new upstream release
611
612* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
613- new upstream release
614- added/removed Patches based on Fedora packages
615  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
616  - Updated patch 102 to fix further implicit function declarations
617  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
618  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
619    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
620  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
621  - Removed upstreamed patch:
622    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
623  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
624  - added patch to calendar/libecal/e-cal.c to fix missing declaration
625    of open_calendar
626- rebuilt with mozilla-1.7.12
627
[7633]628* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
[521]629- rebuilt with mozilla-1.7.7
630
631* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
632- initial build for Vine Linux based on FC package
633- disable krb5 support
634
635* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
636- 1.2.1
637
638* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
639- Removed explicit run-time spec-file requirement on mozilla.
640  The Mozilla NSS API/ABI stabilised by version 1.7.3
641  The libraries are always located in the libdir
642  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
643  and so they move each time the mozilla version changes.
644  So we no longer have an explicit mozilla run-time requirement in the specfile;
645  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
646  We have an explicit, exact build-time version, so that we can find the headers (without
647  invoking an RPM query from the spec file; to do so is considered bad practice)
648- Introduced mozilla_build_version, to replace mozilla_version
649- Set mozilla_build_version to 1.7.6 to reflect current state of tree
650
651* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
652- Added a patch to deal with glibc defining a macro called "read"
653
654* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
655- 1.2.0
656- Removed patch for GCC 4 as this is now in upstream tarball
657
658* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
659- rebuild to fix library linking silliness
660
661* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
662- disabling gtk-doc on ia64 and s390x
663
664* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
665- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
666
667* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
668- extended patch to deal with camel-groupwise-store-summary.c
669
670* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
671- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
672
673* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
674- 1.1.6
675
676* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
677- rebuild
678
679* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
680- forgot to fix sources
681
682* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
683- 1.1.5
684
685* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
686- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
687
688* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
689- disable gtk-doc generation on ia64 for now
690
691* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
692- Exclude ppc64 due to missing mozilla dependency
693
694* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
695- Update from 1.0.3 to 1.1.4.1
696- Updated eds_major from 1.0 to 1.2; fixed translation search path.
697- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
698- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
699- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
700- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
701- Camel code from evolution is now in evolution-data-server:
702  - Added camel-index-control and camel-lock-helper to packaged files
703  - Added mozilla dependency code from the evolution package
704  - Ditto for LDAP
705  - Ditto for krb5
706  - Ditto for NNTP support handling
707  - Ditto for --enable-file-locking and --enable-dot-locking
708- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
709- Updated libsoup requirement from 2.2.1 to 2.2.2
710- Enabled gtk-doc
711
712* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
713- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
714
715* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
716- update from upstream 1.0.2 to 1.0.3:
717  * Address Book
718    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
719    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
720
721  * Calendar
722    #XB59904 - Speed up calendar queries (Rodrigo)
723    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
724    - fix libical build for automake 1.9 (Rodney)
725    - fix putenv usage for portability (Julio M. Merino Vidal)
726
727  * Updated Translations:
728    - sv (Christian Rose)
729
730- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
731
732* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
733- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
734http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
735(The groupwise part of that patch did not cleanly apply, so I removed it).
736
737* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
738- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
739optimisation patch posted to upstream development mailing list here:
740http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
741
742* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
743- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
744
745* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
746- added workaround for a backend leak that causes the "contacts" calendar
747backend to hold open an EBook for the local contacts (filed upstream at:
748http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
749never lose its last addressbook, and hence never quit.  We workaround this by
750detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
751
752* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
753- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
754
755* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
756- update from 1.0.1 to 1.0.2
757- increased libsoup requirement to 2.2.1 to match configuration script
758
759* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
760- update from 1.0.0 to 1.0.1
761- removed patch that fixed warnings in calendar code (now in upstream tarball)
762
763* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
764- fixed various warnings in the calendar code
765  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
766
767* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
768- update from 0.0.99 to 1.0.0
769- changed path in FTP source location from 0.0 to 1.0
770
771* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
772- update from 0.0.98 to 0.0.99
773- increased libsoup requirement to 2.2.0 to match configuration script
774
775* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
776- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
777
778* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
779- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
780
781* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
782- upgraded to 0.0.97; rewrote the package's description
783
784* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
785- rebuilt
786
787* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
788- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
789
790* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
791- 0.0.96; libsoup required is now 2.1.12
792
793* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
794- rebuilt
795
796* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
797- rebuilt
798
799* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
800- 0.0.95
801
802* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
803- 0.0.94.1
804
805* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
806- rebuilt
807
808* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
809- 0.0.94
810
811* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
812- added ORBit2 requirement
813
814* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
815- rebuild again
816
817* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
818- rebuilt
819
820* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
821- 0.0.93; libsoup required is now 2.1.10
822
823* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
824- Update to 0.0.92; added a define and a requirement on the libsoup version
825
826* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
827- 0.0.90
828
829* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
830- rebuilt
831
832* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
833- 0.0.6
834
835* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
836- better fix by using system libtool
837
838* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
839- add some libdb linkage to make the build on x86_64 happy
840
841* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
842- update to 0.0.5
843
844* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
845- Initial build.
Note: See TracBrowser for help on using the repository browser.