source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 8353

Revision 8353, 27.4 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

RevLine 
[521]1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
[6890]7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
[4850]9%define gtk_doc_version 1.18
[521]10%define intltool_version 0.35.5
[2041]11%define orbit2_version 2.14.19
[4850]12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
[2041]14%define libical_version 0.44
[4850]15%define libgdata_version 0.10.1
[521]16
[8353]17%define eds_base_version 3.12
[521]18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
[4616]23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
[6890]26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
[521]27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
[8353]33Version: 3.12.0
[3801]34Release: 1%{?_dist_release}
[521]35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
[8353]38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.12/%{name}-%{version}.tar.xz
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
[6890]48#Requires: ORBit2 >= %{orbit2_version}
[521]49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
[6890]53#BuildRequires: ORBit2-devel >= %{orbit2_version}
[521]54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
[4616]59BuildRequires: gtk3-devel
[6011]60BuildRequires: dbus-glib-devel
[521]61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
[805]65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
[521]67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
[805]70BuildRequires: gperf
[4616]71BuildRequires: krb5-devel
[2041]72BuildRequires: libgdata-devel >= %{libgdata_version}
[4616]73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
[7633]75BuildRequires: libsecret-devel
[8353]76BuildRequires: libicu-devel
[7633]77BuildRequires: gnome-common
[521]78
[7633]79BuildRequires: vala
80BuildRequires: vala-tools
81
[521]82%if %{use_nss}
83BuildRequires: nspr-devel
84BuildRequires: nss-devel
85%else
86BuildRequires: openssl-devel
87%endif
88
89%if %{ldap_support}
90%if %{static_ldap}
91BuildRequires: openldap-evolution-devel
92BuildRequires: openssl-devel
93%else
94BuildRequires: openldap-devel >= 2.0.11
95%endif
96%endif
97
98%if %{krb5_support}
99BuildRequires: krb5-devel
100# tweak for krb5 1.2 vs 1.3
101%define krb5dir /usr/kerberos
102#define krb5dir `pwd`/krb5-fakeprefix
103%endif
104
[4616]105Vendor: Project Vine
106Distribution: Vine Linux
107
[521]108%description
109The evolution-data-server package provides a unified backend for
110programs that work with contacts, tasks, and calendar information.
111
112It was originally developed for Evolution (hence the name), but
113is now used by other packages.
114
[7633]115
[521]116%package devel
117Summary: Development files for building against evolution-data-server
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
[6890]120Requires: pkgconfig
[521]121Requires: sqlite3-devel
[6890]122Requires: libgnome-keyring-devel
[521]123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128
[7633]129%package                doc
130Summary:                Documentation for %{name}
131Summary(ja):    %{name} 用のドキュメント
132Group:                  Documentation
133Requires:               %{name} = %{version}-%{release}
134BuildArch:              noarch
135
[521]136%description doc
[7633]137This package contains documentation for %{name}.
[521]138
[7633]139
140%package        vala
141Summary:        Vala bindings for %{name}
142Summary(ja):    %{name} の Vala バインディング
143Group:          Development/Libraries
144Requires:       %{name} = %{version}-%{release}
145Requires:       vala
146
147%description    vala
148Vala bindings for %{name}.
149
150
[521]151%prep
152%setup -q
153
154%patch12 -p1 -b .fix-64bit-acinclude
155
156mkdir -p krb5-fakeprefix/include
157mkdir -p krb5-fakeprefix/lib
158mkdir -p krb5-fakeprefix/%{_lib}
159
160%build
161%if %{ldap_support}
162
163%if %{static_ldap}
164%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
165# Set LIBS so that configure will be able to link with static LDAP libraries,
166# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
[805]167if pkg-config libssl ; then
168        export LIBS="-lsasl2 `pkg-config --libs libssl`"
[521]169else
170        export LIBS="-lsasl2 -lssl -lcrypto"
171fi
172%else
173%define ldap_flags --with-openldap=yes
174%endif
175
176%else
177%define ldap_flags --without-openldap
178%endif
179
180%if %{krb5_support}
[805]181%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
[521]182%else
183%define krb5_flags --without-krb5
184%endif
185
186%if %{nntp_support}
187%define nntp_flags --enable-nntp=yes
188%else
189%define nntp_flags --enable-nntp=no
190%endif
191
192%if %{use_nss}
193%define ssl_flags --enable-nss=yes --enable-smime=yes
194%else
195%define ssl_flags --enable-openssl=yes
196%endif
197
198%if %{use_nss}
199if ! pkg-config --exists nss; then
200  echo "Unable to find suitable version of nss to use!"
201  exit 1
202fi
203%endif
204
205%if %{use_gnome_keyring}
206%define keyring_flags --enable-gnome-keyring
207%else
208%define keyring flags --disable-gnome-keyring
209%endif
210
211%if %{support_imap4_provider}
212%define imap4_flags --enable-imap4=yes
213%else
214%define imap4_flags --enable-imap4=no
215%endif
216
217export CPPFLAGS="-I%{_includedir}/et"
218export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
219
220# Regenerate configure to pick up configure.in and acinclude.m4 changes.
[7938]221autoreconf -if
[521]222
223# See Ross Burton's blog entry for why we want --with-libdb.
224# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
225
226%configure \
227        --with-libdb=/usr \
[7633]228        --disable-uoa \
[521]229        --enable-file-locking=fcntl \
230        --enable-dot-locking=no \
231        --enable-gtk-doc \
[7633]232        --enable-introspection=yes \
233        --enable-vala-bindings \
[521]234        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
235        %keyring_flags
236export tagname=CC
[4616]237#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
238make LIBTOOL=/usr/bin/libtool
[521]239
240%install
241rm -rf $RPM_BUILD_ROOT
242export tagname=CC
243make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
244
245# remove libtool archives for importers and the like
246find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
[6890]247find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
[521]248
249# give the libraries some executable bits
250find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
251
252%find_lang %{name}-%{eds_base_version}
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
[6011]259%postun
260/sbin/ldconfig
261if [ $1 -eq 0 ]; then
262  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
263fi
[521]264
[6011]265%posttrans
266glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267
268
[521]269%files -f %{name}-%{eds_base_version}.lang
270%defattr(-,root,root,-)
271%doc README COPYING ChangeLog NEWS AUTHORS
272%{_libdir}/*.so.*
[4616]273%{_libdir}/girepository-1.0/*.typelib
[6011]274%{_libexecdir}/evolution-addressbook-factory
275%{_libexecdir}/evolution-calendar-factory
[8011]276%{_libexecdir}/evolution-scan-gconf-tree-xml
[6890]277%{_libexecdir}/evolution-source-registry
[7633]278%{_libexecdir}/evolution-user-prompter
[521]279%{_libexecdir}/camel-index-control-%{eds_api_version}
280%{_libexecdir}/camel-lock-helper-%{eds_api_version}
[6890]281%{_datadir}/GConf/gsettings/evolution-data-server.convert
[6011]282%{_datadir}/dbus-1/services/*
[7633]283%{_datadir}/%{name}/evolutionperson.schema
[6011]284%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
285%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
[6890]286%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
287%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
288%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
[521]289%{_datadir}/pixmaps/evolution-data-server
290
[4616]291%dir %{_libdir}/evolution-data-server
[521]292%dir %{camel_provider_dir}
[4616]293%dir %{ebook_backends_dir}
294%dir %{ecal_backends_dir}
[6890]295%dir %{registry_modules_dir}
[521]296
[4616]297%{camel_provider_dir}/libcamelimapx.so
298%{camel_provider_dir}/libcamelimapx.urls
[521]299
300%{camel_provider_dir}/libcamellocal.so
301%{camel_provider_dir}/libcamellocal.urls
302
303%{camel_provider_dir}/libcamelnntp.so
304%{camel_provider_dir}/libcamelnntp.urls
305
306%{camel_provider_dir}/libcamelpop3.so
307%{camel_provider_dir}/libcamelpop3.urls
308
309%{camel_provider_dir}/libcamelsendmail.so
310%{camel_provider_dir}/libcamelsendmail.urls
311
312%{camel_provider_dir}/libcamelsmtp.so
313%{camel_provider_dir}/libcamelsmtp.urls
314
315# e-d-s extensions:
[4616]316%{ebook_backends_dir}/libebookbackendfile.so
317%{ebook_backends_dir}/libebookbackendgoogle.so
318%{ebook_backends_dir}/libebookbackendldap.so
319%{ebook_backends_dir}/libebookbackendwebdav.so
[521]320
[4616]321%{ecal_backends_dir}/libecalbackendcaldav.so
322%{ecal_backends_dir}/libecalbackendcontacts.so
323%{ecal_backends_dir}/libecalbackendfile.so
324%{ecal_backends_dir}/libecalbackendhttp.so
325%{ecal_backends_dir}/libecalbackendweather.so
326
[6890]327%{registry_modules_dir}/module-cache-reaper.so
328%{registry_modules_dir}/module-google-backend.so
[7633]329%{registry_modules_dir}/module-gnome-online-accounts.so
[7938]330%{registry_modules_dir}/module-outlook-backend.so
[7633]331%{registry_modules_dir}/module-owncloud-backend.so
[8353]332%{registry_modules_dir}/module-secret-monitor.so
[7633]333%{registry_modules_dir}/module-trust-prompt.so
[6890]334%{registry_modules_dir}/module-yahoo-backend.so
335
[521]336%files devel
337%defattr(-,root,root,-)
[7633]338%{_includedir}/%{name}
[521]339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*.pc
[4616]341%{_datadir}/gir-1.0/*.gir
[521]342
343%files doc
344%defattr(-,root,root,-)
345%{_datadir}/gtk-doc/html/camel
[8353]346%{_datadir}/gtk-doc/html/eds
[521]347
[7633]348%files vala
349%defattr(-,root,root,-)
350%{_datadir}/vala/vapi/libebook-1.2.deps
351%{_datadir}/vala/vapi/libebook-1.2.vapi
352%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
353%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
354%{_datadir}/vala/vapi/libedataserver-1.2.deps
355%{_datadir}/vala/vapi/libedataserver-1.2.vapi
356
357
[521]358%changelog
[8353]359* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
360- new upstream release
361- add BuildRequires: libicu-devel
362
[8060]363* Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
364- new upstream release
365
[8011]366* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
367- new upstream release
368
[7938]369* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
370- new upstream release
371
[7756]372* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
373- new upstream release
374
[7712]375* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
376- new upstream release
377
[7681]378* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
379- new upstream release
380
[7633]381* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
382- new upstream release
383- add configure option (--disable-uoa)
384- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
385- create %%{name}-vala subpackage
386
[7538]387* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
388- new upstream release
389
[7474]390* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
391- new upstream release
392
[7119]393* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
394- new upstream release
395
[6933]396* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
397- new upstream release
398
[6890]399* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
400- new upstream release
401
[6739]402* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
403- new upstream release
404
[6401]405* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
406- new upstream release
407
[6201]408* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
409- new upstream release
410
[6078]411* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]412- new upstream release
413- add BuildRequires: dbus-glib-devel
414
[5402]415* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
416- new upstream release
417
[5168]418* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
419- new upstream release
420
[5038]421* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
422- new upstream release
423
[4850]424* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
425- new upstream release
426
[4812]427* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
428- new upstream release
429- remove Patch101
430
[4704]431* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
432- new upstream release
433
[4616]434* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
[3801]435- new upstream release
[4616]436- change BuildRequires: gtk3-devel instead of gtk2-devel
437- BuildRequires: gnome-online-accounts-devel
438- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
439- fix %%files
[3801]440
[2661]441* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
442- new upstream release
443
[2483]444* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
445- rebuild with openssl-1.0.0c
[2219]446
[2041]447* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
448- new upstream release
449- remove Requires: gnome-vfs2, libglade2, libgnomeui
450- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
451- add BuildRequires: libgdata
452- add Requires: nspr-devel, nss-devel (devel package)
453- drop Patch11
454
[1883]455* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
456- rebuild with rpm-4.8.1 for pkg-config file
457
[1231]458* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
459- new upstream release
460
[926]461* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
462- new upstream release
463
[805]464* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
465- new upstream release
466- remove BuildRequires: libbonobo-devel
467- remove Requires: libbonobo
468- drop Patch10
469- add configure option (--with-krb5-libs, --with-krb5-includes)
470
[521]471* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
472- rebuilt with db4-4.8
473
474* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
475- new upstream release
476
477* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
478- new upstream release
479
480* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
481- new upstream release
482
483* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
484- new upstream release
485
486* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
487- added Requires: libical-devel >= 0.43 to devel package
488
489* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
490- new upstream release
491- add BR: libgweather-devel >= 2.26.0
492- add BR: libical-devel >= 0.43
493
494* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
495- new upstream release
496- added BuildRequires: sqlite3-devel
497
498* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
499- enabled krb5 support
500
501* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
502- new upstream release
503
504* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
505- new upstream release
506
507* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
508- new upstream release
509
510* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
511- new upstream release
512
513* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
514- rebuilt with db4-4.6.21
515
516* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
517- new upstream release
518
519* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
520- new upstream release
521
522* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
523- new upstream release
524
525* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
526- new upstream release based on Fedora package 2.20.0-3.fc9
527  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
528  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
529  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
530  - Add patch for RH bug #296671 (GC servers may not support NTLM).
531  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
532  - Try removing the ancient "ldap-x86_64-hack" patch.
533  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
534  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
535- split doc subpackage
536
537* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
538- fixed dependancy
539
540* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
541- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
542  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
543  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
544  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
545  - Make the new ESourceComboBox widget work properly (RH bug #234760).
546  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
547  - Link to static evolution-openldap library (RH bug #210126).
548  - Require openssl-devel when statically linking against openldap.
549  - Add -Wdeclaration-after-statement to strict build settings.
550  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
551  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
552  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
553  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
554  - Update to 1.10.0
555  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
556  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
557  - Patch by Kenny Root.
558- rebuilt with nss-devel and nspr-devel
559
560* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
561- rebuilt with new toolchain and db4-4.3.x
562
563* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
564- new upstream release
565
566* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
567- new upstream release
568- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
569
570* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
571- new upstream release
572- rebuilt with openssl instead of mozilla-nss
573
574* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
575- rebuilt with openldap-2.3.24-0vl4
576
577* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
578- new upstream release
579- build with libsoap-2.2.7
580
581* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
582- new upstream release
583
584* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
585- new upstream release
586- added/removed Patches based on Fedora packages
587  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
588  - Updated patch 102 to fix further implicit function declarations
589  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
590  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
591    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
592  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
593  - Removed upstreamed patch:
594    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
595  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
596  - added patch to calendar/libecal/e-cal.c to fix missing declaration
597    of open_calendar
598- rebuilt with mozilla-1.7.12
599
[7633]600* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
[521]601- rebuilt with mozilla-1.7.7
602
603* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
604- initial build for Vine Linux based on FC package
605- disable krb5 support
606
607* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
608- 1.2.1
609
610* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
611- Removed explicit run-time spec-file requirement on mozilla.
612  The Mozilla NSS API/ABI stabilised by version 1.7.3
613  The libraries are always located in the libdir
614  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
615  and so they move each time the mozilla version changes.
616  So we no longer have an explicit mozilla run-time requirement in the specfile;
617  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
618  We have an explicit, exact build-time version, so that we can find the headers (without
619  invoking an RPM query from the spec file; to do so is considered bad practice)
620- Introduced mozilla_build_version, to replace mozilla_version
621- Set mozilla_build_version to 1.7.6 to reflect current state of tree
622
623* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
624- Added a patch to deal with glibc defining a macro called "read"
625
626* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
627- 1.2.0
628- Removed patch for GCC 4 as this is now in upstream tarball
629
630* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
631- rebuild to fix library linking silliness
632
633* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
634- disabling gtk-doc on ia64 and s390x
635
636* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
637- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
638
639* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
640- extended patch to deal with camel-groupwise-store-summary.c
641
642* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
643- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
644
645* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
646- 1.1.6
647
648* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
649- rebuild
650
651* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
652- forgot to fix sources
653
654* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
655- 1.1.5
656
657* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
658- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
659
660* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
661- disable gtk-doc generation on ia64 for now
662
663* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
664- Exclude ppc64 due to missing mozilla dependency
665
666* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
667- Update from 1.0.3 to 1.1.4.1
668- Updated eds_major from 1.0 to 1.2; fixed translation search path.
669- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
670- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
671- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
672- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
673- Camel code from evolution is now in evolution-data-server:
674  - Added camel-index-control and camel-lock-helper to packaged files
675  - Added mozilla dependency code from the evolution package
676  - Ditto for LDAP
677  - Ditto for krb5
678  - Ditto for NNTP support handling
679  - Ditto for --enable-file-locking and --enable-dot-locking
680- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
681- Updated libsoup requirement from 2.2.1 to 2.2.2
682- Enabled gtk-doc
683
684* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
685- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
686
687* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
688- update from upstream 1.0.2 to 1.0.3:
689  * Address Book
690    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
691    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
692
693  * Calendar
694    #XB59904 - Speed up calendar queries (Rodrigo)
695    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
696    - fix libical build for automake 1.9 (Rodney)
697    - fix putenv usage for portability (Julio M. Merino Vidal)
698
699  * Updated Translations:
700    - sv (Christian Rose)
701
702- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
703
704* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
705- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
706http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
707(The groupwise part of that patch did not cleanly apply, so I removed it).
708
709* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
710- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
711optimisation patch posted to upstream development mailing list here:
712http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
713
714* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
715- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
716
717* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
718- added workaround for a backend leak that causes the "contacts" calendar
719backend to hold open an EBook for the local contacts (filed upstream at:
720http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
721never lose its last addressbook, and hence never quit.  We workaround this by
722detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
723
724* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
725- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
726
727* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
728- update from 1.0.1 to 1.0.2
729- increased libsoup requirement to 2.2.1 to match configuration script
730
731* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
732- update from 1.0.0 to 1.0.1
733- removed patch that fixed warnings in calendar code (now in upstream tarball)
734
735* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
736- fixed various warnings in the calendar code
737  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
738
739* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
740- update from 0.0.99 to 1.0.0
741- changed path in FTP source location from 0.0 to 1.0
742
743* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
744- update from 0.0.98 to 0.0.99
745- increased libsoup requirement to 2.2.0 to match configuration script
746
747* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
748- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
749
750* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
751- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
752
753* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
754- upgraded to 0.0.97; rewrote the package's description
755
756* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
757- rebuilt
758
759* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
760- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
761
762* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
763- 0.0.96; libsoup required is now 2.1.12
764
765* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
766- rebuilt
767
768* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
769- rebuilt
770
771* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
772- 0.0.95
773
774* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
775- 0.0.94.1
776
777* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
778- rebuilt
779
780* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
781- 0.0.94
782
783* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
784- added ORBit2 requirement
785
786* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
787- rebuild again
788
789* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
790- rebuilt
791
792* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
793- 0.0.93; libsoup required is now 2.1.10
794
795* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
796- Update to 0.0.92; added a define and a requirement on the libsoup version
797
798* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
799- 0.0.90
800
801* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
802- rebuilt
803
804* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
805- 0.0.6
806
807* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
808- better fix by using system libtool
809
810* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
811- add some libdb linkage to make the build on x86_64 happy
812
813* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
814- update to 0.0.5
815
816* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
817- Initial build.
Note: See TracBrowser for help on using the repository browser.