source: projects/specs/trunk/e/evolution-data-server/evolution-data-server-vl.spec @ 7681

Revision 7681, 27.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME 3.8.2

RevLine 
[521]1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
[6890]7%define glib2_version 2.34.0
8%define gtk3_version 3.6.0
[4850]9%define gtk_doc_version 1.18
[521]10%define intltool_version 0.35.5
[2041]11%define orbit2_version 2.14.19
[4850]12%define soup_version 2.36.0
13%define libgweather_version 3.2.0
[2041]14%define libical_version 0.44
[4850]15%define libgdata_version 0.10.1
[521]16
[7633]17%define eds_base_version 3.8
[521]18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
[4616]23%define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
24%define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
25%define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
[6890]26%define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
[521]27
28### Abstract ###
29
30Summary: Backend data server for evolution
31Summary(ja): Evolution バックエンドデータサーバ
32Name: evolution-data-server
[7681]33Version: 3.8.2
[3801]34Release: 1%{?_dist_release}
[521]35License: LGPL
36Group: System Environment/Libraries
37URL: http://www.gnome.org/projects/evolution/
[7633]38Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.8/%{name}-%{version}.tar.xz
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40
41### Patches ###
42
43# RH bug #243296
44Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
45
46### Dependencies ###
47
[6890]48#Requires: ORBit2 >= %{orbit2_version}
[521]49Requires: libsoup >= %{soup_version}
50
51### Build Dependencies ###
52
[6890]53#BuildRequires: ORBit2-devel >= %{orbit2_version}
[521]54BuildRequires: bison
55BuildRequires: db4-devel
56BuildRequires: flex
57BuildRequires: gettext
58BuildRequires: glib2-devel
[4616]59BuildRequires: gtk3-devel
[6011]60BuildRequires: dbus-glib-devel
[521]61BuildRequires: gnutls-devel
62BuildRequires: intltool >= %{intltool_version}
63BuildRequires: libsoup-devel >= %{soup_version}
64BuildRequires: libtool
[805]65BuildRequires: libgnome-keyring-devel
66BuildRequires: gtk-doc >= 1.14
[521]67BuildRequires: sqlite3-devel
68BuildRequires: libgweather-devel >= %{libgweather_version}
69BuildRequires: libical-devel >= %{libical_version}
[805]70BuildRequires: gperf
[4616]71BuildRequires: krb5-devel
[2041]72BuildRequires: libgdata-devel >= %{libgdata_version}
[4616]73BuildRequires: gnome-online-accounts-devel
74BuildRequires: liboauth-devel
[7633]75BuildRequires: libsecret-devel
76BuildRequires: gnome-common
[521]77
[7633]78BuildRequires: vala
79BuildRequires: vala-tools
80
[521]81%if %{use_nss}
82BuildRequires: nspr-devel
83BuildRequires: nss-devel
84%else
85BuildRequires: openssl-devel
86%endif
87
88%if %{ldap_support}
89%if %{static_ldap}
90BuildRequires: openldap-evolution-devel
91BuildRequires: openssl-devel
92%else
93BuildRequires: openldap-devel >= 2.0.11
94%endif
95%endif
96
97%if %{krb5_support}
98BuildRequires: krb5-devel
99# tweak for krb5 1.2 vs 1.3
100%define krb5dir /usr/kerberos
101#define krb5dir `pwd`/krb5-fakeprefix
102%endif
103
[4616]104Vendor: Project Vine
105Distribution: Vine Linux
106
[521]107%description
108The evolution-data-server package provides a unified backend for
109programs that work with contacts, tasks, and calendar information.
110
111It was originally developed for Evolution (hence the name), but
112is now used by other packages.
113
[7633]114
[521]115%package devel
116Summary: Development files for building against evolution-data-server
117Group: Development/Libraries
118Requires: %{name} = %{version}-%{release}
[6890]119Requires: pkgconfig
[521]120Requires: sqlite3-devel
[6890]121Requires: libgnome-keyring-devel
[521]122
123%description devel
124Development files needed for building things which link against
125evolution-data-server.
126
127
[7633]128%package                doc
129Summary:                Documentation for %{name}
130Summary(ja):    %{name} 用のドキュメント
131Group:                  Documentation
132Requires:               %{name} = %{version}-%{release}
133BuildArch:              noarch
134
[521]135%description doc
[7633]136This package contains documentation for %{name}.
[521]137
[7633]138
139%package        vala
140Summary:        Vala bindings for %{name}
141Summary(ja):    %{name} の Vala バインディング
142Group:          Development/Libraries
143Requires:       %{name} = %{version}-%{release}
144Requires:       vala
145
146%description    vala
147Vala bindings for %{name}.
148
149
[521]150%prep
151%setup -q
152
153%patch12 -p1 -b .fix-64bit-acinclude
154
155mkdir -p krb5-fakeprefix/include
156mkdir -p krb5-fakeprefix/lib
157mkdir -p krb5-fakeprefix/%{_lib}
158
159%build
160%if %{ldap_support}
161
162%if %{static_ldap}
163%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
164# Set LIBS so that configure will be able to link with static LDAP libraries,
165# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
[805]166if pkg-config libssl ; then
167        export LIBS="-lsasl2 `pkg-config --libs libssl`"
[521]168else
169        export LIBS="-lsasl2 -lssl -lcrypto"
170fi
171%else
172%define ldap_flags --with-openldap=yes
173%endif
174
175%else
176%define ldap_flags --without-openldap
177%endif
178
179%if %{krb5_support}
[805]180%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
[521]181%else
182%define krb5_flags --without-krb5
183%endif
184
185%if %{nntp_support}
186%define nntp_flags --enable-nntp=yes
187%else
188%define nntp_flags --enable-nntp=no
189%endif
190
191%if %{use_nss}
192%define ssl_flags --enable-nss=yes --enable-smime=yes
193%else
194%define ssl_flags --enable-openssl=yes
195%endif
196
197%if %{use_nss}
198if ! pkg-config --exists nss; then
199  echo "Unable to find suitable version of nss to use!"
200  exit 1
201fi
202%endif
203
204%if %{use_gnome_keyring}
205%define keyring_flags --enable-gnome-keyring
206%else
207%define keyring flags --disable-gnome-keyring
208%endif
209
210%if %{support_imap4_provider}
211%define imap4_flags --enable-imap4=yes
212%else
213%define imap4_flags --enable-imap4=no
214%endif
215
216export CPPFLAGS="-I%{_includedir}/et"
217export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
218
219# Regenerate configure to pick up configure.in and acinclude.m4 changes.
220aclocal -I m4
221autoheader
222automake
223libtoolize
224intltoolize --force
225autoconf
226
227# See Ross Burton's blog entry for why we want --with-libdb.
228# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
229
230%configure \
231        --with-libdb=/usr \
[7633]232        --disable-uoa \
[521]233        --enable-file-locking=fcntl \
234        --enable-dot-locking=no \
235        --enable-gtk-doc \
[7633]236        --enable-introspection=yes \
237        --enable-vala-bindings \
[521]238        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
239        %keyring_flags
240export tagname=CC
[4616]241#make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
242make LIBTOOL=/usr/bin/libtool
[521]243
244%install
245rm -rf $RPM_BUILD_ROOT
246export tagname=CC
247make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
248
249# remove libtool archives for importers and the like
250find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
[6890]251find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
[521]252
253# give the libraries some executable bits
254find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
255
256%find_lang %{name}-%{eds_base_version}
257
258%clean
259rm -rf $RPM_BUILD_ROOT
260
261%post -p /sbin/ldconfig
262
[6011]263%postun
264/sbin/ldconfig
265if [ $1 -eq 0 ]; then
266  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
267fi
[521]268
[6011]269%posttrans
270glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
271
272
[521]273%files -f %{name}-%{eds_base_version}.lang
274%defattr(-,root,root,-)
275%doc README COPYING ChangeLog NEWS AUTHORS
276%{_libdir}/*.so.*
[4616]277%{_libdir}/girepository-1.0/*.typelib
[6011]278%{_libexecdir}/evolution-addressbook-factory
279%{_libexecdir}/evolution-calendar-factory
[6890]280%{_libexecdir}/evolution-source-registry
[7633]281%{_libexecdir}/evolution-user-prompter
[521]282%{_libexecdir}/camel-index-control-%{eds_api_version}
283%{_libexecdir}/camel-lock-helper-%{eds_api_version}
[6890]284%{_datadir}/GConf/gsettings/evolution-data-server.convert
[6011]285%{_datadir}/GConf/gsettings/libedataserver.convert
286%{_datadir}/dbus-1/services/*
[7633]287%{_datadir}/%{name}/evolutionperson.schema
[6011]288%{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
289%{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
[6890]290%{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
291%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
292%{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
[521]293%{_datadir}/pixmaps/evolution-data-server
294
[4616]295%dir %{_libdir}/evolution-data-server
[521]296%dir %{camel_provider_dir}
[4616]297%dir %{ebook_backends_dir}
298%dir %{ecal_backends_dir}
[6890]299%dir %{registry_modules_dir}
[521]300
301# Camel providers:
[7633]302#%{camel_provider_dir}/libcamelimap.so
303#%{camel_provider_dir}/libcamelimap.urls
[521]304
[4616]305%{camel_provider_dir}/libcamelimapx.so
306%{camel_provider_dir}/libcamelimapx.urls
[521]307
308%{camel_provider_dir}/libcamellocal.so
309%{camel_provider_dir}/libcamellocal.urls
310
311%{camel_provider_dir}/libcamelnntp.so
312%{camel_provider_dir}/libcamelnntp.urls
313
314%{camel_provider_dir}/libcamelpop3.so
315%{camel_provider_dir}/libcamelpop3.urls
316
317%{camel_provider_dir}/libcamelsendmail.so
318%{camel_provider_dir}/libcamelsendmail.urls
319
320%{camel_provider_dir}/libcamelsmtp.so
321%{camel_provider_dir}/libcamelsmtp.urls
322
323# e-d-s extensions:
[4616]324%{ebook_backends_dir}/libebookbackendfile.so
325%{ebook_backends_dir}/libebookbackendgoogle.so
326%{ebook_backends_dir}/libebookbackendldap.so
[7633]327%{ebook_backends_dir}/module-data-book-factory-goa.so
[4616]328%{ebook_backends_dir}/libebookbackendwebdav.so
[521]329
[4616]330%{ecal_backends_dir}/libecalbackendcaldav.so
331%{ecal_backends_dir}/libecalbackendcontacts.so
332%{ecal_backends_dir}/libecalbackendfile.so
333%{ecal_backends_dir}/libecalbackendhttp.so
334%{ecal_backends_dir}/libecalbackendweather.so
[7633]335%{ecal_backends_dir}/module-data-cal-factory-goa.so
[4616]336
[6890]337%{registry_modules_dir}/module-cache-reaper.so
338%{registry_modules_dir}/module-google-backend.so
[7633]339%{registry_modules_dir}/module-gnome-online-accounts.so
340%{registry_modules_dir}/module-owncloud-backend.so
341%{registry_modules_dir}/module-trust-prompt.so
[6890]342%{registry_modules_dir}/module-yahoo-backend.so
343
[521]344%files devel
345%defattr(-,root,root,-)
[7633]346%{_includedir}/%{name}
[521]347%{_libdir}/*.so
348%{_libdir}/pkgconfig/*.pc
[4616]349%{_datadir}/gir-1.0/*.gir
[521]350
351%files doc
352%defattr(-,root,root,-)
353%{_datadir}/gtk-doc/html/camel
354%{_datadir}/gtk-doc/html/libebackend
355%{_datadir}/gtk-doc/html/libebook
[7633]356%{_datadir}/gtk-doc/html/libebook-contacts
[521]357%{_datadir}/gtk-doc/html/libecal
358%{_datadir}/gtk-doc/html/libedata-book
359%{_datadir}/gtk-doc/html/libedata-cal
360%{_datadir}/gtk-doc/html/libedataserver
361
[7633]362%files vala
363%defattr(-,root,root,-)
364%{_datadir}/vala/vapi/libebook-1.2.deps
365%{_datadir}/vala/vapi/libebook-1.2.vapi
366%{_datadir}/vala/vapi/libebook-contacts-1.2.deps
367%{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
368%{_datadir}/vala/vapi/libedataserver-1.2.deps
369%{_datadir}/vala/vapi/libedataserver-1.2.vapi
370
371
[521]372%changelog
[7681]373* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
374- new upstream release
375
[7633]376* Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
377- new upstream release
378- add configure option (--disable-uoa)
379- add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
380- create %%{name}-vala subpackage
381
[7538]382* Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
383- new upstream release
384
[7474]385* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
386- new upstream release
387
[7119]388* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
389- new upstream release
390
[6933]391* Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
392- new upstream release
393
[6890]394* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
395- new upstream release
396
[6739]397* Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
398- new upstream release
399
[6401]400* Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
401- new upstream release
402
[6201]403* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
404- new upstream release
405
[6078]406* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]407- new upstream release
408- add BuildRequires: dbus-glib-devel
409
[5402]410* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
411- new upstream release
412
[5168]413* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
414- new upstream release
415
[5038]416* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
417- new upstream release
418
[4850]419* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
420- new upstream release
421
[4812]422* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
423- new upstream release
424- remove Patch101
425
[4704]426* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
427- new upstream release
428
[4616]429* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
[3801]430- new upstream release
[4616]431- change BuildRequires: gtk3-devel instead of gtk2-devel
432- BuildRequires: gnome-online-accounts-devel
433- add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
434- fix %%files
[3801]435
[2661]436* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
437- new upstream release
438
[2483]439* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
440- rebuild with openssl-1.0.0c
[2219]441
[2041]442* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
443- new upstream release
444- remove Requires: gnome-vfs2, libglade2, libgnomeui
445- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
446- add BuildRequires: libgdata
447- add Requires: nspr-devel, nss-devel (devel package)
448- drop Patch11
449
[1883]450* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
451- rebuild with rpm-4.8.1 for pkg-config file
452
[1231]453* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
454- new upstream release
455
[926]456* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
457- new upstream release
458
[805]459* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
460- new upstream release
461- remove BuildRequires: libbonobo-devel
462- remove Requires: libbonobo
463- drop Patch10
464- add configure option (--with-krb5-libs, --with-krb5-includes)
465
[521]466* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
467- rebuilt with db4-4.8
468
469* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
470- new upstream release
471
472* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
473- new upstream release
474
475* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
476- new upstream release
477
478* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
479- new upstream release
480
481* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
482- added Requires: libical-devel >= 0.43 to devel package
483
484* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
485- new upstream release
486- add BR: libgweather-devel >= 2.26.0
487- add BR: libical-devel >= 0.43
488
489* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
490- new upstream release
491- added BuildRequires: sqlite3-devel
492
493* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
494- enabled krb5 support
495
496* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
497- new upstream release
498
499* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
500- new upstream release
501
502* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
503- new upstream release
504
505* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
506- new upstream release
507
508* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
509- rebuilt with db4-4.6.21
510
511* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
512- new upstream release
513
514* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
515- new upstream release
516
517* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
518- new upstream release
519
520* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
521- new upstream release based on Fedora package 2.20.0-3.fc9
522  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
523  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
524  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
525  - Add patch for RH bug #296671 (GC servers may not support NTLM).
526  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
527  - Try removing the ancient "ldap-x86_64-hack" patch.
528  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
529  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
530- split doc subpackage
531
532* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
533- fixed dependancy
534
535* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
536- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
537  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
538  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
539  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
540  - Make the new ESourceComboBox widget work properly (RH bug #234760).
541  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
542  - Link to static evolution-openldap library (RH bug #210126).
543  - Require openssl-devel when statically linking against openldap.
544  - Add -Wdeclaration-after-statement to strict build settings.
545  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
546  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
547  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
548  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
549  - Update to 1.10.0
550  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
551  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
552  - Patch by Kenny Root.
553- rebuilt with nss-devel and nspr-devel
554
555* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
556- rebuilt with new toolchain and db4-4.3.x
557
558* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
559- new upstream release
560
561* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
562- new upstream release
563- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
564
565* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
566- new upstream release
567- rebuilt with openssl instead of mozilla-nss
568
569* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
570- rebuilt with openldap-2.3.24-0vl4
571
572* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
573- new upstream release
574- build with libsoap-2.2.7
575
576* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
577- new upstream release
578
579* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
580- new upstream release
581- added/removed Patches based on Fedora packages
582  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
583  - Updated patch 102 to fix further implicit function declarations
584  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
585  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
586    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
587  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
588  - Removed upstreamed patch:
589    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
590  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
591  - added patch to calendar/libecal/e-cal.c to fix missing declaration
592    of open_calendar
593- rebuilt with mozilla-1.7.12
594
[7633]595* Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
[521]596- rebuilt with mozilla-1.7.7
597
598* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
599- initial build for Vine Linux based on FC package
600- disable krb5 support
601
602* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
603- 1.2.1
604
605* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
606- Removed explicit run-time spec-file requirement on mozilla.
607  The Mozilla NSS API/ABI stabilised by version 1.7.3
608  The libraries are always located in the libdir
609  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
610  and so they move each time the mozilla version changes.
611  So we no longer have an explicit mozilla run-time requirement in the specfile;
612  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
613  We have an explicit, exact build-time version, so that we can find the headers (without
614  invoking an RPM query from the spec file; to do so is considered bad practice)
615- Introduced mozilla_build_version, to replace mozilla_version
616- Set mozilla_build_version to 1.7.6 to reflect current state of tree
617
618* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
619- Added a patch to deal with glibc defining a macro called "read"
620
621* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
622- 1.2.0
623- Removed patch for GCC 4 as this is now in upstream tarball
624
625* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
626- rebuild to fix library linking silliness
627
628* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
629- disabling gtk-doc on ia64 and s390x
630
631* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
632- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
633
634* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
635- extended patch to deal with camel-groupwise-store-summary.c
636
637* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
638- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
639
640* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
641- 1.1.6
642
643* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
644- rebuild
645
646* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
647- forgot to fix sources
648
649* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
650- 1.1.5
651
652* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
653- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
654
655* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
656- disable gtk-doc generation on ia64 for now
657
658* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
659- Exclude ppc64 due to missing mozilla dependency
660
661* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
662- Update from 1.0.3 to 1.1.4.1
663- Updated eds_major from 1.0 to 1.2; fixed translation search path.
664- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
665- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
666- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
667- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
668- Camel code from evolution is now in evolution-data-server:
669  - Added camel-index-control and camel-lock-helper to packaged files
670  - Added mozilla dependency code from the evolution package
671  - Ditto for LDAP
672  - Ditto for krb5
673  - Ditto for NNTP support handling
674  - Ditto for --enable-file-locking and --enable-dot-locking
675- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
676- Updated libsoup requirement from 2.2.1 to 2.2.2
677- Enabled gtk-doc
678
679* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
680- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
681
682* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
683- update from upstream 1.0.2 to 1.0.3:
684  * Address Book
685    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
686    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
687
688  * Calendar
689    #XB59904 - Speed up calendar queries (Rodrigo)
690    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
691    - fix libical build for automake 1.9 (Rodney)
692    - fix putenv usage for portability (Julio M. Merino Vidal)
693
694  * Updated Translations:
695    - sv (Christian Rose)
696
697- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
698
699* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
700- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
701http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
702(The groupwise part of that patch did not cleanly apply, so I removed it).
703
704* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
705- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
706optimisation patch posted to upstream development mailing list here:
707http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
708
709* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
710- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
711
712* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
713- added workaround for a backend leak that causes the "contacts" calendar
714backend to hold open an EBook for the local contacts (filed upstream at:
715http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
716never lose its last addressbook, and hence never quit.  We workaround this by
717detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
718
719* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
720- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
721
722* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
723- update from 1.0.1 to 1.0.2
724- increased libsoup requirement to 2.2.1 to match configuration script
725
726* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
727- update from 1.0.0 to 1.0.1
728- removed patch that fixed warnings in calendar code (now in upstream tarball)
729
730* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
731- fixed various warnings in the calendar code
732  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
733
734* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
735- update from 0.0.99 to 1.0.0
736- changed path in FTP source location from 0.0 to 1.0
737
738* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
739- update from 0.0.98 to 0.0.99
740- increased libsoup requirement to 2.2.0 to match configuration script
741
742* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
743- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
744
745* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
746- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
747
748* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
749- upgraded to 0.0.97; rewrote the package's description
750
751* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
752- rebuilt
753
754* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
755- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
756
757* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
758- 0.0.96; libsoup required is now 2.1.12
759
760* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
761- rebuilt
762
763* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
764- rebuilt
765
766* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
767- 0.0.95
768
769* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
770- 0.0.94.1
771
772* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
773- rebuilt
774
775* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
776- 0.0.94
777
778* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
779- added ORBit2 requirement
780
781* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
782- rebuild again
783
784* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
785- rebuilt
786
787* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
788- 0.0.93; libsoup required is now 2.1.10
789
790* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
791- Update to 0.0.92; added a define and a requirement on the libsoup version
792
793* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
794- 0.0.90
795
796* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
797- rebuilt
798
799* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
800- 0.0.6
801
802* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
803- better fix by using system libtool
804
805* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
806- add some libdb linkage to make the build on x86_64 happy
807
808* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
809- update to 0.0.5
810
811* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
812- Initial build.
Note: See TracBrowser for help on using the repository browser.