source: projects/specs/trunk/e/etckeeper/etckeeper-vl.spec @ 7276

Revision 7276, 7.2 KB checked in by daisuke, 11 years ago (diff)

etckeeper: update to 0.64

Line 
1%global with_bzr 0
2
3%global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
4
5Summary: Store /etc in a SCM system (git, mercurial or darcs)
6Summary(ja): /etc をバージョン管理システム(git,mercurialなど)で管理するツール
7
8Name:      etckeeper
9Version:   0.64
10Release:   1%{?_dist_release}
11Group:     Applications/System
12License:   GPLv2+
13URL:       http://kitenet.net/~joey/code/etckeeper/
14
15Source0:   http://ftp.debian.org/debian/pool/main/e/etckeeper/%{name}_%{version}.tar.gz
16Source1:   README.Vine
17Source2:   README.Vine.en
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildArch: noarch
21Requires:  git
22Requires:  perl
23
24%description
25The etckeeper program is a tool to let /etc be stored in a git,
26mercurial, bzr or darcs repository. It hooks into yum to automatically
27commit changes made to /etc during package upgrades. It tracks file
28metadata that version control systems do not normally support, but that
29is important for /etc, such as the permissions of /etc/shadow. It's
30quite modular and configurable, while also being simple to use if you
31understand the basics of working with version control.
32
33The default backend is git, if want to use a another backend please
34install the appropriate tool (mercurial, darcs).
35%if %{with_bzr}
36To use bzr as backend, please also install the %{name}-bzr package.
37%endif
38
39To start using the package please read %{_docdir}/%{name}-%{version}/README
40
41%if %{with_bzr}
42%package bzr
43Summary:  Support for bzr with etckeeper
44Summary(ja):  Support for bzr with etckeeper
45Group:    Applications/System
46Requires: %{name} = %{version}-%{release} bzr
47BuildRequires: bzr
48BuildRequires: python-devel
49
50%description bzr
51This package provides a bzr backend for etckeeper, if you want to use
52etckeeper with bzr backend, install this package.
53%endif
54
55%prep
56%setup -q -n %{name}
57%{__perl} -pi -e '
58    s|LOWLEVEL_PACKAGE_MANAGER=dpkg|LOWLEVEL_PACKAGE_MANAGER=rpm|;
59    ' etckeeper.conf
60cp -av %{SOURCE1} %{SOURCE2} .
61
62%build
63make %{?_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=%{buildroot} INSTALL="%{__install} -p"
68%{__install} -D -p debian/cron.daily %{buildroot}%{_sysconfdir}/cron.daily/%{name}
69%{__install} -d  %{buildroot}%{_localstatedir}/cache/%{name}
70%if %{with_bzr}
71%{__sed} -i -e '1d' %{buildroot}%{python_sitelib}/bzrlib/plugins/%{name}/__init__.py
72%endif
73
74mv %{buildroot}%{_sysconfdir}/apt/apt.conf.d/05etckeeper \
75   %{buildroot}%{_sysconfdir}/apt/apt.conf.d/05etckeeper.conf
76
77%clean
78rm -rf %{buildroot}
79
80%post
81if [ $1 == 1 ] ; then
82  if [ ! -d /etc/.git ] ; then
83    %{_bindir}/%{name} init
84    ( cd /etc; git commit -m 'initial commit' )
85  fi
86fi
87if [ $1 -gt 1 ] ; then
88  %{_bindir}/%{name} update-ignore
89fi
90
91%files
92%defattr(-, root, root, -)
93%doc GPL TODO README README.Vine README.Vine.en
94%{_bindir}/%{name}
95%{_mandir}/man8/%{name}.8*
96%dir %{_sysconfdir}/%{name}
97%{_sysconfdir}/%{name}/*.d
98%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
99%{_sysconfdir}/cron.daily/%{name}
100%dir %{_sysconfdir}/bash_completion.d
101%config(noreplace) %{_sysconfdir}/bash_completion.d/%{name}
102%{_localstatedir}/cache/%{name}
103%config(noreplace) %{_sysconfdir}/apt/apt.conf.d/05etckeeper.conf
104%config(noreplace) %{_sysconfdir}/cruft/filters-unex/etckeeper
105     
106%if %{with_bzr}
107%files bzr
108%defattr(-, root, root, -)
109%doc GPL
110%{python_sitelib}/bzrlib/plugins/%{name}
111%{python_sitelib}/bzr_%{name}-*.egg-info
112%endif
113
114%changelog
115* Sat Dec 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.64-1
116- update to 0.64
117
118* Mon May 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-1
119- initial build for Vine Linux
120- disable bzr support by default
121- run etckeeper initialize and first commit on first install.
122
123* Tue Mar 13 2012 Thomas Moschny <thomas.moschny@gmx.de> - 0.62-2
124- Add missing dependency on perl (bz 798563).
125
126* Tue Mar 13 2012 Thomas Moschny <thomas.moschny@gmx.de> - 0.62-1
127- Update to 0.62.
128
129* Tue Jan 17 2012 Thomas Moschny <thomas.moschny@gmx.de> - 0.61-1
130- Update to 0.61.
131
132* Fri Jan 13 2012 Thomas Moschny <thomas.moschny@gmx.de> - 0.60-1
133- Update to 0.60.
134
135* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.58-2
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
137
138* Thu Dec  1 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.58-1
139- Update to 0.58.
140
141* Wed Nov  9 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.57-1
142- Update to 0.57.
143
144* Wed Aug 17 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.56-2
145- Rebuilt for trailing slash bug of rpm-4.9.1
146
147* Thu Jul 21 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.56-1
148- Update to 0.56.
149
150* Fri Jun 24 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.55-1
151- Update to 0.55.
152
153* Wed Jun  1 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.54-1
154- Update to 0.54.
155- Add patch for bz 709487.
156
157* Mon Mar 28 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.53-1
158- Update to 0.53.
159- Run update-ignore on package upgrade (bz 680632).
160
161* Wed Feb  9 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.52-1
162- Update to 0.52.
163- Include a README.fedora (bz 670934).
164
165* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.51-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
167
168* Mon Jan  3 2011 Thomas Moschny <thomas.moschny@gmx.de> - 0.51-1
169- Update to 0.51.
170- etckeeper has been moved out of sbin.
171
172* Sat Dec 11 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.50-2
173- Don't package INSTALL.
174
175* Wed Oct 27 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.50-1
176- Update to 0.50.
177- Change %%define -> %%global.
178
179* Fri Sep 17 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.49-2
180- Adjust minimum required version of GIT.
181- egg-info files are not created automatically on RHEL5.
182
183* Wed Sep 15 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.49-1
184- Update to 0.49.
185- Remove obsolete patch.
186
187* Fri Sep  3 2010 Thomas Moschny <thomas.moschny@gmx.de> - 0.48-1
188- Update to 0.48.
189- Don't list /etc/etckeeper/*.d directories twice in %%files.
190- Add patch from upstream that fixes bz 588086.
191
192* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.41-2
193- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
194
195* Sat Sep 12 2009 Bernie Innocenti <bernie@codewiz.org> - 0.41-1
196- Update to 0.41
197- Add missing directory ownerships
198
199* Sat Sep 12 2009 Bernie Innocenti <bernie@codewiz.org> - 0.40-3
200- Make the bzr subpackage builddepend on python-devel
201
202* Wed Sep 09 2009 Terje Rosten <terje.rosten@ntnu.no> - 0.40-2
203- Package is noarch
204- Rpmlint clean
205- Random cleanup
206- Ship cache dir in package
207- bzr subpackage
208- Add bzr to buildreq
209
210* Sat Sep 05 2009 Bernie Innocenti <bernie@codewiz.org> - 0.40-1
211- Update to 0.40
212
213* Sun Jun 14 2009 Bernie Innocenti <bernie@codewiz.org> - 0.37-1
214- Update to 0.37
215- Change license tag to GPLv2+
216
217* Fri Feb 27 2009 Jimmy Tang <jtang@tchpc.tcd.ie> - 0.33-4
218- fix up initial install to make directory in /var/cache/etckeeper
219- install the etckeeper daily cron job
220- define some config files that shouldn't be replaced, should the hooks
221in commit.d, init.d etc... saved and not blown away? if so they can
222defined as config files. etckeeper should record the changes anyway.
223
224* Wed Feb 25 2009 Jimmy Tang <jtang@tchpc.tcd.ie> - 0.32-1
225- yum etckeeper plugin is now apart of this package
226
227* Tue Feb 24 2009 Jimmy Tang <jtang@tchpc.tcd.ie> - 0.31-1
228- initial package
Note: See TracBrowser for help on using the repository browser.