source: projects/specs/trunk/e/esound/esound-vl.spec @ 1900

Revision 1900, 8.4 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1# Note that this is NOT a relocatable package
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: Allows several audio streams to play on a single audio device.
5Summary(ja): オーディオストリームを単一デバイスから再生するサーバ
6Name:      esound
7Version:   0.2.38
8Release:   4%{?_dist_release}
9License:   GPL
10Group: System Environment/Daemons
11Source0:   ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-%{version}.tar.bz2
12Patch0:    esound-0.2.19-noerrors.patch
13URL:       http://www.tux.org/~ricdude/EsounD.html
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: alsa-lib-devel
16BuildRequires: audiofile-devel
17Requires: %{name}-libs = %{version}
18
19%description
20EsounD, the Enlightened Sound Daemon, is a server process that mixes
21several audio streams for playback by a single audio device. For
22example, if you're listening to music on a CD and you receive a
23sound-related event from ICQ, the two applications won't have to
24jockey for the use of your sound card.
25
26Install esound if you'd like to let sound applications share your
27audio device. You'll also need to install the audiofile package.
28
29%description -l ja
30EsounD (the Enlightened Sound Daemon) は複数のオーディオストリームを
31単一のオーディオデバイスから出力するためのサーバです。
32例えば、CD から音楽を聞いている時に ICQ からサウンドイベントを
33受け取った際、EsounD を介することによりこの2つのアプリケーションが
34サウンドカードの取り合いをせずに済むようになります。
35
36
37%package libs
38Summary: Library to talk to the EsounD daemon
39Summary(ja): EsounD 共有ライブラリ
40Group: Development/Libraries
41Obsoletes: %{name} < 0.2.38-2
42
43%description libs
44The esound-libs package includes the libraries required
45for applications to talk to the EsounD daemon.
46
47
48%package devel
49Summary: Development files for EsounD applications.
50Summary(ja): EsounD アプリケーション開発用ファイル
51Group: Development/Libraries
52Requires: %{name}-libs = %{version}
53Requires: audiofile-devel
54Requires: alsa-lib-devel
55
56
57%description devel
58The esound-devel Libraries, include files and other resources you can
59use to develop EsounD applications.
60
61Install esound-devel if you want to develop EsounD applications.
62
63%description devel -l ja
64このパッケージには EsounD アプリケーションを開発するのに必要な
65ライブラリ、include ファイル、その他のリソースが含まれます。
66
67EsounD アプリケーションを開発する場合には esound-devel パッケージを
68インストールしてください。
69
70
71%package -n compat32-%{name}-libs
72Summary: Library to talk to the EsounD daemon
73Summary(ja): EsounD 共有ライブラリ
74Group: System Environment/Daemons
75Requires: %{name}-libs = %{version}
76
77%description -n compat32-%{name}-libs
78The esound-libs package includes the libraries required
79for applications to talk to the EsounD daemon.
80
81
82%package -n compat32-%{name}-devel
83Summary: Development files for EsounD applications.
84Summary(ja): EsounD アプリケーション開発用ファイル
85Group: Development/Libraries
86Requires: %{name}-devel    = %{version}
87Requires: compat32-%{name}-libs = %{version}
88
89
90%description -n compat32-%{name}-devel
91The esound-devel Libraries, include files and other resources you can
92use to develop EsounD applications.
93
94Install esound-devel if you want to develop EsounD applications.
95
96%description -n compat32-%{name}-devel -l ja
97このパッケージには EsounD アプリケーションを開発するのに必要な
98ライブラリ、include ファイル、その他のリソースが含まれます。
99
100EsounD アプリケーションを開発する場合には esound-devel パッケージを
101インストールしてください。
102
103
104%prep
105%setup -q
106%patch0 -p1 -b .noerrors
107
108%build
109%configure --disable-static
110make
111
112
113%install
114rm -rf ${RPM_BUILD_ROOT}
115%makeinstall
116
117#strip ${RPM_BUILD_ROOT}%{_bindir}/* ||:
118#strip ${RPM_BUILD_ROOT}%{_libdir}/*.so.* ||:
119
120#cp -pr $RPM_BUILD_ROOT%{_docdir}/esound docs-to-install
121rm -rf $RPM_BUILD_ROOT%{_docdir}/esound
122rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
123
124%clean
125rm -rf ${RPM_BUILD_ROOT}
126
127%post libs -p /sbin/ldconfig
128
129%postun libs -p /sbin/ldconfig
130
131%post -n compat32-%{name}-libs -p /sbin/ldconfig
132
133%postun -n compat32-%{name}-libs -p /sbin/ldconfig
134
135
136%files
137%defattr(-, root, root)
138%{_bindir}/esd
139%{_bindir}/esdcat
140%{_bindir}/esdctl
141%{_bindir}/esddsp
142%{_bindir}/esdfilt
143%{_bindir}/esdloop
144%{_bindir}/esdmon
145%{_bindir}/esdplay
146%{_bindir}/esdrec
147%{_bindir}/esdsample
148%{_mandir}/man1/esd.1*
149%{_mandir}/man1/esdcat.1*
150%{_mandir}/man1/esdctl.1*
151%{_mandir}/man1/esddsp.1*
152%{_mandir}/man1/esdfilt.1*
153%{_mandir}/man1/esdloop.1*
154%{_mandir}/man1/esdmon.1*
155%{_mandir}/man1/esdplay.1*
156%{_mandir}/man1/esdrec.1*
157%{_mandir}/man1/esdsample.1*
158
159%files libs
160%defattr(-, root, root)
161%doc AUTHORS COPYING.LIB ChangeLog docs/esound.sgml docs/html
162%doc INSTALL NEWS README TIPS TODO
163%config(noreplace) %{_sysconfdir}/*
164%{_libdir}/lib*.so.*
165
166%files devel
167%defattr(-, root, root)
168%{_bindir}/esd-config
169%{_includedir}/*
170%{_datadir}/aclocal/*
171%{_libdir}/lib*.so
172%{_libdir}/pkgconfig/*.pc
173%{_mandir}/man1/esd-config.1*
174
175
176%if %{build_compat32}
177%files -n compat32-%{name}-libs
178%defattr(-, root, root)
179%{_libdir}/lib*.so.*
180
181
182%files -n compat32-%{name}-devel
183%defattr(-, root, root)
184%{_libdir}/lib*.so
185%{_libdir}/pkgconfig/*.pc
186%endif
187
188
189%changelog
190* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.38-4
191- rebuild with rpm-4.8.1 for pkg-config file
192
193* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.2.38-3
194- corrected Requires: tag on compat32-esound-devel
195- removed static libraries
196
197* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.38-2
198- split shared library to -libs subpackage.
199
200* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.38-1
201- applied new versioning policy
202- removed *.la file from devel package
203
204* Sat May  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.38-0vl1
205- new upstream release
206
207* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.37-0vl1
208- new upstream release
209
210* Sat Dec 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.2.36-0vl4
211- add Requires: alsa-lib-devel to -devel package
212
213* Mon May 13 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.2.36-0vl3
214- added compat32-* packages for x86_64 architecture support
215
216* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 0.2.36-0vl2
217- added BuildRequires: audiofile-devel
218- rebuilt for x86_64 architecture
219
220* Sun Jun 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.36-0vl1
221- new upstream release
222- build with alsa
223
224* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.35-0vl1
225- new upstream release
226- sync manpages to each package
227- added Patch0 from Fedora development 0.2.34-3
228
229* Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.2.31-0vl2
230- use License tag
231- add .la files to devel package
232
233* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.31-0vl1
234- new upstream release
235- add manpages to filelist
236
237* Tue Jan 07 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.29-0vl4
238- added missing pkgconfig file
239
240* Sun Jan  5 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.29-0vl1
241- new upstream release
242
243* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.22-0vl3
244- rebuild to remove rpmlib dependancy
245
246* Fri May 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
247- remove audio_oss patch
248
249* Thu Dec 14 2000 Yoichi Imai <yoichi@silver-forest.com>
250- 0.2.22-0vl1
251- comment out strip commands
252- changed /var/tmp to %{_tmppath}
253 
254* Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
255- 0.2.20-0vl1
256
257* Wed Sep 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
258- 0.2.19-0vl2
259- included a patch for audio_oss.c (backed to 0.2.17 style)
260
261* Wed Sep 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
262- 0.2.19-0vl1
263- udpated to 0.2.19 release
264- added Japanese Summary and Description
265
266* Sat Jun  3 2000 BIll Nottingham <notting@redhat.com> 0.2.18-2
267- rebuild. Apparently the compiler ate this last time.
268
269* Tue Apr 4 2000 Elliot Lee <sopwith@redhat.com> 0.2.18-1
270- Update to 0.2.18
271
272* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.2.13-1
273- Update to 0.2.13
274- Merge in changes from RHL 6.0 spec file.
275
276* Sat Nov 21 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
277
278- added %{_prefix}/share/aclocal/* to %files devel
279- added spanish and french translations for rpm
280
281* Thu Oct 1 1998 Ricdude <ericmit@ix.netcom.com>
282
283- make autoconf do the version updating for us.
284
285* Wed May 13 1998 Michael Fulbright <msf@redhat.com>
286
287- First try at an RPM
Note: See TracBrowser for help on using the repository browser.