source: projects/specs/trunk/e/epydoc/epydoc-vl.spec @ 5701

Revision 5701, 3.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
2
3Summary: Automatic API documentation generation tool for Python
4Summary(ja): Python 用の自動 API ドキュメント生成ツール
5Name: epydoc
6Version: 3.0.1
7Release: 3%{?_dist_release}
8Group: Development/Tools
9License: MIT
10URL: http://epydoc.sourceforge.net/
11Source0: http://dl.sf.net/epydoc/epydoc-%{version}.tar.gz
12Source1: epydocgui.desktop
13Patch0: epydoc-3.0.1-nohashbang.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15Requires: tkinter
16BuildRequires: python-devel
17BuildRequires: desktop-file-utils
18BuildArch: noarch
19
20%description
21Epydoc  is a tool for generating API documentation for Python modules,
22based  on their docstrings. For an example of epydoc's output, see the
23API  documentation for epydoc itself (html, pdf). A lightweight markup
24language  called  epytext can be used to format docstrings, and to add
25information  about  specific  fields,  such as parameters and instance
26variables.    Epydoc    also   understands   docstrings   written   in
27ReStructuredText, Javadoc, and plaintext.
28
29
30%prep
31%setup -q
32%patch0 -p1 -b .nohashbang
33
34
35%build
36%{__python} setup.py build
37
38
39%install
40%{__rm} -rf %{buildroot}
41%{__python} setup.py install -O1 --skip-build --root=%{buildroot}
42
43desktop-file-install \
44    --vendor="" \
45    --dir=%{buildroot}%{_datadir}/applications \
46    --mode=0644 \
47    %{SOURCE1}
48
49# Also install the man pages
50%{__mkdir_p} %{buildroot}%{_mandir}/man1
51%{__install} -p -m 0644 man/*.1 %{buildroot}%{_mandir}/man1/
52
53# Prevent having *.pyc and *.pyo in _bindir
54%{__mv} %{buildroot}%{_bindir}/apirst2html.py %{buildroot}%{_bindir}/apirst2html
55
56
57%clean
58%{__rm} -rf %{buildroot}
59
60
61%files
62%defattr(-,root,root,-)
63%doc LICENSE.txt README.txt doc/
64%{_bindir}/apirst2html
65%{_bindir}/epydoc
66%{_bindir}/epydocgui
67%{python_sitelib}/epydoc/
68%{python_sitelib}/epydoc-*.egg-info
69%{_datadir}/applications/epydocgui.desktop
70%{_mandir}/man1/*.1*
71
72
73%changelog
74* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-3
75- rebuild with python-2.7.2
76
77* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.1-2
78- rebuilt with python-2.6.4
79
80* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
81- initial build for Vine Linux
82
83* Sat Mar 22 2008 Matthias Saou <http://freshrpms.net/> 3.0.1-1
84- Update to 3.0.1.
85- Update nohashbang patch.
86- Include new apirst2html script, but remove .py extension to avoid .pyc/pyo.
87- Include egg-info file.
88
89* Tue Jun 19 2007 Matthias Saou <http://freshrpms.net/> 2.1-8
90- Remove desktop file prefix and X-Fedora category.
91- Include patch to remove #! python from files only meant to be included.
92
93* Mon Dec 11 2006 Matthias Saou <http://freshrpms.net/> 2.1-7
94- Rebuild against python 2.5.
95- Remove no longer needed explicit python-abi requirement.
96- Change python build requirement to python-devel, as it's needed now.
97
98* Wed Sep  6 2006 Matthias Saou <http://freshrpms.net/> 2.1-6
99- No longer ghost the .pyo files, as per new python guidelines (#205374).
100
101* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 2.1-5
102- FC6 rebuild.
103- Add %%{?dist} tag.
104- Update summary line.
105
106* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
107- rebuilt
108
109* Mon Dec 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 2.1-3
110- Change to noarch.
111- Get Python site-packages dir from distutils, should fix x86_64 build.
112- Require python-abi and tkinter.
113- %%ghost'ify *.pyo.
114- Fix man page permissions.
115- Add menu entry for epydocgui.
116
117* Tue Nov 16 2004 Matthias Saou <http://freshrpms.net/> 2.1-2
118- Bump release to provide Extras upgrade path.
119
120* Thu Oct 21 2004 Matthias Saou <http://freshrpms.net/> 2.1-1
121- Picked up and rebuilt.
122- Added doc and man pages.
123
124* Fri May 07 2004 Thomas Vander Stichele <thomas at apestaart dot org>
125- 2.1-0.fdr.1: Initial package
126
Note: See TracBrowser for help on using the repository browser.