source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 7633

Revision 7633, 11.3 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.7.92
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 3.6.1
14Release: 2%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.6/%{name}-%{version}.tar.xz
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,postun): shared-mime-info
29
30%if %{with_gecko}
31BuildRequires: gecko-devel-unstable >= %{gecko_version}
32%endif
33%if %{with_webkit}
34BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
35%endif
36BuildRequires: glib2-devel >= 2.31.2
37BuildRequires: gtk3-devel >= 3.3.14
38BuildRequires: libxml2-devel >= 2.6.12
39BuildRequires: libxslt-devel >= 1.1.7
40BuildRequires: libnotify-devel >= 0.4.0
41BuildRequires: libsoup-devel >= 2.37.1
42BuildRequires: gnome-desktop3-devel >= 2.91.2
43BuildRequires: libSM-devel
44BuildRequires: libgnome-keyring-devel
45BuildRequires: gcr-devel >= 3.5.5
46BuildRequires: gobject-introspection-devel
47BuildRequires: gsettings-desktop-schemas-devel
48BuildRequires: sqlite3-devel
49BuildRequires: seed-devel
50BuildRequires: nss-devel
51BuildRequires: avahi-gobject-devel
52BuildRequires: iso-codes
53BuildRequires: yelp-tools
54
55Vendor: Project Vine
56Distribution: Vine Linux
57
58%description
59epiphany is a simple GNOME web browser based on the Mozilla rendering
60engine
61
62%description -l ja
63epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
64ウェブブラウザです。
65
66%package devel
67Summary:        Epipany development environment
68Summary(ja):    Epipany の開発環境
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       pkgconfig
72
73%description devel
74Header files and libraries for building a extension library for the
75epipany.
76
77
78%prep
79%setup -q
80
81#patch1 -p1
82
83%build
84MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
85export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
86
87%configure \
88%if %{with_gecko}
89  --with-gecko=libxul-embedding \
90%endif
91%if %{with_webkit}
92  --with-engine=webkit \
93%endif
94  --enable-zeroconf \
95  --enable-network-manager \
96  --without-ca-file \
97  --enable-introspection=yes \
98  --enable-seed
99
100%__make %{?_smp_mflags}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make install DESTDIR=$RPM_BUILD_ROOT
106unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
107
108%find_lang %{name} --with-gnome
109
110rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
111
112
113%postun
114if [ $1 -eq 0 ] ; then
115    update-desktop-database %{_datadir}/applications >& /dev/null ||:
116    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117fi
118
119%posttrans
120update-desktop-database %{_datadir}/applications >& /dev/null ||:
121glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
122
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%files -f %{name}.lang
128%defattr(-,root,root,-)
129%doc AUTHORS ChangeLog* COPYING* NEWS README
130%{_bindir}/epiphany
131%{_bindir}/ephy-profile-migrator
132%{_libdir}/girepository-1.0/*.typelib
133%if %{with_gecko}
134%{_libdir}/epiphany
135%endif
136#{_datadir}/pygtk/*/defs/*
137%{_datadir}/GConf/gsettings/*.convert
138%{_datadir}/applications/*.desktop
139%{_datadir}/epiphany
140%{_datadir}/glib-2.0/schemas/*.xml
141%{_datadir}/dbus-1/services/*
142%{_mandir}/man1/epiphany.1*
143
144%files devel
145%defattr(-,root,root,-)
146%{_includedir}/%{name}
147%{_libdir}/pkgconfig/*.pc
148%{_datadir}/aclocal/*
149%{_datadir}/gir-1.0/*.gir
150%{_datadir}/gtk-doc/html/*
151
152
153%changelog
154* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
155- rebuild with gcr-3.8.1
156
157* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
158- new upstream release
159
160* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
161- new upstream release
162- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
163- change BuildRequires: yelp-tools instead of gnome-doc-utils
164- add BuildRequires: gcr-devel
165
166* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
167- new upstream release
168
169* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
170- new upstream release
171
172* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
173- new upstream release
174
175* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
176- new upstream release
177
178* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
182- new upstream release
183
184* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
185- new upstream release
186
187* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
188- new upstream release
189- add BuildRequires: gsettings-desktop-schemas
190- create -devel sub package
191
192* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
193- new upstream release
194- remove BuildRequires: gir-repository-devel
195
196* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
197- rebuilt with rpm-4.8.1 for pkg-config
198
199* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
200- new upstream release
201- add BuildRequires: gobject-introspection-devel, seed-devel
202- add configure option (--enable-introspection=yes, --enable-seed)
203
204* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
205- new upstream release
206- add BuildRequires: gobject-introspection-devel, gir-repository-devel
207- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
208- add configure option (--without-ca-file)
209- remove unrecognized configure option (--with-engine)
210
211* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
212- new upstream release
213- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
214
215* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
216- new upstream release
217
218* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
219- run gtk-update-icon-cache in %%post/postun script.
220
221* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
222- new upstream release
223
224* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
225- rebuild with gecko-1.9.1
226
227* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
228- new upstream release
229
230* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
231- new upstream release
232- build with xulrunner-1.9.0.7
233
234* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
235- new upstream release
236
237* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
238- build with gecko-1.9.0.3 instead of WebKit.
239  - WebKit port is unstable yet.
240- enable zeroconf, NetworkManager support
241
242* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
243- new upstream release
244
245* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
246- build with WebKit instead of gecko.
247
248* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
249- new upstream release
250- added %%pre and %%preun section
251
252* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
253- new upstream release
254- rebuilt with firefox-2.0.0.6-0vl3
255
256* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
257- add BuildRequires: gnome-python
258
259* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
260- new upstream release
261- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
262
263* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
264- new upstream release
265
266* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
267- source update
268- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
269- add BuildRequires: pygtk2-devel
270
271* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
272- new upstream release
273
274* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
275- rebuild with firefox-1.5.0.2-0vl4
276
277* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
278- new upstream release
279- build with firefox-1.5.0.2
280
281* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
282- new upstream release
283
284* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
285- new upstream release
286- build with firefox-1.5.0.1
287
288* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
289- new upstream release
290- build with mozilla-1.7.12
291
292* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
293- rebuild with mozilla-1.7.8
294
295* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
296- new upstream release
297
298* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
299- new upstream release
300- build with mozilla-1.7.7
301
302* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
303- rebuild with mozilla-1.7.6
304
305* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
306- new upstream release
307
308* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
309- new upstream release
310- build with mozilla-1.7.5
311
312* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
313- new upstream release
314
315* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
316- new upstream release
317
318* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
319- rebuild with mozilla-1.7.3
320
321* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
322- new upstream release
323- build with mozilla-1.7.2
324- add Patch10 to build with gnome-2.4
325
326* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
327- new upstream version
328        -- dropped patch10
329- changed URL
330
331* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
332- add alpha into ExclusiveArch
333
334* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
335- rebuild with mozilla-1.5.1
336
337* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
338- new upstream release
339
340* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
341- new upstream release
342
343* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
344- fixed missing locale files
345
346* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
347- new upstream release
348
349* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
350- new upstream release
351
352* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
353- new upstream release
354
355* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
356- new upstream release
357- build with mozilla 1.4
358
359* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
360- new upstream release
361
362* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
363- build for Vine Linux
364
365* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
366- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
367
368* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
369- 0.6.1
370
371* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
372- add patch to fix gint/gpointer conversion bugs for 64bit arches
373
374* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
375- only build on arches mozilla is built on
376
377* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
378- rebuild against new mozilla, make mozilla requires dynamic
379
380* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
381- update to 0.6.0
382- fix tyop in %%postun
383
384* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
385- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
386
387* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
388- add some buildrequires, prereq GConf2
389- disable building nautilus view
390
391* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
392- Initial build.
393
394
Note: See TracBrowser for help on using the repository browser.