source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 6951

Revision 6951, 11.2 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.7.92
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 3.6.1
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.6/%{name}-%{version}.tar.xz
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,postun): shared-mime-info
29
30%if %{with_gecko}
31BuildRequires: gecko-devel-unstable >= %{gecko_version}
32%endif
33%if %{with_webkit}
34BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
35%endif
36BuildRequires: glib2-devel >= 2.31.2
37BuildRequires: gtk3-devel >= 3.3.14
38BuildRequires: libxml2-devel >= 2.6.12
39BuildRequires: libxslt-devel >= 1.1.7
40BuildRequires: libnotify-devel >= 0.4.0
41BuildRequires: libsoup-devel >= 2.37.1
42BuildRequires: gnome-desktop3-devel >= 2.91.2
43BuildRequires: libSM-devel
44BuildRequires: libgnome-keyring-devel
45BuildRequires: gcr-devel >= 3.5.5
46BuildRequires: gobject-introspection-devel
47BuildRequires: gsettings-desktop-schemas-devel
48BuildRequires: sqlite3-devel
49BuildRequires: seed-devel
50BuildRequires: nss-devel
51BuildRequires: avahi-gobject-devel
52BuildRequires: iso-codes
53BuildRequires: yelp-tools
54
55Vendor: Project Vine
56Distribution: Vine Linux
57
58%description
59epiphany is a simple GNOME web browser based on the Mozilla rendering
60engine
61
62%description -l ja
63epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
64ウェブブラウザです。
65
66%package devel
67Summary:        Epipany development environment
68Summary(ja):    Epipany の開発環境
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       pkgconfig
72
73%description devel
74Header files and libraries for building a extension library for the
75epipany.
76
77
78%prep
79%setup -q
80
81#patch1 -p1
82
83%build
84MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
85export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
86
87%configure \
88%if %{with_gecko}
89  --with-gecko=libxul-embedding \
90%endif
91%if %{with_webkit}
92  --with-engine=webkit \
93%endif
94  --enable-zeroconf \
95  --enable-network-manager \
96  --without-ca-file \
97  --enable-introspection=yes \
98  --enable-seed
99
100%__make %{?_smp_mflags}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make install DESTDIR=$RPM_BUILD_ROOT
106unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
107
108%find_lang %{name} --with-gnome
109
110rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
111
112
113%postun
114if [ $1 -eq 0 ] ; then
115    update-desktop-database %{_datadir}/applications >& /dev/null ||:
116    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
117fi
118
119%posttrans
120update-desktop-database %{_datadir}/applications >& /dev/null ||:
121glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
122
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%files -f %{name}.lang
128%defattr(-,root,root,-)
129%doc AUTHORS ChangeLog* COPYING* NEWS README
130%{_bindir}/epiphany
131%{_bindir}/ephy-profile-migrator
132%{_libdir}/girepository-1.0/*.typelib
133%if %{with_gecko}
134%{_libdir}/epiphany
135%endif
136#{_datadir}/pygtk/*/defs/*
137%{_datadir}/GConf/gsettings/*.convert
138%{_datadir}/applications/*.desktop
139%{_datadir}/epiphany
140%{_datadir}/glib-2.0/schemas/*.xml
141%{_datadir}/dbus-1/services/*
142%{_mandir}/man1/epiphany.1*
143
144%files devel
145%defattr(-,root,root,-)
146%{_includedir}/%{name}
147%{_libdir}/pkgconfig/*.pc
148%{_datadir}/aclocal/*
149%{_datadir}/gir-1.0/*.gir
150%{_datadir}/gtk-doc/html/*
151
152
153%changelog
154* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
155- new upstream release
156
157* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
158- new upstream release
159- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
160- change BuildRequires: yelp-tools instead of gnome-doc-utils
161- add BuildRequires: gcr-devel
162
163* Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
164- new upstream release
165
166* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
167- new upstream release
168
169* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
170- new upstream release
171
172* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
173- new upstream release
174
175* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
176- new upstream release
177
178* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
179- new upstream release
180
181* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
182- new upstream release
183
184* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
185- new upstream release
186- add BuildRequires: gsettings-desktop-schemas
187- create -devel sub package
188
189* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
190- new upstream release
191- remove BuildRequires: gir-repository-devel
192
193* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
194- rebuilt with rpm-4.8.1 for pkg-config
195
196* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
197- new upstream release
198- add BuildRequires: gobject-introspection-devel, seed-devel
199- add configure option (--enable-introspection=yes, --enable-seed)
200
201* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
202- new upstream release
203- add BuildRequires: gobject-introspection-devel, gir-repository-devel
204- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
205- add configure option (--without-ca-file)
206- remove unrecognized configure option (--with-engine)
207
208* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
209- new upstream release
210- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
211
212* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
213- new upstream release
214
215* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
216- run gtk-update-icon-cache in %%post/postun script.
217
218* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
219- new upstream release
220
221* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
222- rebuild with gecko-1.9.1
223
224* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
225- new upstream release
226
227* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
228- new upstream release
229- build with xulrunner-1.9.0.7
230
231* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
232- new upstream release
233
234* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
235- build with gecko-1.9.0.3 instead of WebKit.
236  - WebKit port is unstable yet.
237- enable zeroconf, NetworkManager support
238
239* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
240- new upstream release
241
242* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
243- build with WebKit instead of gecko.
244
245* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
246- new upstream release
247- added %%pre and %%preun section
248
249* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
250- new upstream release
251- rebuilt with firefox-2.0.0.6-0vl3
252
253* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
254- add BuildRequires: gnome-python
255
256* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
257- new upstream release
258- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
259
260* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
261- new upstream release
262
263* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
264- source update
265- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
266- add BuildRequires: pygtk2-devel
267
268* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
269- new upstream release
270
271* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
272- rebuild with firefox-1.5.0.2-0vl4
273
274* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
275- new upstream release
276- build with firefox-1.5.0.2
277
278* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
279- new upstream release
280
281* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
282- new upstream release
283- build with firefox-1.5.0.1
284
285* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
286- new upstream release
287- build with mozilla-1.7.12
288
289* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
290- rebuild with mozilla-1.7.8
291
292* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
293- new upstream release
294
295* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
296- new upstream release
297- build with mozilla-1.7.7
298
299* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
300- rebuild with mozilla-1.7.6
301
302* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
303- new upstream release
304
305* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
306- new upstream release
307- build with mozilla-1.7.5
308
309* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
310- new upstream release
311
312* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
313- new upstream release
314
315* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
316- rebuild with mozilla-1.7.3
317
318* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
319- new upstream release
320- build with mozilla-1.7.2
321- add Patch10 to build with gnome-2.4
322
323* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
324- new upstream version
325        -- dropped patch10
326- changed URL
327
328* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
329- add alpha into ExclusiveArch
330
331* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
332- rebuild with mozilla-1.5.1
333
334* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
335- new upstream release
336
337* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
338- new upstream release
339
340* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
341- fixed missing locale files
342
343* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
344- new upstream release
345
346* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
347- new upstream release
348
349* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
350- new upstream release
351
352* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
353- new upstream release
354- build with mozilla 1.4
355
356* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
357- new upstream release
358
359* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
360- build for Vine Linux
361
362* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
363- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
364
365* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
366- 0.6.1
367
368* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
369- add patch to fix gint/gpointer conversion bugs for 64bit arches
370
371* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
372- only build on arches mozilla is built on
373
374* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
375- rebuild against new mozilla, make mozilla requires dynamic
376
377* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
378- update to 0.6.0
379- fix tyop in %%postun
380
381* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
382- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
383
384* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
385- add some buildrequires, prereq GConf2
386- disable building nautilus view
387
388* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
389- Initial build.
390
391
Note: See TracBrowser for help on using the repository browser.