source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 6201

Revision 6201, 10.9 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.7.92
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 3.4.2
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.4/%{name}-%{version}.tar.xz
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,postun): scrollkeeper, shared-mime-info
29
30%if %{with_gecko}
31BuildRequires: gecko-devel-unstable >= %{gecko_version}
32%endif
33%if %{with_webkit}
34BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
35%endif
36BuildRequires: glib2-devel >= 2.31.2
37BuildRequires: gtk3-devel >= 3.3.14
38BuildRequires: libxml2-devel >= 2.6.12
39BuildRequires: libxslt-devel >= 1.1.7
40BuildRequires: libnotify-devel >= 0.4.0
41BuildRequires: libsoup-devel >= 2.37.1
42BuildRequires: gnome-desktop-devel >= 2.30.0
43BuildRequires: libSM-devel
44BuildRequires: libgnome-keyring-devel
45BuildRequires: gobject-introspection-devel
46BuildRequires: gsettings-desktop-schemas-devel
47BuildRequires: sqlite3-devel
48BuildRequires: seed-devel
49BuildRequires: nss-devel
50BuildRequires: avahi-gobject-devel
51BuildRequires: iso-codes
52BuildRequires: gnome-doc-utils
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58epiphany is a simple GNOME web browser based on the Mozilla rendering
59engine
60
61%description -l ja
62epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
63ウェブブラウザです。
64
65%package devel
66Summary:        Epipany development environment
67Summary(ja):    Epipany の開発環境
68Group:          Development/Libraries
69Requires:       %{name} = %{version}-%{release}
70Requires:       pkgconfig
71
72%description devel
73Header files and libraries for building a extension library for the
74epipany.
75
76
77%prep
78%setup -q
79
80#patch1 -p1
81
82%build
83MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
84export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
85
86%configure \
87%if %{with_gecko}
88  --with-gecko=libxul-embedding \
89%endif
90%if %{with_webkit}
91  --with-engine=webkit \
92%endif
93  --enable-zeroconf \
94  --enable-network-manager \
95  --disable-scrollkeeper \
96  --without-ca-file \
97  --enable-introspection=yes \
98  --enable-seed
99
100%__make %{?_smp_mflags}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make install DESTDIR=$RPM_BUILD_ROOT
106unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
107
108%find_lang %{name} --with-gnome
109
110rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
111rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
112
113
114%postun
115if [ $1 -eq 0 ] ; then
116    update-desktop-database %{_datadir}/applications >& /dev/null ||:
117    scrollkeeper-update >& /dev/null ||:
118    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119fi
120
121%posttrans
122update-desktop-database %{_datadir}/applications >& /dev/null ||:
123scrollkeeper-update >& /dev/null ||:
124glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
125
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files -f %{name}.lang
131%defattr(-,root,root,-)
132%doc AUTHORS ChangeLog* COPYING* NEWS README
133%{_bindir}/epiphany
134%{_bindir}/ephy-profile-migrator
135%{_libdir}/girepository-1.0/*.typelib
136%if %{with_gecko}
137%{_libdir}/epiphany
138%endif
139#{_datadir}/pygtk/*/defs/*
140%{_datadir}/GConf/gsettings/*.convert
141%{_datadir}/applications/*.desktop
142%{_datadir}/epiphany
143%{_datadir}/glib-2.0/schemas/*.xml
144%{_datadir}/dbus-1/services/*
145%{_mandir}/man1/epiphany.1*
146
147%files devel
148%defattr(-,root,root,-)
149%{_includedir}/%{name}
150%{_libdir}/pkgconfig/*.pc
151%{_datadir}/aclocal/*
152%{_datadir}/gir-1.0/*.gir
153%{_datadir}/gtk-doc/html/*
154
155
156%changelog
157* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
158- new upstream release
159
160* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
161- new upstream release
162
163* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
164- new upstream release
165
166* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
167- new upstream release
168
169* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
170- new upstream release
171
172* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
173- new upstream release
174
175* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
176- new upstream release
177- add BuildRequires: gsettings-desktop-schemas
178- create -devel sub package
179
180* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
181- new upstream release
182- remove BuildRequires: gir-repository-devel
183
184* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
185- rebuilt with rpm-4.8.1 for pkg-config
186
187* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
188- new upstream release
189- add BuildRequires: gobject-introspection-devel, seed-devel
190- add configure option (--enable-introspection=yes, --enable-seed)
191
192* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
193- new upstream release
194- add BuildRequires: gobject-introspection-devel, gir-repository-devel
195- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
196- add configure option (--without-ca-file)
197- remove unrecognized configure option (--with-engine)
198
199* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
200- new upstream release
201- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
202
203* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
204- new upstream release
205
206* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
207- run gtk-update-icon-cache in %%post/postun script.
208
209* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
210- new upstream release
211
212* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
213- rebuild with gecko-1.9.1
214
215* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
216- new upstream release
217
218* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
219- new upstream release
220- build with xulrunner-1.9.0.7
221
222* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
223- new upstream release
224
225* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
226- build with gecko-1.9.0.3 instead of WebKit.
227  - WebKit port is unstable yet.
228- enable zeroconf, NetworkManager support
229
230* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
231- new upstream release
232
233* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
234- build with WebKit instead of gecko.
235
236* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
237- new upstream release
238- added %%pre and %%preun section
239
240* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
241- new upstream release
242- rebuilt with firefox-2.0.0.6-0vl3
243
244* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
245- add BuildRequires: gnome-python
246
247* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
248- new upstream release
249- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
250
251* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
252- new upstream release
253
254* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
255- source update
256- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
257- add BuildRequires: pygtk2-devel
258
259* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
260- new upstream release
261
262* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
263- rebuild with firefox-1.5.0.2-0vl4
264
265* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
266- new upstream release
267- build with firefox-1.5.0.2
268
269* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
270- new upstream release
271
272* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
273- new upstream release
274- build with firefox-1.5.0.1
275
276* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
277- new upstream release
278- build with mozilla-1.7.12
279
280* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
281- rebuild with mozilla-1.7.8
282
283* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
284- new upstream release
285
286* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
287- new upstream release
288- build with mozilla-1.7.7
289
290* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
291- rebuild with mozilla-1.7.6
292
293* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
294- new upstream release
295
296* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
297- new upstream release
298- build with mozilla-1.7.5
299
300* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
301- new upstream release
302
303* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
304- new upstream release
305
306* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
307- rebuild with mozilla-1.7.3
308
309* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
310- new upstream release
311- build with mozilla-1.7.2
312- add Patch10 to build with gnome-2.4
313
314* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
315- new upstream version
316        -- dropped patch10
317- changed URL
318
319* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
320- add alpha into ExclusiveArch
321
322* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
323- rebuild with mozilla-1.5.1
324
325* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
326- new upstream release
327
328* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
329- new upstream release
330
331* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
332- fixed missing locale files
333
334* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
335- new upstream release
336
337* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
338- new upstream release
339
340* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
341- new upstream release
342
343* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
344- new upstream release
345- build with mozilla 1.4
346
347* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
348- new upstream release
349
350* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
351- build for Vine Linux
352
353* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
354- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
355
356* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
357- 0.6.1
358
359* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
360- add patch to fix gint/gpointer conversion bugs for 64bit arches
361
362* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
363- only build on arches mozilla is built on
364
365* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
366- rebuild against new mozilla, make mozilla requires dynamic
367
368* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
369- update to 0.6.0
370- fix tyop in %%postun
371
372* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
373- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
374
375* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
376- add some buildrequires, prereq GConf2
377- disable building nautilus view
378
379* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
380- Initial build.
381
382
Note: See TracBrowser for help on using the repository browser.