source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 4616

Revision 4616, 10.9 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.4.2
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 3.1.3
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.1/%{name}-%{version}.tar.xz
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,pre,preun): GConf2
29Requires(post,postun): scrollkeeper, shared-mime-info
30
31%if %{with_gecko}
32BuildRequires: gecko-devel-unstable >= %{gecko_version}
33%endif
34%if %{with_webkit}
35BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
36%endif
37BuildRequires: glib2-devel >= 2.24.0
38BuildRequires: gtk3-devel >= 3.0.0
39BuildRequires: libxml2-devel >= 2.6.12
40BuildRequires: libxslt-devel >= 1.1.7
41BuildRequires: libnotify-devel >= 0.4.0
42BuildRequires: dbus-glib-devel >= 0.35
43BuildRequires: libsoup-devel >= 2.30.0
44BuildRequires: gnome-desktop-devel >= 2.30.0
45BuildRequires: GConf2-devel
46BuildRequires: nss-devel
47BuildRequires: avahi-gobject-devel >= 0.6.22
48BuildRequires: NetworkManager-devel
49BuildRequires: iso-codes
50BuildRequires: intltool >= 0.40
51BuildRequires: libICE-devel
52BuildRequires: libSM-devel
53BuildRequires: libgnome-keyring-devel
54BuildRequires: gobject-introspection-devel
55BuildRequires: gnome-doc-utils
56BuildRequires: seed-devel
57BuildRequires: gsettings-desktop-schemas
58
59Vendor: Project Vine
60Distribution: Vine Linux
61
62%description
63epiphany is a simple GNOME web browser based on the Mozilla rendering
64engine
65
66%description -l ja
67epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
68ウェブブラウザです。
69
70%package devel
71Summary:        Epipany development environment
72Summary(ja):    Epipany の開発環境
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       pkgconfig
76
77%description devel
78Header files and libraries for building a extension library for the
79epipany.
80
81
82%prep
83%setup -q
84
85#patch1 -p1
86
87%build
88MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
89export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
90
91%configure \
92%if %{with_gecko}
93  --with-gecko=libxul-embedding \
94%endif
95%if %{with_webkit}
96  --with-engine=webkit \
97%endif
98  --enable-zeroconf \
99  --enable-network-manager \
100  --disable-scrollkeeper \
101  --without-ca-file \
102  --enable-introspection=yes \
103  --enable-seed
104
105%__make %{?_smp_mflags}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
110make install DESTDIR=$RPM_BUILD_ROOT
111unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
112
113%find_lang %{name} --with-gnome
114
115rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
116rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
117
118rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
119
120
121%post
122touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
123
124%postun
125if [ $1 -eq 0 ] ; then
126    touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
127    gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
128    update-desktop-database %{_datadir}/applications >& /dev/null ||:
129    scrollkeeper-update >& /dev/null ||:
130    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
131fi
132
133%posttrans
134gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
135update-desktop-database %{_datadir}/applications >& /dev/null ||:
136scrollkeeper-update >& /dev/null ||:
137glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
138
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files -f %{name}.lang
144%defattr(-,root,root,-)
145%doc AUTHORS ChangeLog* COPYING* NEWS README
146%{_bindir}/epiphany
147%{_bindir}/ephy-profile-migrator
148%{_libdir}/girepository-1.0/*.typelib
149%if %{with_gecko}
150%{_libdir}/epiphany
151%endif
152#{_datadir}/pygtk/*/defs/*
153%{_datadir}/GConf/gsettings/*.convert
154%{_datadir}/applications/*.desktop
155%{_datadir}/epiphany
156%{_datadir}/glib-2.0/schemas/*.xml
157%{_datadir}/icons/*
158%{_datadir}/dbus-1/services/*
159%{_mandir}/man1/epiphany.1*
160
161%files devel
162%defattr(-,root,root,-)
163%{_includedir}/%{name}
164%{_libdir}/pkgconfig/*.pc
165%{_datadir}/aclocal/*
166%{_datadir}/gir-1.0/*.gir
167%{_datadir}/gtk-doc/html/*
168
169
170%changelog
171* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
172- new upstream release
173- add BuildRequires: gsettings-desktop-schemas
174- create -devel sub package
175
176* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
177- new upstream release
178- remove BuildRequires: gir-repository-devel
179
180* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
181- rebuilt with rpm-4.8.1 for pkg-config
182
183* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
184- new upstream release
185- add BuildRequires: gobject-introspection-devel, seed-devel
186- add configure option (--enable-introspection=yes, --enable-seed)
187
188* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
189- new upstream release
190- add BuildRequires: gobject-introspection-devel, gir-repository-devel
191- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
192- add configure option (--without-ca-file)
193- remove unrecognized configure option (--with-engine)
194
195* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
196- new upstream release
197- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
198
199* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
200- new upstream release
201
202* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
203- run gtk-update-icon-cache in %%post/postun script.
204
205* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
206- new upstream release
207
208* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
209- rebuild with gecko-1.9.1
210
211* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
212- new upstream release
213
214* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
215- new upstream release
216- build with xulrunner-1.9.0.7
217
218* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
219- new upstream release
220
221* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
222- build with gecko-1.9.0.3 instead of WebKit.
223  - WebKit port is unstable yet.
224- enable zeroconf, NetworkManager support
225
226* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
227- new upstream release
228
229* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
230- build with WebKit instead of gecko.
231
232* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
233- new upstream release
234- added %%pre and %%preun section
235
236* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
237- new upstream release
238- rebuilt with firefox-2.0.0.6-0vl3
239
240* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
241- add BuildRequires: gnome-python
242
243* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
244- new upstream release
245- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
246
247* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
248- new upstream release
249
250* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
251- source update
252- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
253- add BuildRequires: pygtk2-devel
254
255* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
256- new upstream release
257
258* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
259- rebuild with firefox-1.5.0.2-0vl4
260
261* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
262- new upstream release
263- build with firefox-1.5.0.2
264
265* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
266- new upstream release
267
268* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
269- new upstream release
270- build with firefox-1.5.0.1
271
272* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
273- new upstream release
274- build with mozilla-1.7.12
275
276* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
277- rebuild with mozilla-1.7.8
278
279* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
280- new upstream release
281
282* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
283- new upstream release
284- build with mozilla-1.7.7
285
286* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
287- rebuild with mozilla-1.7.6
288
289* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
290- new upstream release
291
292* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
293- new upstream release
294- build with mozilla-1.7.5
295
296* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
297- new upstream release
298
299* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
300- new upstream release
301
302* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
303- rebuild with mozilla-1.7.3
304
305* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
306- new upstream release
307- build with mozilla-1.7.2
308- add Patch10 to build with gnome-2.4
309
310* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
311- new upstream version
312        -- dropped patch10
313- changed URL
314
315* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
316- add alpha into ExclusiveArch
317
318* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
319- rebuild with mozilla-1.5.1
320
321* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
322- new upstream release
323
324* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
325- new upstream release
326
327* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
328- fixed missing locale files
329
330* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
331- new upstream release
332
333* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
334- new upstream release
335
336* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
337- new upstream release
338
339* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
340- new upstream release
341- build with mozilla 1.4
342
343* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
344- new upstream release
345
346* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
347- build for Vine Linux
348
349* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
350- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
351
352* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
353- 0.6.1
354
355* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
356- add patch to fix gint/gpointer conversion bugs for 64bit arches
357
358* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
359- only build on arches mozilla is built on
360
361* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
362- rebuild against new mozilla, make mozilla requires dynamic
363
364* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
365- update to 0.6.0
366- fix tyop in %%postun
367
368* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
369- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
370
371* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
372- add some buildrequires, prereq GConf2
373- disable building nautilus view
374
375* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
376- Initial build.
377
378
Note: See TracBrowser for help on using the repository browser.