source: projects/specs/trunk/e/epiphany/epiphany-vl.spec @ 1058

Revision 1058, 10.8 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release, and new package pyclutter, pyclutter-gst and pyclutter-gtk

Line 
1# gecko backend was removed 2.27.0
2%define with_gecko 0
3%define with_webkit 1
4
5%define gecko_version 1.9.1
6%define webkit_version 1.1.15
7
8ExclusiveArch: %ix86 ppc x86_64 alpha
9
10Summary: GNOME web browser based on Gecko/WebKit
11Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
12Name: epiphany
13Version: 2.30.2
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Internet
17URL: http://www.gnome.org/projects/epiphany/
18
19Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
20Patch1: epiphany-2.26.2-gecko191.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Requires: gnome-icon-theme >= 2.30.0
25%if %{with_gecko}
26Requires: gecko-libs
27%endif
28Requires(post,pre,preun): GConf2
29Requires(post,postun): scrollkeeper, shared-mime-info
30
31%if %{with_gecko}
32BuildRequires: gecko-devel-unstable >= %{gecko_version}
33%endif
34%if %{with_webkit}
35BuildRequires: WebKit-gtk-devel >= %{webkit_version}
36%endif
37BuildRequires: glib2-devel >= 2.24.0
38BuildRequires: gtk2-devel >= 2.20.0
39BuildRequires: libxml2-devel >= 2.6.12
40BuildRequires: libxslt-devel >= 1.1.7
41BuildRequires: libnotify-devel >= 0.4.0
42BuildRequires: dbus-glib-devel >= 0.35
43BuildRequires: libsoup-devel >= 2.30.0
44BuildRequires: gnome-desktop-devel >= 2.30.0
45BuildRequires: GConf2-devel
46BuildRequires: nss-devel
47BuildRequires: avahi-gobject-devel >= 0.6.22
48BuildRequires: NetworkManager-devel
49BuildRequires: iso-codes
50BuildRequires: intltool >= 0.40
51BuildRequires: libICE-devel
52BuildRequires: libSM-devel
53BuildRequires: libgnome-keyring-devel
54BuildRequires: gobject-introspection-devel
55BuildRequires: gir-repository-devel
56BuildRequires: gnome-doc-utils
57BuildRequires: gobject-introspection-devel
58BuildRequires: seed-devel
59
60%description
61epiphany is a simple GNOME web browser based on the Mozilla rendering
62engine
63
64%description -l ja
65epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
66ウェブブラウザです。
67
68%prep
69%setup -q
70
71#patch1 -p1
72
73%build
74MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
75export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
76
77%configure \
78%if %{with_gecko}
79  --with-gecko=libxul-embedding \
80%endif
81%if %{with_webkit}
82  --with-engine=webkit \
83%endif
84  --enable-zeroconf \
85  --enable-network-manager \
86  --disable-scrollkeeper \
87  --without-ca-file \
88  --enable-introspection=yes \
89  --enable-seed
90
91%__make %{?_smp_mflags}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
96make install DESTDIR=$RPM_BUILD_ROOT
97unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
98
99%find_lang %{name} --with-gnome
100
101rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
102rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
103
104rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
105
106%pre
107if [ "$1" -gt 1 ]; then
108  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
110  for S in $SCHEMAS; do
111    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
112  done
113fi
114
115%post
116touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
117export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
119for S in $SCHEMAS; do
120  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
121done
122
123%preun
124if [ "$1" -eq 0 ]; then
125  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
126  SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
127  for S in $SCHEMAS; do
128    gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
129  done
130fi
131
132%postun
133if [ $1 -eq 0 ] ; then
134    touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
135    gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
136    update-desktop-database %{_datadir}/applications >& /dev/null ||:
137    scrollkeeper-update >& /dev/null ||:
138fi
139
140%posttrans
141gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
142update-desktop-database %{_datadir}/applications >& /dev/null ||:
143scrollkeeper-update >& /dev/null ||:
144
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%files -f %{name}.lang
150%defattr(-,root,root,-)
151%doc AUTHORS ChangeLog* COPYING* NEWS README
152%{_sysconfdir}/gconf/schemas/epiphany*.schemas
153%{_bindir}/epiphany
154%{_includedir}/epiphany/*
155%{_libdir}/pkgconfig/epiphany*.pc
156%{_libdir}/girepository-1.0/Epiphany-2.29.typelib
157%if %{with_gecko}
158%{_libdir}/epiphany
159%endif
160%{_datadir}/gir-1.0/Epiphany-2.29.gir
161#{_datadir}/pygtk/*/defs/*
162%{_datadir}/applications/*.desktop
163%{_datadir}/epiphany
164%{_datadir}/gtk-doc/html/*
165%{_datadir}/icons/*
166%{_datadir}/aclocal/*
167%{_datadir}/dbus-1/services/*
168%{_mandir}/man1/epiphany.1*
169
170%changelog
171* Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
172- new upstream release
173- add BuildRequires: gobject-introspection-devel, seed-devel
174- add configure option (--enable-introspection=yes, --enable-seed)
175
176* Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
177- new upstream release
178- add BuildRequires: gobject-introspection-devel, gir-repository-devel
179- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
180- add configure option (--without-ca-file)
181- remove unrecognized configure option (--with-engine)
182
183* Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
184- new upstream release
185- added BR: libICE-devel, libSM-devel and gnome-keyring-devel
186
187* Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
188- new upstream release
189
190* Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
191- run gtk-update-icon-cache in %%post/postun script.
192
193* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
194- new upstream release
195
196* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
197- rebuild with gecko-1.9.1
198
199* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
200- new upstream release
201
202* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
203- new upstream release
204- build with xulrunner-1.9.0.7
205
206* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
207- new upstream release
208
209* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
210- build with gecko-1.9.0.3 instead of WebKit.
211  - WebKit port is unstable yet.
212- enable zeroconf, NetworkManager support
213
214* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
215- new upstream release
216
217* Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
218- build with WebKit instead of gecko.
219
220* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
221- new upstream release
222- added %%pre and %%preun section
223
224* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
225- new upstream release
226- rebuilt with firefox-2.0.0.6-0vl3
227
228* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
229- add BuildRequires: gnome-python
230
231* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
232- new upstream release
233- rebuilt with new toolchain and firefox-2.0.0.4-0vl6
234
235* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
236- new upstream release
237
238* Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
239- source update
240- add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
241- add BuildRequires: pygtk2-devel
242
243* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
244- new upstream release
245
246* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
247- rebuild with firefox-1.5.0.2-0vl4
248
249* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
250- new upstream release
251- build with firefox-1.5.0.2
252
253* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
254- new upstream release
255
256* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
257- new upstream release
258- build with firefox-1.5.0.1
259
260* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
261- new upstream release
262- build with mozilla-1.7.12
263
264* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
265- rebuild with mozilla-1.7.8
266
267* Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
268- new upstream release
269
270* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
271- new upstream release
272- build with mozilla-1.7.7
273
274* Fri Apr  1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
275- rebuild with mozilla-1.7.6
276
277* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
278- new upstream release
279
280* Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
281- new upstream release
282- build with mozilla-1.7.5
283
284* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
285- new upstream release
286
287* Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
288- new upstream release
289
290* Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
291- rebuild with mozilla-1.7.3
292
293* Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
294- new upstream release
295- build with mozilla-1.7.2
296- add Patch10 to build with gnome-2.4
297
298* Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
299- new upstream version
300        -- dropped patch10
301- changed URL
302
303* Fri Jan  9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
304- add alpha into ExclusiveArch
305
306* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
307- rebuild with mozilla-1.5.1
308
309* Sat Dec  6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
310- new upstream release
311
312* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
313- new upstream release
314
315* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
316- fixed missing locale files
317
318* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
319- new upstream release
320
321* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
322- new upstream release
323
324* Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
325- new upstream release
326
327* Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
328- new upstream release
329- build with mozilla 1.4
330
331* Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
332- new upstream release
333
334* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
335- build for Vine Linux
336
337* Mon Jun  2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
338- Rebuild to fix broken mozilla dep, patch for mozilla 1.4
339
340* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
341- 0.6.1
342
343* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
344- add patch to fix gint/gpointer conversion bugs for 64bit arches
345
346* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
347- only build on arches mozilla is built on
348
349* Fri May  9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
350- rebuild against new mozilla, make mozilla requires dynamic
351
352* Sun May  4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
353- update to 0.6.0
354- fix tyop in %%postun
355
356* Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
357- make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
358
359* Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
360- add some buildrequires, prereq GConf2
361- disable building nautilus view
362
363* Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
364- Initial build.
365
366
Note: See TracBrowser for help on using the repository browser.