source: projects/specs/trunk/e/epiphany-extensions/epiphany-extensions-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%global ephy_major          2.28
2%global ephy_min_version    %{ephy_major}.1
3%global gecko_version       1.9.1
4
5Summary:        Extensions for Epiphany, the GNOME web browser
6Summary(ja):    Epiphany (GNOMEウェブブラウザ) 用の拡張
7
8Name:           epiphany-extensions
9Version:        %{ephy_major}.1
10Release:        1%{?_dist_release}
11
12## The Live HTTP Headers extension is LGPLv2.1+; the Gestures extension is
13## GPLv2 (only); and all other extensions are GPLv2+.
14License:        LGPLv2+ and GPLv2 and GPLv2+ and GFDL
15Group:          Applications/Internet
16URL:            http://www.gnome.org/projects/epiphany/extensions
17
18Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany-extensions/%{ephy_major}/%{name}-%{version}.tar.bz2
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  epiphany >= %{ephy_min_version}
23BuildRequires:  perl(XML::Parser)
24BuildRequires:  gettext
25BuildRequires:  intltool
26BuildRequires:  libtool
27BuildRequires:  opensp-devel
28BuildRequires:  pcre-devel
29BuildRequires:  WebKit-gtk-devel
30
31Requires:       epiphany
32Requires:       pygtk2
33
34Requires(post): scrollkeeper
35Requires(postun): scrollkeeper
36
37%description
38Epiphany Extensions is a collection of extensions for Epiphany, the
39GNOME web browser.
40
41%prep
42%setup -q
43
44%build
45%configure --disable-scrollkeeper               \
46           --disable-schemas-install            \
47           --disable-static                     \
48           --with-extensions=really-all
49
50%{__make} %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
51
52
53%install
54%{__rm} -rf %{buildroot}
55make DESTDIR=%{buildroot} LIBTOOL=%{_bindir}/libtool install
56
57%{find_lang} %{name}-%{ephy_major}
58
59%clean
60%{__rm} -rf %{buildroot}
61
62
63%post
64scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
65
66%postun
67scrollkeeper-update -q ||:
68
69%files -f %{name}-%{ephy_major}.lang
70%defattr(-,root,root,-)
71%doc AUTHORS COPYING COPYING.README ChangeLog README NEWS
72%{_datadir}/epiphany/icons/hicolor/*/status/feed-presence.*
73%{_datadir}/epiphany/icons/hicolor/*/status/ad-blocked.*
74%{_datadir}/%{name}/
75%{_datadir}/gnome/help/%{name}
76%{_datadir}/omf/%{name}
77%exclude %{_libdir}/epiphany/%{ephy_major}/extensions/*.a
78%exclude %{_libdir}/epiphany/%{ephy_major}/extensions/*.la
79%{_libdir}/epiphany/%{ephy_major}/extensions/
80#{_sysconfdir}/gconf/schemas/smart-bookmarks.schemas
81#{_sysconfdir}/gconf/schemas/epilicious.schemas
82
83%changelog
84* Sun Nov 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
85- new upstream release
86- BR: WebKit-gtk-devel instead of gecko-devel
87
88* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
89- rebuild with gecko-1.9.1
90
91* Fri May 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.26.1-1
92- new upstream release
93
94* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
95- new upstream release
96
97* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
98- initial build for Vine Linux
99
100* Mon Sep 29 2008 Peter Gordon <peter@thecodergeek.com> - 2.24.0-1
101- Update to new upstream release (2.24.0)
102
103* Wed Sep 24 2008 Christopher Aillon <caillon@redhat.com> - 2.23.91-2
104- Rebuild against newer gecko
105
106* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.91-1
107- Update to new upstream release (2.23.91)
108- Drop fixes for Ephy 2.23 API bump (applied upstream):
109  - 2.22_23-api.diff
110
111* Sat Jul 26 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.0-0.1
112- Adapt internal build scripts so that the Extensions are built against and
113  run with Ephy 2.23/2.24:
114  + 2.22_23-api.diff
115- Rebuild for XULrunner 1.9.0.1 while we're at it. :)
116
117* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> - 2.22.1-1
118- Update to 2.22.1
119
120* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> - 2.22.0-1
121- Update to 2.22.0
122
123* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> - 2.21.92-1
124- Update to 2.91.92
125- Build against xulrunner 4realz, yo
126
127* Wed Jan  9 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 2.20.1-4
128- Switch to building against xulrunner (gecko 1.9) rather than firefox
129
130* Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 2.20.1-2
131- Rebuild against newer gecko
132
133* Tue Nov 06 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.1-2
134- Rebuild for new Gecko (Firefox 2.0.0.9)
135
136* Mon Oct 15 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.1-1
137- Update to new upstream release (2.20.1), which fixes the "About" dialog of
138  the AdBlocker extension and contains updated translations for Thai (th) and
139  Catalan (ca).
140- Use the system libtool for building, to avoid unnecessary RPATH inclusions. 
141
142* Tue Sep 18 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.0-1
143- Update to new upstream release (2.20.0).
144
145* Tue Sep 04 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.90-1
146- Update to new upstream release (2.19.90), which contains reworked
147  installation rules for the icons and a fix for the Greasemonkey
148  extension so that it does not break when the directory is not
149  created (GNOME bug 437648).
150
151* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 2.19.6-1
152- Rebuild for build ID
153
154* Wed Aug 08 2007 Christopher Aillon <caillon@redhat.com> - 2.19.6-1
155- Update to 2.19.6
156- Rebuild against newer gecko
157
158* Thu Aug 02 2007 Peter Gordon <peter@thecodergeek.com>
159- Update License tag (LGPLv2.1+ and GPLv2 and GPLv2+).
160
161* Sat Jul 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.5-1
162- Update to new upstream release (2.19.5), which contains significant
163  Epilicious updates and improved filterset.g syncing support in the
164  AdBlocker extension.
165- Build against the new Gecko release (Firefox 2.0.0.5)
166
167* Sat Jun 09 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-5
168- Revert previous Yelp dependency addition. It's in the default install (via
169  comps) and the only bad thing to happen if it's not available is that
170  clicking the "Help" option simply does nothing. It's not a strict requirement
171  in this case.
172
173* Fri Jun 08 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-4
174- Add yelp dependency to ensure that its built-in "Help" functionality works
175  as expected. (Resolves bug 243378; Thanks to Matej Cepl for his script.)
176
177* Wed Jun 06 2007 Christopher Aillon <caillon@redhat.com> - 2.19.2-3
178- Specfiles should _NOT_ call rpm directly.  Fix the previous bug the
179  correct way, by doing explicit requires on the exact versions instead
180  of via rpm -q
181
182* Tue Jun 05 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-2
183- Add %%{_target_cpu} to versioned Firefox dependency to avoid multilib
184  updating issues such as bug 242318, wherein the 32-bit older Firefox build
185  matches the versioned dependency, but the updated 64-bit Firefox build
186  matches the 64-bit shared library dependencies. (Thanks to Frederik Hertzum
187  for the bug report.)
188
189* Tue May 30 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-1
190- Update to new upstream release (2.19.2); and rebuild for newer Firefox/Gecko
191  version (2.0.0.4).
192
193* Wed Apr 11 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.1-1
194- Update to new upstream release (2.18.1).
195
196* Sat Mar 24 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.0-2
197- Rebuild against new Gecko release (Firefox 2.0.0.3).
198
199* Wed Mar 14 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.0-1
200- Update to new upstream release (2.18.0).
201- Remove shell syntax error (erroneous "||:") in %%preun scriptlet.
202
203* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.92-1
204- Update to new upstream release (2.17.92), which includes the Epilicious
205  extension (thus closing bug #223746). 
206- Add an explicit versioned dependency on firefox to help avoid version-bump
207  incompatibilities in the future.(Thanks to Brian Pepple for the fix.) 
208
209* Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-3
210- Enable all extensions. (Woo!)
211- Fix summary (it shouldn't end with a period).
212
213* Fri Jan 26 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-2
214- Fix %%post GConf scriptlet (thanks to David Nielsen for the bug report via
215  email) and a spelling mistake in previous %%changelog entry.
216- Lots of aesthetic fixes to the spec file.
217
218* Wed Jan 24 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-1
219- Update to new upstream release (2.17.4)
220- Use %%find_lang instead of a hardcoded call to 'find_lang.sh --all-name'
221- A couple of fixes from Brian Pepple:
222  (1) Own only the extensions subdirectory in %%_libdir/epiphany, not the
223  toplevel epiphany directory (which is owned by epiphany).
224  (2) Don't package libtool archive (*.la) files.
225- Make macro usage a bit more consistent.
226- Add AUTHORS, COPYING, and COPYING.README to installed documentation (%%doc).
227- Includes smart-bookmarks GConf schema, so add associated gconftool-2
228  scriptlet calls, etc.
229
230* Fri Dec 01 2006 Peter Gordon <peter@thecodergeek.com> - 2.17.0-1
231- Update to new upstream release (2.17.0), for new Epiphany 2.17/2.18 in Devel.
232- Fix BuildRoot to be in compliance with Fedora Extras packaging policy 
233
234* Thu Oct 12 2006 Peter Gordon <peter@thecodergeek.com>
235- Change perl-XML-Parser BR to perl(XML::Parser)
236- DESTDIR is a make variable, not an external one
237
238* Thu Oct 12 2006 Zack Cerza <zcerza@redhat.com> 2.16.0-1
239- Update to 2.16.0
240
241* Tue Aug 29 2006 Christopher Aillon <caillon@redhat.com> 2.15.2-1
242- Update to 2.15.2
243
244* Sun Apr 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 2.14.1-1
245- Upstream update
246
247* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 1.9.7-1
248- Update to 1.9.7
249
250* Sun Feb  5 2006 Christopher Aillon <caillon@redhat.com> - 1.9.6-1
251- Update to 1.9.6
252
253* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com> - 1.9.4-1
254- Update to 1.9.4
255
256* Fri Dec 30 2005 Christopher Aillon <caillon@redhat.com> - 1.9.3-1
257- Update to 1.9.3
258
259* Mon Oct 10 2005 Christopher Aillon <caillon@redhat.com> - 1.8.1-1
260- Update to 1.8.1
261
262* Tue Sep  6 2005 Christopher Aillon <caillon@redhat.com> - 1.8.0-1
263- Update to 1.8.0
264
265* Wed Aug 10 2005 Christopher Aillon <caillon@redhat.com> - 1.7.4-1
266- Update to 1.7.4
267
268* Fri Jul 29 2005 Christopher Aillon <caillon@redhat.com> - 1.7.3-1
269- Update to 1.7.3
270
271* Mon Jul 11 2005 Christopher Aillon <caillon@redhat.com> - 1.7.2-1
272- Update to 1.7.2
273
274* Mon Jun 27 2005 Christopher Aillon <caillon@redhat.com> - 1.7.1-2
275- Own %%{_libdir}/epiphany
276- Run find-lang.sh manually since the macro doesn't help us
277- Clean up summary
278
279* Thu Jun 16 2005 Christopher Aillon <caillon@redhat.com> - 1.7.1-1
280- Initial RPM
Note: See TracBrowser for help on using the repository browser.