source: projects/specs/trunk/e/epiphany-extensions/epiphany-extensions-vl.spec @ 6924

Revision 6924, 10.6 KB checked in by Takemikaduchi, 12 years ago (diff)

libunistring: add Requires,
others: new upstream release

Line 
1%global ephy_major          3.6
2%global ephy_api_major      3.6
3%global ephy_min_version    %{ephy_major}.0
4
5Summary:        Extensions for Epiphany, the GNOME web browser
6Summary(ja):    Epiphany (GNOMEウェブブラウザ) 用の拡張
7
8Name:           epiphany-extensions
9Version:        %{ephy_min_version}
10Release:        1%{?_dist_release}
11
12## The Live HTTP Headers extension is LGPLv2.1+; the Gestures extension is
13## GPLv2 (only); and all other extensions are GPLv2+.
14License:        LGPLv2+ and GPLv2 and GPLv2+ and GFDL
15Group:          Applications/Internet
16URL:            http://www.gnome.org/projects/epiphany/extensions
17
18Source0:        http://ftp.gnome.org/pub/GNOME/sources/epiphany-extensions/%{ephy_major}/%{name}-%{version}.tar.xz
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  epiphany-devel >= %{ephy_min_version}
23BuildRequires:  perl(XML::Parser)
24BuildRequires:  gettext
25BuildRequires:  WebKit3-gtk-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  opensp-devel
28BuildRequires:  gnome-doc-utils >= 0.3.2
29
30Requires:       epiphany
31
32Requires(post): scrollkeeper
33Requires(postun): scrollkeeper
34
35%description
36Epiphany Extensions is a collection of extensions for Epiphany, the
37GNOME web browser.
38
39%prep
40%setup -q
41
42%build
43%configure --disable-scrollkeeper               \
44           --disable-schemas-install            \
45           --disable-static                     \
46           --with-extensions=actions,adblock,auto-reload,extensions-manager-ui,gestures,greasemonkey,html5tube,push-scroller,rss,sample,soup-fly,tab-key-tab-navigate,tab-states
47
48%{__make} %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
49
50
51%install
52%{__rm} -rf %{buildroot}
53make DESTDIR=%{buildroot} LIBTOOL=%{_bindir}/libtool install
54
55find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
56find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
57
58%find_lang %{name}-%{ephy_api_major}
59
60%clean
61%{__rm} -rf %{buildroot}
62
63
64%post
65scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
66
67%postun
68scrollkeeper-update -q ||:
69
70%files -f %{name}-%{ephy_api_major}.lang
71%defattr(-,root,root,-)
72%doc AUTHORS COPYING COPYING.README ChangeLog README NEWS
73%{_libdir}/epiphany/%{ephy_api_major}/extensions/
74%{_datadir}/epiphany/icons/hicolor/*/status/feed-presence.*
75%{_datadir}/epiphany/icons/hicolor/*/status/ad-blocked.*
76%{_datadir}/%{name}/
77%{_datadir}/glib-2.0/schemas/org.gnome.epiphanyextensions.gschema.xml
78%{_datadir}/gnome/help/%{name}
79%{_datadir}/omf/%{name}
80
81%changelog
82* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
83- new upstream release
84
85* Mon Apr 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
86- new upstream release
87
88* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
89- new upstream release
90- fix %install and %files (change installation diretory)
91
92* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
93- new upstream release
94- add BuildRequires: GConf2-devel, gnome-doc-utils >= 0.3.2
95- fix find_lang from %{name}-%{ephy_major} to %{name}-2.29
96
97* Sun Nov 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
98- new upstream release
99- BR: WebKit-gtk-devel instead of gecko-devel
100
101* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
102- rebuild with gecko-1.9.1
103
104* Fri May 29 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.26.1-1
105- new upstream release
106
107* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
108- new upstream release
109
110* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
111- initial build for Vine Linux
112
113* Mon Sep 29 2008 Peter Gordon <peter@thecodergeek.com> - 2.24.0-1
114- Update to new upstream release (2.24.0)
115
116* Wed Sep 24 2008 Christopher Aillon <caillon@redhat.com> - 2.23.91-2
117- Rebuild against newer gecko
118
119* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.91-1
120- Update to new upstream release (2.23.91)
121- Drop fixes for Ephy 2.23 API bump (applied upstream):
122  - 2.22_23-api.diff
123
124* Sat Jul 26 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.0-0.1
125- Adapt internal build scripts so that the Extensions are built against and
126  run with Ephy 2.23/2.24:
127  + 2.22_23-api.diff
128- Rebuild for XULrunner 1.9.0.1 while we're at it. :)
129
130* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> - 2.22.1-1
131- Update to 2.22.1
132
133* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> - 2.22.0-1
134- Update to 2.22.0
135
136* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> - 2.21.92-1
137- Update to 2.91.92
138- Build against xulrunner 4realz, yo
139
140* Wed Jan  9 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 2.20.1-4
141- Switch to building against xulrunner (gecko 1.9) rather than firefox
142
143* Tue Nov 27 2007 Christopher Aillon <caillon@redhat.com> - 2.20.1-2
144- Rebuild against newer gecko
145
146* Tue Nov 06 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.1-2
147- Rebuild for new Gecko (Firefox 2.0.0.9)
148
149* Mon Oct 15 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.1-1
150- Update to new upstream release (2.20.1), which fixes the "About" dialog of
151  the AdBlocker extension and contains updated translations for Thai (th) and
152  Catalan (ca).
153- Use the system libtool for building, to avoid unnecessary RPATH inclusions. 
154
155* Tue Sep 18 2007 Peter Gordon <peter@thecodergeek.com> - 2.20.0-1
156- Update to new upstream release (2.20.0).
157
158* Tue Sep 04 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.90-1
159- Update to new upstream release (2.19.90), which contains reworked
160  installation rules for the icons and a fix for the Greasemonkey
161  extension so that it does not break when the directory is not
162  created (GNOME bug 437648).
163
164* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 2.19.6-1
165- Rebuild for build ID
166
167* Wed Aug 08 2007 Christopher Aillon <caillon@redhat.com> - 2.19.6-1
168- Update to 2.19.6
169- Rebuild against newer gecko
170
171* Thu Aug 02 2007 Peter Gordon <peter@thecodergeek.com>
172- Update License tag (LGPLv2.1+ and GPLv2 and GPLv2+).
173
174* Sat Jul 21 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.5-1
175- Update to new upstream release (2.19.5), which contains significant
176  Epilicious updates and improved filterset.g syncing support in the
177  AdBlocker extension.
178- Build against the new Gecko release (Firefox 2.0.0.5)
179
180* Sat Jun 09 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-5
181- Revert previous Yelp dependency addition. It's in the default install (via
182  comps) and the only bad thing to happen if it's not available is that
183  clicking the "Help" option simply does nothing. It's not a strict requirement
184  in this case.
185
186* Fri Jun 08 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-4
187- Add yelp dependency to ensure that its built-in "Help" functionality works
188  as expected. (Resolves bug 243378; Thanks to Matej Cepl for his script.)
189
190* Wed Jun 06 2007 Christopher Aillon <caillon@redhat.com> - 2.19.2-3
191- Specfiles should _NOT_ call rpm directly.  Fix the previous bug the
192  correct way, by doing explicit requires on the exact versions instead
193  of via rpm -q
194
195* Tue Jun 05 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-2
196- Add %%{_target_cpu} to versioned Firefox dependency to avoid multilib
197  updating issues such as bug 242318, wherein the 32-bit older Firefox build
198  matches the versioned dependency, but the updated 64-bit Firefox build
199  matches the 64-bit shared library dependencies. (Thanks to Frederik Hertzum
200  for the bug report.)
201
202* Tue May 30 2007 Peter Gordon <peter@thecodergeek.com> - 2.19.2-1
203- Update to new upstream release (2.19.2); and rebuild for newer Firefox/Gecko
204  version (2.0.0.4).
205
206* Wed Apr 11 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.1-1
207- Update to new upstream release (2.18.1).
208
209* Sat Mar 24 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.0-2
210- Rebuild against new Gecko release (Firefox 2.0.0.3).
211
212* Wed Mar 14 2007 Peter Gordon <peter@thecodergeek.com> - 2.18.0-1
213- Update to new upstream release (2.18.0).
214- Remove shell syntax error (erroneous "||:") in %%preun scriptlet.
215
216* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.92-1
217- Update to new upstream release (2.17.92), which includes the Epilicious
218  extension (thus closing bug #223746). 
219- Add an explicit versioned dependency on firefox to help avoid version-bump
220  incompatibilities in the future.(Thanks to Brian Pepple for the fix.) 
221
222* Sat Jan 27 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-3
223- Enable all extensions. (Woo!)
224- Fix summary (it shouldn't end with a period).
225
226* Fri Jan 26 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-2
227- Fix %%post GConf scriptlet (thanks to David Nielsen for the bug report via
228  email) and a spelling mistake in previous %%changelog entry.
229- Lots of aesthetic fixes to the spec file.
230
231* Wed Jan 24 2007 Peter Gordon <peter@thecodergeek.com> - 2.17.4-1
232- Update to new upstream release (2.17.4)
233- Use %%find_lang instead of a hardcoded call to 'find_lang.sh --all-name'
234- A couple of fixes from Brian Pepple:
235  (1) Own only the extensions subdirectory in %%_libdir/epiphany, not the
236  toplevel epiphany directory (which is owned by epiphany).
237  (2) Don't package libtool archive (*.la) files.
238- Make macro usage a bit more consistent.
239- Add AUTHORS, COPYING, and COPYING.README to installed documentation (%%doc).
240- Includes smart-bookmarks GConf schema, so add associated gconftool-2
241  scriptlet calls, etc.
242
243* Fri Dec 01 2006 Peter Gordon <peter@thecodergeek.com> - 2.17.0-1
244- Update to new upstream release (2.17.0), for new Epiphany 2.17/2.18 in Devel.
245- Fix BuildRoot to be in compliance with Fedora Extras packaging policy 
246
247* Thu Oct 12 2006 Peter Gordon <peter@thecodergeek.com>
248- Change perl-XML-Parser BR to perl(XML::Parser)
249- DESTDIR is a make variable, not an external one
250
251* Thu Oct 12 2006 Zack Cerza <zcerza@redhat.com> 2.16.0-1
252- Update to 2.16.0
253
254* Tue Aug 29 2006 Christopher Aillon <caillon@redhat.com> 2.15.2-1
255- Update to 2.15.2
256
257* Sun Apr 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 2.14.1-1
258- Upstream update
259
260* Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 1.9.7-1
261- Update to 1.9.7
262
263* Sun Feb  5 2006 Christopher Aillon <caillon@redhat.com> - 1.9.6-1
264- Update to 1.9.6
265
266* Tue Jan  3 2006 Christopher Aillon <caillon@redhat.com> - 1.9.4-1
267- Update to 1.9.4
268
269* Fri Dec 30 2005 Christopher Aillon <caillon@redhat.com> - 1.9.3-1
270- Update to 1.9.3
271
272* Mon Oct 10 2005 Christopher Aillon <caillon@redhat.com> - 1.8.1-1
273- Update to 1.8.1
274
275* Tue Sep  6 2005 Christopher Aillon <caillon@redhat.com> - 1.8.0-1
276- Update to 1.8.0
277
278* Wed Aug 10 2005 Christopher Aillon <caillon@redhat.com> - 1.7.4-1
279- Update to 1.7.4
280
281* Fri Jul 29 2005 Christopher Aillon <caillon@redhat.com> - 1.7.3-1
282- Update to 1.7.3
283
284* Mon Jul 11 2005 Christopher Aillon <caillon@redhat.com> - 1.7.2-1
285- Update to 1.7.2
286
287* Mon Jun 27 2005 Christopher Aillon <caillon@redhat.com> - 1.7.1-2
288- Own %%{_libdir}/epiphany
289- Run find-lang.sh manually since the macro doesn't help us
290- Clean up summary
291
292* Thu Jun 16 2005 Christopher Aillon <caillon@redhat.com> - 1.7.1-1
293- Initial RPM
Note: See TracBrowser for help on using the repository browser.