source: projects/specs/trunk/e/eog-plugins/eog-plugins-vl.spec @ 9761

Revision 9761, 4.8 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define pkg_version 3.16.2
4%define pkg_release 1%{?_dist_release}
5
6Summary: Plugins for eog
7Summary(ja): eog用のプラグイン
8Name: eog-plugins
9Version: %{pkg_version}
10Release: %{pkg_release}
11Source0: http://download.gnome.org/sources/%{name}/3.16/%{name}-%{version}.tar.xz
12Source1: README.vine
13License: GPLv2+
14Group: Applications/Graphics
15URL: http://live.gnome.org/EyeOfGnome/Plugins
16
17BuildRequires: gtk3-devel
18BuildRequires: eog-devel
19BuildRequires: libexif-devel
20BuildRequires: libchamplain-devel, libchamplain-gtk-devel
21BuildRequires: libpeas-devel
22BuildRequires: gsettings-desktop-schemas-devel
23BuildRequires: libgdata-devel
24BuildRequires: python3-devel
25BuildRequires: postr
26
27Requires: eog
28Requires(postun,posttrans): glib2
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Takemikaduchi
35
36
37%description
38It's a collection of plugins for use with the Eye of GNOME Image Viewer.
39
40%description -l ja
41Eye of GNOME イメージビューア用のプラグイン集
42
43
44%prep
45%setup -q
46%{__cp} %{SOURCE1} .
47
48%build
49%configure --with-plugins=map,exif-display,fit-to-width,pythonconsole,slideshowshuffle,postr,postasa,send-by-mail
50%{__make} %{?_smp_mflags}
51
52
53%install
54%{__rm} -rf ${RPM_BUILD_ROOT}
55%{__make} install DESTDIR=${RPM_BUILD_ROOT}
56
57# remove *.la
58%{__rm} -f ${RPM_BUILD_ROOT}/%{_libdir}/eog/plugins/*.la
59
60%find_lang %{name}
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66%postun
67if [ $1 -eq 0 ]; then
68  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
69fi
70
71%posttrans
72glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
73
74
75%files -f %{name}.lang
76%defattr(-,root,root)
77%doc COPYING ChangeLog NEWS README README.vine
78%{_libdir}/eog/plugins
79%{_datadir}/appdata/eog-*.xml
80%{_datadir}/eog/plugins/pythonconsole/config.ui
81%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.exif-display.gschema.xml
82%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.pythonconsole.gschema.xml
83
84
85%changelog
86* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
87- new upstream release
88
89* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
90- new upstream release
91
92* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
93- new upstream release
94
95* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-2
96- rebuild with python-3.4.2
97
98* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
99- new upstream release
100
101* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
102- new upstream release
103
104* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
105- new upstream release
106
107* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
108- new upstream release
109
110* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
111- rebuild with VineSeed environment
112
113* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
114- new upstream release
115
116* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
117- new upstream release
118
119* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
120- new upstream release
121
122* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
123- new upstream release
124
125* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
126- new upstream release
127- add BuildRequires: gsettings-desktop-schemas-devel
128
129* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
130- new upstream release
131- remove Patch0
132
133* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
134- new upstream release
135
136* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
137- new upstream release
138
139* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
140- new upstream release
141
142* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
143- new upstream release
144- add BuildRequires: postr
145
146* Sun Sep 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.1.2-2
147- enable postr (upload picture to Flickr)
148- enable postasa (upload picture to Picasa web)
149- enable send-by-mail (Send picture to friends by evolution mail)
150- add libgdata-devel to BR
151- add README.vine
152
153* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
154- new upstream release
155- add BuildRequires: libpeas-devel
156- change BuildRequires: gtk3-devel instead of gtk2-devel
157- update Patch0
158
159* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
160- new upstream release
161- change BuildRequires: eog-devel instead of eog
162
163* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
164- rebuild with libchamplain-0.8
165
166* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
167- new upstream release
168
169* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
170- new upstream release
171
172* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
173- initial build for Vine Linux
174- exclude postr plugin
175
Note: See TracBrowser for help on using the repository browser.