source: projects/specs/trunk/e/eog-plugins/eog-plugins-vl.spec @ 8369

Revision 8369, 4.2 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define pkg_version 3.12.1
4%define pkg_release 1%{?_dist_release}
5
6Summary: Plugins for eog
7Summary(ja): eog用のプラグイン
8Name: eog-plugins
9Version: %{pkg_version}
10Release: %{pkg_release}
11Source0: http://download.gnome.org/sources/%{name}/3.12/%{name}-%{version}.tar.xz
12Source1: README.vine
13License: GPLv2+
14Group: Applications/Graphics
15URL: http://live.gnome.org/EyeOfGnome/Plugins
16
17BuildRequires: gtk3-devel
18BuildRequires: eog-devel
19BuildRequires: libexif-devel
20BuildRequires: libchamplain-devel, libchamplain-gtk-devel
21BuildRequires: libpeas-devel
22BuildRequires: gsettings-desktop-schemas-devel
23BuildRequires: libgdata-devel
24BuildRequires: python3-devel
25BuildRequires: postr
26
27Requires: eog
28Requires(postun,posttrans): glib2
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Takemikaduchi
35
36
37%description
38It's a collection of plugins for use with the Eye of GNOME Image Viewer.
39
40%description -l ja
41Eye of GNOME イメージビューア用のプラグイン集
42
43
44%prep
45%setup -q
46%{__cp} %{SOURCE1} .
47
48%build
49%configure --with-plugins=map,exif-display,fit-to-width,pythonconsole,slideshowshuffle,postr,postasa,send-by-mail
50%{__make} %{?_smp_mflags}
51
52
53%install
54%{__rm} -rf ${RPM_BUILD_ROOT}
55%{__make} install DESTDIR=${RPM_BUILD_ROOT}
56
57# remove *.la
58%{__rm} -f ${RPM_BUILD_ROOT}/%{_libdir}/eog/plugins/*.la
59
60%find_lang %{name}
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66%postun
67if [ $1 -eq 0 ]; then
68  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
69fi
70
71%posttrans
72glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
73
74
75%files -f %{name}.lang
76%defattr(-,root,root)
77%doc COPYING ChangeLog NEWS README README.vine
78%{_libdir}/eog/plugins
79%{_datadir}/eog/plugins/pythonconsole/config.ui
80%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.exif-display.gschema.xml
81%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.pythonconsole.gschema.xml
82
83
84%changelog
85* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
86- new upstream release
87
88* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
89- new upstream release
90
91* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
92- rebuild with VineSeed environment
93
94* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
95- new upstream release
96
97* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
98- new upstream release
99
100* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
101- new upstream release
102
103* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
104- new upstream release
105
106* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
107- new upstream release
108- add BuildRequires: gsettings-desktop-schemas-devel
109
110* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
111- new upstream release
112- remove Patch0
113
114* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
115- new upstream release
116
117* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
118- new upstream release
119
120* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
121- new upstream release
122
123* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
124- new upstream release
125- add BuildRequires: postr
126
127* Sun Sep 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.1.2-2
128- enable postr (upload picture to Flickr)
129- enable postasa (upload picture to Picasa web)
130- enable send-by-mail (Send picture to friends by evolution mail)
131- add libgdata-devel to BR
132- add README.vine
133
134* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
135- new upstream release
136- add BuildRequires: libpeas-devel
137- change BuildRequires: gtk3-devel instead of gtk2-devel
138- update Patch0
139
140* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
141- new upstream release
142- change BuildRequires: eog-devel instead of eog
143
144* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
145- rebuild with libchamplain-0.8
146
147* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
148- new upstream release
149
150* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
151- new upstream release
152
153* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
154- initial build for Vine Linux
155- exclude postr plugin
156
Note: See TracBrowser for help on using the repository browser.