source: projects/specs/trunk/e/eog-plugins/eog-plugins-vl.spec @ 12005

Revision 12005, 4.9 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define pkg_version 3.26.3
4%define pkg_release 1%{?_dist_release}
5
6Summary: Plugins for eog
7Summary(ja): eog用のプラグイン
8Name: eog-plugins
9Version: %{pkg_version}
10Release: %{pkg_release}
11Source0: http://download.gnome.org/sources/%{name}/3.16/%{name}-%{version}.tar.xz
12License: GPLv2+
13Group: Applications/Graphics
14URL: http://live.gnome.org/EyeOfGnome/Plugins
15
16BuildRequires: gtk3-devel
17BuildRequires: eog-devel
18BuildRequires: libexif-devel
19BuildRequires: libchamplain-devel, libchamplain-gtk-devel
20BuildRequires: libpeas-devel
21BuildRequires: gsettings-desktop-schemas-devel
22BuildRequires: libgdata-devel
23BuildRequires: python3-devel
24BuildRequires: postr
25BuildRequires: libappstream-glib-devel
26
27Requires: eog
28Requires(postun,posttrans): glib2
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35
36%description
37It's a collection of plugins for use with the Eye of GNOME Image Viewer.
38
39%description -l ja
40Eye of GNOME イメージビューア用のプラグイン集
41
42
43%prep
44%setup -q
45
46%build
47%configure --with-plugins=map,exif-display,fit-to-width,pythonconsole,slideshowshuffle,postr,postasa,send-by-mail
48%{__make} %{?_smp_mflags}
49
50
51%install
52%{__rm} -rf ${RPM_BUILD_ROOT}
53%{__make} install DESTDIR=${RPM_BUILD_ROOT}
54
55# remove *.la
56%{__rm} -f ${RPM_BUILD_ROOT}/%{_libdir}/eog/plugins/*.la
57
58%find_lang %{name}
59
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64%postun
65if [ $1 -eq 0 ]; then
66  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
67fi
68
69%posttrans
70glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
71
72
73%files -f %{name}.lang
74%defattr(-,root,root)
75%license COPYING
76%doc NEWS README
77%{_libdir}/eog/plugins
78%{_datadir}/appdata/eog-*.xml
79%{_datadir}/eog/plugins/pythonconsole/config.ui
80%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.exif-display.gschema.xml
81%{_datadir}/glib-2.0/schemas/org.gnome.eog.plugins.pythonconsole.gschema.xml
82
83
84%changelog
85* Mon Dec 31 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.26.3-1
86- new upstream release.
87
88* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
89- new upstream release
90
91* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
92- new upstream release
93
94* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
95- new upstream release
96
97* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
98- new upstream release
99
100* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-2
101- rebuild with python-3.4.2
102
103* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
104- new upstream release
105
106* Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
107- new upstream release
108
109* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
110- new upstream release
111
112* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
113- new upstream release
114
115* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
116- rebuild with VineSeed environment
117
118* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
119- new upstream release
120
121* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
122- new upstream release
123
124* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
125- new upstream release
126
127* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
128- new upstream release
129
130* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
131- new upstream release
132- add BuildRequires: gsettings-desktop-schemas-devel
133
134* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
135- new upstream release
136- remove Patch0
137
138* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
139- new upstream release
140
141* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
142- new upstream release
143
144* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
145- new upstream release
146
147* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
148- new upstream release
149- add BuildRequires: postr
150
151* Sun Sep 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.1.2-2
152- enable postr (upload picture to Flickr)
153- enable postasa (upload picture to Picasa web)
154- enable send-by-mail (Send picture to friends by evolution mail)
155- add libgdata-devel to BR
156- add README.vine
157
158* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
159- new upstream release
160- add BuildRequires: libpeas-devel
161- change BuildRequires: gtk3-devel instead of gtk2-devel
162- update Patch0
163
164* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
165- new upstream release
166- change BuildRequires: eog-devel instead of eog
167
168* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
169- rebuild with libchamplain-0.8
170
171* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
172- new upstream release
173
174* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
175- new upstream release
176
177* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
178- initial build for Vine Linux
179- exclude postr plugin
180
Note: See TracBrowser for help on using the repository browser.