source: projects/specs/trunk/e/engrampa/engrampa-vl.spec @ 11673

Revision 11673, 4.4 KB checked in by iwaim, 6 years ago (diff)

engrampa 1.20.0-1

Line 
1%define major_ver 1.20
2%define ver %{major_ver}.0
3%define rel 1
4
5Summary:        Archive manipulator for MATE
6Name:           engrampa
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9Source0:        http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
10License:        GPLv2
11Group:          Applications/Archiving
12URL:            http://mate-desktop.org/
13
14BuildRequires:  mate-common
15BuildRequires:  gtk3-devel
16BuildRequires:  libSM-devel
17BuildRequires:  json-glib-devel
18BuildRequires:  caja-devel
19BuildRequires:  gtk-doc
20BuildRequires:  itstool
21BuildRequires:  autoconf
22BuildRequires:  automake
23
24Requires(posttrans,postun):     glib2
25Requires(post,postun):  gtk2
26Requires(post,postun):  desktop-file-utils
27
28Obsoletes:      mate-file-archiver < 1.8.0
29Provides:       mate-file-archiver = %{version}-%{release}
30
31BuildRoot:      %{_tmppath}/%{name}-%{version}-root
32
33Vendor:         Project Vine
34Distribution:   Vine Linux
35Packager:       Takemikaduchi, iwaim
36
37
38%description
39Engrampa is an archive manager for the MATE environment.  This means
40that you can create and modify archives; view the content of an archive;
41view and modify a file contained in the archive; extract files from the
42archive.
43
44
45%prep
46%setup -q
47
48
49%build
50(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
51%configure \
52        --libexecdir=%{_libexecdir}/mate \
53        --disable-static
54
55%{__make} %{?_smp_mflags}
56
57
58%install
59%{__rm} -rf ${RPM_BUILD_ROOT}
60
61%{__make} install DESTDIR=${RPM_BUILD_ROOT}
62
63find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
64find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
65
66%find_lang engrampa
67
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72%post
73/sbin/ldconfig
74update-desktop-database %{_datadir}/applications >& /dev/null ||:
75touch --no-create %{_datadir}/icons/hicolor
76gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
77
78%postun
79/sbin/ldconfig
80if [ $1 -eq 0 ]; then
81  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
82  update-desktop-database %{_datadir}/applications >& /dev/null ||:
83  touch --no-create %{_datadir}/icons/hicolor
84  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
85fi
86
87%posttrans
88glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
89
90
91%files -f engrampa.lang
92%defattr(-,root,root,-)
93%doc COPYING ChangeLog NEWS README
94%{_bindir}/%{name}
95%{_libdir}/caja/extensions-2.0/libcaja-%{name}.so
96%{_libexecdir}/mate/%{name}/isoinfo.sh
97%{_libexecdir}/mate/%{name}/rpm2cpio
98%{_libexecdir}/mate/%{name}-server
99%{_datadir}/appdata/%{name}.appdata.xml
100%{_datadir}/applications/%{name}.desktop
101%{_datadir}/caja/extensions/libcaja-%{name}.caja-extension
102%{_datadir}/dbus-1/services/org.mate.Engrampa.service
103%{_datadir}/%{name}
104%{_datadir}/glib-2.0/schemas/org.mate.%{name}.gschema.xml
105%{_datadir}/icons/hicolor/*/*/*
106%{_datadir}/help/*/%{name}
107%{_mandir}/man1/%{name}.1.gz
108
109
110%changelog
111* Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20.0-1
112- update to 1.20.0
113
114* Thu Jan 18 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.3-1
115- update to 1.18.3
116
117* Thu May 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.2-1
118- update to 1.18.2
119
120* Sat Apr  8 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.1-1
121- update to 1.18.1
122
123* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.0-1
124- new upstream release
125- update GTK+ version
126 - BR: gtk3-devel
127- update Packager
128
129* Sun May 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.1-1
130- new upstream release
131
132* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
133- new upstream release
134
135* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
136- new upstream release
137
138* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
139- new upstream release
140
141* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
142- new upstream release
143
144* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
145- new upstream release
146
147* Wed Nov 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
148- new upstream release
149- rename package
150- add BuildRequies: json-glib-devel, caja-devel, itstool
151
152* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-2
153- rebuild with VineSeed environment
154
155* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
156- new upstream release
157
158* Thu Aug 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
159- new upstream release
160
161* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
162- new upstream release
163
164* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
165- change category
166
167* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
168- initial build for Vine Linux
169
Note: See TracBrowser for help on using the repository browser.