source: projects/specs/trunk/e/enchant/enchant-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%bcond_with voikko
2%bcond_with hunspell
3
4Summary: An Enchanting Spell Checking Library
5Summary(ja): スペルチェックライブラリ
6Name: enchant
7Version: 1.4.2
8Release: 1%{?_dist_release}
9Group: System Environment/Libraries
10License: LGPLv2+
11Source: http://www.abisource.com/downloads/enchant/%{version}/enchant-%{version}.tar.gz
12URL: http://www.abisource.com/
13BuildRequires: glib2-devel >= 2.6.0
14BuildRequires: aspell-devel
15%if %{with hunspell}
16BuildRequires: hunspell-devel
17%endif
18%if %{with voikko}
19BuildRequires: libvoikko-devel
20%endif
21BuildRequires: automake, libtool
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23
24%description
25A library that wraps other spell checking backends.
26
27%package hunspell
28Summary: Integration with hunspell for libenchant
29Summary(ja): Integration with hunspell for libenchant
30Group: System Environment/Libraries
31Requires: enchant = %{version}-%{release}
32
33%description hunspell
34Libraries necessary to integrate applications using libenchant with hunspell.
35
36%package voikko
37Summary: Integration with voikko for libenchant
38Summary(ja): Integration with voikko for libenchant
39Group: System Environment/Libraries
40Requires: enchant = %{version}-%{release}
41
42%description voikko
43Libraries necessary to integrate applications using libenchant with voikko.
44
45
46%package devel
47Summary: Support files necessary to compile applications with libenchant.
48Summary(ja): Support files necessary to compile applications with libenchant.
49Group: Development/Libraries
50Requires: enchant = %{version}-%{release}
51Requires: glib2-devel
52
53%description devel
54Libraries, headers, and support files necessary to compile applications using libenchant.
55
56%prep
57%setup -q
58
59%build
60%configure \
61  --disable-ispell \
62  --disable-hspell \
63%if %{with hunspell}
64  --with-myspell \
65%else
66  --disable-myspell \
67%endif
68%if !%{with voikko}
69  --disable-voikko \
70%endif
71  --disable-zemberek \
72  --disable-static
73 
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make DESTDIR=$RPM_BUILD_ROOT install
79rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
80rm -f $RPM_BUILD_ROOT/%{_libdir}/enchant/*.la
81
82%files
83%defattr(-,root,root)
84%doc AUTHORS COPYING.LIB README
85%{_bindir}/*
86%{_libdir}/lib*.so.*
87%dir %{_libdir}/enchant
88%{_libdir}/enchant/lib*aspell.so*
89%{_mandir}/man1/enchant.1.gz
90%{_datadir}/enchant
91
92%if %{with hunspell}
93%files hunspell
94%{_libdir}/enchant/lib*myspell.so*
95%endif
96
97%if %{with voikko}
98%files voikko
99%{_libdir}/enchant/lib*_voikko.so*
100%endif
101
102%files devel
103%defattr(-,root,root)
104%{_libdir}/*.so
105%{_libdir}/pkgconfig/enchant.pc
106%{_includedir}/enchant
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112%clean
113rm -r $RPM_BUILD_ROOT
114
115%changelog
116* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
117- initial build for Vine Linux
118
119* Sat Jul 26 2008 Michael Schwendt <mschwendt@fedoraproject.org> 1:1.4.2-4
120- Rebuild for ABI-incompatible hunspell-1.2.4.2-2.fc10
121
122* Thu Jul 10 2008 Marc Maurer <uwog@abisource.com> 1:1.4.2-3
123- Fix 426712: don't build static libs (patch from Michael Schwendt)
124
125* Wed May 21 2008 Marc Maurer <uwog@abisource.com> 1:1.4.2-2
126- Rebuild
127
128* Wed May 21 2008 Marc Maurer <uwog@abisource.com> 1:1.4.2-1
129- New upstream release
130- Add voikko support in an enchant-voikko package
131- Bump glib-devel BR to 2.6.0
132
133* Fri Feb 08 2008 Caolan McNamara <caolanm@redhat.com> 1:1.3.0-4.fc9
134- minor cockup
135
136* Sat Jan 26 2008 Caolan McNamara <caolanm@redhat.com> 1:1.3.0-3.fc9
137- Resolves: rhbz#426402 use system hunspell not internal one and
138  split out aspell backend.
139- See: rhbz#430354 hspell backend disabled until pic issue fixed
140
141* Wed Dec 19 2007 Caolan McNamara <caolanm@redhat.com> 1:1.3.0-2.fc9
142- tell enchant where the myspell dictionaries are
143
144* Thu Oct 12 2006 Marc Maurer <uwog@abisource.com> 1:1.3.0-1.fc6
145- Update to 1.3.0
146
147* Mon Sep 11 2006 Marc Maurer <uwog@abisource.com> 1:1.2.5-3.fc6
148- Rebuild for FC6
149
150* Mon Apr 10 2006 Marc Maurer <uwog@abisource.com> 1:1.2.5-2.fc6
151- Rebuild
152
153* Mon Apr 10 2006 Marc Maurer <uwog@abisource.com> 1:1.2.5-1.fc6
154- Package the data dir as well (bug 188516)
155- New upstream version
156- Add hspell requirement/support
157
158* Tue Feb 14 2006 Marc Maurer <uwog@abisource.com> 1:1.2.2-2.fc5
159- Rebuild for Fedora Extras 5
160
161* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> 1:1.2.2-1.fc5
162- Update to 1.2.2
163
164* Mon Jan 30 2006 Marc Maurer <uwog@abisource.com> 1:1.2.1-1.fc5
165- Update to 1.2.1
166- Drop glib Require
167
168* Sat Oct 22 2005 Marc Maurer <uwog@abisource.com> 1:1.2.0-1.fc5
169- Update to 1.2.0
170
171* Wed Oct  5 2005 Marc Maurer <uwog@abisource.com> 1:1.1.6-4.fc5
172- Add dist flag to the release number
173
174* Mon Apr  4 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1:1.1.6-3
175- make in %%build
176- disable bad buildroot rpaths in libs, don't use %%makeinstall
177- require %%{epoch} of main package in -devel package (Fridrich Strba)
178
179* Thu Mar 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> 1:1.1.6-2
180- add dep glib2-devel for pkgconfig in -devel package
181- include %%{_libdir}/enchant dir in main package
182- make -devel package require exact VR of main package
183- use -p /sbin/ldconfig in scriptlets
184
185* Mon Mar 28 2005 Marc Maurer <uwog@abisource.com> 1:1.1.6-1
186- update to 1.1.6
187- drop the manpage patch (RH#145010#)
188- fix version numbers in the spec changelog
189
190* Wed Mar  2 2005 Caolan McNamara <caolanm@redhat.com> 1:1.1.5-3
191- rebuild with gcc4
192
193* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> 1:1.1.5-2
194- RH#145010# misformatted manpage
195
196* Mon Dec 20 2004 Caolan McNamara <caolanm@redhat.com> 1:1.1.5-1
197- initial fedora import
198
199* Sun Aug 24 2003 Rui Miguel Seabra <rms@1407.org>
200- update spec to current stat of affairs
201- building from source rpm is now aware of --with and --without flags:
202- --without aspell --without ispell --without myspell --with uspell
203
204* Wed Jul 16 2003 Rui Miguel Seabra <rms@1407.org>
205- take advantage of environment rpm macros
206
207* Sun Jul 13 2003 Dom Lachowicz <cinamod@hotmail.com>
208- Initial version
Note: See TracBrowser for help on using the repository browser.