source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 8622

Revision 8622, 17.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define major_ver 3.12
2%define minor_ver 4
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.12.0
10%global glib2_min_version       2.40.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  eudev-libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  libaccounts-glib-devel
71BuildRequires:  yelp-tools
72
73Requires:       telepathy-filesystem
74Requires:       telepathy-gabble
75Requires:       telepathy-salut
76Requires:       telepathy-idle
77## Also hardcode Haze dependency since Empathy is the default IM client in F10+
78## and I'd hate for people to simply disregard it for lack of the "out of the
79## box" protocol support that Pidgin has. (RHBZ: 458935)
80BuildRequires:  telepathy-haze
81# Require this for VOIP support
82Requires:       telepathy-mission-control >= %{tp_mc_min_version}
83
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
88## upstream 2.29.1 removed shared libraries: #599086
89Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
90## upstream 2.29.1 removed python bindings' #599039
91Obsoletes: empathy-python < 2.29.1
92
93Obsoletes: nautilus-sendto-empathy < 3.7.0
94
95Vendor: Project Vine
96Distribution: Vine Linux
97
98%description
99Empathy provides a powerful multiple protocol instant messaging
100client using the Telepathy framework.
101
102
103%prep
104%setup -q
105
106
107%build
108## GCC complains about some unused functions, so we forcibly show those as
109## simple warnings instead of build-halting errors.
110%configure --disable-static
111
112##make %{?_smp_mflags}
113## don't use _smp_mflags at empathy-2.18.1
114make
115
116install -m 0644 %{SOURCE1} ./README.ConnectionManagers
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make install DESTDIR=$RPM_BUILD_ROOT
122find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
123
124%find_lang %{name}
125%find_lang %{name}-tpaw
126
127desktop-file-install --vendor "" --delete-original      \
128        --dir %{buildroot}%{_datadir}/applications      \
129        %{buildroot}%{_datadir}/applications/%{name}.desktop
130
131
132%clean
133rm -rf %{buildroot}
134
135
136%post
137touch --no-create %{_datadir}/icons/hicolor ||:
138%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
139
140%postun
141touch --no-create %{_datadir}/icons/hicolor || :
142if [ -x %{_bindir}/gtk-update-icon-cache ]; then
143        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
144        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
145fi
146
147%posttrans
148gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
149glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
150
151
152%files -f %{name}.lang -f %{name}-tpaw.lang
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING README README.ConnectionManagers NEWS
155%{_bindir}/empathy
156%{_bindir}/empathy-accounts
157%{_bindir}/empathy-debugger
158%{_libexecdir}/empathy-auth-client
159%{_libexecdir}/empathy-call
160%{_libexecdir}/empathy-chat
161%{_libdir}/%{name}/libempathy*.so
162%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
163%{_datadir}/GConf/gsettings/*
164%{_datadir}/appdata/empathy.appdata.xml
165%{_datadir}/applications/*.desktop
166%{_datadir}/adium/message-styles
167%{_datadir}/dbus-1/services/*
168%{_datadir}/%{name}
169%{_datadir}/glib-2.0/schemas/*.xml
170%{_datadir}/help/*/%{name}
171%{_datadir}/icons/hicolor/*/apps/%{name}*
172%{_datadir}/telepathy/clients/*.client
173%{_mandir}/man1/empathy*.1*
174
175
176%changelog
177* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.4-1
178- new upstream release
179- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
180
181* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
182- new upstream release
183
184* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
185- new upstream release
186- add BuildRequires: libaccounts-glib-devel
187
188* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
189- new upstream release
190
191* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
192- new upstream release
193
194* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
195- new upstream release
196
197* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
198- new upstream release
199
200* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
201- new upstream release
202
203* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
204- new upstream release
205- remove BuildRequires: gnome-panel, nautilus-sendto-devel
206- remove nautilus-sendto-empathy subpackage
207
208* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
209- fix spec
210
211* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
212- new upstream release
213
214* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
215- new upstream release
216
217* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
218- rebuild with telepathy-logger-0.6.0
219
220* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
221- new upstream release
222
223* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
224- new upstream release
225
226* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
227- new upstream release
228- add BuildRequires: libsecret-devel, yelp-tools
229- remove BuildRequires: libgnome-keyring-devel
230
231* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
232- new upstream release
233
234* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
235- new upstream release
236
237* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
238- new upstream release
239
240* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
241- new upstream release
242- change BuildRequires: gcr-devel instead of gnome-keyring-devel
243- change BuildRequires: farstream-devel instead of farsight2-devel
244- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
245- add BuildRequires: itstool
246- remove Requires: telepathy-stream-engine
247- add Requires: telepathy-idle
248
249* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
250- new upstream release
251
252* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
253- new upstream release
254
255* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
256- new upstream release
257- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
258
259* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
260- new upstream release
261
262* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
263- new upstream release
264
265* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
266- new upstream release
267
268* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
269- new upstream release
270
271* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
272- new upstream release
273
274* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
275- new upstream release
276- add BuildRequires: pulseaudio-libs-devel
277
278* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
279- new upstream release
280- change BuildRequires: gtk3-devel instead of gtk2-devel
281- change BuildRequires: unique3-devel instead of unique-devel
282- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
283- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
284- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
285
286* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
287- new upstream release
288- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
289                     geoclue-devel, enchant-devel
290- add Requires: telepathy-mission-control
291- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
292
293* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
294- new upstream release
295- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
296- fix %files
297- fix %post, %postun
298- drop %pre, %preun
299
300* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
301- rebuild with evolution-data-server-2.30.2
302- add nautilus-sendto-empathy package
303  - add configure option (--enable-nautilus-sendto=yes)
304  - add BuildRequires: nautilus-sendto-devel
305
306* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
307- add Obsoletes: empathy-python < 2.29.1
308
309* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
310- new upstream release
311- add new files: %%{_bindir}/empathy-{accounts,debugger}
312- drop -libs, -devel, -python sub packages: upstream removed
313  - Obsoletes: empathy-{libs,devel} < 2.29.1
314  - drop BuildRequires: python-devel
315- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
316- drop applet files in %%files: upstream removed the panel applets
317  - update %%post, %pre and %%preun
318- update BuildRequires version for glib2 and tp_glib
319- defined major_ver, minor_ver and rel
320- fix BuildRequires for gnome-keyring
321
322* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
323- new upstream release
324- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
325
326* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
327- rebuilt with python-2.6.4
328
329* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
330- unuse %%{?_smp_mflags} option to make
331
332* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
333- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
334
335* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
336- new upstream release
337
338* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
339- new upstream release
340
341* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
342- initial build for Vine Linux
343
344* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
345- Update to 2.23.92
346
347* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
348- Update to 2.23.91
349
350* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
351- Now that Empathy will be the default IM client in F10+, hardcode a dependency
352  on telepathy-haze to keep the same protocol functionality across upgrades,
353  for a much improved "out of the box" experience.
354- Reference: bug 458935.
355
356* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
357- Update to new upstream release (2.23.90)
358
359* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
360- Apply patch from Colin Walters to automagically update profile namings for
361  the switch to using Empathy's provided profiles.
362- Drop the upgrade script (no longer needed since it's automatically done).
363  - upgrade-haze-profiles.sh
364
365* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
366- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
367  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
368  horribly stale...). This makes for better automagic functionality (if Haze is
369  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
370  + upgrade-haze-profiles.sh
371
372* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
373- Update to new upstream release (2.23.6)
374- Use the in-tarball libtool scripts instead of the system copy to workaround
375  'make install' errors.
376
377* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
378- Update to 0.23.4.
379- Update source url.
380
381* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
382- Update to 0.23.3.
383- Remove reference to stream-engine in connections managers readme.
384
385* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
386- Update to 0.23.2.
387- Add man pages.
388- Use enchant-devel, instead of aspell-devel.
389
390* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
391- Rebuild for new e-d-s.
392
393* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
394- Drop multiple copies of COPYING file.
395- Drop BR on gnome-vfs2-devel.
396- Require telepathy-stream-engine for VOIP support.
397- Add BR on iso-codes-devel, so spell-checking is enabled.
398
399* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
400- Update to new upstream release (0.23.1)
401- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
402
403* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
404- Update to new upstream release (0.22.1)
405
406* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
407- Update to new upstream release (0.22.0)
408
409* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
410- Update to new upstream release (0.21.91)
411
412* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
413- Update to new upstream release (0.21.90)
414
415* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
416- Autorebuild for GCC 4.3
417
418* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
419- Update to new upstream release (0.21.4)
420
421* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
422- Update to new upstream release (0.21.2)
423- Drop backported drag-and-drop patch (fixed upstream):
424    - svn380-fix-contact-DnD.patch
425- Update README.ConnectionManagers: Include Haze package note, remove Galago
426  note (a feed-only connection manager isn't useful for instant messaging),
427  and fix some wording.
428
429* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
430- Backport upstream patch to fixes crashes when using drag-and-drop of a
431  contact from the buddy list to the current conversation window to initiate a
432  conversation:
433    + svn380-fix-contact-DnD.patch
434- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
435  dragged a contact ...)
436
437* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
438- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
439  is essentially useless due to the need to install an external connection
440  manager. Also, add a README.ConnectionManagers to the installed
441  documentation which lists other possibilities.
442- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
443  and bug 334221 (Default empathy install is useless).
444
445* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
446- Enable VoIP support for those brave enough to test/break/debug it (F9+
447  only). Though it is functional, it is still deemed rather unstable by
448  upstream. Use it at your own risk. :)
449
450* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
451- Disable VoIP support at this time, since it is deemed unstable by upstream
452  for now. (Thanks to Brian Pepple for the notice.)
453 
454* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
455- Update to new upstream release (0.14).
456
457* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
458- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
459  and python bindings.
460- Split shared libraries into a libs subpackage for easier handling
461  in multi-lib environments.
462
463* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
464- Add ldconfig invocations to %%post and %%postun scriptlets.
465
466* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
467- Update to new upstream release (0.12).
468- Build against new mission-control stack.
469- Update License tag (GPLv2+).
470- Alphabetize BuildRequires list (aesthetic-only change).
471
472* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
473- Rebuild for selinux ppc32 issue.
474
475* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
476- Update to new upstream release (0.11)
477
478* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
479- bump to 0.8
480- Now with aspell support (deat to teh speeling mistaks)
481
482* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
483- bump to 0.7
484
485* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
486- Add telepathy-filesystem to Requires
487- Move .desktop from autostart to applications
488- Nasty hackery to make empathy launch from the menu
489
490* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
491- Add gettext to BuildRequires
492
493* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
494- Bump to 0.6
495
496* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
497- Let Empathy own the directory and not just the files in it
498
499* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
500- Initial package
Note: See TracBrowser for help on using the repository browser.