source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 8369

Revision 8369, 17.5 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.1

Line 
1%define major_ver 3.12
2%define minor_ver 1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.12.0
10%global glib2_min_version       2.40.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  libaccounts-glib-devel
71BuildRequires:  yelp-tools
72
73Requires:       telepathy-filesystem
74Requires:       telepathy-gabble
75Requires:       telepathy-salut
76Requires:       telepathy-idle
77## Also hardcode Haze dependency since Empathy is the default IM client in F10+
78## and I'd hate for people to simply disregard it for lack of the "out of the
79## box" protocol support that Pidgin has. (RHBZ: 458935)
80BuildRequires:  telepathy-haze
81# Require this for VOIP support
82Requires:       telepathy-mission-control >= %{tp_mc_min_version}
83
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
88## upstream 2.29.1 removed shared libraries: #599086
89Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
90## upstream 2.29.1 removed python bindings' #599039
91Obsoletes: empathy-python < 2.29.1
92
93Obsoletes: nautilus-sendto-empathy < 3.7.0
94
95Vendor: Project Vine
96Distribution: Vine Linux
97
98%description
99Empathy provides a powerful multiple protocol instant messaging
100client using the Telepathy framework.
101
102
103%prep
104%setup -q
105
106
107%build
108## GCC complains about some unused functions, so we forcibly show those as
109## simple warnings instead of build-halting errors.
110%configure --disable-static
111
112##make %{?_smp_mflags}
113## don't use _smp_mflags at empathy-2.18.1
114make
115
116install -m 0644 %{SOURCE1} ./README.ConnectionManagers
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make install DESTDIR=$RPM_BUILD_ROOT
122find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
123
124%find_lang %{name}
125%find_lang %{name}-tpaw
126
127desktop-file-install --vendor "" --delete-original      \
128        --dir %{buildroot}%{_datadir}/applications      \
129        %{buildroot}%{_datadir}/applications/%{name}.desktop
130
131
132%clean
133rm -rf %{buildroot}
134
135
136%post
137touch --no-create %{_datadir}/icons/hicolor ||:
138%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
139
140%postun
141touch --no-create %{_datadir}/icons/hicolor || :
142if [ -x %{_bindir}/gtk-update-icon-cache ]; then
143        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
144        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
145fi
146
147%posttrans
148gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
149glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
150
151
152%files -f %{name}.lang -f %{name}-tpaw.lang
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING README README.ConnectionManagers NEWS
155%{_bindir}/empathy
156%{_bindir}/empathy-accounts
157%{_bindir}/empathy-debugger
158%{_libexecdir}/empathy-auth-client
159%{_libexecdir}/empathy-call
160%{_libexecdir}/empathy-chat
161%{_libdir}/%{name}/libempathy*.so
162%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
163%{_datadir}/GConf/gsettings/*
164%{_datadir}/appdata/empathy.appdata.xml
165%{_datadir}/applications/*.desktop
166%{_datadir}/adium/message-styles
167%{_datadir}/dbus-1/services/*
168%{_datadir}/%{name}
169%{_datadir}/glib-2.0/schemas/*.xml
170%{_datadir}/help/*/%{name}
171%{_datadir}/icons/hicolor/*/apps/%{name}*
172%{_datadir}/telepathy/clients/*.client
173%{_mandir}/man1/empathy*.1*
174
175
176%changelog
177* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
178- new upstream release
179- add BuildRequires: libaccounts-glib-devel
180
181* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
182- new upstream release
183
184* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
185- new upstream release
186
187* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
188- new upstream release
189
190* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
191- new upstream release
192
193* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
194- new upstream release
195
196* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
197- new upstream release
198- remove BuildRequires: gnome-panel, nautilus-sendto-devel
199- remove nautilus-sendto-empathy subpackage
200
201* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
202- fix spec
203
204* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
205- new upstream release
206
207* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
208- new upstream release
209
210* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
211- rebuild with telepathy-logger-0.6.0
212
213* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
214- new upstream release
215
216* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
217- new upstream release
218
219* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
220- new upstream release
221- add BuildRequires: libsecret-devel, yelp-tools
222- remove BuildRequires: libgnome-keyring-devel
223
224* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
225- new upstream release
226
227* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
228- new upstream release
229
230* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
231- new upstream release
232
233* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
234- new upstream release
235- change BuildRequires: gcr-devel instead of gnome-keyring-devel
236- change BuildRequires: farstream-devel instead of farsight2-devel
237- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
238- add BuildRequires: itstool
239- remove Requires: telepathy-stream-engine
240- add Requires: telepathy-idle
241
242* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
243- new upstream release
244
245* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
246- new upstream release
247
248* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
249- new upstream release
250- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
251
252* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
253- new upstream release
254
255* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
256- new upstream release
257
258* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
259- new upstream release
260
261* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
262- new upstream release
263
264* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
265- new upstream release
266
267* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
268- new upstream release
269- add BuildRequires: pulseaudio-libs-devel
270
271* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
272- new upstream release
273- change BuildRequires: gtk3-devel instead of gtk2-devel
274- change BuildRequires: unique3-devel instead of unique-devel
275- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
276- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
277- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
278
279* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
280- new upstream release
281- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
282                     geoclue-devel, enchant-devel
283- add Requires: telepathy-mission-control
284- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
285
286* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
287- new upstream release
288- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
289- fix %files
290- fix %post, %postun
291- drop %pre, %preun
292
293* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
294- rebuild with evolution-data-server-2.30.2
295- add nautilus-sendto-empathy package
296  - add configure option (--enable-nautilus-sendto=yes)
297  - add BuildRequires: nautilus-sendto-devel
298
299* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
300- add Obsoletes: empathy-python < 2.29.1
301
302* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
303- new upstream release
304- add new files: %%{_bindir}/empathy-{accounts,debugger}
305- drop -libs, -devel, -python sub packages: upstream removed
306  - Obsoletes: empathy-{libs,devel} < 2.29.1
307  - drop BuildRequires: python-devel
308- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
309- drop applet files in %%files: upstream removed the panel applets
310  - update %%post, %pre and %%preun
311- update BuildRequires version for glib2 and tp_glib
312- defined major_ver, minor_ver and rel
313- fix BuildRequires for gnome-keyring
314
315* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
316- new upstream release
317- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
318
319* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
320- rebuilt with python-2.6.4
321
322* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
323- unuse %%{?_smp_mflags} option to make
324
325* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
326- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
327
328* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
329- new upstream release
330
331* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
332- new upstream release
333
334* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
335- initial build for Vine Linux
336
337* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
338- Update to 2.23.92
339
340* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
341- Update to 2.23.91
342
343* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
344- Now that Empathy will be the default IM client in F10+, hardcode a dependency
345  on telepathy-haze to keep the same protocol functionality across upgrades,
346  for a much improved "out of the box" experience.
347- Reference: bug 458935.
348
349* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
350- Update to new upstream release (2.23.90)
351
352* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
353- Apply patch from Colin Walters to automagically update profile namings for
354  the switch to using Empathy's provided profiles.
355- Drop the upgrade script (no longer needed since it's automatically done).
356  - upgrade-haze-profiles.sh
357
358* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
359- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
360  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
361  horribly stale...). This makes for better automagic functionality (if Haze is
362  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
363  + upgrade-haze-profiles.sh
364
365* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
366- Update to new upstream release (2.23.6)
367- Use the in-tarball libtool scripts instead of the system copy to workaround
368  'make install' errors.
369
370* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
371- Update to 0.23.4.
372- Update source url.
373
374* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
375- Update to 0.23.3.
376- Remove reference to stream-engine in connections managers readme.
377
378* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
379- Update to 0.23.2.
380- Add man pages.
381- Use enchant-devel, instead of aspell-devel.
382
383* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
384- Rebuild for new e-d-s.
385
386* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
387- Drop multiple copies of COPYING file.
388- Drop BR on gnome-vfs2-devel.
389- Require telepathy-stream-engine for VOIP support.
390- Add BR on iso-codes-devel, so spell-checking is enabled.
391
392* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
393- Update to new upstream release (0.23.1)
394- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
395
396* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
397- Update to new upstream release (0.22.1)
398
399* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
400- Update to new upstream release (0.22.0)
401
402* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
403- Update to new upstream release (0.21.91)
404
405* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
406- Update to new upstream release (0.21.90)
407
408* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
409- Autorebuild for GCC 4.3
410
411* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
412- Update to new upstream release (0.21.4)
413
414* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
415- Update to new upstream release (0.21.2)
416- Drop backported drag-and-drop patch (fixed upstream):
417    - svn380-fix-contact-DnD.patch
418- Update README.ConnectionManagers: Include Haze package note, remove Galago
419  note (a feed-only connection manager isn't useful for instant messaging),
420  and fix some wording.
421
422* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
423- Backport upstream patch to fixes crashes when using drag-and-drop of a
424  contact from the buddy list to the current conversation window to initiate a
425  conversation:
426    + svn380-fix-contact-DnD.patch
427- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
428  dragged a contact ...)
429
430* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
431- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
432  is essentially useless due to the need to install an external connection
433  manager. Also, add a README.ConnectionManagers to the installed
434  documentation which lists other possibilities.
435- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
436  and bug 334221 (Default empathy install is useless).
437
438* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
439- Enable VoIP support for those brave enough to test/break/debug it (F9+
440  only). Though it is functional, it is still deemed rather unstable by
441  upstream. Use it at your own risk. :)
442
443* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
444- Disable VoIP support at this time, since it is deemed unstable by upstream
445  for now. (Thanks to Brian Pepple for the notice.)
446 
447* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
448- Update to new upstream release (0.14).
449
450* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
451- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
452  and python bindings.
453- Split shared libraries into a libs subpackage for easier handling
454  in multi-lib environments.
455
456* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
457- Add ldconfig invocations to %%post and %%postun scriptlets.
458
459* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
460- Update to new upstream release (0.12).
461- Build against new mission-control stack.
462- Update License tag (GPLv2+).
463- Alphabetize BuildRequires list (aesthetic-only change).
464
465* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
466- Rebuild for selinux ppc32 issue.
467
468* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
469- Update to new upstream release (0.11)
470
471* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
472- bump to 0.8
473- Now with aspell support (deat to teh speeling mistaks)
474
475* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
476- bump to 0.7
477
478* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
479- Add telepathy-filesystem to Requires
480- Move .desktop from autostart to applications
481- Nasty hackery to make empathy launch from the menu
482
483* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
484- Add gettext to BuildRequires
485
486* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
487- Bump to 0.6
488
489* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
490- Let Empathy own the directory and not just the files in it
491
492* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
493- Initial package
Note: See TracBrowser for help on using the repository browser.