source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 8152

Revision 8152, 17.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define major_ver 3.10
2%define minor_ver 3
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.10.0
10%global glib2_min_version       2.38.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  yelp-tools
71
72Requires:       telepathy-filesystem
73Requires:       telepathy-gabble
74Requires:       telepathy-salut
75Requires:       telepathy-idle
76## Also hardcode Haze dependency since Empathy is the default IM client in F10+
77## and I'd hate for people to simply disregard it for lack of the "out of the
78## box" protocol support that Pidgin has. (RHBZ: 458935)
79BuildRequires:  telepathy-haze
80# Require this for VOIP support
81Requires:       telepathy-mission-control >= %{tp_mc_min_version}
82
83
84## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
85Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
86Provides:       telepathy-haze-mission-control = 0.2.0-3
87## upstream 2.29.1 removed shared libraries: #599086
88Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
89## upstream 2.29.1 removed python bindings' #599039
90Obsoletes: empathy-python < 2.29.1
91
92Obsoletes: nautilus-sendto-empathy < 3.7.0
93
94Vendor: Project Vine
95Distribution: Vine Linux
96
97%description
98Empathy provides a powerful multiple protocol instant messaging
99client using the Telepathy framework.
100
101
102%prep
103%setup -q
104
105
106%build
107## GCC complains about some unused functions, so we forcibly show those as
108## simple warnings instead of build-halting errors.
109%configure --disable-static
110
111##make %{?_smp_mflags}
112## don't use _smp_mflags at empathy-2.18.1
113make
114
115install -m 0644 %{SOURCE1} ./README.ConnectionManagers
116
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make install DESTDIR=$RPM_BUILD_ROOT
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
122
123%find_lang %{name}
124%find_lang %{name}-tpaw
125
126desktop-file-install --vendor "" --delete-original      \
127        --dir %{buildroot}%{_datadir}/applications      \
128        %{buildroot}%{_datadir}/applications/%{name}.desktop
129
130
131%clean
132rm -rf %{buildroot}
133
134
135%post
136touch --no-create %{_datadir}/icons/hicolor ||:
137%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
138
139%postun
140touch --no-create %{_datadir}/icons/hicolor || :
141if [ -x %{_bindir}/gtk-update-icon-cache ]; then
142        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
143        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
144fi
145
146%posttrans
147gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
148glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
149
150
151%files -f %{name}.lang -f %{name}-tpaw.lang
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING README README.ConnectionManagers NEWS
154%{_bindir}/empathy
155%{_bindir}/empathy-accounts
156%{_bindir}/empathy-debugger
157%{_libexecdir}/empathy-auth-client
158%{_libexecdir}/empathy-call
159%{_libexecdir}/empathy-chat
160%{_libdir}/%{name}/libempathy*.so
161%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
162%{_datadir}/GConf/gsettings/*
163%{_datadir}/appdata/empathy.appdata.xml
164%{_datadir}/applications/*.desktop
165%{_datadir}/adium/message-styles
166%{_datadir}/dbus-1/services/*
167%{_datadir}/%{name}
168%{_datadir}/glib-2.0/schemas/*.xml
169%{_datadir}/help/*/%{name}
170%{_datadir}/icons/hicolor/*/apps/%{name}*
171%{_datadir}/telepathy/clients/*.client
172%{_mandir}/man1/empathy*.1*
173
174
175%changelog
176* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
177- new upstream release
178
179* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
180- new upstream release
181
182* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
183- new upstream release
184
185* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
186- new upstream release
187
188* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
189- new upstream release
190- remove BuildRequires: gnome-panel, nautilus-sendto-devel
191- remove nautilus-sendto-empathy subpackage
192
193* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
194- fix spec
195
196* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
197- new upstream release
198
199* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
200- new upstream release
201
202* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
203- rebuild with telepathy-logger-0.6.0
204
205* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
206- new upstream release
207
208* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
209- new upstream release
210
211* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
212- new upstream release
213- add BuildRequires: libsecret-devel, yelp-tools
214- remove BuildRequires: libgnome-keyring-devel
215
216* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
217- new upstream release
218
219* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
220- new upstream release
221
222* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
223- new upstream release
224
225* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
226- new upstream release
227- change BuildRequires: gcr-devel instead of gnome-keyring-devel
228- change BuildRequires: farstream-devel instead of farsight2-devel
229- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
230- add BuildRequires: itstool
231- remove Requires: telepathy-stream-engine
232- add Requires: telepathy-idle
233
234* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
235- new upstream release
236
237* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
238- new upstream release
239
240* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
241- new upstream release
242- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
243
244* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
245- new upstream release
246
247* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
248- new upstream release
249
250* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
251- new upstream release
252
253* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
254- new upstream release
255
256* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
257- new upstream release
258
259* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
260- new upstream release
261- add BuildRequires: pulseaudio-libs-devel
262
263* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
264- new upstream release
265- change BuildRequires: gtk3-devel instead of gtk2-devel
266- change BuildRequires: unique3-devel instead of unique-devel
267- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
268- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
269- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
270
271* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
272- new upstream release
273- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
274                     geoclue-devel, enchant-devel
275- add Requires: telepathy-mission-control
276- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
277
278* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
279- new upstream release
280- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
281- fix %files
282- fix %post, %postun
283- drop %pre, %preun
284
285* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
286- rebuild with evolution-data-server-2.30.2
287- add nautilus-sendto-empathy package
288  - add configure option (--enable-nautilus-sendto=yes)
289  - add BuildRequires: nautilus-sendto-devel
290
291* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
292- add Obsoletes: empathy-python < 2.29.1
293
294* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
295- new upstream release
296- add new files: %%{_bindir}/empathy-{accounts,debugger}
297- drop -libs, -devel, -python sub packages: upstream removed
298  - Obsoletes: empathy-{libs,devel} < 2.29.1
299  - drop BuildRequires: python-devel
300- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
301- drop applet files in %%files: upstream removed the panel applets
302  - update %%post, %pre and %%preun
303- update BuildRequires version for glib2 and tp_glib
304- defined major_ver, minor_ver and rel
305- fix BuildRequires for gnome-keyring
306
307* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
308- new upstream release
309- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
310
311* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
312- rebuilt with python-2.6.4
313
314* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
315- unuse %%{?_smp_mflags} option to make
316
317* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
318- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
319
320* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
321- new upstream release
322
323* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
324- new upstream release
325
326* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
327- initial build for Vine Linux
328
329* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
330- Update to 2.23.92
331
332* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
333- Update to 2.23.91
334
335* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
336- Now that Empathy will be the default IM client in F10+, hardcode a dependency
337  on telepathy-haze to keep the same protocol functionality across upgrades,
338  for a much improved "out of the box" experience.
339- Reference: bug 458935.
340
341* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
342- Update to new upstream release (2.23.90)
343
344* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
345- Apply patch from Colin Walters to automagically update profile namings for
346  the switch to using Empathy's provided profiles.
347- Drop the upgrade script (no longer needed since it's automatically done).
348  - upgrade-haze-profiles.sh
349
350* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
351- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
352  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
353  horribly stale...). This makes for better automagic functionality (if Haze is
354  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
355  + upgrade-haze-profiles.sh
356
357* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
358- Update to new upstream release (2.23.6)
359- Use the in-tarball libtool scripts instead of the system copy to workaround
360  'make install' errors.
361
362* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
363- Update to 0.23.4.
364- Update source url.
365
366* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
367- Update to 0.23.3.
368- Remove reference to stream-engine in connections managers readme.
369
370* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
371- Update to 0.23.2.
372- Add man pages.
373- Use enchant-devel, instead of aspell-devel.
374
375* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
376- Rebuild for new e-d-s.
377
378* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
379- Drop multiple copies of COPYING file.
380- Drop BR on gnome-vfs2-devel.
381- Require telepathy-stream-engine for VOIP support.
382- Add BR on iso-codes-devel, so spell-checking is enabled.
383
384* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
385- Update to new upstream release (0.23.1)
386- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
387
388* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
389- Update to new upstream release (0.22.1)
390
391* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
392- Update to new upstream release (0.22.0)
393
394* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
395- Update to new upstream release (0.21.91)
396
397* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
398- Update to new upstream release (0.21.90)
399
400* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
401- Autorebuild for GCC 4.3
402
403* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
404- Update to new upstream release (0.21.4)
405
406* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
407- Update to new upstream release (0.21.2)
408- Drop backported drag-and-drop patch (fixed upstream):
409    - svn380-fix-contact-DnD.patch
410- Update README.ConnectionManagers: Include Haze package note, remove Galago
411  note (a feed-only connection manager isn't useful for instant messaging),
412  and fix some wording.
413
414* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
415- Backport upstream patch to fixes crashes when using drag-and-drop of a
416  contact from the buddy list to the current conversation window to initiate a
417  conversation:
418    + svn380-fix-contact-DnD.patch
419- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
420  dragged a contact ...)
421
422* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
423- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
424  is essentially useless due to the need to install an external connection
425  manager. Also, add a README.ConnectionManagers to the installed
426  documentation which lists other possibilities.
427- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
428  and bug 334221 (Default empathy install is useless).
429
430* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
431- Enable VoIP support for those brave enough to test/break/debug it (F9+
432  only). Though it is functional, it is still deemed rather unstable by
433  upstream. Use it at your own risk. :)
434
435* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
436- Disable VoIP support at this time, since it is deemed unstable by upstream
437  for now. (Thanks to Brian Pepple for the notice.)
438 
439* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
440- Update to new upstream release (0.14).
441
442* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
443- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
444  and python bindings.
445- Split shared libraries into a libs subpackage for easier handling
446  in multi-lib environments.
447
448* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
449- Add ldconfig invocations to %%post and %%postun scriptlets.
450
451* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
452- Update to new upstream release (0.12).
453- Build against new mission-control stack.
454- Update License tag (GPLv2+).
455- Alphabetize BuildRequires list (aesthetic-only change).
456
457* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
458- Rebuild for selinux ppc32 issue.
459
460* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
461- Update to new upstream release (0.11)
462
463* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
464- bump to 0.8
465- Now with aspell support (deat to teh speeling mistaks)
466
467* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
468- bump to 0.7
469
470* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
471- Add telepathy-filesystem to Requires
472- Move .desktop from autostart to applications
473- Nasty hackery to make empathy launch from the menu
474
475* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
476- Add gettext to BuildRequires
477
478* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
479- Bump to 0.6
480
481* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
482- Let Empathy own the directory and not just the files in it
483
484* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
485- Initial package
Note: See TracBrowser for help on using the repository browser.