source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 7938

Revision 7938, 17.0 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define major_ver 3.10
2%define minor_ver 1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.10.0
10%global glib2_min_version       2.38.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  yelp-tools
71
72Requires:       telepathy-filesystem
73Requires:       telepathy-gabble
74Requires:       telepathy-salut
75Requires:       telepathy-idle
76## Also hardcode Haze dependency since Empathy is the default IM client in F10+
77## and I'd hate for people to simply disregard it for lack of the "out of the
78## box" protocol support that Pidgin has. (RHBZ: 458935)
79BuildRequires:  telepathy-haze
80# Require this for VOIP support
81Requires:       telepathy-mission-control >= %{tp_mc_min_version}
82
83
84## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
85Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
86Provides:       telepathy-haze-mission-control = 0.2.0-3
87## upstream 2.29.1 removed shared libraries: #599086
88Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
89## upstream 2.29.1 removed python bindings' #599039
90Obsoletes: empathy-python < 2.29.1
91
92Obsoletes: nautilus-sendto-empathy < 3.7.0
93
94Vendor: Project Vine
95Distribution: Vine Linux
96
97%description
98Empathy provides a powerful multiple protocol instant messaging
99client using the Telepathy framework.
100
101
102%prep
103%setup -q
104
105
106%build
107## GCC complains about some unused functions, so we forcibly show those as
108## simple warnings instead of build-halting errors.
109%configure --disable-static
110
111##make %{?_smp_mflags}
112## don't use _smp_mflags at empathy-2.18.1
113make
114
115install -m 0644 %{SOURCE1} ./README.ConnectionManagers
116
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make install DESTDIR=$RPM_BUILD_ROOT
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
122
123%find_lang %{name}
124%find_lang %{name}-tpaw
125
126desktop-file-install --vendor "" --delete-original      \
127        --dir %{buildroot}%{_datadir}/applications      \
128        %{buildroot}%{_datadir}/applications/%{name}.desktop
129
130
131%clean
132rm -rf %{buildroot}
133
134
135%post
136touch --no-create %{_datadir}/icons/hicolor ||:
137%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
138
139%postun
140touch --no-create %{_datadir}/icons/hicolor || :
141if [ -x %{_bindir}/gtk-update-icon-cache ]; then
142        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
143        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
144fi
145
146%posttrans
147gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
148glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
149
150
151%files -f %{name}.lang -f %{name}-tpaw.lang
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING README README.ConnectionManagers NEWS
154%{_bindir}/empathy
155%{_bindir}/empathy-accounts
156%{_bindir}/empathy-debugger
157%{_libexecdir}/empathy-auth-client
158%{_libexecdir}/empathy-call
159%{_libexecdir}/empathy-chat
160%{_libdir}/%{name}/libempathy*.so
161%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
162%{_datadir}/GConf/gsettings/*
163%{_datadir}/applications/*.desktop
164%{_datadir}/adium/message-styles
165%{_datadir}/dbus-1/services/*
166%{_datadir}/%{name}
167%{_datadir}/glib-2.0/schemas/*.xml
168%{_datadir}/help/*/%{name}
169%{_datadir}/icons/hicolor/*/apps/%{name}*
170%{_datadir}/telepathy/clients/*.client
171%{_mandir}/man1/empathy*.1*
172
173
174%changelog
175* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
176- new upstream release
177
178* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
179- new upstream release
180
181* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
182- new upstream release
183- remove BuildRequires: gnome-panel, nautilus-sendto-devel
184- remove nautilus-sendto-empathy subpackage
185
186* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
187- fix spec
188
189* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
190- new upstream release
191
192* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
193- new upstream release
194
195* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
196- rebuild with telepathy-logger-0.6.0
197
198* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
199- new upstream release
200
201* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
202- new upstream release
203
204* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
205- new upstream release
206- add BuildRequires: libsecret-devel, yelp-tools
207- remove BuildRequires: libgnome-keyring-devel
208
209* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
210- new upstream release
211
212* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
213- new upstream release
214
215* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
216- new upstream release
217
218* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
219- new upstream release
220- change BuildRequires: gcr-devel instead of gnome-keyring-devel
221- change BuildRequires: farstream-devel instead of farsight2-devel
222- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
223- add BuildRequires: itstool
224- remove Requires: telepathy-stream-engine
225- add Requires: telepathy-idle
226
227* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
228- new upstream release
229
230* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
231- new upstream release
232
233* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
234- new upstream release
235- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
236
237* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
238- new upstream release
239
240* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
241- new upstream release
242
243* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
244- new upstream release
245
246* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
247- new upstream release
248
249* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
250- new upstream release
251
252* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
253- new upstream release
254- add BuildRequires: pulseaudio-libs-devel
255
256* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
257- new upstream release
258- change BuildRequires: gtk3-devel instead of gtk2-devel
259- change BuildRequires: unique3-devel instead of unique-devel
260- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
261- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
262- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
263
264* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
265- new upstream release
266- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
267                     geoclue-devel, enchant-devel
268- add Requires: telepathy-mission-control
269- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
270
271* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
272- new upstream release
273- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
274- fix %files
275- fix %post, %postun
276- drop %pre, %preun
277
278* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
279- rebuild with evolution-data-server-2.30.2
280- add nautilus-sendto-empathy package
281  - add configure option (--enable-nautilus-sendto=yes)
282  - add BuildRequires: nautilus-sendto-devel
283
284* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
285- add Obsoletes: empathy-python < 2.29.1
286
287* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
288- new upstream release
289- add new files: %%{_bindir}/empathy-{accounts,debugger}
290- drop -libs, -devel, -python sub packages: upstream removed
291  - Obsoletes: empathy-{libs,devel} < 2.29.1
292  - drop BuildRequires: python-devel
293- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
294- drop applet files in %%files: upstream removed the panel applets
295  - update %%post, %pre and %%preun
296- update BuildRequires version for glib2 and tp_glib
297- defined major_ver, minor_ver and rel
298- fix BuildRequires for gnome-keyring
299
300* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
301- new upstream release
302- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
303
304* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
305- rebuilt with python-2.6.4
306
307* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
308- unuse %%{?_smp_mflags} option to make
309
310* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
311- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
312
313* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
314- new upstream release
315
316* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
317- new upstream release
318
319* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
320- initial build for Vine Linux
321
322* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
323- Update to 2.23.92
324
325* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
326- Update to 2.23.91
327
328* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
329- Now that Empathy will be the default IM client in F10+, hardcode a dependency
330  on telepathy-haze to keep the same protocol functionality across upgrades,
331  for a much improved "out of the box" experience.
332- Reference: bug 458935.
333
334* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
335- Update to new upstream release (2.23.90)
336
337* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
338- Apply patch from Colin Walters to automagically update profile namings for
339  the switch to using Empathy's provided profiles.
340- Drop the upgrade script (no longer needed since it's automatically done).
341  - upgrade-haze-profiles.sh
342
343* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
344- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
345  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
346  horribly stale...). This makes for better automagic functionality (if Haze is
347  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
348  + upgrade-haze-profiles.sh
349
350* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
351- Update to new upstream release (2.23.6)
352- Use the in-tarball libtool scripts instead of the system copy to workaround
353  'make install' errors.
354
355* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
356- Update to 0.23.4.
357- Update source url.
358
359* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
360- Update to 0.23.3.
361- Remove reference to stream-engine in connections managers readme.
362
363* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
364- Update to 0.23.2.
365- Add man pages.
366- Use enchant-devel, instead of aspell-devel.
367
368* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
369- Rebuild for new e-d-s.
370
371* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
372- Drop multiple copies of COPYING file.
373- Drop BR on gnome-vfs2-devel.
374- Require telepathy-stream-engine for VOIP support.
375- Add BR on iso-codes-devel, so spell-checking is enabled.
376
377* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
378- Update to new upstream release (0.23.1)
379- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
380
381* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
382- Update to new upstream release (0.22.1)
383
384* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
385- Update to new upstream release (0.22.0)
386
387* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
388- Update to new upstream release (0.21.91)
389
390* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
391- Update to new upstream release (0.21.90)
392
393* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
394- Autorebuild for GCC 4.3
395
396* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
397- Update to new upstream release (0.21.4)
398
399* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
400- Update to new upstream release (0.21.2)
401- Drop backported drag-and-drop patch (fixed upstream):
402    - svn380-fix-contact-DnD.patch
403- Update README.ConnectionManagers: Include Haze package note, remove Galago
404  note (a feed-only connection manager isn't useful for instant messaging),
405  and fix some wording.
406
407* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
408- Backport upstream patch to fixes crashes when using drag-and-drop of a
409  contact from the buddy list to the current conversation window to initiate a
410  conversation:
411    + svn380-fix-contact-DnD.patch
412- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
413  dragged a contact ...)
414
415* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
416- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
417  is essentially useless due to the need to install an external connection
418  manager. Also, add a README.ConnectionManagers to the installed
419  documentation which lists other possibilities.
420- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
421  and bug 334221 (Default empathy install is useless).
422
423* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
424- Enable VoIP support for those brave enough to test/break/debug it (F9+
425  only). Though it is functional, it is still deemed rather unstable by
426  upstream. Use it at your own risk. :)
427
428* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
429- Disable VoIP support at this time, since it is deemed unstable by upstream
430  for now. (Thanks to Brian Pepple for the notice.)
431 
432* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
433- Update to new upstream release (0.14).
434
435* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
436- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
437  and python bindings.
438- Split shared libraries into a libs subpackage for easier handling
439  in multi-lib environments.
440
441* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
442- Add ldconfig invocations to %%post and %%postun scriptlets.
443
444* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
445- Update to new upstream release (0.12).
446- Build against new mission-control stack.
447- Update License tag (GPLv2+).
448- Alphabetize BuildRequires list (aesthetic-only change).
449
450* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
451- Rebuild for selinux ppc32 issue.
452
453* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
454- Update to new upstream release (0.11)
455
456* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
457- bump to 0.8
458- Now with aspell support (deat to teh speeling mistaks)
459
460* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
461- bump to 0.7
462
463* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
464- Add telepathy-filesystem to Requires
465- Move .desktop from autostart to applications
466- Nasty hackery to make empathy launch from the menu
467
468* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
469- Add gettext to BuildRequires
470
471* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
472- Bump to 0.6
473
474* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
475- Let Empathy own the directory and not just the files in it
476
477* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
478- Initial package
Note: See TracBrowser for help on using the repository browser.