source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 7712

Revision 7712, 16.9 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define major_ver 3.8
2%define minor_ver 3
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.8.0
10%global glib2_min_version       2.36.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  yelp-tools
71
72Requires:       telepathy-filesystem
73Requires:       telepathy-gabble
74Requires:       telepathy-salut
75Requires:       telepathy-idle
76## Also hardcode Haze dependency since Empathy is the default IM client in F10+
77## and I'd hate for people to simply disregard it for lack of the "out of the
78## box" protocol support that Pidgin has. (RHBZ: 458935)
79BuildRequires:  telepathy-haze
80# Require this for VOIP support
81Requires:       telepathy-mission-control >= %{tp_mc_min_version}
82
83
84## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
85Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
86Provides:       telepathy-haze-mission-control = 0.2.0-3
87## upstream 2.29.1 removed shared libraries: #599086
88Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
89## upstream 2.29.1 removed python bindings' #599039
90Obsoletes: empathy-python < 2.29.1
91
92Obsoletes: nautilus-sendto-empathy < 3.7.0
93
94Vendor: Project Vine
95Distribution: Vine Linux
96
97%description
98Empathy provides a powerful multiple protocol instant messaging
99client using the Telepathy framework.
100
101
102%prep
103%setup -q
104
105
106%build
107## GCC complains about some unused functions, so we forcibly show those as
108## simple warnings instead of build-halting errors.
109%configure --disable-static
110
111##make %{?_smp_mflags}
112## don't use _smp_mflags at empathy-2.18.1
113make
114
115install -m 0644 %{SOURCE1} ./README.ConnectionManagers
116
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make install DESTDIR=$RPM_BUILD_ROOT
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
122
123%find_lang %{name}
124
125desktop-file-install --vendor "" --delete-original      \
126        --dir %{buildroot}%{_datadir}/applications      \
127        %{buildroot}%{_datadir}/applications/%{name}.desktop
128
129
130%clean
131rm -rf %{buildroot}
132
133
134%post
135touch --no-create %{_datadir}/icons/hicolor ||:
136%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
137
138%postun
139touch --no-create %{_datadir}/icons/hicolor || :
140if [ -x %{_bindir}/gtk-update-icon-cache ]; then
141        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
142        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
143fi
144
145%posttrans
146gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
147glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
148
149
150%files -f %{name}.lang
151%defattr(-,root,root,-)
152%doc AUTHORS COPYING README README.ConnectionManagers NEWS
153%{_bindir}/empathy
154%{_bindir}/empathy-accounts
155%{_bindir}/empathy-debugger
156%{_libexecdir}/empathy-auth-client
157%{_libexecdir}/empathy-call
158%{_libexecdir}/empathy-chat
159%{_libdir}/%{name}/libempathy*.so
160%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
161%{_datadir}/GConf/gsettings/*
162%{_datadir}/applications/*.desktop
163%{_datadir}/adium/message-styles
164%{_datadir}/dbus-1/services/*
165%{_datadir}/%{name}
166%{_datadir}/glib-2.0/schemas/*.xml
167%{_datadir}/help/*/%{name}
168%{_datadir}/icons/hicolor/*/apps/%{name}*
169%{_datadir}/telepathy/clients/*.client
170%{_mandir}/man1/empathy*.1*
171
172
173%changelog
174* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
175- new upstream release
176
177* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
178- new upstream release
179- remove BuildRequires: gnome-panel, nautilus-sendto-devel
180- remove nautilus-sendto-empathy subpackage
181
182* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
183- fix spec
184
185* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
186- new upstream release
187
188* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
189- new upstream release
190
191* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
192- rebuild with telepathy-logger-0.6.0
193
194* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
195- new upstream release
196
197* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
198- new upstream release
199
200* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
201- new upstream release
202- add BuildRequires: libsecret-devel, yelp-tools
203- remove BuildRequires: libgnome-keyring-devel
204
205* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
206- new upstream release
207
208* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
209- new upstream release
210
211* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
212- new upstream release
213
214* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
215- new upstream release
216- change BuildRequires: gcr-devel instead of gnome-keyring-devel
217- change BuildRequires: farstream-devel instead of farsight2-devel
218- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
219- add BuildRequires: itstool
220- remove Requires: telepathy-stream-engine
221- add Requires: telepathy-idle
222
223* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
224- new upstream release
225
226* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
227- new upstream release
228
229* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
230- new upstream release
231- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
232
233* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
234- new upstream release
235
236* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
237- new upstream release
238
239* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
240- new upstream release
241
242* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
243- new upstream release
244
245* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
246- new upstream release
247
248* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
249- new upstream release
250- add BuildRequires: pulseaudio-libs-devel
251
252* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
253- new upstream release
254- change BuildRequires: gtk3-devel instead of gtk2-devel
255- change BuildRequires: unique3-devel instead of unique-devel
256- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
257- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
258- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
259
260* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
261- new upstream release
262- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
263                     geoclue-devel, enchant-devel
264- add Requires: telepathy-mission-control
265- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
266
267* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
268- new upstream release
269- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
270- fix %files
271- fix %post, %postun
272- drop %pre, %preun
273
274* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
275- rebuild with evolution-data-server-2.30.2
276- add nautilus-sendto-empathy package
277  - add configure option (--enable-nautilus-sendto=yes)
278  - add BuildRequires: nautilus-sendto-devel
279
280* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
281- add Obsoletes: empathy-python < 2.29.1
282
283* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
284- new upstream release
285- add new files: %%{_bindir}/empathy-{accounts,debugger}
286- drop -libs, -devel, -python sub packages: upstream removed
287  - Obsoletes: empathy-{libs,devel} < 2.29.1
288  - drop BuildRequires: python-devel
289- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
290- drop applet files in %%files: upstream removed the panel applets
291  - update %%post, %pre and %%preun
292- update BuildRequires version for glib2 and tp_glib
293- defined major_ver, minor_ver and rel
294- fix BuildRequires for gnome-keyring
295
296* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
297- new upstream release
298- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
299
300* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
301- rebuilt with python-2.6.4
302
303* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
304- unuse %%{?_smp_mflags} option to make
305
306* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
307- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
308
309* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
310- new upstream release
311
312* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
313- new upstream release
314
315* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
316- initial build for Vine Linux
317
318* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
319- Update to 2.23.92
320
321* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
322- Update to 2.23.91
323
324* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
325- Now that Empathy will be the default IM client in F10+, hardcode a dependency
326  on telepathy-haze to keep the same protocol functionality across upgrades,
327  for a much improved "out of the box" experience.
328- Reference: bug 458935.
329
330* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
331- Update to new upstream release (2.23.90)
332
333* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
334- Apply patch from Colin Walters to automagically update profile namings for
335  the switch to using Empathy's provided profiles.
336- Drop the upgrade script (no longer needed since it's automatically done).
337  - upgrade-haze-profiles.sh
338
339* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
340- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
341  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
342  horribly stale...). This makes for better automagic functionality (if Haze is
343  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
344  + upgrade-haze-profiles.sh
345
346* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
347- Update to new upstream release (2.23.6)
348- Use the in-tarball libtool scripts instead of the system copy to workaround
349  'make install' errors.
350
351* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
352- Update to 0.23.4.
353- Update source url.
354
355* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
356- Update to 0.23.3.
357- Remove reference to stream-engine in connections managers readme.
358
359* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
360- Update to 0.23.2.
361- Add man pages.
362- Use enchant-devel, instead of aspell-devel.
363
364* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
365- Rebuild for new e-d-s.
366
367* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
368- Drop multiple copies of COPYING file.
369- Drop BR on gnome-vfs2-devel.
370- Require telepathy-stream-engine for VOIP support.
371- Add BR on iso-codes-devel, so spell-checking is enabled.
372
373* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
374- Update to new upstream release (0.23.1)
375- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
376
377* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
378- Update to new upstream release (0.22.1)
379
380* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
381- Update to new upstream release (0.22.0)
382
383* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
384- Update to new upstream release (0.21.91)
385
386* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
387- Update to new upstream release (0.21.90)
388
389* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
390- Autorebuild for GCC 4.3
391
392* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
393- Update to new upstream release (0.21.4)
394
395* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
396- Update to new upstream release (0.21.2)
397- Drop backported drag-and-drop patch (fixed upstream):
398    - svn380-fix-contact-DnD.patch
399- Update README.ConnectionManagers: Include Haze package note, remove Galago
400  note (a feed-only connection manager isn't useful for instant messaging),
401  and fix some wording.
402
403* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
404- Backport upstream patch to fixes crashes when using drag-and-drop of a
405  contact from the buddy list to the current conversation window to initiate a
406  conversation:
407    + svn380-fix-contact-DnD.patch
408- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
409  dragged a contact ...)
410
411* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
412- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
413  is essentially useless due to the need to install an external connection
414  manager. Also, add a README.ConnectionManagers to the installed
415  documentation which lists other possibilities.
416- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
417  and bug 334221 (Default empathy install is useless).
418
419* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
420- Enable VoIP support for those brave enough to test/break/debug it (F9+
421  only). Though it is functional, it is still deemed rather unstable by
422  upstream. Use it at your own risk. :)
423
424* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
425- Disable VoIP support at this time, since it is deemed unstable by upstream
426  for now. (Thanks to Brian Pepple for the notice.)
427 
428* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
429- Update to new upstream release (0.14).
430
431* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
432- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
433  and python bindings.
434- Split shared libraries into a libs subpackage for easier handling
435  in multi-lib environments.
436
437* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
438- Add ldconfig invocations to %%post and %%postun scriptlets.
439
440* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
441- Update to new upstream release (0.12).
442- Build against new mission-control stack.
443- Update License tag (GPLv2+).
444- Alphabetize BuildRequires list (aesthetic-only change).
445
446* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
447- Rebuild for selinux ppc32 issue.
448
449* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
450- Update to new upstream release (0.11)
451
452* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
453- bump to 0.8
454- Now with aspell support (deat to teh speeling mistaks)
455
456* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
457- bump to 0.7
458
459* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
460- Add telepathy-filesystem to Requires
461- Move .desktop from autostart to applications
462- Nasty hackery to make empathy launch from the menu
463
464* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
465- Add gettext to BuildRequires
466
467* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
468- Bump to 0.6
469
470* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
471- Let Empathy own the directory and not just the files in it
472
473* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
474- Initial package
Note: See TracBrowser for help on using the repository browser.